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Introduction
This kit has been replaced by an improved version, 
ZCRMZNICE01ZEMG.

Zilog’s Crimzon® In-Circuit Emulator (ICE) provides Crimzon chip 
family emulation with a Trace and Event system for program debugging 
using Zilog Developer Studio II (ZDS II) development tools. Use the 
included OTP programming module to burn your design code to OTP 
devices. 

Kit Features 
The kit features include:

•   Emulation and OTP Programming support for the Crimzon  
family

•   Emulation Pod and adapters for 20- and 28-pin Packages

•   IR Development Board

•   Trace and Event System

•   Ethernet and USB Interface

•   Up to 8 MHz Clock Frequency

•   2.0–3.6 V VDD

•   ZDS II

•   Assembler and Full ANSI C Compiler

•   Documentation

•   Sample OTP Devices

Note:
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System Requirements
Table 1 lists the system requirements for running ZDS II.

Software Installation
Follow the steps below to install ZDS II with ANSI C-Compiler:

1. DemoShield program available in the ZDS II installation CD 
launches automatically. If it does not automatically launch, go to the 
root of the CD-ROM and double-click the launch.exe file.

Table 1. ZDS II System Requirements

Recommended Configuration Minimum Configuration

PC running Windows XP Professional PC running Windows 98 SE

Pentium III/500 MHz processor Pentium II/233 MHz processor

128 MB RAM 96 MB RAM

65 MB hard disk space 25 MB hard disk space (documentation 
not included)

Super VGA video adapter Super VGA video adapter

CD-ROM drive CD-ROM drive

Ethernet port Ethernet port

USB high-speed or full-speed port

One or more RS-232 communications ports One or more RS-232 communications 
ports

Internet browser (Internet Explorer or 
Netscape)

Internet browser (Internet Explorer or 
Netscape)
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2. DemoShield provides several installation options to install ZDS II, 
select Install ZDS II. You can install other software and accompany-
ing documentation later.

3. Follow the instructions on the screen to complete the installation.

To receive free technical support, register your software at 
www.zilog.com. To access the registration page, open the Support menu 
at the top of the web page and click Product Registration.

Hardware Installation
The Crimzon ICE and Programming System features an Ethernet inter-
face, a USB interface, and an RS-232 serial port. Hardware installation 
consists of the following:

•   Connecting Target Pod
•   Connecting Crimzon ICE to the Target Pod
•   Connecting Crimzon ICE to OTP Programming Module (Optional)
•   Connecting Crimzon ICE to a PC

You have to reconfigure network settings on the PC or on the Crimzon 
ICE before using the emulator.

Connecting Target Pod
Use an appropriate target pod and pin converter to connect the Crimzon 
ICE to the target board. Figure 1 on page 4 displays the Crimzon ICE top 
panel connectors and Figure 2 on page 4 displays the IR development 
board included with the kit. The 20-/28-/40-PDIP target pods plug into the 
associated PDIP sockets on the target board. For example, if your target 
board has a 20-SOIC socket, mate the 20-PDIP target Pod onto the 20-
PDIP to 20-SOIC converter. Then install the target pod and converter 
assembly into the board’s 20-SOIC socket.
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Figure 1. Crimzon ICE Top View

Figure 2. IR Development Board
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To set up the 20-/28-PDIP emulation pods for use in specific applications 
of Port P31 on the ZLP128ICE01ZEM/G, see Figure 3 and Table 2.

Figure 3. Location of J1 Jumper

Table 2. Jumper Settings

Jumper Port P31 Function

J1 ON Infrared (IR) Amplifier

J1 OFF Digital/Analog

J1 Jumper
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The jumper settings provided in Table 2 on page 5 applies to the 20-/28-
PDIP emulation pods shipped along with the following:

•   ZLP128P2X10ZAC/G Rev. A or later

•   ZLP128ICE01ZEM Rev. G or later

•   ZLP128ICE01ZEMG Rev. A or later

For ZLP128ICE01ZEM Rev. F or earlier releases, refer to the documen-
tation shipped with the kit for the emulation pods. If you have any ques-
tion, contact Zilog® technical support at 

http://support.zilog.com/support/custom_login.asp

Connecting Crimzon ICE to the Target Pod
After installing the appropriate target pod (and converter, if required) onto 
the target development board, connect the Crimzon ICE to the target pod 
as follows:

•   For 40-PDIP and 48-SSOP target pods:
– Connect the 20-circuit cable from P9 on the emulator to P2 

on the 40-PDIP target pod. (The 20-circuit cable is included 
in the 40-/48-pin accessory kit, ZLP323ICE01ZAC, ordered 
separately.)

– Connect the 34-circuit cable from P10 on the emulator to P1 
on the 40-PDIP target pod.

•   For 20-PDIP and 28-PDIP target pods: 
– Connect the 34-circuit cable from P10 on the emulator to P16 

on the target pod. (Emulator connector P9 is not used.)

Note:
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Connecting Crimzon ICE to OTP Programming Module 
(Optional)

After developing and debugging your software, follow the steps below to 
connect the Crimzon ICE to the OTP programming module so that you 
can burn your code onto the OTP chip:

1. Connect the 40-circuit ribbon cable from the Crimzon ICE OTP Pro-
gramming connector (P8) to connector P8 on the ICE OTP program-
mer module.

2. The 40-PDIP ZIF socket on the OTP programming module is 
designed to accept 40-PDIP OTP chips. The OTP programming 
adapters supplied with the Crimzon ICE allow you to adapt the ZIF 
socket to accept 20-/28-SOIC, 20-/28-SSOP, 20-/28-PDIP chip pack-
ages.

After installing the OTP chip into the ZIF socket (or programming 
adapter), you can program the chip using the instructions provided in 
OTP Programming on page 26.

Connecting Crimzon ICE to a PC
You can connect the Crimzon ICE to a host PC using either an Ethernet or 
USB port. To connect the Crimzon ICE to a host PC using Ethernet, see 
Ethernet Port Connection on page 7. To connect the Crimzon ICE to a 
host PC using USB port, see USB Port Connection on page 15.

Ethernet Port Connection
Follow the steps below to connect the Crimzon ICE to a host PC using 
Ethernet:

1. Connect a CAT-5 crossover cable from the PC to the Ethernet port on 
the Crimzon ICE, see Figure 4 on page 8.

You can connect the ICE to an Ethernet hub using a CAT-5 patch 
cable.

Note:
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2. Connect the serial COM port on the PC to the SETUP serial port on 
the Crimzon ICE using the DB9-to-DB9 serial cable, see Figure 5. 

Figure 4. Connecting a PC to the Crimzon ICE

Figure 5. Crimzon ICE Rear Panel

Ensure that the target board is not powered ON.

3. Connect a 5 V DC power supply to the Crimzon ICE. The 3.3 V DC 
and 1.8 V DC power LEDs must illuminate, see Figure 5. Contact 
Zilog® support at www.zilog.com if there is any problem.

PC

Crimzon

ICE

DB9-to-DB9 Cable

CAT-5 Crossover Cable

Caution:
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Figure 6. Crimzon ICE Front-Panel

Setting Up Ethernet Communications
The default IP address and subnet mask of the Crimzon ICE are 
192.168.1.50 and 255.255.255.0, respectively. To enable communication 
between the PC running ZDS II and the Crimzon ICE, you must either 
change the PC’s Ethernet settings to match those of the Crimzon ICE or 
vice versa.

If using the PC in a stand-alone configuration, set the PC’s IP address to 
192.168.1.21 and its subnet mask to 255.255.255.0. For more details, see 
Changing the PC’s Settings to Match the Crimzon ICE on page 10.

In a networked environment, set the Crimzon ICE IP address and subnet 
mask to match the network setup. For more details, see Changing Crim-
zon ICE Settings on page 14.

                    ICE Fail LED

ICE Run LED
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Changing the PC’s Settings to Match the Crimzon ICE
Follow the steps below to change the PC’s Ethernet settings:

The following instructions are for MS Windows XP. If your Win-
dows OS is different, refer to your MS Windows OS online help for 
details.

1. Open the Windows Control Panel and double-click the Network 
Connections icon, see Figure 7.

Figure 7. Network Connections 

Note:
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2. In the panel labeled LAN or High-Speed Internet, double-click the 
Local Area Connection icon. The Local Area Connection Status 
window appears, see Figure 8.

Figure 8. Local Area Connection Status Window
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3. In the Local Area Connection Status window, click Properties but-
ton. The Local Area Connection Properties dialog box appears, see 
Figure 9.

Figure 9. Local Area Connection Properties Dialog Box

4. Select Internet Protocol (TCP/IP) from the scroll down list, and 
click Properties button. The Internet Protocol (TCP/IP) Properties 
dialog box appears, see Figure 10.
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Figure 10. Internet Protocol Properties Dialog

5. Enter the IP address and subnet mask to match those displayed in 
Figure 10 on page 13. Leave the remaining fields blank. In this exam-
ple, an IP address of 192.168.1.21 and a subnet mask of 
255.255.255.0 are being assigned to the PC. These values connect the 
PC to the same network as the Crimzon ICE unit.

6. Click OK and restart the PC.

To execute a sample project, see Sample Project on page 19.Note:
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Changing Crimzon ICE Settings
Follow the steps below to change the Crimzon ICE Settings:

1. Connect the serial port of the PC to the Crimzon ICE serial port using 
the DB9-to-DB9 serial cable.

2. Launch HyperTerminal on the PC by selecting Start → Programs  
→ Accessories → Communications → HyperTerminal. The Con-
nection Description dialog box appears. 

3. Enter the name for a new connection in the Connection Description 
dialog box, and click OK to open the Connect To dialog box. 

4. In the Connect To dialog, set the Connect Using drop-down menu to 
match the COM port to which the Crimzon ICE is connected. Click 
OK.

5. A COM Properties dialog appears. Enter the following port settings 
and click OK. HyperTerminal should automatically attempt a connec-
tion. Otherwise, select Call → Connect.

6. When the emulator is turned on or reset, a Crimzon ICE console boot-
up message appears in the HyperTerminal. A typical boot-up message 
is shown below: 
ZiLOG Z8 LXM ICE
Firmware Version 2.0, Build (Aug 22 2005 08:14:37)
Copyright (C) 2005 ZiLOG, Inc. All Rights Reserved.
Adding emac driver...
Attempting to establish Ethernet connection.
10 Mbps Half-Duplex Link established

Bits per second 57600
Data bits 8
Parity None
Stop bits 2
Flow control None
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IP Address: 10.1.7.95
IP Subnet: 10.1.0.0/255.255.0.0
IP Gateway: 10.1.1.254

Press 'Ctrl-Z' to enter configuration mode

7. Press Ctrl-z. The emulator command prompt appears:  
Z8 LXM ICE %

The emulator console prompt is not case-sensitive.

Type help or ? at the emulator command prompt to see a list of available 
commands. For information on the description of the complete Crimzon 
ICE commands, see Appendix A–Crimzon ICE Commands on page 40.

8. When you have finished configuring the emulator, type exit to exit 
the command shell.

9. Press Alt+F4 to exit HyperTerminal.

10. Type reboot and press Return or cycle the power on the Crimzon 
ICE for the new settings to take effect.

11. The hardware is now configured and ready for application develop-
ment. 

To execute a sample project, see Sample Project on page 19.

USB Port Connection
To connect the Crimzon ICE to your PC using a USB port, load the appro-
priate driver from the ZDS II installation directory or CD-ROM provided 
with your emulator. ZDS II software is available for download from 
www.zilog.com. The procedure of loading the appropriate driver, depends 
on your Windows OS version. 

Note:

Note:
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Windows XP
Follow the steps below to connect the Crimzon ICE to a host PC using 
USB Connection for Windows XP OS version:

1. Connect the Crimzon ICE to the host PC using the supplied USB 
cable. See Figure 11 for Crimzon ICE rear panel connection.

Figure 11. Crimzon ICE Rear Panel

Ensure the target board is not powered ON.

2. Connect a 5 V DC power supply to the Crimzon ICE. The 3.3 V DC 
and 1.8 V DC power LEDs should illuminate, see Figure 5 on page 8. 
Contact Zilog® support at www.zilog.com if there is any problem.  
In Windows, the Found New Hardware wizard should activate auto-
matically.

Caution:
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Figure 12. Crimzon ICE Front Panel

3. In the wizard, select Install from a list or specific location 
(Advanced); click Next.

If the Windows Logo testing dialog appears, select Continue 
Anyway.

4. Select Search for the best driver in these locations and include 
those locations in the search.

5. Browse to one of the following driver directories: 
<ZDS II Installation Directory>\device drivers\USB 
<ZDS II Installation CD>\Device Drivers\USB

6. Click Next.

7. Select the appropriate driver, and click Next.

8. Click Finish to complete the installation.

                    ICE Fail LED

ICE Run LED

Note:
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Windows 2000/Windows 98SE
Follow the steps below to connect the Crimzon ICE to a host PC using 
USB Connection for Windows 2000/Windows 98SE OS version:

1. Connect the Crimzon ICE to the host PC using the supplied USB 
cable. See Figure 11 on page 16 for Crimzon ICE rear panel connec-
tion.

Ensure the target board is not powered ON.

2. Connect a 5 V DC power supply to the Crimzon ICE. The 3.3 V DC 
and 1.8 V DC power LEDs should illuminate, see Figure 5 on page 8. 
Contact Zilog® support at www.zilog.com if there is any problem. 
In Windows, the Found New Hardware wizard must activate auto-
matically.

3. In the wizard, click Next.

4. Select Search for a suitable driver for my device (Recommended); 
click Next.

5. Select Specify a location, click Next.

6. Browse to one of the following driver directories: 
<ZDS II Installation Directory>\device drivers\USB 
<ZDS II Installation CD>\Device Drivers\USB

7. Click Next.

8. Select the appropriate driver, and click Next.

9. Click Finish to complete the installation.

Caution:
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Sample Project
After installing the ZDS II software and setting up the hardware, you are 
ready to execute the sample software project to verify proper emulator 
operation and to test with the Trace and Event system. This section 
describes how to run the emulator in the in-circuit mode.

1. If you run the emulator with a target attached, the emulator’s voltage 
comparator is designed to serve as a target power sensor, and not as 
a precision voltage measurement device. If you set the Target VCC to 
match your target and the target’s voltage drifts downward, the power 
sensor may no longer detect it. The emulator may therefore not con-
nect to the target. In such cases, set the Target VCC voltage progres-
sively lower until a proper connection is established.

2. If the IR development board supplied with the kit is used, see Techni-
cal Information on the IR Development Board on page 34 for techni-
cal details and Table 6 on page 39 for jumper settings.

The sample project ZLP12840100kit ver 1.zdsproj is included in 
the ZDS II sample directory, located in:
c:\Program Files\ZiLOG\ZDSII_<product>_<version>\sam-
ples\<processor type>_<demo name>

Start ZDS II for the Crimzon ICE Emulator by selecting Start  
→ Zilog ZDS II - Crimzon Emulator <software_version> and fol-
low the instructions below to run ZLP12840100kit ver 1.zdsproj, 
the sample project.

1. Ensure that the Crimzon ICE and the target board are powered ON.

2. Use File → Open Project menu option to open the sample project 
file located at the following path: 
c:\Program Files\ZiLOG\ZDSII_CrimzonGP_Emulator_ 
<version>\samples\ZLX12840_IRRemote\src\ZLP128401
00kit ver 1.zdsproj

Notes:
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3. To open the source file, double-click on irmain.s file in the 
Project Files Window.

4. Select Project → Settings.

5. In the General tab, set the CPU Family field to ZLP12840 and the 
CPU field type to ZLP12840X2828.

6. Follow either of the below options to connect the emmulator and the 
PC:

•   If you are using Ethernet communications between the emulator 
and the PC:
– In the Debugger tab, see Figure 13 on page 21, select  

EthernetEmulator from the debug tool area and click Setup  
button.

– The Ethernet Configure Driver dialog box appears. The IP 
Address field displays a default IP address, 192.168.1.50. 
Enter the Crimzon ICE IP address if it has been modified. 
Leave the Port setting at 4040.

– Click OK.

•   If you are using USB communications between the emulator and 
the PC:
– In the Debugger tab, see Figure 13 on page 21, select 

USBEmulator from the debug tool area and click Setup but-
ton.

– The USB Configure Driver dialog box appears. The Serial 
Number field displays a serial number for the USB interface. 
Click OK.
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Figure 13. Project Settings, Debugger Tab

7. In the Debugger tab, click Setup button from target area, Configure 
Target window appears.

8. Set the Voltage drop-down menu to Standalone if the emulator is not 
connected to a target. If the emulator is connected to a target, set the 
Voltage drop-down menu to the voltage appropriate for the connected 
target.

9. In Clock Source section, select the Internal radio button if the emu-
lator is not connected to a target, and set the Clock Frequency to  
7.5 MHz.
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10. If the emulator is connected to a target, select the External radio but-
ton and the appropriate frequency.

11. In the Programming Option Bits section, ensure that none of the 
options are selected.

12. Click OK.

13. Click OK in the Project Settings window and you will be prompted 
to rebuild the affected files, click Yes to rebuild the project. (You can 
also rebuild later by pressing F7.)

14. Click Go  button to connect to the target and start debugging.

15. Click Break  button and Stop Debugging, to exit the debug ses-
sion.

Collecting a Trace
Follow the steps below to obtain a sample trace:

1. Collect a simple trace by starting the program, stopping it, and view-
ing the trace buffer. Click Go  button in the toolbar, wait a 
moment, and then click Break  button. The Trace buffer acts as a 
ring buffer that continuously fills and then overwrites itself until you 
stop execution. 

2. Select the Trace window by selecting View → Debug Windows 
→ Trace and click Get Frames to display the trace information.

Using an Event to Stop Execution
Events allow you to stop execution based on more complex conditions 
than a simple instruction address.

The following events are available:

•   Program counter position, with mask

•   Data on Port0 (state of its pins), with mask
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•   Data on Port2 (state of its pins), with mask

•   Data on Port3 (state of its three input pins), with mask

•   External Trigger In (0 or 1)

Follow the steps below to setup and execute an event:

1. Select Tools → Trace and Event System. The Trace and Event Sys-
tem window appears, see Figure 14.

2. Check Enable event system check box and in the Then: section, 
check Break radio button.

3. In the When: section, check Program Counter check box and set 
Program Counter to 0044 and Mask to FFFF.

Figure 14. Trace and Event System Window

4. Click OK.
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5. Open the Trace window by selecting View → Debug Windows → 
Trace.

6. In the Trace window, click Clear Trace button.

7. To reset the Debugger click Reset button in the toolbar, or select 
Debug → Reset.

8. Click Go button or select Debug → Go to run the Debugger.

9. When the program counter reaches 0044, execution stops on event 
match.

10. Click Get Frames to display the trace information.

Collecting Trace After an Event
The Trace and Event System is also used to capture trace data after an 
event. Set up the events as described in Using an Event to Stop Execution 
on page 22. In the Then: section, check Event Position in Buffer radio 
button instead of Break. Use the slider bar to select the number of cycles 
from the 64K buffer to be captured after the event.

When the event is detected, the selected number of cycles after the event 
are collected. Execution stops after the cycles are collected. After the 
event, selected number of cycles are left in the trace buffer.

Single-Stepping Through a Program
ZDS II provides a simple mechanism for single-stepping through a pro-
gram. Follow the steps below to single-step through a program:

1. Reset the program to main() by either clicking Reset icon or by 
selecting Debug → Reset. Set the Reset to main() option by select-
ing Tools → Options. In the Options window, select the Debugger 
tab and select the Reset to symbol ‘main’ check box.

2. To step through the program one instruction at a time, use F11 or click 
Go  button in the Debug toolbar or select Build → Debug → Step 
Into.
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Peek/Poke Registers
Follow the steps below to read the emulator register contents:

1. ZDS II makes it easy for you to set and read emulator register con-
tents. With the ZLP12840100kit ver 1.zdsproj project open 
and ZDS II connected to the emulator (target), select View → Debug 
Windows → Registers.

2. In the Registers window, double-click the value of any register and 
type in a new value.

3. Press Enter. The new value is displayed in red.

Refer to ZDS II User Manual (UM0164) on the ZDS II CD-ROM and the 
ZDS II online help for more information on setting and reading register 
values.

Peek/Poke Memory
Follow the steps below to set and read the peek/poke memory contents: 

1. With the ZLP12840100kit ver 1.zdsproj project open and  
ZDS II connected to the emulator (target), select View → Debug 
Windows → Memory.

2. In Memory window, double-click the value you want to change and 
type in a new value. (Values begin in the second column after the 
Address column.)

3. Press Enter. The new value is displayed in red.

Refer to ZDS II User Manual (UM0164) on the ZDS II CD-ROM and the 
ZDS II online help for further information on setting, filling, and reading 
memory.
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OTP Programming
Use the Crimzon ICE OTP Programming Module to burn your program 
onto a Crimzon family chip. There are two ways to burn an OTP chip:

1. Burn Code from the Current Project

2. Burn Code from an Existing Hex File

Do not connect to the emulator when programming windowed 
CDIP parts. See Burn Code from an Existing Hex File on page 29 
when programming windowed CDIP parts.

Burn Code from the Current Project
Follow the steps below to burn code from the current project built in  
ZDS II (loaded in emulator RAM):

1. Connect the OTP programming module to the emulator as described 
in Connecting Crimzon ICE to OTP Programming Module (Optional) 
on page 7.

2. Select the OTP chip to be burned and the appropriate package con-
verter.

3. Install the package converter, if used, into the ZIF socket on the OTP 
programming module.

4. Install the OTP chip to be burned into the ZIF socket on the OTP pro-
gramming adapter. Match pin 1 of the chip with pin 1 of the ZIF 
socket.

5. In ZDS II, open the project for the code to be burned onto the chip.

If you are currently in debugging mode, click Build → Debug  
→ Stop Debug or press Shift-F5 to stop debugging.

6. In ZDS II, connect to the emulator by clicking the Connect to Target 
 button.

Note:

Note:
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7. Select Tools → OTP Programming to open the OTP window, see 
Figure 15.

Figure 15. OTP Programming Window (ZDS II Current Project Example)
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8. Click Ram Checksum button to calculate the checksum of the data in 
emulator RAM. Use this to compare with the OTP checksum after 
burning.

9. Select the option bits to be programmed in the Programming Option 
Bits area.

10. Select None button in the Method panel of Device Serialization to 
leave the serial number blank.

11. To load a serial number:

•   Select Sequential or Pseudorandom button in the Method 
panel. This determines how the serial number is incremented on  
subsequent burns. 

•     Select the size of the serial number (1, 2, 3, or 4 bytes) in the 
Serial Number Size area.

•   Enter the starting serial number in the Serial Number field.

•   In the Address field, enter the address of the serial number.

12. Click Blank Check to verify that the OTP chip is actually blank.

13. Click Burn to program the OTP chip with the contents of emulator 
RAM. The OTP chip content value is also verified.

14. When the burn is complete, click OTP Checksum to calculate the 
checksum of data on the OTP chip and compare it to the RAM 
checksum calculated earlier.

15. Click Close to close the OTP Programming window.
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Burn Code from an Existing Hex File
Follow the steps below to load an existing hex file into emulator RAM 
and burn an OTP chip:

1. Connect the OTP programming module to the emulator as described 
in Connecting Crimzon ICE to OTP Programming Module (Optional) 
on page 7.

2. Select the OTP chip to be burned and the appropriate package con-
verter.

3. Install the package converter, if used, into the ZIF socket on the OTP 
programming module.

4. Install the OTP chip to be burned into the ZIF socket on the OTP pro-
gramming adapter. Match pin 1 of the chip with pin 1 of the ZIF 
socket.

Stop any current debugging process by selecting Build → Debug 
→ Stop Debug or press Shift-F5 to stop debugging.

5. In ZDS II, open the project for the code to be burned onto the chip.

Note:
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6. Select Tools → OTP Programming to open the OTP window, see 
Figure 16.

Figure 16. OTP Programming Window-Hex File Example

7. Select the appropriate target device from the Device drop-down 
menu.

8. In the Hex File: section, click  button and select the hex file to be 
programmed on to the OTP chip.

9. If you do not want to pad the hex file, select None button in the Pad 
File With panel. Otherwise, select FF, 00, or Other button. If you 
select the Other button, type the hex value to pad the file with in the 
text field provided with Other.

10. Click Load File to load the hex file into emulator RAM.
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11. Click Ram Checksum to calculate the checksum of the data in emu-
lator RAM. Use this to compare with the OTP checksum after burn-
ing.

12. Select the option bits to program in the Programming Option Bits 
area.

13. Select None button in the Method panel of Device Serialization to 
leave the serial number blank.

14. To load a serial number:

•   Select Sequential or Pseudorandom button. This determines 
how the serial number is incremented on subsequent burns.

•   Select the size of the serial number (1, 2, 3, or 4 bytes) in the 
Serial Number Size area.

•   Enter the starting serial number in the Serial Number field.

•   In the Address field, enter the address of the serial number.

15. Click Blank Check to verify that the OTP chip is actually blank.

16. Click Burn to program the OTP chip with the contents of emulator 
RAM. The OTP chip contents is also verified.

17. When the burn is complete, click OTP Checksum to calculate the 
checksum of data on the OTP chip and compare it to the RAM check-
sum calculated earlier.

18. Click Close to close the OTP Programming window.
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LED Indicators
There are three sets of dual LED indicators on the Crimzon ICE, as 
described below:

1. The dual ICE RUN LED on the front panel, see Crimzon ICE Front-
Panel on page 9, indicates emulator status. If the top LED is ON, the 
emulator is executing your system code. When the top LED is off, 
emulation has stopped. If the bottom LED is ON, the emulator is not 
functioning properly, contact technical support for assistance.

2. The dual 3.3 V DC/1.8 V DC LED on the rear panel, see Crimzon 
ICE Rear Panel on page 8, indicates the status of internal voltages. 
Both LEDs are normally illuminated when power is connected.

3. The dual LAN/LINK LED on the rear panel, see Crimzon ICE Rear 
Panel on page 8, indicates Ethernet status. The LINK LED indicates 
that the Ethernet connection is live. The LAN LED indicates that data 
is being transferred across the connected network.

External Interface Connectors
There are five external interface connectors (P8, P9, P10, J4, J5) on the 
Crimzon ICE as explained below:

•   Connectors P9 and P10 are used to connect the emulator to the tar-
get pod and adapter board assembly, see Figure 1 on page 4.

•   The OTP Programming connector P8 is used to connect the emu-
lator to the OTP programming module.

•   Connector J4 on the emulator front panel (see Figure 1 on page 4 
and Figure 6 on page 9), provides a ground connection on all 
three pins.

•   Connector J5 on the emulator front panel, see Figure 1 on page 4, 
provides access to the following functions:
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– Pin 3 provides a HIGH external trigger out for use in trigger-
ing a device such as a logic analyzer or oscilloscope. Pin 3 is 
under software control, and can be activated through the ZDS 
II Trace and Event system. The trigger can be set to toggle or 
pulse.

– Pin 1 provides an input for an external HIGH or LOW trigger 
in, allowing use of an external trigger as an event for the ZDS 
II Trace and Event system.

Using J5 Pin 3, External Trigger Out
The Crimzon ICE external trigger out feature is always enabled. Set your 
Trace and Event system parameters, before executing the code. When the 
set up event occurs, pin 3 of connector J5 goes HIGH and stays HIGH as 
long as the event is active. Longer the event window, longer the trigger 
out stays HIGH.

Using J5 Pin 1, External Trigger In 
The Crimzon ICE external trigger in feature can be enabled as follows:

•   With the ZLP12840100kit ver 1.zdsproj project open in  
ZDS II as described in Sample Project on page 19, select Tools → 
Trace and Event System.

•   In the Trace and Event System window, select an Event entry. In 
the When section, check Trigger In box.

•   Select either 0 or 1 to trigger on LOW or HIGH, respectively 
(edge-triggering not supported).

•   Click OK to set the Trace and Event System parameters. If you 
set trigger=1 in the Trace and Event System window, then a 
HIGH on pin 1 of connector J5 generates an event in the ZDS II 
Trace and Event System. If you set trigger=0, then a LOW on 
pin 1 of connector J5 generates an event.
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Crimzon Package Support and Ordering Information
The Crimzon ICE supports the packages listed in Table 3.

20-SOIC and 20-SSOP adapters are available from Ironwood at 
www.ironwoodelectronics.com/.

Technical Information on the IR Development Board
The IR development board shipped with the Crimzon ICE provides a uni-
versal remote control development platform for Zilog’s ZLP12840 and 
ZLP32300 families of IR microcontrollers. The board supports both 20-
pin and 28-pin PDIP devices without adapters. The adapters and convert-
ers described in Table 4 on page 36 provide support for other Crimzon 
family package types.

Table 3. Crimzon Package Support

Chip Package For OTP Programming Order For In-Circuit Emulation, Order

20 PDIP Included in ZLP128ICE01ZEM kit Included in ZLP128ICE01ZEM kit

20 SOIC Included in ZLP128ICE01ZEM kit 20-PDIP to 20-SOIC adapter from 
Ironwood, P/N SOIC20-02

20 SSOP Included in ZLP128ICE01ZEM kit 20-PDIP to 20-SSOP adapter from 
Ironwood, P/N SOIC20-09

28 PDIP Included in ZLP128ICE01ZEM kit Included in ZLP128ICE01ZEM kit

28 SOIC Included in ZLP128ICE01ZEM kit Included in ZLP128ICE01ZEM kit

28 SSOP Included in ZLP128ICE01ZEM kit Included in ZLP128ICE01ZEM kit

40 PDIP Included in ZLP128ICE01ZEM kit ZLP323ICE01ZAC

48 SSOP ZLP323ICE01ZAC ZLP323ICE01ZAC

Note:
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For information on Schematics for IR development board, see Schematics 
on page 60.

IR Development Board Operation
Three-digit codesets enable the IR development board to be used as a 
remote controller for a variety of devices. The codeset tables are provided 
in Appendix B–Codesets on page 42.

Applying Power to the Board
Insert the two AAA batteries supplied with the kit into the battery holder 
on the bottom of the IR development board and set the Battery Power 
switch to the ON position.

You can also apply an external 3.0 V DC power supply to the board 
between terminals J7 (Vbat) and J8 (Gnd). (The board supports a voltage 
range of 2.0 V DC to 3.6 V DC. Match ZDS II project settings to ensure 
proper operation.)

Enabling the Universal Remote Control Feature
Follow the steps below to enable a universal remote control:

1. To change a device (device can be TV, VCR, CABLE, SAT, and so 
forth), press and release any device key (for example, a TV, VCR, 
CABLE or AUX1).

2. To change a code (CODE is the three-digit number for the code 
selected from Table 8 on page 42 through Table 11 on page 58), press 
and hold the device key for three seconds. LED D2 stays ON for three 
seconds and then turns OFF.

3. Release the device key. LED D2 is ON.

4. Press and release the three digit keys one by one. LED D2 stays OFF 
when pressing a key and ON when the key is released.

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/844857/ZLP128ICE01ZEM.html


Crimzon® In-Circuit Emulator
User Manual

UM018408-0408 Sample Project

36

5. LED D2 turns OFF if the three-digit code is accepted. If the number is 
rejected or is invalid, LED D2 blinks quickly eight times. Reenter the 
code number.

Key Matrix
The IR development platform key matrix has eight rows and columns 
with two alternate configurations. The default configuration uses the eight 
port 2 (input) pins as column signals for key press detection and the eight 
port 0 (output) pins as row signals for the key scanning signal. This con-
figuration provides 64 keys.

The key matrix is provided in Table 4. See Figure 2 on page 4 for key 
locations.

Table 4. IR Development Board Key Matrix

K1
SUR MODE

K2
TT HOLD
SUR ON

K3
YELLOW
FRONT

K4
RED
CENTER

K5
GREEN
REAR

K6
BLUE
DELAY

K7
TT OFF
DELAY 
UP

K8
TT ON
DELAY 
DN

K9
DISC

K10
TAPE

K11
TUNER

K12
TELEVISI
ON

K13
VIDEO 1

K14
VIDEO 
2

K15
AUDIO

K16
TEST

K17
UP ARROW

K18
DOWN 
ARROW

K19
LEFT 
ARROW

K20
RIGHT 
ARROW

K21
DSP_MOD
E

K22
DSP_O
N

K23
PIP

K24
SWAP

K25 K26
REC

K27
STOP

K28
PLAY

K29
PAUSE

K30
REW

K31
FF

K32
AV

K33
TV

K34
SAT

K35
DVD

K36
1

K37
2

K38
3

K39 K40
CH+

K41
VCR

K42
AMP

K43
AUX

K44
4

K45
5

K46
6

K47
GUIDE

K48
CH-
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Learning Circuit
The learning circuit on the ZLP12840/ZLP32300 IR development plat-
form consists of the following components:

•   Photo detector D1

•   Off-chip IR amplifier Q2, Q3 with related resistors, used only 
with LP32300 part 

•   Setup jumpers J2 and J9

When using ZLP12840, the internal on-chip IR amplifier is used to 
amplify the signal from D1. When using ZLP32300, the off-chip amplifi-
ers, Q2 and Q3 are used to amplify the signal.

Jumper and Switch Settings
The jumpers on the IR development board supplied with the Crimzon ICE 
function as follows:

•   J1—Future use, for factory testing

•   J2—Selects device type (ZLP12840 or ZLP32300)

•   J3, J4, …, J8—Test points

•   J9 pins 1-2—Selects whether external IR amplifier is being 
enabled by P37, or P37 is used as SCLK

•   J9 3-4—Connects P37 to U1.6 (SCLK)

•   J9 5-6—Connects P27 to U1.5 (SDA)

•   J10—Connects P2 pins to the columns of the keypad

K49
CABLE

K50
CD

K51
INFO

K52
7

K53
8

K54
9

K55
RECALL

K56
VOL+

K57
POWER

K58
MUTE

K59
MENU

K60
EXIT

K61
0

K62
ENTER

K63
SELECT

K64
VOL-
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•   J11—Connects P0 to the rows of the keypad

•   J12—Selects whether LEDs ON/OFF are being controlled by P34

•   J13—Selects whether CTS and RTS signals on the RS-232 inter-
face are being shorted. Certain communication software requires 
these signals to be shorted

•   J14—Enables/disables RS-232 interface

Factory settings for IR development board jumpers are described in 
Table 5. 

Table 5. Default Jumper Settings, IR Development Board 

Jumper Description Pins Configuration Default Setting

J2 IR Amplifier 1-2 Connect external IR Amplifier OUT (for 
ZLP12840)

J2 IR Amplifier 3-4 IN for direct IR photodiode 
connection

IN (for 
ZLP12840)

J2 IR Amplifier 5-6 Connect external IR amplifier OUT (for 
ZLP12840)

J9 IR Amplifier 1-2 IN to allow P37 to enable 
external IR Amplifier

OUT (for 
ZLP12840)

J9 I2C Interface 3-4 IN to connect P37 to SCLK of 
EEPROM

IN

J9 I2C Interface 5-6 IN to connect P27 to SDA of 
EEPROM

IN

J10 All Keypad 1-16 Connect keypad column 0-7 
to P20-P27

IN

J11 All Keypad 1-16 Connect keypad row 0-7 to 
P00-P07

IN

J13 RTS-CTS 1-2 Connect RTS and CTS OUT
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Table 6 lists the functions of the four eight-position DIP switches avail-
able on the IR development board.

J14 RS232_EN 1-2 IN to enable Rx
OUT to disable Rx (tri-state)

OUT

J14 RS232_SHDN 3-4 IN to disable Tx (tri-state)
OUT to enable Tx

IN

Table 6. IR Development Board DIP Switch Settings

Switch Description

SW2 Controls the connection of eight LEDs to port 0 when it is 
configured as output. Default = all OFF

SW3 Controls the pull-up resistors for Port 0. Default = all OFF

SW4 Controls the pull-up resistors for Port 2. Default = all OFF

SW5 Controls the pull-up resistors for Port 3. Default = all ON

Table 5. Default Jumper Settings, IR Development Board (Continued)

Jumper Description Pins Configuration Default Setting
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Appendix A–Crimzon ICE  
Commands

Table 7 lists the Crimzon ICE Commands. 

Table 7. Crimzon ICE Commands 

Command Description and Options

? Displays available emulator command shell options

bpool Displays buffer pool 

date Displays current date

debugport Configures the TCP port usage: 
       debugport—displays current settings 
       debugport tcp_port—sets debugport to specified TCP port 
Example 
        debugport 4040—sets debugport to TCP port 4040

devs Not used

echo Echoes arguments typed into the command line

exit Exits the command shell

hang Not used

help Displays available emulator commands
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ifconfig Configures the emulator network interface. Entering ifconfig with no 
options lists current configuration. 

The following command options are available:

•   i—specifies IP address

•   s—specifies subnet mask

•   g—specifies a network gateway address

•   dhcp—configures the emulator network interface to look for a dhcp 
host to obtain network settings

Example
ifconfig i 192.168.1.1 s 255.255.255.0 g 192.165.1.254
configures the emulator to use IP address 192.168.1.1 on subnet 
255.255.255.0 with gateway address 192.168.1.254
ifconfig dhcp on
configures the emulator to use DHCP

kill Not used

mem displays memory usage information

password Not used

port Displays port information

ps Displays a list of processes running on the ICE by process id number

reboot Reboots the emulator

restore Restores factory default network interface settings

sem Displays semaphore information

sleep Not used

time Displays current time and date

Table 7. Crimzon ICE Commands (Continued)

Command Description and Options
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Appendix B–Codesets
Table 8 through Table 11 on page 58 lists the three-digit codesets for the 
IR development board.

Table 8. Television Brands 

Brand Zilog Code Numbers

Admiral 116  234

Adventura      235

Aiko 126

Akai 63    91   117

Alba 33

Alleron 151

A-Mark 29

Amstrad 90

Amtron 145

Anam 28    29    83    105  145

Anam 
National

248 249  269

AOC 14    29   99    108  109   118  119  120  251

Archer 29

Audiovox 29    145

Bauer 35

Belcor 118

Bell & Howell 116  183  230

Bradford 145

Brockwood 14    118
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Brand Zilog Code Numbers

Candle 14    95    97    98    108  118  120  121 235

Capehart 14

Celebrity 117

Circuit City 14

Citizen 18    94    95    96    97    98    101   108 118  120  121  126  145 199  235  236

Colortyme 14    118  120  122 254

Concerto 97   118   120

Contec 49    83

Contec/Cony 123 124 145

Craig 15 83 145

Crown 94 145

Curtis Mathes 94 101 108 115 118 120 125 199 230

CXC 83 145

Daewoo 2 91 92 94 109 118 119 120 126 127 213 214 256

Daytron 14 118 120

Dimensia 115

Dixi 29 52 91

Dumont 14 118

Electroband 117

Electrohome 3 5 94 118 120 128 129 130 269

Elta 91

Emerson 1 12 14 83 84 85 86 87 88 89 90 94 118 120 123 131 132

133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149

150 151 152 211 230 236 237 260 270

Table 8. Television Brands (Continued)

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/844857/ZLP128ICE01ZEM.html


Crimzon® In-Circuit Emulator
User Manual

UM018408-0408 Appendix B–Codesets

44

 
Brand Zilog Code Numbers

Envision 108 118 120

Etron 91

Fisher 50 82 153 154 155 230

Formenti 35

Fortress 39

Fujitsu 15 89 151

Funai 15 83 89 145 151

Futuretec 145

Futuretech 15 83

GE 14 20 80 81 84 102 105 106 111 115 118 120 130 156 187 231 232

239 269

Genexxa 33

Gibralter 118

Goldstar 14 52 78 79 94 97 109 118 119 120 123 128 129 159 160 161 228

Granada 3 14

Grand 14

Grandiente 3

Grundy 145 151

Hallmark 14 118 120

Harvard 145

Hinari 89

Hitachi 3 10 24 71 72 73 74 75 76 77 94 97 118 120 123 124 163

164 218 221 222 223 224 237 253

Table 8. Television Brands (Continued)
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Brand Zilog Code Numbers

Hitachi Pay 
TV

273

IMA 145

Infinity 64 165

Janeil 235

JBL 64 165

JC Penney 46 81 94 101 108 109 111 115 118 119 120 121 130 156 161 166 167

174 187 199 239 255

JCB 117

Jensen 70 118 120

JVC 66 67 68 69 123 124 163 168 169 229 240

Kawasho 65 117 118 120

Kenwood 108 118 120 128 129

Kloss 36 98 235

Kloss 
Novabeam

170 171 241

KTV 83 84 85 94 145 172 236

Lloyds 14

Loewe 165

Logik 183 266

Luxman 97 118 120

LXI 25 30 47 50 64 111 115 120 153 165 173 174 175 230 239

Magnavox 4 36 64 95 99 108 118 120 121 128 165 170 171 176 177 178 184

188 215 216 217 241 267

Majestic 183

Table 8. Television Brands (Continued)
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Brand Zilog Code Numbers

Marants 165 52 64 108 118 120 165 179

Matsui 91

Megatron 14 120

Memorex 14 50 91 116 120 182 183 230 266

MGA 14 62 108 109 110 118 119 120 128 129 130 155 180 182

Midland 239

Minutz 156

Mitsubishi 7 14 27 61 62 63 109 110 118 119 120 128 129 130 155 180 181

182 212

Motorola 234 269

MTC 14 97 101 108 109 118 119 120 199

Multitech 145

NAD 14 30 112 120 173 174 243

National 13 105 13

NEC 23 97 100 107 108 109 118 119 120 129 185 254 269

Nikkai 33 34

Nikko 14 120 126

Normande 0

NTC 126

Onwa 83 145

Optimus 243

Optonica 37 39 192 234

Orion 15 142 260

Osaki 34

Table 8. Television Brands (Continued)
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Brand Zilog Code Numbers

Panasonic 6 11 12 13 60 64 104 105 106 165 263 265 269

Philco 36 95 108 109 118 119 120 121 123 128 165 170 171 176 178 184 241

267 269

Philips 52 64 118 121 123 128 165 170 171 177 186 187 188 269 176

Pilot 118

Pioneer 59 77 112 118 120 189 190 237 243 264

Portland 94 109 118 119 120 
126

Price Club 199

Proscan 111 115 239

Proton 14 26 94 103 120 123 191 244 118

Pulsar 113 118

Quasar 11 105 106 172 263 269

Radio Shack 34 37 83 94 115 118 120 123 145 153 192 230

RCA 16 17 25 53 54 55 56 57 58 77 102 109 111 115 118 119 120

128 193 194 196 197 239 245 256 269 273 274

Realistic 50 118 120 123 145 153 192 230

Saisho 90 91

Sampo 108 118 120

Samsung 0 8 14 34 52 91 94 97 101 108 109 118 119 120 123 125 127

128 129 198 255

Sansui 260

Sansung 199

Sanyo 49 50 51 82 118 153 154 180 200 230

Table 8. Television Brands (Continued)
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Brand Zilog Code Numbers

SBR 52

Schneider 52

Scotch 120

Scott 83 87 89 94 118 120 123 132 142 145 151

Sears 9 14 30 40 41 42 43 44 45 46 47 50 51 82 89 97 111

118 120 124 128 129 151 153 154 155 169 173 174 201 202 230 239

Seimitsu 14

Sharp 21 22 37 38 39 49 94 118 120 123 137 192 203 205 210 234

Shogun 118

Siemens 49

Signature 116 183 266

Simpson 121

Sony 114 117 259 268 272

Soundesign 14 83 95 118 120 121 145 151

Spectricon 29 99

Squareview 15

SSS 83 109 118 145

Starlite 145

Supra 97

Supre-Macy 98 235

Supreme 117

Sylvania 35 36 64 95 108 118 120 121 128 165 170 171 176 177 178 188 207

241 267 184

Symphonic 15 145 270

Table 8. Television Brands (Continued)
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Brand Zilog Code Numbers

Tandy 33 39 234

Tatung 105 237 269

Technics 106

Techwood 97 118 120 157

Teknika 31 32 83 89 94 95 96 97 98 101 109 110 118 119 120 121 123

124 126 145 151 177 182 183 199 266

Teletech 91

Tera 103 244

Thomas 14

Thompson 5

TMK 14 97 118 120

Toshiba 19 30 46 50 101 153 173 174 199 201 230 255

Totevision 94

Toyomenko 14

Universal 81 156 187

Vector 
Research

108

Victor 69 169 240

Video 
Concepts

63

Vidtech 14 109 118 119 120

Viking 98 235

Wards 37 81 89 102 108 109 116 118 119 120 128 132 151 156 156 165 170

171 176 177 183 184 187 188 192 208 209 266 267 268 270

Yamaha 108 109 119 120 128 129

Table 8. Television Brands (Continued)

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/844857/ZLP128ICE01ZEM.html


Crimzon® In-Circuit Emulator
User Manual

UM018408-0408 Appendix B–Codesets

50

Brand Zilog Code Numbers

York 14

Zenith 113 118 183 226 227 261 266 271

Zonda 29

Table 9. VCR Brands 

Brand Zilog Code Numbers

Admiral 154

Aiko 169

Aiwa 21

Akai 75 76 77 136 137 138 139 140 156 157 141 155

Alba 115

Amstrad 21

ASA 101

Asha 160

Audio 
Dynamics

12

Audio 
Dynamics

158

Audiovox 161

Beaumark 160

Broksonic 159

Broksonic 167

Bush 20

Table 8. Television Brands (Continued)
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Calix 161

Candle 17 160 161 162 163

Canon 108 117

Capehart 115 116

Capeheart 74 164

Carver 36

CCE 35 169

Citizen 17 18 160 161 162 163 169

Colt 35

Craig 5 18 35 160 161 165

Curtis 
Mathes

8 17 78 108 153 163 166 160

Cybernex 160

Daewoo 74 114 115 123 167 169 170 162

Daytron 74 115

DBX 12 158

Dumont 112

Dynatech 21

Electroho
me

4 161 171

Electroph
onic

161

Emerson 4 19 21 23 38 77 79 142 143 144 145 146 147 159 161 162 166 167

171 173 174 175 176 177 178 179 180

Fisher 3 5 21 25 26 28 29 80 86 112 113 165

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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GE 8 18 30 52 78 108 109 110 111 153 160

Go Video 106 107

Goldstar 2 17 31 126 161

Goodman
s

20

Gradiente 168

Grundig 101

Harley 
Davidson

168

Harman 
Kardon

98 126

Harwood 35

Hinari 20

Hi-Q 165

Hitachi 15 16 21 32 33 72 75 118 119 120 121 122

JC 
Penney

11 12 18 72 80 108 126 158 160 161

Jensen 32 75

JVC 11 12 17 75 82 102 103 104 105 158

Kenwood 11 12 17 75 82 89 104 158 163

KLH 35

Kodak 161

Lloyd 21 168

Logik 20 35

LXI 161

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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M. Wards 4 5 6 18 19 20 21 108 129

Magnavox 36 37 101 108 129

Magnin 160

Marantz 10 11 12 17 36 101 108 158 163

Marta 161

MEI 108

Memorex 5 21 89 100 108 112 124 154 160 161 165 168

MGA 4 38 77 99 171

MGN 
Technolog
y

160

Midland 30

Minolta 32 72

Mitsubishi 4 32 38 39 40 41 42 44 45 46 47 71 77 82 97 98 99 104

171

Motorola 154

MTC 21 160 168

Mukltitech 160

Multitech 30 35 163 168 18 20 21

NAD 96

NEC 9 10 11 12 13 17 49 50 51 75 82 104 125 126 158

Nikko 161

Noblex 160

Optimus 154 161

Optonica 65

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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Panasonic 1 14 73 108 130 132 133 134 135

Pentax 17 32 72 121 163

Perdio 21

Philco 36 37 108

Philips 65 101 108 181 36

Pilot 161

Pioneer 12 32 52 53 82 93 94 95 96 104 158

Portland 74 115 163

Proscan 8 52 129 153

Protec 35

Pulsar 124

Quartz 89

Quasar 91 92 108

Radio 
Shack

3 4 5 6 26 65 154 160 161 165 168 171

Radix 161

Randex 161

RCA 0 7 8 18 32 52 54 55 56 57 60 61 62 72 78 121 127 128

129 130 131 153 155 160

Realistic 21 26 65 86 89 108 112 154 160 161 165 168 171

Ricoh 150

Saisho 145 146

Salora 89 99

Samsung 18 30 76 90 110 123 138 156 160 162 174

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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Sanky 154

Sansui 12 63 75 82 104 125 158

Sanyo 5 87 88 89 112 160 165

SBR 101

Schneider 20

Scott 19 38 64 144 159 162 167 173

Sears 3 5 25 26 28 32 72 80 86 89 112 113 161 165

Sentra 115

Sharp 4 6 65 65 171

Shintom 20 35

Shogun 160

Singer 35

Sony 148 149 150 151 152

STS 72

Sylvania 21 36 37 38 99 108 168

Symphoni
c

21 168

Tandy 21

Tashiko 21 161

Tatung 11 75 85

Teac 11 21 56 75 168

Technics 73 108

Teknika 21 22 67 108 161 168

TMK 146 160 166

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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Toshiba 19 26 28 32 38 64 99 123 162

Totevision 18 160 161

Unitech 160

Vector 
Research

12 126 158 162 163

Victor 12 104 105 158

Video 
Concepts

12 77 158 162 163

Vid-
eosonic

18 160

Wards 32 35 48 65 68 69 70 72 154 160 161 162 165 168 171

XR-1000 35 168

Yamaha 11 12 17 75 126 158

Zenith 124 151 152

Table 10. Cable Brands 

Brand Zilog Code Numbers

ABC 7 8 9 10

Archer 11 12

Century 12

Citizen 12

Colour Voice 13 14

Comtronic 15

Eastern 16

Table 9. VCR Brands (Continued)

Brand Zilog Code Numbers
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Garrard 12

Hytex 7

Jasco 12

Jerrold 5 17 18 30 9 10

Magnavox 19

Movie Time 20

NSC 20

Oak 0 21 7

Panasonic 1 6

Philips 24 12 13 14 19

Pioneer 2 3 25

RCA 34

Regency 16

Samsung 26 15

Scientific Atlanta 3 4 27 28

Signal 15

SL Marx 15

Starcom 10

Stargate 15

Teleview 15

Tocom 8 17

TV86 20

Unika 12

United Artists 7

Table 10. Cable Brands (Continued)

Brand Zilog Code Numbers
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Universal 12 11

Viewstar 20 19

Zenith 3 32 33

Table 11. Satellite Brands 

Brand Zilog Code Numbers

Alphastar 19

Chaparral 0 1

Cheyenne 1

Dishnet 18

Drake 2

Drake 3

Echostar Dish 27

GE 13 20 21

General 
Instruments

4 5 6

Hitachi 23 24

Hughes Network 17 28

JVC 22

Magnavox 25

Philips 25

Primestar 16

Proscan 20 21 13

Table 10. Cable Brands (Continued)

Brand Zilog Code Numbers
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RCA 13 20 21

Realistic 7

Sierra 1

Sony 14

STS 8 9 10 11

Toshiba 12 15

Uniden 26

Table 11. Satellite Brands (Continued)

Brand Zilog Code Numbers
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Schematics
Figure 17 displays the layout of the 20-pin Target Pod. 

Figure 17. 20-Pin Target Pod
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Figure 18 displays the layout of the 28-pin Target Pod.

Figure 18. 28-Pin Target Pod

T_0P7

T_3P2
T_3P3
T_3P4

T_0P2

T_0P5

T_2P3

T_3P7

T_3P3

T_2P2

T_0P4

T_2P1

T_0P1

T_2P7

T_0P3
T_0P0

T_2P6

T_2P0

T_2P4

T_0P2

T_3P4

T_VCC

T_0P6

T_3P5 T_3P6

T_Pref1
T_3P2

T_0P7

T_2P5

T_0P6

T_2P6
T_2P7

T_2P5

T_0P4
T_0P5

T_XOUT
T_XIN

T_2P2
T_2P3

T_0P3

T_2P4

T_2P0
T_2P1

T_Pref1
T_0P0

T_3P5

T_0P1

T_3P7
T_3P6

T_VCC
GND

IR_AMP_OUT

T_3P1

T_3P1

R2
10K

P16

Con 17x2

1
3
5
7
9
11
13
15
17
19
21
23
25
27
29
31
33

2
4
6
8

10
12
14
16
18
20
22
24
26
28
30
32
34

C2 0.1uF

U3

SN74LVC1G34DCK

1
2
34

5 NC
A

GNDY

VCC

R3
33

C1

100pF

U2

ZLP12840 28 SSOP

1
2
3
4
5
6
7
8
9

10
11
12
13
14 15

16
17
18
19
20
21
22
23
24
25
26
27
28P25

P26
P27
P04
P05
P06
P07
VCC
XOUT
XIN
P31
P32
P33
P34 P35

P37
P36

Pref1
P00
P01
P02

GND
P03
P20
P21
P22
P23
P24R1

10K

U1

ZLP12840 target pins

1
2
3
4
5
6
7
8
9

10
11
12
13
14 15

16
17
18
19
20
21
22
23
24
25
26
27
28P25

P26
P27
P04
P05
P06
P07
VCC
XOUT
XIN
P31
P32
P33
P34 P35

P37
P36

Pref1
P00
P01
P02

GND
P03
P20
P21
P22
P23
P24

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/844857/ZLP128ICE01ZEM.html


UM018408-0408              Schematics

Crimzon®  In-Circuit Emulator
User Manual

62
Figure 19 displays the layout of the 40-pin Target Pod.

Figure 19. 40-Pin Target Pod
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Figure 20 and Figure 21 display the layout of the IR Development Board.

Figure 20. IR Development Board
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Figure 21. IR Development Board (Continued)
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Customer Support
For answers to technical questions about the product, documentation, or 
any other issues with Zilog’s offerings, please visit Zilog’s Knowledge 
Base at http://www.zilog.com/kb.

For any comments, detail technical questions, or reporting problems, 
please visit Zilog’s Technical Support at http://support.zilog.com.
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DO NOT USE IN LIFE SUPPORT

LIFE SUPPORT POLICY
ZILOG'S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL 
COMPONENTS IN LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE 
EXPRESS PRIOR WRITTEN APPROVAL OF THE PRESIDENT AND GENERAL 
COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant 
into the body, or (b) support or sustain life and whose failure to perform when properly 
used in accordance with instructions for use provided in the labeling can be reasonably 
expected to result in a significant injury to the user. A critical component is any 
component in a life support device or system whose failure to perform can be reasonably 
expected to cause the failure of the life support device or system or to affect its safety or 
effectiveness.

Document Disclaimer
©2008 by Zilog, Inc. All rights reserved. Information in this publication concerning the 
devices, applications, or technology described is intended to suggest possible uses and 
may be superseded. ZILOG, INC. DOES NOT ASSUME LIABILITY FOR OR 
PROVIDE A REPRESENTATION OF ACCURACY OF THE INFORMATION, 
DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
D O E S  N O T  A S S U M E LI A B I L I T Y  F O R  I N T E L L EC T U A L  PR O P E RT Y  
INFRINGEMENT RELATED IN ANY MANNER TO USE OF INFORMATION, 
DEVICES, OR TECHNOLOGY DESCRIBED HEREIN OR OTHERWISE. The 
information contained within this document has been verified according to the general 
principles of electrical and mechanical engineering.  

Crimzon is a registered trademark of Zilog, Inc. All other product or service names are the 
property of their respective owners.

Warning:
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