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We want your feedback!

SMH Technologies is always on the lookout for new ways to improve its Products and
Services. For this reason feedback, comments, suggestions or criticisms, however small,
are always welcome.

Our policy at SMH Technologies is to comply with all applicable worldwide safety and EMC/EMI
regulations. Our products are certified to comply with the European New Approach Directives and the
CE mark is applied on all our products.

This product as shipped from the factory has been verified to meet with requirements FCC as a CLASS
A product.

In a domestic environment, this product may cause radio interference in which case the user may be
required to take adequate prevention measures.

‘ Attaching additional wiring to this product or modifying the product operation from the factory default as
shipped may effect its performance and cause interference with other apparatus in the immediate
vicinity. If such interference is detected, suitable mitigating measures should be taken.

SMH Technologies

E-mail (general information): info@smh-tech.com
E-mail (technical support): support@smh-tech.com
Web: http://www.smh-tech.com

Important

SMH Technologies reserves the right to make improvements to FlashRunner, its documentation and software routines,
without notice. Information in this manual is intended to be accurate and reliable. However, SMH Technologies assumes no
responsibility for its use; nor for any infringements of rights of third parties which may result from its use.

SMH TECHNOLOGIES WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF
PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.

Trademarks

SMH Technologies is the licensee of the SofTec Microsystems trademark.
Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc.
All other product or service names are the property of their respective owners.
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1 Introduction

1.1 Overview

The DEMO9S12PFAME Demonstration board has been designed for the evaluation,
demonstration and the debugging of the Freescale MC9S12P128 microcontroller.

The DEMO9S12PFAME can be used as a standalone application, or via its built-in USB-to-
BDM bridge, or together the Freescale Student Learning Kit (Freescale code: MCUSLK)
through three external 40-pin I/O female header connectors.

1.2 Package Contents

The DEMO9S12PFAME package includes the following items:

= The DEMO9S12PFAME evaluation board;

" A USB cable;

] A LIN cable;

" The SofTec Microsystems “System Software” CD-ROM,;

" The CodeWarrior Development Studio Special Edition CD-ROM,;
] A Quick Start Guide sheet;

" This user's manual.

1.3 Supported Devices

The DEMO9S12PFAME Demonstration Board supports the following devices:

MC9S12P128.

1.4 Recommended Reading

] Freescale S12 microcontroller-specific datasheets;
] DEMO9S12PFAME Schematic.
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2 Hardware Features

2.1 Demonstration Board Features

The DEMO9S12PFAME board features:

" A MC9S12P128 microcontroller (in 80-Pin QFP package, already programmed with a
demo application);

= A 4 MHz crystal;
= A 12V DC power supply input connector;
. Power input selection jumper for selecting the input voltage source:

o 12 V DC input connector;
o USB connector.

" A built-in USB-to-BDM circuitry which allows the host PC to communicate with the
microcontroller through a standard USB interface. USB 2.0 is fully supported. When
using an external in-circuit debugger (via the “BDM” connector), the USB-to-BDM
circuitry must be bypassed by removing the BKGD and RESET# jumpers.

" A Reset push-button connected to the MCU Reset pin.
. A series of inputs:

o Two push-buttons, together with jumpers to connect/disconnect them to/from the
microcontroller;

o Four DIP-switches, together with jumpers to connect/disconnect them to/from the
microcontroller;

o A potentiometer, together with a jumper to connect/disconnect it to/from the
microcontroller;

o A photocell, together with a jumper to connect/disconnect it to/from the
microcontroller.

" Four high-efficiency (low-current) LEDs together with jumpers to connect/disconnect
them to/from the microcontroller;

] An RS-232 channel connected to the microcontroller’'s SCI serial communication
interface, together with a jumper to select the RS-232 or LIN functionality (see point

below);

" Two LIN connectors sharing one LIN transceiver, together with jumpers for
configuration;

. One CAN connector with high-speed CAN transceiver, together with jumpers for
configuration.
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3 Software Setup

3.1 Overview

Note: before connecting the Demonstration Board to the PC, it is
recommended that you install all of the required software first (see
below), so that the appropriate USB driver will be automatically found by
Windows when you connect the Demonstration Board.

The Demonstration Board requires that both CodeWarrior Development Studio Special Edition
and SofTec Microsystems Additional Components be installed in the host PC.

Note: CodeWarrior Development Studio for HCS12(X) must be installed
first.

3.2 Host System Requirements

The Demonstration Board is controlled by CodeWarrior Development Studio. The following
hardware and software are required to run the CodeWarrior user interface together with the
Demonstration Board:

" A 200-MHz (or higher) PC compatible system running Windows 98, Windows 2000 or
Windows XP;

. 128 MB of available system RAM plus 1 GB of available hard disk space;
= A USB port;
. CD-ROM drive for installation.

3.3 Installing CodeWarrior Development Studio

To install the CodeWarrior Development Studio Special Edition, insert the CodeWarrior CD-
ROM into your computer's CD-ROM drive. A startup window will automatically appear. Follow
the on-screen instructions.

Page 9
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3.4 |Installing SofTec Microsystems Additional
Components

The SofTec Microsystems “System Software” CD-ROM contains other required components to
your hard drive. These components include:

. SofTec Microsystems DLL for DEMO9S12PFAME support;

" Examples;

] Demonstration Board’s user’'s manual;
] Demonstration Board’s schematic;

" Additional documentation.

To install the required components, do the following:

1. Insert the SofTec Microsystems “System Software” CD-ROM into your computer’s CD-
ROM drive. A startup window will automatically appear.

2. Choose “Install Instrument Software” from the main menu.

3. Click on the “Copy SofTec Microsystems DLL to \CodeWarrior for HCS12
V4.7\Prog\gdi” option. An Explorer window will open. Copy the “SofTec_BDM12.dII”
file to your PC in the “\CodeWarrior for HC12 V4.7\Prog\gdi” folder, relative to the
CodeWarrior installation path.

4. Click on the “Copy examples for CodeWarrior for HCS12 V.4.7” option. An Explorer
window will open. Copy the “DEMO9S12PFAME” folder to your PC, in a location of your
choice. These are the examples specific for the demonstration board, and will be used
later in the step-by-step tutorial.

Note: to install the Additional Components on Windows 2000 or Windows
XP, you must log in as Administrator.
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4 Hardware Setup

4.1 First Connection

The Demonstration Board connects to a host PC through a USB port. Connection steps are
listed below in the recommended flow order:

Install all the required system software as described in the previous section.
Make sure the “POWER SEL” jumper is in the “USB” position.
Insert one end of the USB cable into a free USB port.

Insert the other end of the USB cable into the USB connector on the Demonstration
Board.

5. The first time the Demonstration Board is connected to the PC, Windows recognizes the
instrument and starts the “Found New Hardware Wizard” procedure, asking you to
specify the driver to use for the instrument. On Windows XP (SP2) the following dialog
box will appear.

Ao DN~

Found Mew Hardware Wizard

Welcome to the Found New
Hardware Wizard
Wwindows will search for curent and updated software by

laoking on wour computer, on the hardware installation CD, or on
the ‘Windows Update ‘Web site [with your permission).

Can Windows connect toWindows Update to search for
software?

(D) es, this time only
(D) fes, now and every time | connect a device
() Na, nat this time

Click Next to continue.

et » ][ Cancel

Select the “No, not this time” option and click the “Next >” button.
0. The following dialog box will appear.
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Found New Hardware Wizard

Thiz wizard helps you install software for:

uDART In-Circuit Debugger

f'\') If your hardware came with an installation CD
B2 or floppy disk. inzert it now.
What do you want the wizard to do?

(%) Install the software automatically [Fecommended)
() Install fram & list ar specific locatian [Advanced)

Click Next to continue.

< Back H Mlext > ][ Cancel

Click the “Next >” button.
7. Depending on your Windows settings, the following warning may appear.

Hardware Installation

{ ] 'j The software you are installing for this hardware:
-
UDART In-Circuit Debugager

has not paszed ‘Windows Loga testing to verify itz compatibility

with Windows xP. [Tell me why this testing iz impartant. ]

Continuing your installation of this software may impair
or destabilize the comect operation of your system
either immediately or in the future. Microsoft strongly
recommends that you stop this installation now and
contact the hardware vendor for software that has
passed Windows Logo testing.

Continue drymway ] [ STOR Inztallation

Note: this warning is related to the fact that the USB driver used by
the Demonstration Board is not digitally signed by Microsoft, and
Windows considers it to be potentially malfunctioning or dangerous
for the system. However, you can safely ignore the warning, since
every kind of compatibility/security test has been carried out by
SofTec Microsystems.

Click the “Continue Anyway” button.

8. Windows will install the driver files to your system. At the end of the installation, the
following dialog box will appear.
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Found New Hardware Wizard

Completing the Found New
:'?\ Hardware Wizard

The wizard has finished instaling the software for:

% uDART In-Circuit Debugger

Click Finish to close the wizard.

Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure.
9. The Demonstration Board’'s USB driver is now installed on your system.

4.2 Power Supply

The Demonstration Board can be powered in three ways:

] 12 V DC input connector;
= USB connector;
] I/0 header connector.

The “POWER SEL” jumper allows you to power the board through either the 12 V DC input
connector or the USB connector.

When using the 1/O header connector, its pin 1 is connected to the VDD line of the carrier
board through the “VAUX ENA” jumper.
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5 Operating Modes

5.1 Overview

The Demonstration Board can work in two modes: “standalone” mode and “host” mode.

5.2 Standalone Mode

In standalone mode, no PC connection is required. The microcontroller is factory programmed
with a sample application.

To run the built-in example:

Ensure that the light sensor “ENA” jumper is inserted.

Ensure that all of the “LED ENA” jumpers are inserted.

Ensure that the two push-button “ENA” jumpers are inserted.

Ensure that the “RS-232/LIN SEL” jumper selects the “RS-232” position.
Ensure that the “POWER SEL” jumper selects the “UNREG” position.

Power on the Demonstration Board through the 12 V DC plug-in power supply.
The green “POWER” LED on the board should turn on.

Press the “PP0” push-button. Rotate the potentiometer. Its value will be shown on the
LEDs.

9. Press the "PP1" push-button. The output of the light sensor will be displayed on the
LEDs.

10. The value of the potentiometer or the light sensor is also sent to the RS-232 port (baud
rate = 9600, data bits = 8, parity = N, stop bits = 1).

® N O hA N =

5.3 Host Mode

In host mode the program execution is controlled by the host PC through the “USB” connector.
You can use the PC to debug the application by, for example, executing the program step by
step and watching how the microcontroller registers vary, using the provided CodeWarrior
Development Studio.
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Note: all MCUs in the S12 family contain a single-wire background debug
interface which supports in-circuit programming of on-chip non-volatile
memory. This system does not interfere with normal application
resources. It does not use any user memory or locations in the memory
map. The Background Debug Module (BDM) uses a single-wire
communication interface (via the BKGD line) to allow non-intrusive access
to target system memory and registers.

To work in host mode (using the built-in USB to BDM interface):

" Make sure that both the “RESET#” and “BKGD” jumpers are inserted.
. Make sure that the “POWER SEL” jumper is in the “USB” position.
" Connect the host PC to the board through the provided USB cable.
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6 Application Tutorial

6.1 Overview

This section will provide a step-by-step guide on how to launch your first project and get
started with the CodeWarrior for HCS12(X) user interface.

6.2 Step-by-Step Tutorial

The sample application is the same as the one described in the “Standalone Mode” section
above.

1. Ensure that the Demonstration Board is connected to the PC (via the USB cable) and
that the board is powered on.

2. Make sure that all of the Demonstration Board jumpers are set to their factory position
(see chapter “7.1 Jumpers” for details).

3. Start CodeWarrior by selecting it in the Windows Start menu.

4, From the CodeWarrior main menu, choose “File > Open” and choose the
“DEMO9S12PFAME\C\Demo\Demo.mcp” file. This is the board example you copied
from the SofTec Microsystems “System Software” CD-ROM.

5. Click “Open”. The Project window will open.

6. The C code of this example is contained in the “main.c” file. Double click on it to open
it.

7. From the main menu, choose “Project > Debug”. This will compile the source code,
generate an executable file and download it to the demo board.

8. A new debugger environment will open. From the main menu, choose “Run >
Start/Continue”. The program will be executed in real-time.

9. From the main menu, choose “Run > Halt”. The program execution will stop. The next
instruction to be executed is highlighted in the Source window.

10. From the main menu, choose “Run > Single Step”. The instruction highlighted in the
Source window will be executed, and the program execution will be stopped immediately
after.

11.  From the main menu, choose “Run > Start/Continue”. The application will restart from
where it was previously stopped.

Congratulations! You have successfully completed this tutorial! You can continue to
experiment with the CodeWarrior user interface and discover by yourself its potentialities. For
an in-depth guide of all of the user interface features, select “Help > CodeWarrior Help” from
CodeWarrior Development Studio’s main menu.
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7 Summary of Jumper and Connector

Settings

7.1 Jumpers

Name Reference Description/Pinout
J104 W o] VAUX ENABLE
Installed: Power the demonstration board
through the VDD line of the carrier
board (connects the pin 1 of the J101
connector to the VDD line of the
demonstration board) (default)
Not Installed: The demonstration board is not powered
by the carrier board.
J202 1 El RESET# BDM ENABLE
@ BKGD
All installed: The USB to BDM interface is enabled
(default)
Not Installed: The USB to BDM interface is disabled
J304 LIN ENABLE
Installed: The microcontroller’s PA7 line is
routed to the LIN transceiver (default)
Not Installed: The LIN transceiver is not connected to

the microcontroller

J305 1
3
L

RS-232/LIN SELECTION

1-3, 2-4 (“RS-232"):

3-5, 4-6 (“LIN"):

The RS-232 transceiver is connected
to the microcontroller’s SCI peripheral
(default)

The LIN transceiver is connected to the
microcontroller’s SCI peripheral

J401

VDD CAN ENABLE

Installed:

Not Installed:

Powers the CAN transceiver with the
VDD voltage (default)

CAN transceiver not powered

Downloaded from Elcodis.com electronic components distributor
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Name Reference Description/Pinout
J402 1/l @] ™ CAN ENABLE
® o~
(@ @ = All Installed: The CAN transceiver is connected to
(@ @] crre the microcontroller (default)
(@ @ s Not Installed: The CAN transceiver is not connected to
the microcontroller
J502 1 1 POWER SELECTION
2
3 1-2 (“UNREG"): The power supply is taken from the
power supply connector (J501)
2-3 (“USB”): The power supply is taken from the
USB connector (default)
J503 PUSH-BUTTON “PP0” ENABLE
Installed: The “PP0” push-button is connected
to the microcontroller’s PPO line
(default)
Not Installed: The “PP0” push-button is not connected
to the microcontroller
J504 PUSH-BUTTON “PP1” ENABLE
Installed: The “PP1” push-button is connected
to the microcontroller’'s PP1 line
(default)
Not Installed: The “PP1” push-button is not connected
to the microcontroller
J505 | o] POTENTIOMETER ENABLE
Installed: The “PAD00” potentiometer is
connected to the microcontroller’s
PADOO line (default)
Not Installed: The “PADO0OQ” potentiometer is not
connected to the microcontroller
J506 PHOTO RESISTOR ENABLE
Installed: The photoresistor network is
connected to the microcontroller’s
PADO1 analog input (default)
Not Installed: The photoresistor network is not
connected to the microcontroller
J507 1l @ DIP-SWITCH ENABLE
@ o
@ o Installed: The DIP-switches are connected to
e @ PBJ3..0] ports of the microcontroller
(default)
Not Installed: The DIP-switches are not connected to
the microcontroller
Page 20
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Name

Reference

Description/Pinout

J508

1

HHHH

LED ENABLE

Installed:

Not Installed:

The LEDs are connected to PA[3..0]
ports of the microcontroller (default)

The LEDs are not connected to the
microcontroller

Downloaded from Elcodis.com electronic components distributor
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7.2 Connectors

Name Reference Description/Pinout
J101 1l @ |2 40-Pin 1/0 Female Header Connector 1

3@ @ |4

‘@ @ 1. VDD (5.0V)

@ @8 2.  PE1

° @ @0 3. GND

"o @2 4. RESET#

LA Ji 5. PS1

5@ @0 6. BKGD

’ : : ’ 7. PSO

v e e 8. PP7

5@ @ 9. PPO

%@ @ 10. PADO7

7@ @ 11. PP1

% @ @30 12. PADO06

3@ @ | 13. PTO

B @ @ |4 14. PADO5

5| @ @ |36 15. PT1

37| @ @ |38 16. PADO04

9@ @ |4 17. PM4
18. PADO03
19. PM2
20. PADO02
21. PM5
22. PADO1
23. PM3
24. PADOO
25. PA7
26. PJ6
27. PA6
28. PJ7
29. PA5
30. PP2
31. PA4
32. PP3
33. PA3
34. PP4
35. PA2
36. PP5
37. PA1
38. PS2
39. PAO
40. PS3
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Name Reference Description/Pinout
J102 1l @ |2 40-Pin I/O Female Header Connector 2
3@ @ |4
'@ @|¢ 1. PBO
7@ @ |8 2. PMO
°® @ 0 3. PB1
"o @ 4. PM1
ELAdk 5. PB2
@ @6 6. PT2
! : : ’ 7. PB3
v e e 8. PT3
5@ @ 9. PB4
5@ @ 10. N.C.
7 @ @l 11. PB5
% @ @30 12. N.C.
3@ @ |32 13. PBG6
3B @ @ |34 14. N.C.
5| @ @ |36 15. PB7
7 @ @ |38 16. N.C.
Q@ @ |4 17. PT4
18. N.C.
19. PT5
20. N.C.
21. PT6
22. N.C.
23. PT7
24. PADO08
25. PE7
26. PADO09
27. PE6
28. N.C.
29. PE5
30. N.C.
31. PE4
32. N.C.
33. PE3
34. N.C.
35. PE2
36. N.C.
37. GND
38. N.C.
39. PEO
40. N.C.

Downloaded from Elcodis.com electronic components distributor
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Name Reference Description/Pinout
J103 1l @ |2 40-Pin I/O Female Header Connector 3
3@ @ |4
'@ @|¢ 1. N.C.
7@ @ |8 2. GND
°® @1 3. N.C.
10 @2 4.  GND
ELAdk 5. N.C.
@ @6 6. GND
7@ @ 7. N.C.
©® @ 8. GND
21 @ @ |22
5@ @ 9. N.C.
%@ @2 10. GND
7 @ @l 11. N.C.
% @ @30 12. GND
31 @ @ |32 13. N.C.
3B @ @ |34 14. GND
5 @ @ |36 15. N.C.
7| @ @ |38 16. GND
Q@ @ |4 17. N.C.
18. GND
19. N.C.
20. GND
21. N.C.
22. GND
23. N.C.
24. GND
25. N.C.
26. GND
27. N.C.
28. GND
29. PJO
30. GND
31. P
32. GND
33. PJ2
34. GND
35. GND
36. GND
37. GND
38. GND
39. GND
40. GND
Page 24
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Name Reference Description/Pinout
J105 1 @ |2 BDM Connector (Not Populated)
4
0 ® 1 BKGD
5@ @5 2. GND
3. N.C.
4. RESET
5. N.C
6. VDD

- -

USB Connector

1 5V DC USB Bus Power Supply Line
2 USB D-

3. USBD+

4 GND

J301

RS-232 Connector

Connected to pins 4 and 6

TX

RX

Connected to pins 1 and 6

GND

Connected to pins 1 and 4

Connected to transceiver for testing purposes
Connected to transceiver for testing purposes
N.C.

© NGk~ wN=

J302,
J303

-

LIN Connectors

1 GND

2. GND

3. 12 V — LIN Bus Power Supply
4 LIN — LIN Signal

J403 1

CAN Connector

1 CANH
2 CANL
3. GND
4 N.C.

J501 ) 3 1-

12 V DC Power Supply Input Connector

1. 12V DC
2. Ground
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8 Troubleshooting

8.1 USB Driver Problems

If you connected the Demonstration Board to the PC before installing the SofTec
Microsystems Additional Components, the Demonstration Board’s USB driver may not have
been correctly installed on your system. Unplugging and replugging the USB cable is of no
use, since Windows has marked the device as “disabled”. As a consequence, the PC cannot
communicate with the Demonstration Board.

To restore the USB driver (provided the SofTec Microsystems Additional Components have
been installed), perform the following steps under Windows XP:

1. Connect the Demonstration Board to the PC.

2. Open the Control Panel (Start > Settings > Control Panel).

3. Open the “System” options.

4. Select the “Hardware” tab.

5. Click the “Device Manager” button.

6. The “uDART In-Circuit Debugger” device will be shown with an exclamation mark next
to it. Double click on this device.

7. In the “General” tab, click the “Reinstall Driver” button. Follow the on-screen

instructions.

8.2 Communication Problems between the PC and the
Demo Board

1. Make sure that both the “BKGD” and “RESET#” jumpers are inserted.

2. Make sure that the “POWER SEL” jumper selects the appropriate power source
(typically “USB” when the board is connected to the PC).
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