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Copyrights

Copyrights

© Cypress Semiconductor Corporation, 2008. The information contained herein is subject to change without notice. Cypress
Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress
product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor
intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express
written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-
support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The
inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use
and in doing so indemnifies Cypress against all charges. 

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by
and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty
provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create
derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom soft-
ware and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as speci-
fied in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source
Code except as specified above is prohibited without the express written permission of Cypress. 

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATE-
RIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described
herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein.
Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure
may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support sys-
tems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all
charges. 

Use may be limited by and subject to the applicable Cypress software license agreement. 

FirstTouch™, PSoC Designer™, Programmable System-on-Chip™, and PSoC Express™ are trademarks and PSoC® is a
registered trademark of Cypress Semiconductor Corp. All other trademarks or registered trademarks referenced herein are
property of the respective corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guaran-
tee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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1. Introduction

1.1 Welcome
Thank you for purchasing the CY3271-EXP1 Environmental Sensing Kit. The CY3271-EXP1 is
designed to quickly evaluate the flexibility, integration, and mixed signal capabilities of Cypress'
Programmable System-on-Chip (PSoC®) when interfacing with sensors. 

Use the sample projects to explore:
■ PSoC's programmable analog and digital blocks to interface to common sensors (such as ther-

mistors and ambient light sensors) 
■ PSoC Designer Integrated Development Environment (IDE) to create embedded designs in two 

methods: traditional chip level designs that involve writing code and code free system level 
designs 

■ PSoC's flexible analog to allow multiple sensors to connect the same internal resources 

If you have questions about or need help with the CY3271-EXP1 kit, visit our online support center at 
http://www.cypress.com/support for support options, or contact your local Cypress sales
representative or authorized distributor.

1.2 CY3271-EXP1 System Overview

1.2.1 CY3271-EXP1 Hardware Overview
The CY3271-EXP1 kit hardware consists of a Weather Station Expansion Board and a Pigtail Ther-
mistor Expansion Board.

1.2.1.1 Weather Station Expansion Board

The Weather Station Expansion Board features a PSoC device, and several sensors:
■ Thermistor
■ Ambient light sensor
■ Humidity sensor
■ Atmospheric pressure sensor
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Figure 1-1.  Weather Station Expansion Board

The Weather Station Expansion Board sends the sensor data over I2C to the RF Expansion Card,
which is contained in the CY3271 PSoC FirstTouch Start Kit.

1.2.1.2 Pigtail Thermistor Expansion Board

The Pigtail Thermistor Expansion Board features a thermistor on a 3 foot cable.  The thermistor at
the end of the cable is identical to the thermistor used on the RF Expansion Board allowing dual tem-
perature readings.

The Pigtail Thermistor Expansion Board does not have a PSoC on board, rather it uses the PSoC
from the RF Expansion Board to read the sensor.

Figure 1-2.  Pigtail Thermistor Expansion Board

1.2.2 CY3271-EXP1 Software Overview
The software noted in this section is not included in the CY3271-EXP1 Kit, but instead, is located on
the CY3271 PSoC FirstTouch Starter Kit CD.

1.2.2.1 PSoC Designer

PSoC Designer is the integrated development environment (IDE) where all PSoC projects are cre-
ated, edited, built, and debugged. You are able to open all firmware examples included with the
CY3271-EXP1 kit in PSoC Designer.
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Figure 1-3.  PSoC Designer

1.2.2.2 PSoC Programmer

After a PSoC project is built, the PSoC Programmer tool (along with the PC Bridge board) programs
the target PSoC.

Figure 1-4.  PSoC Programmer
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1.2.2.3 Cypress Sense and Control Dashboard (SCD)

SCD enables data logging and monitoring of wired and wireless sensors created using PSoC. The
features include data logging, calibration, alarms, and data aggregation from hundreds of sensors.

The CY3271-EXP1 Kit uses the SCD application to wirelessly log data from the sensors connected
to the PC Bridge using the CY3271 PSoC FirstTouch Starter Kit.

Figure 1-5.  SCD

1.3 Document Revision History  
Table 1-1.  Revision History

Revision PDF 
Creation Date

Origin of 
Change Description of Change

** 10/07/2008 YUR New Guide
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1.4 Documentation Conventions 
Table 1-2.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.
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2. Installation Guide

The CY3271-EXP1 uses the same software as the PSoC FirstTouch™ Starter kit. If you have
installed the software for your FirstTouch kit, then no additional installation is necessary. If, however,
you did not install the PSoC FirstTouch™ Starter kit then follow these instructions.

2.1 CY3271 Installation Instructions
Insert the CY3271 kit CD into your CD drive. This automatically launches the installer. If the autorun
fails, then manually choose "autorun.exe" on the root of the CD, as shown in Figure 2-1.

Figure 2-1.  Selecting autorun.exe

The installer presents three options. The first option launches the kit installer, which installs the
following:
■ PSoC Designer 5.0 
■ PSoC Programmer 3.00
■ Cypress Sense and Control Dashboard
■ Kit Contents
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Figure 2-2.  Kit Installer 

Click Install CY3271 Kit and Tools to start the kit installations. Click Next to start the installer and
then choose Install to launch the PSoC Designer installer.

Click Next through the next several screens.

When the Device Driver screen appears, click Next and then Finish.

Figure 2-3.  Device Driver Screen 
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Wait for the Setup Status screen to complete. Then select Finish to complete the installation of
PSoC Designer 5.0.

Figure 2-4.  Setup Status Screen

The Hi-TECH compiler for PSoC Designer begins installation. 

Figure 2-5.  Hi-TECH Compiler 
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PSoC Programmer 3.0 begins to install. Click Next through the next several screens. 

Figure 2-6.  PSoC Programmer Installer 

Another Device Driver Installation Wizard appears. Click Next and Finish to complete the
installation of PSoC Programmer.

The Sense and Control Dashboard Software setup wizard appears. Click Next through the next sev-
eral screens to install the default configuration. This installer also installs Microsoft SQL server.

Figure 2-7.  Installing SCD Software
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Figure 2-8.  Installing Microsoft SQL Server 

Click Finish to complete installing the CY3271 kit.

A directory structure similar to that sown in Figure 2-9 is created during the installation process. 

Figure 2-9.  Device Templates Directory

The device templates directory contains templates for all of the FTRF Design examples as outlined
in the Design Example Summary Table on page 21.

The firmware section contains the firmware projects for all of the projects used in this kit. Each
project contains the source code as well as the compiled .HEX image enabling you to quickly pro-
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gram each application into the hardware. It is advised to generate and build each project before
making changes to the project source code.

The Hardware section contains the design files for the schematics and PCB layout. There are also in
PDF format for ease of viewing.
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3. Design Examples

3.1 Design Example Summary Table   

3.2 Out of Box Design Examples
These demonstrations operate at +10dBm of RF output power. They are limited to +10dBm because
of the RF power restrictions imposed in Europe and Japan. The power can be increased to +20dBm
in the United States and Canada only. The process is explained in detail on pages 47 and 64 of the
CY3271 PSoC FirstTouch Starter Kit Guide.

3.2.1 Weather Station Expansion Board
Operate the Weather Station demonstration by downloading the corresponding .hex file onto the RF
Expansion Board. 
1. Connect the RF Expansion Board to the PC Bridge.
2. Insert the PC Bridge into any free USB port of your PC/laptop.
3. Open PSoC Programmer, and load RF_I2C_Bridge.hex from the Hex Files folder located on the 

CY3271-EXP1 Kit CD.
4. Set Programming Mode to Reset, Device Family to 27x43, Device to CY8C27443 and click 

Program.

Design Example Overview

Weather Station Expansion Board

This example demonstrates the Weather Station Expansion 
Board talking to the RF Expansion Board.  The RF 
Expansion Board transmits data from the sensors to the PC 
Bridge. The bridge receives this data and sends it to the host 
PC, which displays the data from all four sensors in text or 
graph form in the SCD program. 

Pigtail Thermistor Expansion Board

This example demonstrates the RF Expansion Board reading 
two identical thermistors: one thermistor on the RF 
Expansion Board and the other on the Pigtail Thermistor 
Expansion board.  The RF Expansion Board transmits data 
from both thermistors to the PC Bridge. The Bridge receives 
this data and sends it to the host PC, which displays the data 
from both sensors in text or graph form in the SCD program. 
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Figure 3-1.  PSoC Programmer Settings

5. Disconnect the RF Expansion Board from the PC Bridge, leaving the Bridge connected to your 
computer. 

6. Attach the Weather Station Expansion Board and the battery pack to the RF Expansion board as 
shown in Figure 3-2.

Figure 3-2.   RF Expansion Board Connected to the Battery Pack and Weather Station Boards

7. Switch on power to the RF Expansion Board by sliding the ON/OFF switch on the battery pack 
towards the RF Expansion Board.
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Figure 3-3.  Turning ON the Switch

8. Open the SCD software.
9. Place the PC Bridge in Bind mode using the SCD software. 
■ Click Manage to set up the sensor network.

Figure 3-4.   Manage Network within the SCD

■ In the Manage Network screen, click Add to add a new node.
■ On the Node Binding screen, click Begin Binding. 

Figure 3-5.   Node Binding Window

■ After activating this function, you have aproximately 20 seconds to press the bind button on the 
RF Expansion Board.

ON
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Figure 3-6.   Press the Bind Button

■ Verify the success of the bind. A successful bind window looks similar to Figure 3-7.

Figure 3-7.   Successful Bind Window

9. Click Next to go to the Node Binding (2 of 2) window. In this window, assign a name to the newly 
bound node. On the Node Configuration pane, click Load Node configuration from a file and 
load Weather_Station_Dashboard_Configuration.xml from the Configuration Files folder.
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Figure 3-8.   Node Configuration

10.Select graphical or textual mode of data display. The data is displayed in graphical or text format 
on the SCD screen.

11.Click Apply on all successive dialog boxes until the main SCD window reappears.
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3.2.2 Pigtail Thermistor Expansion Board
The Pigtail Thermistor demonstration can be operated by downloading the corresponding .hex file
onto the RF Expansion Board. 
1. Connect the RF Expansion Board to the PC Bridge.
2. Insert the PC Bridge into any free USB port of your PC/laptop.
3. Open PSoC Programmer, and load RF_Therm_Bridge.hex from the Hex Files folder.
4. Set Programming Mode to Reset, Device Family to 27x43, Device to CY8C27443 and click 

Program.
5. Disconnect the PC Bridge and the RF Expansion Board and connect the battery pack and Pigtail 

Thermistor boards to the latter.
6. Switch on power to the RF Expansion Board by sliding the ON/OFF switch on the battery pack 

towards the RF Expansion Board.
7. Open the SCD software.
8. Place the PC Bridge in Bind mode using the SCD software. This is described below:
■ Click Manage button to set up the sensor network.
■ In the Manage Network screen, click Add to add a new node.
■ On the Node Binding screen, click on Begin Binding. 
■ After this function is activated, the user has about 20 seconds to press the bind button on the RF 

Expansion Board.
■ Verify the success of the bind.
9. Click Next to go to the Node Binding (2 of 2) window. In this window, assign a name to the newly 

bound node. On the Node Configuration pane, click the Load Node configuration from a file 
radio button and load Pigtail_Thermistor_Dashboard_Configureation.xml from the Configuration 
Files folder located on the CY3271-EXP1 Kit CD 

10.Select graphical or textual mode of data display. The data is displayed in graphical or text format 
on the SCD screen.

11.Click Apply on all successive dialog boxes until the main SCD window reappears.
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4. Firmware

4.1 Weather Station

4.1.1 Weather Station Interface Definition
The board interfaces to the FirstTouch RF unit using the standard hardware interface defined for
FirstTouch RF Expansion Boards. This interface is an augmented I2C interface that transmits data in
8 byte packets. The Weather Station board is an I2C slave device that presents the eight bytes of
data on a virtual register interface. The eight bytes are interpreted as four 16-bit, 2's compliment data
values, each corresponding to one of the four sensors monitored by the onboard PSoC. The 16 bit
values are presented in this order: 
■ Humidity
■ Temperature
■ Ambient light
■ Pressure 

The following sections specify the exact definition of the engineering units provided for each sensor.

In addition to the I2C interface, the board uses two hardware signals to control interaction with the
FirstTouch PC Bridge: Board Select and Board Ready. The Board Select line is controlled by the
Bridge and signals the PSoC on the weather station board to obtain readings. When readings are
received, the PSoC sets the Board Ready line high to indicate to the PC Bridge that the values pre-
sented are stable.

Table 4-1.  Weather Station Interface Definition

Field Size Format Units Byte Offset
Humidity 16-bit 2's compliment Percent relative 0

Temperature 16-bit 2's compliment Degrees Celsius * 100 2

Ambient Light 16-bit 2's compliment Lux 4

Pressure 16-bit 2's compliment Inches of mercury * 100 6
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4.2 Pigtail Thermistor Expansion Board 

4.2.1 Pigtail Thermistor Interface Definition
The Pigtail Thermistor board does not have an onboard PSoC. Instead, the analog signal is routed
directly to the PSoC on the RF Expansion Board. This PSoC handles the signal measurement and
processing, and communicates the results to the PC Bridge. 

Table 4-2.  Pigtail Thermistor Interface Definition

Field Size Format Units Byte Offset
Temperature (RF 
EXP) 16-bit 2's compliment Degrees Celsius *10 0

Temperature (Pigtail) 16-bit 2's compliment Degrees Celsius *10 2
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5. Calibrating Sensors

5.1 Calibrating Sensors
Selecting the manual configuration route in the second step of Node Binding Wizard activates the
Configure Node dialog.
1. Click Add to add a new sensor and Edit to edit a selected sensor.

Figure 5-1.  Configure Node

2. In the Configure Sensor dialog,  specify:
■ Sensor name
■ Sensor physical unit
■ Sensor data format
■ Sensor bit range
■ Scaling factor
■ Sensor display option

Notepad.lnk
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Click Apply.

Figure 5-2.  Adding a Sensor

The sensor entry appears in the Configure Node dialog:

Figure 5-3.   Sensor Added Successfully

Click Edit to start sensor editing. 
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5.2 Calibrating the Sensor
■ SCD allows you to calibrate any sensor in the system using linear calibration
■ SCD sensor calibration is based on data pairs (raw value, adjusted value)
■ To register a calibration data pair, the last reported raw value from a sensor is displayed. You are

prompted to adjust the value.
■ When you begin to calibrate a sensor, specify at least one calibration data pair. You can choose

not to calibrate the sensor or you can calibrate the sensor using at least one calibration data pair.
There is no upper limit on the number of data pairs; more data pairs mean more accurate calibra-
tion.

■ If you provide one data pair, SCD computes the calibration equation of the form y = x + b using
the provided data pair.
Calibrated Value = Raw Value + Offset

■ If you provide  two or more data pairs, SCD computes the calibration equation of the form 
y = mx + b using a least squares best fit of the provided data:
Calibrated Value = (Slope)*(Raw Value) + Offset

■ This calibration equation is used to calibrate all incoming raw data from that sensor before dis-
playing it in SCD.

■ SCD records both raw and calibrated data for each sensor in its data log. 

The Calibrate Sensor window is where you calibrate the sensor. 

Figure 5-4.  Calibrate Sensor Window
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Open this dialog using the Tools > Selected Sensor > Calibrate  menu item and Calibrate Sensor
toolbar button. Use the buttons Add Point and Remove Point to add or remove calibration data
pairs.

5.3 Wired Sensor Support
 I2C and USB are the two tyes of  wired sensors supported in SCD. To bind a sensor  to the network,
go to Tools > Manage Network and click Add button in Network Nodes tab. The Node Binding win-
dow opens. Select the Wired sensor tab and click Find Wired Sensor.. All connected sensors are
displayed in a box.

For I2C sensors the status message appears like  "Sensor @ I2C Address  = N”, were N is the  wired
sensor I2C address. If you select I2C sensor and Next, on the second window, sensor nodeID is
automatically equal to I2C Address + 0x80. Enter a unique name and press Finish.

USB sensors are displayed by the name from the unique USB product string of less then 25 charac-
ters. You cannot change this name in SCD because this name is used to compare with the original
for auto detect purpose. Node ID is automatically equal to sensor USB index + 0x40.

USB sensors count connected to network, are shown in the status tray.
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5.4 Alarms and Data Aggregation Intervals
The Chart Options dialog provides a way to set low and high alarms for a selected sensor. This dia-
log is activated using Tools > Selected Sensor > Chart Options or by selecting Chart Options  in
the toolbar.

Figure 5-5.  Chart Options for Setting Alarms
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If the application detects a triggered low or high alarm, and reports this event on the Alarms panel.
The alarm values are also reflected on the sensor display tile if graph option is selected.

Figure 5-6.  Alarm History

Data aggregation intervals are also specified using the Chart Options dialog. To enable long or
short term aggregation, select the corresponding check box and specify the data sampling period.
The long term aggregation interval must be longer than the short term aggregation interval. 

5.5 Data Export
Selected sensor data, data reported by all sensors, and alarm history is exported to a file using
comma separated values format. The corresponding menu items is in the main menu at File >
Export Data. 

5.6 Saving a Configuration
To save your network configuration, use File > Save Configuration or File > Save Configuration
As. The network configuration is saved as an XML file.
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