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Preface 
 

Information in this manual is subject to change without notice and does not 
represent a commitment on the part of Eaton Electrical Inc. Permission is 
granted to duplicate this material without modification only for your use or 
the internal use of other members of your company or your agents to assist 
you in the use and servicing of products purchased from Eaton Electrical. 
No permission is granted to modify this material or include this material in a 
compilation. 

RESTRICTED RIGHTS LEGEND 
Use, duplication, or disclosure by the Government is subject to restrictions 
set forth in paragraph (b)(3)(B) of the Rights in Technical Data and 
Computer Software clause of DAR 7-104.9(a). Contractor/Manufacturer is 
Eaton Corporation, Operator Interface Business, 811 Green Crest Drive, 
Westerville, OH 43081. 

TRADEMARKS 
PanelMate, Cutler-Hammer, Eaton and ePro Canvas are either federally 
registered trademarks or trademarks of Eaton Corporation.  

Commercial brand names (trademarks) of products of manufacturers or 
developers, other than Eaton Corporation or its affiliates, that appear in this 
manual may be registered or unregistered trademarks of those respective 
manufacturers or developers, which have expressed neither approval nor 
disapproval of Cutler-Hammer products and services. 

2005 Eaton Electrical Inc. All rights reserved. 

Printed in the United States of America. 

P/N MN05003001E 
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Support Services 
The goal of Eaton is to ensure your greatest possible satisfaction with the operation of our products. We 
are dedicated to providing fast, friendly and accurate assistance. That is why we offer you so many ways 
to get the support you need. Whether it's by phone, fax or e-mail, you can access Eaton’s support 
information 24 hours a day, seven days a week. Our wide range of services is listed below. 
You should contact your local distributor for product pricing, availability, ordering, expediting and repairs. 

Website 
Use the Eaton Electrical website to find product information. You can also find information on local 
distributors or Eaton’s Cutler-Hammer sales offices. 

Website Address www.eatonelectrical.com 

e-COM Support Center 
Call the e-COM Support Center if you need assistance with placing an order, stock availability or proof of 
shipment, expediting an existing order, emergency shipments, product price information, returns other 
than warranty returns, and information on local distributors or sales offices. 

e-COM Support Center Voice: 800-356-1243 (8a.m.–6p.m. EST) 
FAX: 800-752-8602 
After-Hours Emergency: 800-543-7038 
(6p.m.–8a.m. EST) 

e-TRC Technical Resource Center 
If you are in the US or Canada, and have OI/PLC/IPC questions, you can take advantage of our toll-free 
line for technical assistance with hardware and software product selection, system design and 
installation, and system debugging and diagnostics. Technical support engineers are available for calls 
during regular business hours. 

e-TRC  
Technical Resource Center 
(support for OI, PLC and IPC) 

Voice: 
• 800-809-2772, selection 5 (8a.m.–5p.m. EST) 
• 414-449-7100, selection 5 (8a.m.–5p.m. EST) 
FAX: 614-882-0417 
e-mail: CHATechSupport@eaton.com 
After-Hours Emergency (Plant Down Only): 
• 800-809-2772, selection 5 (5p.m.–8a.m. EST) 
• 414-449-7100, selection 5 (5p.m.–8a.m. EST) 
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1.1 Introductions and System Requirement 

ELCSoft is a program editor of Eaton ELC series for WINDOWS. Except for general ELC 

program planning and general WINDOWS edition functions (e.g. cut, paste, copy, 

multi-windows, etc.), ELCSoft also provides various comment edition and other special 

functions (e.g. register editing, settings, the data readout, the file saving, and contacts 

monitor and set, etc.). 

 
What follows is the system requirement to comply with the operation environment of 

ELCSoft: 

 

Item System Requirement 

Operation System Windows 95/98/2000/NT/ME/XP 

CPU Pentium 90 and above 

Memory 16MB and above (32MB and above is recommended) 

Hard Disk Capacity: 50MB and above 
CD-ROM (for installing ELCSoft) 

Monitor 
Resolution: 640×480, 16 colors and above, 
It is recommended to set display setting of Windows to 
800×600. 

Mouse General mouse or the device compatible with Windows

Printer Printer with Windows driver 

RS-232 At least one of COM1 ~ COM8 can connect to ELC 

Adaptive Models All Eaton ELC series 
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1.2 System Installations and Setup 

Start-up your computer to Windows 95/98/2000/NT/ME/XP system.  Insert ELCSoft CD 

into the CD-ROM drive. 

Press “START” button, and click on “RUN”.  

 

Designate the drive and location where ELCSoft is to be installed and saved.  
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It will show the message box explaining the ELCSoft copyright and the system requirement; 

users could press the “Next>” button to proceed with the installation.  
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Key in the user name and the organization, then press “Next>” for the next step.  

 

 

For the following procedure, simply press the “Next>” button to continue or press the 

“Change> button to change install path.  
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For the following procedure, simply press the “Install>” button to continue.  
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Finally, press the “Finish” button to complete the installation.  

 
1.3 Program Execution 

After finishing installation, ELCSoft will be installed in the default directory "C:\Program 

Files\Eaton\ELC".  At this time, simply double-click the ELCSoft icon on your desktop to 

start the program or navigate to Start>Programs>ELC>ELCSoft.  The start-up screen 

will display briefly. (see figure below). 
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Next, the ELC editor window will show up (see figure below). There are only File (F), 

Communication(C), Option(O) and Help(H) in the toolbar when executing ELC editor 

without opening new file. 

 
It will open the last file you edited when entering ELCSoft at the second time. 
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Following is ELC editor introduction.  

Title bar

Working area

Menu bar

Status Bar

 Toolbar

 

Title bar: display file name and directory that is editing.  

Menu bar: there are ten items in menu bar: File(F), Edit(E), Compile(P), Comments(M), 

Search(S), View(V), Communication(C), Option(O), Window(W), and Help(H).  

Toolbar: used to execute instruction by clicking directly. There are four types:  

1. Standard toolbar:  

 

2. ELCSoft toolbar: 

 

3. Ladder diagram toolbar: (display in ladder diagram mode)  
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4. SFC toolbar: (display in SFC diagram mode)  

 

Working area: the area for design and program. The edition can be instruction edition, 

ladder diagram edition and SFC edition by requirement.  

Status row: used to display messages, including replace/insert mode, edition coordinate, 

ELC scan time, program size after compiling, communication indication LED 

(blinking during communication), ELC status (RUN/STOP/HALT/ ERROR), 

ELC COM port number (baud rate), ELC models, etc. 

 

1.4 Initial Setup 

After executing ELCSoft, it can open new file for ELC program design. It can set program 

title, ELC Type, program capacity (refer to the specification of ELC model name and 

program capacity) and file name.  

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


1 Introduction 
 

 
 
1-10

 
After above settings, there is two windows will be shown up: one is ladder diagram mode 

window and the other is instruction mode window. User can select the edition mode by their 

interests to edit ELC program.  
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Ladder diagram mode: (it needs to convert to instruction code or SFC diagram by compiler 

to finish ladder diagram edition.) 
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Instruction mode: (it needs to convert to instruction code or SFC diagram by compiler to 

finish ladder diagram edition.) 
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SFC edition mode: (it needs to convert to instruction code by compiler to finish SFC edition. 

If getting ladder diagram, it needs to convert instruction code to ladder diagram by 

compiler.) 
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When ELCSoft is activated, the first window to show up is as follows; four selections: File, 

Communication, Option and Help, will be shown on the menu bar.  
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After clicking “File” > “New”, the window below will be shown; some other selections: Edit, 

Compiler, Comments, Search, View, and Window will be listed on the menu bar. We will 

introduce them one by one.  

 

2.1 File 

The “File” function is shown as follows, including pull-down menu options: 
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■ New(N)  Create a new file.  

 Method 1: Click “File” > “  New(N)”. 

 Method 2: Click the icon  on toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (N). 

■ Open(O)  open old file. 

 Method 1: Click “File” > “  Open(O)”. 

 Method 2: Click the icon  on toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (O).  

■ Save(S)  save current file. 

 Method 1: Click “File” > “  Save(S)”. 

 Method 2: Click the icon  on toolbar.  

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (S).  

■ Save as (A)  Save current file to another file name. 

 Method 1: Click “File” > “  Save as (A)”. 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (S). 

■ Close project (C)  Close current file.  

 Method: Click “File” > “  Close project (C)”. 

■ Print (P)  Print current file (only print current window, i.e. one of ladder 
diagram/SFC/instruction mode).  

 Method 1: Click “File” > “  Print (P)”. 

 Method 2: Click the icon  from the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (P). 

■ Printer Setup (Q)  Select and set printer. 

 Method 1: Click “File” > “  Printer Setup(Q)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Q). 
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■ Exit  End ELCSoft. 

 Method 1: Click “File” > “Exit(X)”. 

 Method 2: Click the icon  at the right upper corner of the window. 

 Method 3: Use keyboard shortcuts by pressing keys (Alt) + (X).  

File Explanation: 

There will be 13 different extension names for save after finishing edition and compiler; 

actual files will vary according to the differences on the edition files. It is recommended to 

copy all the same file names with different extension name if you want to copy the 

completed program (including all program comments and settings) to other disk or directory. 

Besides, you only need to copy the file with extension name .EPC for execution file copy.  
 Extension 

Name   Explanation 

1 * .EPC   Execution file with program code; the file generated after the 
ladder diagram program has gone through a successful compiler 

2 * .LAD   The ladder diagram file 
3 * .SFC   SFC diagram file 
4 * .LMT   The file used to record ladder diagram segment comment 
5 * .SMT   The file used to record ladder diagram device comment 
6 * .LAB   The file used to record label P and I 
7 * .RCM   The default comment file for special D/special M 
8 * .WFT   The file used to record file register 
9 * .DVL   The file used to record register T, C and D 
10 * .DVB   The file used to record device state (M and S) 
11 * .DEV   The file used to record device monitor  
12 * .DUP   The file used to save “Duplicate ELC Service” 
13 * .SYM   The file used to record “Symbol Table” 

For general programs that request a thorough backup file, it is necessary to copy the 

above-mentioned 13 files to make it complete. And to get a basic backup file, it is required 

to save those files with ELC as their extension names (* .EPC); what the user has to do is 

to use ELCSoft to reload this file and files with extension names LAB, LAD and SFC (*.LAB, 

*.LAD and *.SFC) would be generated after compiling. If the user wants to backup file 

before successful compiler, it needs to save those files with the extension name LAD 

(*.LAD). By the same way, if the user wants to backup file before successful compiler, it 

needs to save those files with the extension name SFC (*.SFC). If you want to see the 
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complete comments in backup program, you should also save comments file. 

2.2 Communication 

The “Communication” function is shown as follows: 

 

■ Transfer Setup(C)  PC communicates with ELC or HHP and read/write program 

 Method 1: Click “Communication” > “  Transfer Setup(C)”. 

 Method 2: Click the icon  to download program to ELC or click the icon to 
upload to PC. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F1).  

■ Verify with ELC(V)  to verify if current ELC program is the same as editing program 

 Method: “Communication” > “  Verify with ELC(V)”.  

■ Password Setting(P)  set or remove ELC password. 

 Method 1: Click “Communication” > “  Password Setting(P)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (F5).  

■ Run(R)  to execute ELC. 

 Method 1: Click “Communication” > “  Run(R)”. 

 Method 2: Click the icon  on the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F8).  
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■ Stop(S)  to stop executing ELC. 

 Method 1: Click “Communication(C)” > “  Stop(S)”. 

 Method 2: Click the icon  on the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F7).  

■ Ladder start monitoring(L) switch to ladder diagram monitor mode (only for ladder 
diagram mode). 

 Method 1: Click “Communication(C)” > “  Ladder start monitoring (L)” or “Stop 
monitoring ladder diagram(L)”. 

 Method 2: Click the icon  on the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F1).  

■ SFC start monitoring  switch to SFC monitor mode (only for SFC mode). 

 Method 1: Click “Communication(C)” > “  SFC start monitoring” or “SFC Stop 
monitoring”. 

 Method 2: Click the icon  on the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F2).  

■ Devices batch monitoring(D) change to monitor device to get the information of 
device state and value. 

 Method 1: Click “Communication(C)” > “  Devices batch monitoring(D)”. 

 Method 2: Click the icon  on the toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F3). 

 Set Device On/Off(O)  Force devices (Y, M, S, T and C) to be set as On or Off. (Only 
for monitor mode). 

 Method 1: Click “Communication(C)” > “Set Device On/Off(O)”. 

 Method 2: Put the mouse pointer on the device in ladder diagram mode and then 
Right-click to get the instructions “Set On” and “Set Off”. 
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■ Enter Value(E)  Change the current value of the designated device register (T, C and 
D). (only for ladder diagram monitor mode or device monitor mode) 

 Method 1: Click “Communication(C)” > “Enter Value (E)”. 

 Method 2: Put the mouse pointer on the device in ladder diagram mode and then 
right-click to get the instructions “Enter value”. 

 Method 3: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F7). 

■ Edit Register Memory (T,C,D)(B)  Proceed with functions such as read, write, print, 
file readout, and save the file within internal registers (T, C and D) of the ELC. 

 Method 1: Click “Communication(C)” > “Edit Register Memory (T,C,D) (B)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (R). 

■ Edit Bit Memory (M, S)  Proceed with functions such as read and save the file within 
internal registers (M and S) of the ELC. 

 Method 1: Click “Communication(C)” > “Edit Bit Memory (M, S)”. 

■ Format ELC Memory(M)  clear ELC memory and set ELC to factory settings (the 
ELC is communicating with ELCSoft).  

 Method 1: Click “Communication(C)” > “  Format ELC Memory (M)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F5).  

■ Edit File Register Memory(A)  Proceed with functions such as read, write, file 
readout, and save the file within file registers of the ELC.  

 Method: Click “Communication(C)” > “Edit File Register Memory (A)”. 

■ Send Changes(N)  the device can be updated online for ELC PC/PA/PH series.
(online update means update program when ELC is running)  

  Method: Click “Communication(C)” > “Send Changes(N)”. 

■ Baud Rate Auto-Detect(Q) It will detect current ELC model, communication baud 
rate and communication protocol according to the COM Port setting in “Options(O)” > 
“Select COM Port(P)”. It will display ELC information, including ELC series, 
communication protocol and PC COM port when ELC connects to PC correctly. 

 Method: Click “Communication(C)” > “  Baud Rate Auto-Detect(Q)”  
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■ ELC Information  It will display current ELC information, including ELC state, 
capacity, ELC version, host, slave address, syntax check, error address and lock state. 

 Method 1: Click “Communication(C)” > “  ELC information(I)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (I). 

 

2.3 Options 

The “Options” function is shown as follows: 

 

■ Select COM Port(P)  ELCSoft will detect applicable PC COM port and user can 
choose one of applicable COM port to connect to ELC.   

 Method: Click “Options” > “  Select COM Port(P)” 

■ Change ELC type(U)  it is used to set program title, ELC type setting (PB and 
PC/PA/PH), program capacity (4000, 8000 and 16000 Steps) and file name.  

 Method 1: Click “Options” > “  Change ELC type(U)”  

 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F6). 

■ Station Address(A)  Default address of ELCSoft is 1. It means that PC connects to 
the ELC, which the address is 1 (D1121). The setting range is from 0 to 255. 

 Method 1: Click “Options” > “  Station Address(A)”  

 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F8)  

■ Autosave Setup(S) it is used to save file automatically before compiling or for a 
time interval (5 minutes~60 minutes).   

 Method: Click “Options” > “  Autosave Setup(S)”  
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■ Font Setting and Comment Format  there are 16-color for user to set the display 
color of ladder diagram, ladder text, ladder symbol, ladder cursor, ladder monitor 
state, ladder device comment, ladder segment comment, ladder row comment and 
ladder monitor value. It also provides those fonts that Windows® uses. The text of 
device comment and row comment also can be arranged in this setting. It also 
provides symbol name display enabled or disable. 

 Method: Click “Options” > “  Font Setting and Comment Format”  

 .symbol name display enabled or disable 

 Method 1: Click “Options” > “  Font Setting and Comment Format” choice 
symbol name display enabled. 

 Method 2: Click the icon  on the toolbar. 

■ Response Setup(R)  it is used to set the auto query times (1-50 times) and query 
interval time (3-10 seconds) when transmission error occurs.  

 Method: Click “Options” > “  Response Setup(R)”  

■ Set Baud Rate(B)  the communication baud rate of ELC-PC/PA/PH series can be 
9600, 19200, 38400, 57600 and 115200 bps.  

 Method: Click “Options” > “  Set Baud Rate(B)”  

■ Set ELC Date and Time(T)  user can set RTC settings of ELC-PC/PA/PH series to 
be the same as computer RTC or defined by user.  

 Method: Click “Options” > “  Set ELC Date and Time(T)”  

■ Prompt to Edit Device Comment(H)  Once you enable this function, you will get 
the comment input dialog box when you edit ELC by entering instructions directly in 
the instruction mode or ladder diagram mode.  

 Method: Click “Options” > “Prompt to Edit Device Comment(H)”  
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2.4 Window 

The “Window” function is shown as follows: 

 

■ Cascade(C)  Arrange windows in an overlapping way. 

 Method: Click “Window” > “Cascade(C)”  

■ Title Horizontally(H)  Arrange the file in a horizontal way.  

 Method: Click “Window” > “Title Horizontally(H)  

■ Title Vertically(V)  Arrange files in a vertical way.  

 Method: Click “Window” > “Title Vertically(V)” 

■ The current files list  e.g. the Ladder Diagram Mode, the Instruction Mode, the 
SFC Edition, the Device Comment, the Device usage State, the Register State, 
the Device State Edition, the File Register and the Device Monitor.  

2.5 Help 

The “Help” function is shown as follows:  
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■ About ELCSoft(A)  Display ELCSoft relevant information, including EATON
website and ELCSoft program version.  

 Method: Click “Help” > “  About ELCSoft(A)” 

■ Intelligent Function Utility(C)  The settings are RS-485 protocol setting 
(D1120), LRC/CRC generator, duplicate ELC service, screen capture and 
special instruction wizard. 

 Method: Click “Help” > “  Intelligent Function Utility (C)”  

▲ RS-485 Protocol Setting (D1120) 

▲ LRC/CRC Generator 

▲ Duplicate ELC Service 

▲ Screen Capture 

○ To Clipboard: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + 
(P) 

○ To File: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (F) 

▲ Special Instruction Wizard 

○ PID Instruction Input Assistance 

○ High Speed Counter Auxiliary Function 

○ Pulse Output Auxiliary Function 

○ ELC Link Auxiliary Function 

○ Communication Program 

○ Position Control 

○ Extension Module Setup 

○ Interrupt Label 

■ ELC Instruction & Special Registers Reference(S) all instructions list and 
explanation, the manual for internal special auxiliary relay of all ELC series and 
the manual for internal special data register of all ELC series. 

 Method: Click “Help” > “  ELC Instruction & Special Registers Reference 
(S)” 

■ ELCSoft User Manual(I)  User Manual for ELCSoft 

 Method: Click “Help” > “  ELCSoft User Manual(I)” 
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2.6 Edit 

The “Edit” function is shown as follows:  

 

■ Undo(U)  undo the previous actions (max. is 10 times) 

 Method 1: Click “Edit” > “  Undo(U)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Z) 

 Method 4: Right-click to get pop-up menu and select “undo” in the pop-up menu 

■ Redo(R)  redo the previous actions. 

 Method 1: Click “Edit” > “  Redo(R)”  

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (Z)  

 Method 4: Right-click to get pop-up menu and select “redo” in the pop-up menu 

■ Select All(A)  select entire document and marked with inverse  

 Method 1: Click “Edit” > “Select All (A)” 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (A) 
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■ Delete  delete marked block or the words where the cursor is. 

 Method 1: Click “Edit” > “  Delete” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing key (Delete)  

 Method 4: Right-click to get pop-up menu and select “delete” in the pop-up menu 

■ Cut(T)  cut down those words that are selected  

 Method 1: Click “Edit” > “  Cut(T)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (X) 

 Method 4: Right-click to get pop-up menu and select “Cut” in the pop-up menu  

■ Copy(C)  copy those words that are selected  

 Method 1: Click “Edit” > “  Copy(C)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (C) 

 Method 4: Right-click to get pop-up menu and select “Copy” in the pop-up menu 

■ Paste(P)  Paste those words that are selected on the document  

 Method 1: Click “Edit” > “  Paste(P)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (V) 

 Method 4: Right-click to get pop-up menu and select “Paste” in the pop-up menu 

■ Insert Block(O)  insert those words that are selected (only for ladder diagram mode)

 Method 1: Click “Edit” > “Insert Bock (O)” 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Ins)  

 Method 3: Right-click to get pop-up menu and select “Insert a block” in the pop-up 
menu 
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■ Insert Row(I)  insert a line into the document 

 Method 1: Click “Edit” > “  Insert Row(I)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (I)  

 Method 3: Right-click to get pop-up menu and select “Insert Row” in the pop-up 
menu 

■ DeleteRow(L)  delete a line from the document 

 Method 1: Click “Edit” > “  Delete Row(L)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Y) 

 Method 3: Right-click to get pop-up menu and select “Delete Row” in the pop-up 
menu 

■ Delete Vertical Line(D) delete the vertical lines from the document (only for ladder 
diagram mode) 

 Method 1: Click “Edit” > “  Delete Vertical Line (D)”  

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (D)  

 Method 4: Right-click to get pop-up menu and select “Delete Vertical Line” in the 
pop-up menu 

■ Insert Cell(B)  Insert a cell on the right side in SFC edition page. (Only for SFC 
mode)  

 Method 1: Click “Edit” > “  Insert Cell(B)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (B)  

 Method 3: Right-click to get pop-up menu and select “Insert Cell” in the pop-up 
menu  

■ Delete Cell(K) delete a cell at the left side in SFC page (Only for SFC mode)  

 Method 1: Click “Edit” > “  Delete Cell(K)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (K)  

 Method 3: Right-click to get pop-up menu and select “Delete Cell” in the pop-up 
menu  
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■ Program Title  the information of program title, file name, company name and 
designer are shown here. This information can be printed as easy cover. 

 Method 1: Click “Edit” > “  Program Title (S)”. 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (T).  

2.7 Compiler 

The “Compiler” function is shown as follows: 

 

■ Ladder => Instruction(I)  Convert ladder diagram to instruction 

 Method 1: Click “Compiler” > “  Ladder => Instruction(I)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F9) 

■ Instruction => Ladder(L)  Convert instruction to ladder diagram  

 Method 1: Click “Compiler” > ”  Instruction => Ladder(L)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F10) 

■ SFC=> Instruction(C)  Convert SFC diagram to instruction (Before converting 
SFC diagram to ladder diagram, it needs to convert SFC diagram to instruction 
first.)  

 Method 1: Click “Compiler” > ”  SFC=> Instruction (C)” 

 Method 2: Click the icon  on the toolbar  

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F11)  

■ Instruction =>SFC (S)  Convert instruction to SFC diagram 
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 Method 1: Click “Compiler” > ”  Instruction =>SFC (S)” 

 Method 2: Click the icon  on the toolbar  

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F12)  
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2.8 Comments 

The “Comments” function is shown as follows: 

 

■ Edit Device Comments(D) you can have comment for device while cursor is on 
the instruction with operand.  

 Method 1: Click “Comment” > ”  Edit Device comments(D)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (D).  

 Method 3: Right-click to get pop-up menu and select “Edit Device comments” in 
the pop-up menu. 

■ Edit Segment Comments you can have segment comment in the blank row. 
(Only for ladder diagram mode)  

 Method 1: Click Comment > ”  Edit Segment Comments (B) ”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (B).  

 Method 3: Right-click to get pop-up menu and select “Edit Segment Comments” 
in the pop-up menu. 

■ Edit Row comments  you can have row comment after output coil or instruction 
of each row (Only for ladder diagram mode) 

 Method 1: Click “Comment” > ”  Edit Row comments(L)”.  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (L).  

 Method 3: Right-click to get pop-up menu and select “Edit Row comments” in 
the pop-up menu. 
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2.9 Search 

The “Search” function is shown as follows: 

 

■ Go to(J)  used to jump to designated location (unit: Step)  

 Method 1: Click “Search” > ”  Go to(J)”  

 Method 2: Click the icon on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (J) 

■ Search/Replace(F)  search or replace designated device name and instruction  

 Method 1: Click “Search” > ”  Search/Replace(F)”  

 Method 2: Click the icon  on the toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F)  

■ Go to the Start(T)  jump to program start 

 Method 1: Click “Search” > ” Go to the Start (T)” 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Home)  

■ Go to the End(N)  jump to the end of program 

 Method 1: Click “Search” > ” Go to the End (N)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (End)  
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2.10 View 

The “View” function is shown as follows: 

 

■ Toolbars  tools of status bar, standard, ELC, Ladder diagram and SFC diagram 
is included. 

▲ Status bar: display or hide status bar. 

 Method: Click “View” > “Toolbars(T)” > “Status bar“ 

▲ Standard: display or hide standard tools.  

 

 Method: Click “View” > “Toolbars(T)” > “Standard” 

▲ ELC: display or hide ELCSoft toolbar.  

 

 Method: Click “View” > “Toolbars(T)” > “ELC”  
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▲ Ladder diagram: display or hide ladder diagram toolbar. (Only for ladder 
diagram mode)  

 

 Method: Click “View” > “Toolbars(T)” > “Ladder diagram” 

▲ SFC diagram: display or hide SFC diagram toolbar. (Only for SFC diagram 
mode)  

 

 Method: Click “View” > “Toolbars(T)” > “SFC diagram”  

■ Workspace(W)  display or hide project work area. You can click related windows 
and detect or set communication. 

 

 Method: Click “View” > “Workspace(W)” 

■ Output Window(M)  display or hide output window. The error message after 
executing compiler, grammar check and SFC compile will be shown in output 
window. 

 Method: Click “View” > “Output Window(M)” 
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■ Monitoring Data Format(N) convert the register content to different number 
system in ladder monitor mode. The number system can be signed decimal, 
hexadecimal and ASCII in ladder monitor mode and device monitor mode. 
Moreover, number system can be unsigned decimal, BCD or binary when 
right-click in device monitor mode.  

 Method: Click “View” > “Monitoring Data Format (N)” 

■ Zoom(Z)  you can zoom in  or zoom out  the window and the settings 
can be 50 %, 75 %, 100 %, 125 %, 150 %, 175 % and 200 %.   

 Method 1: Click “View” > “Zoom (Z)” 

 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Alt) + (I) or click 
the icon  on the toolbar to zoom in.  

 Method 3: Use keyboard shortcuts by pressing keys (Shift) + (Alt) + (O) or click 
the icon  on the toolbar to zoom in.  

■ Instruction List(I)  change to instruction mode  

 Method 1: Click “View” > “  Instruction List(I)”  
 Method 2: Click the icon  on the toolbar  

 Method 3: Double click instruction list in project tree diagram. (You can get a 
project tree diagram after clicking view > workspace.)  

■ Ladder Diagram(L)  change to ladder diagram mode  

 Method 1: Click “View” > “  Ladder Diagram(L)”  

 Method 2: Click the icon  on the toolbar 

 Method 3: Double click Ladder Diagram in project tree diagram. (You can get a 
project tree diagram after clicking view > workspace.) 

■ SFC Diagram(S)  change to SFC diagram mode  

 Method 1: Click “View” > “  SFC Diagram(S)”  

 Method 2: Click the icon  on the toolbar 

 Method 3: Double click SFC Diagram in project tree diagram. (You can get a 
project tree diagram after clicking view > workspace.)  
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■ Edit Device Comments(D) display all device comments (you can edit all device 
comments in this window) 

 Method 1: Click “View” > “  Edit Device Comments(D)” 

 Method 2: Click the icon  on the toolbar 

 Method 3: Double click Edit Device Comments in project tree diagram. (You can 
get a project tree diagram after clicking view > workspace.)  

■ List of Used Device(U)  display all device usage status  

 Method 1: Click “View” > “  List of Used Device(U)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl)+ (Alt) + (U)  

 Method 3: Double click Edit Device Comments in project tree diagram. (You can 
get a project tree diagram after clicking view > workspace.)  

■ Cross Reference List(F)  check the repeated use of the basic instructions OUT, 
SET, RST, TMR, CNT, DCNT, PLS and PLF.   

 Method 1: Click “View” > “  Cross Reference List(F)”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (K)  

■ Show Comments(M)  display or hide device comments. 

 Method 1: Click “View” > “  Show Comments(M)” 

 Method 2: Click the icon  on the toolbar 

■ Symbol Table(B)  display Symbol Table. 

 Method 1: Click “View” > “  Symbol Table(B)” 

 Method 2: Click the icon  on the toolbar 
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3.1 Creating Documents 

ELCSoft lets users create a blank document by clicking the icon  on toolbar or clicking 

“File” > “New(N)”. The methods of creating a new file are listed as follows:  

 Method 1: Click “File” > “New(N)” 

a. Click “File” > “New(N)” to create a blank document. 

 

b. Then, the dialog box of “ELC Type Setting” will pop up and you can set program title, 

ELC type, program capacity and file name. 
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c. You can design a new program and set ELC type via this dialog box. After ELC type 

is determined, ELCSoft will select the available program capacity (Steps) 

automatically.  

d. The program title is used to record the basic functions explanation of the program. 

For example, if all control functions edited in this program are concerned with 

Inverters, it is thus named as “TEST”. 

e. By default in ELCSoft, created documents are all saved to the file name extension 

as “* .epc” and the first filename of a new document will be named as ” doc0.epc”. 

(When creating a new document, ELCSoft will check automatically whether there is 

an existing filename named as doc0.epc in the folder. If this “doc0.epc“ filename 

already existed, ELCSoft will save the document to doc1.epc, the next number 

follows the pre-set filename, and so forth). 

The following figure is the window when a new file is created:  

 

 Method 2: Click the icon  on toolbar to create a new blank document. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (N) to create a new blank 

document. 
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3.2 Opening Documents 

ELCSoft utilizes the project-by-project conducts. Thus, users can only open one document 

at a time. Users can select an old file that users want to open in the “Open” dialog box. If 

users want to edit two ELC programs at the same time, simply execute the ELCSoft editor 

twice, and then user can conduct functions such as editing, copying, cutting and pasting in 

two ELC programs simultaneously. 

ELCSoft lets users open an old file by clicking the icon  on toolbar or clicking “File” > 

“Open(O)”. The methods of opening an old file are listed as follows:  

 Method 1: Click “File” > “Open(O)” 

a. Click “File” > “Open(O)” to open an old document stored on your hard disk. 
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b. The “Open(O)” Dialog Box:  

 

You can open a document you want that stored on your hard disk in the following 

ways: 

■ Look in  Locate the hard disk and the folder where the “*.epc” file you want 
is stored. 

■ File name  Type or select the filename you want in the File name box.
From this dialog box, you can see all files with different file names which the 
file name extension is “*.epc”. 

■ Files of type  Select the file format you want in the Files of type box; for 
example, type *.epc to find ELC files. 

 Method 2: To quickly open an existing document, click the icon  on toolbar.  

 Method 3: To quickly open an existing document, use keyboard shortcuts by pressing 

keys (Ctrl) + (N). 

Up to five old files can be stored in ELCSoft, therefore, users can double-click the filename 

directly and open it.  

3.3 Saving Documents 

ELCSoft lets users save editing file by clicking the icon  on toolbar or clicking “File” > 

“Save(S)”. The editing file can be saved by its original filename in the current folder. The 

methods of saving a file are listed as follows: 
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 Method 1: Click “File” > “Save(S)” 

 

 Method 2: To quickly save a document, click the icon  on toolbar. 

 Method 3: To quickly save a document, use keyboard shortcuts by pressing keys (Ctrl) + 

(S). 

3.4 Saving Copies of Documents 

ELCSoft lets users save a copy of a document by clicking “Save as(A)” on the File menu. 

The editing program can be saved on the hard disk as a different name. If this is the first 

time you have saved the document, ELCSoft will save the document by using a default 

filename. Before saving a document, if you want to change the filename of the document or 

save the document in different folder, click “Save as(A)”. The methods of saving a copy of a 

document are listed as follows:  
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 Method 1: Click “File” > “Save as(A)” 

 

Type a new name for the document and click the button “Save”. 
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If you select "save as" and ELC file type, it will store all the generated files into designated 

folder. You can also select "save as" and "ECL project type", it will generate a new folder 

that named with file name and store all generated files into new folder. 

 
 Method 2: To quickly save a copy of a document, use keyboard shortcuts by pressing 

keys (Ctrl) + (Alt) + (S). 

3.5 Printing 

When the programs are completed, ELCSoft provides extensive options for printing your 

work. In the ELCSoft, you can click the icon  on toolbar or choose “Print(P)” command 

from the “File” menu to print the data in the currently-active window. Therefore, if you click 

the icon  on toolbar or choose “Print(P)” command from the “File” menu when the 

ladder diagram edit window is active, the ladder diagram will be printed. ELCSoft allows 

users to print: ladder diagrams, SFC diagrams, instructions, editing register devices and 

device comments. Please refer to the following for more introductions on Printing function. 

■ Printing Ladder Diagrams 

In ladder diagrams mode (when the ladder diagram edit window is active), click the icon 

 on toolbar or choose “Print(P)” command from the “File” menu. The printing dialog box 

will pop up and then users can select printing options to print the ladder diagrams. Users 

can choose to print all or partial document in the selection box and decide the printing 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


3 Creating Programs and Printing 

 3-8

range that users specify (Start and End). Also, users can determine if the title, page 

numbers and cover are printed out or not. Clicking “Preview” button can check how the 

document is going to look before printing it. Clicking “Printer setup” button can setup the 

printer and the layout of the whole document. 

If the printed out data is the same as displayed result, it indicates that the comments can 

also be printed out if there are comments displayed on the ladder diagrams. 

■ Printing SFC Diagrams  

In SFC mode (when the SFC diagram edit window is active), click the icon  on toolbar 

or choose “Print(P)” command from the “File” menu to print the SFC diagrams. When the 

printing dialog box pops up and then users can select printing options to print the SFC 

diagrams. Users can choose to print all or partial document in the selection box and decide 

the printing range that users specify (Start and End). Also, users can determine if the title, 

page numbers and cover are printed out or not. Clicking “Preview” button can check how 

the document is going to look before printing it. Clicking “Printer setup” button can setup 

the printer and the layout of the whole document. 
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■ Printing Instructions 

In the instructions mode (when the instruction mode window is activate), click the icon  

on toolbar or choose “Print” command from the “File” menu. The printing dialog box will pop 

up and then users can select printing options to print the instructions. Users can choose to 

print all or partial document in the selection box and decide the printing range that users 

specify (Start and End). Also, users can determine if the title, page numbers and cover are 

printed out or not. Clicking “Preview” button can check how the document is going to look 

before printing it. Clicking “Printer setup” button can setup the printer and the layout of the 

whole document.  
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■ Printing Editing Registers (T, C, D) and Bit Memory (M, S) 

When the registers or devices editing windows is activate, click the icon  on toolbar or 

choose “Print” command from the “File” menu. The printing dialog box will pop up and then 

users can select printing options to print the editing registers or devices. Users can choose 

to print all or partial document in the selection box and decide the printing range that users 

specify (Start and End). Also, users can determine if the title, page numbers and cover are 

printed out or not. Clicking “Preview” button can check how the document is going to look 

before printing it. Clicking “Printer setup” button can setup the printer and the layout of the 

whole document.  

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


3 Creating Programs and Printing 

 3-11

■ Printing Device Comments  

When the device comments editing window is activate, click the icon  on toolbar or 

choose “Print” command from the “File” menu. The printing dialog box will pop up and then 

users can select printing options to print the device comments. Users can choose to print 

all or partial document in the selection box and decide the printing range that users specify 

(Start and End). Also, users can determine if the title, page numbers and cover are printed 

out or not. Clicking “Preview” button can check how the document is going to look before 

printing it. Clicking “Printer setup” button can setup the printer and the layout of the whole 

document. 
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■ Printing Editing File Registers Memory 

When the File Registers Memory editing windows is activate, click the icon  on toolbar 

or choose “Print” command from the “File” menu. The printing dialog box will pop up and 

then users can select printing options to print the editing registers or devices. Users can 

choose to print all or partial document in the selection box and decide the printing range 

that users specify (Start and End). Also, users can determine if the title, page numbers and 

cover are printed out or not. Clicking “Preview” button can check how the document is 

going to look before printing it. Clicking “Printer setup” button can setup the printer and the 

layout of the whole document.  
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■ Printing Symbol table  

When the Symbol table editing window is activate, click the icon  on toolbar or choose 

“Print” command from the “File” menu. The printing dialog box will pop up and then users 

can select printing options to print the device comments. Users can choose to print all or 

partial document in the selection box and decide the printing range that users specify (Start 

and End). Also, users can determine if the title, page numbers and cover are printed out or 

not. Clicking “Preview” button can check how the document is going to look before printing 

it. Clicking “Printer setup” button can setup the printer and the layout of the whole 

document. 
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4.1 Editing Environment 

Start up ELCSoft, and click “New” to create a new screen or click “Open” to open an old file. 

Then, users can enter into the editing environment of ladder diagram mode and use ladder 

diagrams to create ELC programs as shown as the figure below.  

 

There is a ladder diagram toolbar shown on the top of the ladder diagram mode window. To 

create and edit a ladder diagram, you can click the icon on toolbar directly by mouse or 

move the editing block to the proper position and enter instructions. Besides, you also can 

press the F1 ~ F12 function keys on the keyboard to create and edit the ladder diagram. 

Please refer to the following sections for how to create and edit ladder diagram.  

4.2 Basic Operation 

Example: Create the diagram shown below  
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■ Using Mouse and F1 ~ F12 function keys on the keyboard.  

1. Click “File” > “New” (refer to section 3.1) to create a new document, and enter the 

ladder diagram mode shown below. 
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2. Click the Normally Open Contact icon  on toolbar or press F1 function key. 

 

3. The “Device Input” dialog box will appear. You can select device name (e.g. M) and 

number (e.g. 10), and enter comments (e.g. Internal Relay). Then, press the button 

“OK” to save the setting. 
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4. Click the Output Coil icon  on toolbar or press F7 function key. The “Device Input” 

dialog box will appear. You can select device name (e.g. Y) and number (e.g. 0), and 

enter comments (e.g. Output Coil). Then, press the button “OK” to save the setting.  

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-5 

5. Click Application Instruction icon  or press F6 function key. Choose “Functions” in 

the Function List box and select “END” instruction from the pull-down menu or type the 

“END” instruction in the Application Instruction list box. Then, press the button “OK” to 

save the setting.  

 

6. Click the icon  to compiler ladder diagram and convert the ladder diagram to 

instruction. After compiler action is completed, the numbers of steps will show on the 

left-hand side of the start of the ladder diagram.  
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7. If the ladder diagram is not correct, a Ladder Diagram Error message dialog box will 

appear and point out the exact erroneous rows and addresses after the compiler action 

is completed.  

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-7 

■ Keyboard Operation  

1. Place the editing block at the start of the document, and type LD M10 (or A M10) by 

using the keyboard. Then, press the Enter key on the keyboard, or click the button 

“OK” to complete the setting.  

 

2. Type OUT Y0 (or O Y0) and press Enter key on the keyboard. Then, type END and 

press Enter key on the keyboard. Finally, click the icon  to compiler the completed 

ladder diagram.  

If you want to edit the comments at the same time when input an instruction by using 

keyboard, you can click the “Prompt to Edit Device Comment(H)” under the “Options” menu. 

Then, the “Comment” dialog box (see the figure below) will appear for you to enter and edit 

the corresponding comments after an instruction is input correctly.  
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4.3 Editing Example 

■ Ladder Diagram  

 

■ Operation Steps of Editing the Ladder Diagram: 

Step Ladder 
Symbol Cursor Location Input by clicking the Icon on 

toolbar 
Input by using the 

Keyboard 

1  Row: 0, Column: 1  
*Footnote 1

Device name: X 
Device number: 1 LD X1 ↵ or A X1 ↵ 

2  Row: 0, Column: 2  
*Footnote 2

Device name: Y 
Device number: 1 OUT Y1 ↵ or O Y1 ↵

3  Row: 1, Column: 1  
Device name: X 
Device number: 2 LD X2 ↵ or A X2 ↵ 

4  Row: 1, Column: 2   F9 

5  Row: 1, Column: 2  
Device name: Y 
Device number: 2 OUT Y2 ↵ or O Y2 ↵

6  Row: 2, Column: 1  
Device name: X 
Device number: 1 LD X1 ↵ or A X1 ↵ 

7  Row: 3, Column: 1  
Device name: M 
Device number: 0 LD M0 ↵ or A M0 ↵ 
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Step Ladder 
Symbol Cursor Location Input by clicking the Icon on 

toolbar 
Input by using the 

Keyboard 

8  Row: 3, Column: 2  
*Footnote 3

MOV instruction 
OP 1: D Device 
number: 1 
OP 2: D Device 
number: 2 

MOV D1 D2  ↵ 

9  Row: 4, Column: 0  
Double click the 
mouse and enter 
P0 

P0  ↵ 

10  Row: 4, Column: 1  
Device name: M 
Device number: 1 LDP M1 ↵ or + M1 ↵

11  Row: 4, Column: 2   F9 

12  Row: 4, Column: 2  

CNT instruction 
OP 1: C Device 
number: 0 
OP 2: K Device 
number: 100 

CNT C0 K100  ↵ 

13  Row: 5, Column: 1  
Device name: M 
Device number: 1 LDF M1 ↵ or – M1 ↵

14  Row: 6, Column: 1  END instruction  END  ↵ 
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■ After the ladder diagram is completed, you can compiler and convert the completed 

ladder diagram to instruction code and SFC diagram. The ladder diagram is shown 

as the figure below: 

 

*Footnote 1: Input Basic Instruction 

1. Click the icon  on toolbar or press the F1 function key on the keyboard and the 

“Device input” dialog box will appear. Then, you can enter device name and number, 

and edit comments in this dialog box.  
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2. For example, select or type the device name “X” and device number “1”. Then, press 

Enter key on the keyboard or click the button “OK” to save the setting.  

 

*Footnote 2: Input Output Coil 

1. Click the icon  on toolbar or press the F7 function key on the keyboard and the 

“Device input” dialog box will appear. Then, you can enter device name and number, and 

edit comments in this dialog box. 

 

2. For example, select or type the device name “Y” and device number “1”. Then, press 

Enter key on the keyboard or Click the button “OK” to save the setting. 

*Footnote 3: Input Application Instruction  
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1. Click the icon  on toolbar or press the F6 function key on the keyboard. Then, the 

“Application instruction” dialog box will appear. 

 

2. First, choose one selection in the function list menu (including all application 

instructions and output commands, etc.). Then, select the API Number or choose the 

instruction from pull-down menu, or type the name of the instruction directly, e.g. MOV 

in the application instruction list box. After all settings are completed, press Enter key 

on the keyboard. 
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3. Select “Transfer and Compare” from pull-down menu in the function list box and type 

“MOV” into the “Application Instruction” list box directly (or choose “MOV” instruction 

from pull-down menu in the “Application Instruction” dialog box). Then, press Enter key 

on the keyboard, and the dialog box shown below will appear on the screen.  

 

4. Input device name in “OP1” (Operand 1) and “OP2” (Operand 2) list box, and device 

number in “Device Number” list box in order. Select index register E or F if it exists. 

Then, press the button “OK” to save the setting.  

5. Moreover, you can also double click the mouse on the “@” or “*” symbol in the device 

reference table (refer to the figure above) to designate the device name (The symbol @ 

indicates this device can be modified by index register E or F and the symbol * 

indicates this device can not be modified by index register E or F) 
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4.4 Ladder Diagram Editing Explanation 

♦ Input Brevity Code  

■ ELCSoft provides several brevity codes for yours to input Instructions more quickly 

and conveniently when editing a ladder diagram.  

Explanation  Instruction
Icon 

Instruction Code 
(Mnemonic Code)

Brevity 
Code Example 

Normally open contact   LD  A LD M0 or A M0 
Normally closed contact  LDI  B LDI M0 or B M0 
Rising pulse  LDP  + LDP M0 or + M0 
Falling pulse   LDF  – LDF M0 or – M0 
Output coil   OUT  O OUT M0 or O M0 

♦  Insert / Replace Mode  

■ Use the Insert key on the keyboard can switch to the Insert Mode or the Replace 

Mode when editing a ladder diagram. 

 If the “Replace” word is displayed on the status bar, press the Insert key on the 

keyboard could switch to the Insert Mode. In the Insert Mode, insert a new ladder 

diagram to where the editing block locates, and the original ladder diagrams 

following the new diagram would shift one space to the right.  

 If the “Insert” word is displayed on the status bar, press the Insert key on the 

keyboard could switch to the Replace Mode. In Replace Mode, insert a new ladder 

diagram could replace the original ladder diagram located in the editing block, and 

the following other ladder diagrams would not be changed.  
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♦  Editing 

■ Undo: Undo an action you perform. (ELCSoft allows you can undo 10 times 

maximum) 

 Method 1: Click “Edit” > “Undo” 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Z) 

 Method 4: Right click the mouse and select the “Undo” command in the pop-up menu 

■ Redo: Redo an action. If you don’t like the result of undoing an action, you can redo 

it. 

 Method 1: Click “Edit” > “Redo”. If you click “Redo” after an Undo action, it can return 

to the last action before you undo it. 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (Z) 
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 Method 4: Right click the mouse and select the “Redo” command in the pop-up menu 

. Select Block: drag the cursor to select the 
block you want. Delete the selected block. 

 

. After delete the block, the programs listed 
below the block will move up. Then, click the 
icon  (“Undo”). 

 

. It will return to its previous status (the most 
recent action). 

 

. After return to its previous status, click the 
icon  (“Redo”), the programs listed below 
the block will move up.  

 

■ Delete: Delete the selected block, e.g. devices 

 Method 1: Click “Edit” > “Delete” 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing key (Delete) 
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 Method 4: Right click the mouse and select the “Delete” command in the pop-up 

menu 

 

■ Delete Rows: Delete a row or several rows in the ladder diagram 

 Method 1: Click “Edit” > “Delete Rows” 

 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Y) 

 Method 3: Right click the mouse and select the “Delete Rows” command in the 

pop-up menu 

 Method 4: Select the block that you want to delete and right click the mouse to select 

the “Delete Rows” command in the pop-up menu or pressing the Delete 

key on the keyboard. Clicking the icon  on toolbar also can delete the 

selected block. 
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■ Delete Vertical Line: Delete the vertical line on the left-hand side of the editing block 

 Method 1: Click “Edit” > “Delete Vertical Line” 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (D)  

 Method 3: Move the editing block to the right-hand side of the vertical line that you 

want to delete and click the icon  on toolbar. Then, the vertical line 

would be deleted.  

 Method 4: Move the editing block to the right-hand side of the vertical line that you 

want to delete. Right click the mouse and select the “Delete Vertical Line” 

command in the pop-up menu. Then, the vertical line would be deleted 

(refer to the figure below). 
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■ Delete Block: Deleted the selected block 

 Method 1: Selected the block that you want to delete and then click “Edit” > “Delete” 

 

 Method 2: Select the block that you want to delete and click the icon  on toolbar. 

 Method 3: Select the block that you want to delete and right click the mouse to select 

the “Delete” command in the pop-up menu.  

 Method 4: Select the block that you want to delete and press the Delete key on the 

keyboard.  

■ Copy Block: Copy the selected block 

 Method 1: Click “Edit” > “Copy”  

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (C) 
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 Method 4: Right click the mouse to select the “Copy” command in the pop-up menu 

 

■ Cut Block: Cut the selected block 

 Method 1: Click “Edit” > “Cut”  

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (X) 

 Method 4: Right click the mouse and select the “Cut” command in the pop-up menu 

■ Paste Block: Paste the selected block 

 Method 1: Click “Edit” > “Paste”  

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (V) 

 Method 4: Right click the mouse and select the “Paste” command in the pop-up 

menu 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-21

■ Insert Block (Before inserting the selected block, perform “Copy Block” action first) 

 Method 1: Click “Edit” > “Insert Block” 

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Ins) 

 Method 3: Right click the mouse and select the “Insert Block” command in the 

pop-up menu. 

 

●  Compiler 

This function is used to compile current ELC programs. If the you complete the editing of 

the ladder diagram in the ladder diagram mode, performing this function will check whether 

the ladder diagram is valid or not, and if the conversion is correct, the ladder diagram could 

thus be converted to the instruction program or the SFC diagram. And at the same time, 

the program memory addresses (numbers of steps) for each editing block will appear on 

the left-hand side of the start of the ladder diagram. However, if an error occurred, a ladder 

diagram error message dialog box will appear, display the error code and point out the 

exact erroneous addresses after the compiler action is completed (please refer to the ELC 

user manual). 

If the program editing is completed in the instruction mode when performing this function, it 

will start to check whether the conversion is correct or not, and if the conversion is correct, 

the instruction program will be converted to the ladder diagram. However, if error occurred, 

an error message dialog box will appear, display the error code and point out the exact 

erroneous steps after the compiler action is completed (Please refer to the ELC User 

Manual). 
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Error message dialog box: 

In ladder diagram mode:  
 

 

In ladder diagram mode: 

In instruction mode: 

 

■ Ladder Diagram => Instruction (only for ladder diagram mode) 

 Method 1: Click “Compiler” > “Ladder => Instruction” 

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-23

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F9)  

■ Instruction => Ladder Diagram (only for Instruction mode) 

 Method 1: Click “Compiler” > “Instruction => Ladder” 

 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F10) 

■ Instruction => SFC (only for Instruction mode) 

 Method 1: Click “Compiler” > “Instruction => SFC”  

 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F12) 

■ SFC => Instruction (only for SFC mode) 

 Method 1: Click “Compiler” > “SFC => Instruction” 

 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F11) 
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♦  Cross Reference List 

Select this command to examine the programs and check the device repeated use 

condition of the application instructions, such as OUT, CNT, TMR, DCNT, SET, RST, PLS, 

and PLF, etc.  

 Method 1: Click “View” > “Cross Reference List”. The “Cross Reference List” dialog 

box will appear. You can tick the instructions that you want to examine and 

then press the button “OK”. Then, it will start the examination and display 

the result after examination. If there is a double circuit in the program, the 

repeated addresses will be shown on the screen.  

 

  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (K) 

♦ Search 

■ Go to 

This command is used to specify the program to jump to a designated location (unit: Step). 

If the designated step already exists, the program will jump to this existing designated step 

and put it in the first line. 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-25

 Method 1: Click “Search” > “Go to” 

 

For example, enter the designated step, e.g. 35 where you want to jump to, and then the 

ladder diagram will put this designated step in the first line (please refer to the figure 

below). 

 

 

 Method 2: Click the icon  on toolbar  

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (J) 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-26

■ Search/Replace  

The “Search/Replace” command is used to search and replace the device and instruction 

within the program (if only the “Search” command is conducted, simply enter the device 

name to be searched in the dialog box). If the device or the command is found, the view 

will be scrolled to the device or the command. Also, you can search and replace the device 

and instruction by specifying the type of the device and instruction.  

 Method 1: Click “Search” > “Search/Replace” 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (F)  

When choose this “Search/Replace” command, the following dialog box will appear. You 

can select “search device”, “replace device”, “search instruction” and “replace other 

instruction” these four functions in this dialog box.  
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 Search Device  

Use this command to search the specified device name in the program. From the example 

ladder diagram shown below, we can know the instructions that contain device Y1 are OUT 

Y1 and INC K4Y1. 

 

Choose the “Search Device” dialog box and enter device name “Y1” in the “Search Device” 

box and select the type “None” from the type list box (refer to the dialog box shown below). 

Then, press the button “Search”. Two instructions “OUT Y1” and “INC K4Y1” will be found. 
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If enter device name “Y1” in the “Search Device” box and specify the type “Fun.” from the 

type list box (refer to the dialog box shown below). Then, press the button “Search”. Only 

the instruction “INC K4Y1” will be found. 

 

 Replace Device 

Use this command to replace the specified device name in the program. For example, 

choose to open the “Replace Device” dialog box, enter the search device “X0”, select the 

type “LD”, and enter the replace device “M100”, select the type “LD” and specify the device 

number as “10”. Then, press the button “Replace”, and the instructions will be changed to 

LD M100~M109. 

 
Original 

Command Replacement Condition  Replaced 
Command 

LD X0~X7 

LD X10~X11 

Type LD + Device X0  Type LD + Device M100 

Device number: 10 

LD M100~M107

LD M108~M109

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-29

If you specify the device type as None, Out and Fun these three types, it only can replace 

the device with the same type. Otherwise, a warning message shown below will appear.   

 

 Restrictive Conditions  

In “Replace Device” dialog box, only the devices of the same type could be replaced, e.g. if 

D1 is replaced by D11, it is thus viewed as successful, but if it is replaced by C100, it is 

then a failure. 

 Search Instruction  

Use this command to search the specified device name in the program. Choose to open 

the “Search Instruction” dialog box, and enter the instruction name that we are looking for. 

Then, press the button “Search”.  

ELCSoft will record all the instruction names that you had searched before. Next time, if 

you want to search the instructions that you had searched before, you can just choose the 

instruction name from the pull-down menu in “search instruction” box.  
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 Replace Other Instruction  

ELCSoft provides the condition replace functions of SET, RST, PLS and PLF, these four 

kinds of instructions. User can replace the devices that meet the condition of these 

instructions in the program. For example, if user wants to replace SET M0 ~ M35 with SET 

Y0 ~ Y43, user can perform the settings shown in the figure below. 

 

■ Go to the Start: Jump to the start of the program.  

 Method 1: Click “Search” > “Go to the Start”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (Home) 

■ Go to the End: jump to the end (last row) of the program. 

 Method 1: Click “Search” > “Go to the End”  

 Method 2: Use keyboard shortcuts by pressing keys (Ctrl) + (End) 

♦  Copy between Files 

If user wants to edit two or more than two ELC programs at the same time, simply execute 

ELCSoft for two or more than two times, and then user could edit different ladder diagrams 

in different ELCSoft editor windows simultaneously. 

 

ELCSoft allows user can perform “Copy Block” action from one file to another file. This 

copy function can be used in the instruction mode (please refer to Section 5.3) and ladder 
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diagram mode only. User can copy the selected block in the ladder diagram mode of one 

file (the first ELCSoft window) and paste them onto the ladder diagram mode of another file 

(the second ELCSoft window). In other word, user can perform copy and paste function 

between different files but their editing mode should be the same. ELCSoft does not allow 

user to copy and paste in different files if their editing modes are not the same. Therefore, if 

user copy the selected block in the ladder diagram mode of one file and paste them on the 

instruction mode of another file, the copied block will not be copied or pasted.  

1. Copy the selected block from the ladder diagram mode of the first ELCSoft window. 

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


4 Ladder Diagram Mode 

 4-32

2. Paste the copied block onto the ladder diagram mode of the second ELCSoft window. 
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3. Copy between these two files is completed. 

 

4.5 Symbol Editing Explanation 

1. Click “View” > “Symbol Table(B)”  to get "Symbol table" window 
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2. The symbol that corresponds to edited device name. It can use Device Name and 

Symbol to input when editing program. In symbol mode, you can also input symbol 

name to search or replace. 

 

3. Click “Options” > “  Font Setting and Comment Format” choice symbol name 

display enabled, or Click the icon  on the toolbar. 

Device Name mode: 
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Symbol mode: 
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ELCSoft provides three modes for editing ELC programs. The ladder diagram mode 

(Please refer to Chapter 4) and instruction mode are two familiar operation modes for users 

to edit ELC programs. These two modes can be converted to each other through 

compiling.  

5.1 Editing Environment 

 

5.2 Basic Operation 

This section describes various functions (include Delete, Insert, Block Copy and Replace, 

etc.) that provided by ELCSoft for creating and editing the instruction programs. 

■  Input ELC Instructions 

After entering the instruction mode, type a complete ELC instruction immediately. If the 

instruction format is valid, press the Enter key on your keyboard to complete the setting. 

The instructions that you type will locate in the editing area and the program memory 

address of ELC will appear on the left-hand side of the program. Thus, users can get the 

corresponding program memory address of the instruction clearly. Please refer to ELC 

User Manual for the formats of all instructions. 
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Enter the Instruction Mode: 

1. Execute ELCSoft and choose “New” command to create a new document (or click the 

icon  on toolbar). Then click “View” > “Instruction List(I)” (or click the icon  on 

toolbar) 

 

2. Start to input instruction program at the blue highlighted editing row.  
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■  Input Operation Example  

Instruction program…refer to the following table and input programs 

(0000) LD X1 
(0001) OR M0 
(0002) OUT Y1 
(0003) MOV D1 D2 
(0008) OUT Y2 
(0009) END  

After an instruction program is completed, it can be converted to the ladder diagram and 

SFC diagram through compiling. 

 

The converted ladder diagram is shown as the figure below: 

 

No matter you are editing programs in ladder diagram mode, instruction mode or SFC 

mode, if the program is edited or revised, be sure to compile the program before writing it 

into ELC (please refer to Section 4.4). 
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5.3 Instruction Diagram Editing Explanation 

Insert / Replace Mode 

Use the Insert key on the keyboard can switch to the Insert mode or the Replace mode. If 

the “Replace” word is displayed on the status bar, pressing the Insert key on the keyboard 

could switch to the Insert mode. 

1. Enter the Insert mode, and if the following program has already existed: 

 

2. Move the blue highlighted editing row to the position of STEP 00002 (OUT Y1). 
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3. Type AND X1, and then press Enter key. 

As the figure is shown below, the new instruction AND X1 is inserted into the row between 

instruction OR M0 and MOV D1 D2.  

 

 

If the “Insert” word is displayed on the status bar, pressing the Insert key on the keyboard 

could switch to the Replace mode.  

1. Enter the Replace Mode, and if the following program has already existed: 
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2. Move the blue highlighted editing row to the position of STEP 00002 (OUT Y1). 

 

3. Type AND X1, and then press Enter key. 

As the figure is shown below, the OUT Y1 is replaced with the new instruction AND X1. 
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Editing 

■  Undo: Undo an action you perform. (ELCSoft allows you can undo 10 times maximum) 

 Method 1: Click “Edit” > “Undo”. 

 Method 2: Click the icon  on toolbar. 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Z). 

 Method 4: Right click the mouse and select the “Undo” command in the pop-up 

menu. 

1. Select Block: drag the cursor to 
select the block you want. 

 

2. Delete the selected block. 
 

 
 
3. After delete the block, the programs 

listed below the block will move up. 
Then, click the icon  (“Undo”). 

 

 
4. It will return to its previous status (the 

most recent action).  
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■   Redo: Redo an action. If you don’t like the result of undoing an action, you can redo it. 

 Method 1: Click “Edit” > “Redo”. If you click “Redo” after an Undo action, it can return 

to the last action before you undo it.  

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (Z) 

 Method 4: Right click the mouse and select the “Redo” command in the pop-up 

menu  

■  Select Block 

To select block that you want, point to where you want to start selecting the block, and drag 

to where you want it to end by your mouse.  

1. Use your mouse to point to where you want to start selecting the block.  

 

2. Drag to where you want it to end.  

 

The above blue highlighted area is thus the “Selected Block”. 
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■  Copy Block: Copy the selected block 

 Method 1: Click “Edit” > “Copy”  

 Method 2: Click the icon  on toolbar 

 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (C) 

 Method 4: Right click the mouse to select the “Copy” command in the pop-up menu 

 

■  Cut Block: Cut the selected block 

 Method 1: Click “Edit” > “Cut” 

 Method 2: Click the icon  on toolbar 

 Method 3: Use keyboard shortcuts by pressing keys (Ctrl) + (X) 
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 Method 4: Right click the mouse and select the “Cut” command in the pop-up menu 

 

 

The selected block is cut.  

 

■  Delete Block: Delete the selected block 

 Method 1: Click “Edit” > “Delete” 

 Method 2: Press the Delete key on the keyboard. 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


5 Instruction Mode 

 5-11

 Method 3: Right click the mouse to select the “Delete” command in the pop-up 

menu. 

 Method 4: Click the icon  on toolbar 

■  Paste Block: Paste the selected block 

1. Copy the block (refer to the copy methods mentioned on page 5-7 and 5-8) -> Move 

the copied block (blue highlighted block) to where you want to insert or paste -> Click 

the icon  on toolbar. No matter you are editing in the Insert mode or Replace 

mode, the original content will move down when the copy block (blue highlighted 

block) is inserted or pasted. 

 

2. The blue highlighted block is in the position of 00012. After “Paste Block” action is 

performed, the previously selected block will be pasted in the position of 00012. 
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■  Copy between Files 

If user wants to edit two or more than two ELC programs at the same time, simply execute 

ELCSoft for two or more than two times, and then user could edit different ELC programs in 

different ELCSoft editor windows simultaneously. 

ELCSoft allows user can perform “Copy Block” action from one file to another file.  This 

copy function can be used in ladder diagram mode (please refer to Section 4.4) and 

instruction mode only.  Users can copy the selected block in the instruction mode of one 

file (the first ELCSoft window) and paste it onto the instruction mode of another file (the 

second ELCSoft window.)  In other word, users can perform copy and paste function 

between different files but their editing mode should be the same. Due to different editing 

environment, ELCSoft does not allow user to copy and paste the selected block in different 

files if their editing modes are not the same. Therefore, if user copy the selected block in 

the instruction mode of one file and paste them onto the ladder diagram mode of another 

file, the copied block will not be copied or pasted.  

1. Copy the selected block from the instruction mode of the first ELCSoft window.  

 

2. Paste the copied block onto the ladder diagram mode of the second ELCSoft window. 
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3. Copy between these two files is completed. 
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In the ladder diagram mode, there are three operating modes for editing comments: Device 

comments, Segment comments and Row comments. However, while within the SFC mode 

and instruction mode, only “Edit Device Comments” function is provided. Please refer to 

the following for more introductions on editing comments. 

Ladder Diagram Mode:  
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■ Edit Device Comments(D):  

Move the editing block on the desired device and right click your mouse. The pop-up menu 

box shown on the above figure will appear. From this pop-up menu, choosing “Edit Device 

Comments” can enter and edit device comments. After the comments editing is completed, 

press “Enter” key on your keyboard or click the button “Close” by your mouse to have the 

record saved. 
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■ Edit Row Comments(L): (Only for ladder diagram mode) 

Enable this function, and then you can edit all row comments at the same time. 

 

■ Edit Segment Comments(B): (Only for ladder diagram mode) 

After the segment comments editing is completed, press the button “OK”. 
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SFC Mode: (only “Edit Device Comments” function is provided) 

 

 

Instruction Mode: (only “Edit Device Comments” function is provided) 
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6.1 Edit Device Comments(D) 

In the ladder diagram mode, Instruction mode and SFC mode, user can set the comments 

to be displayed in the device.  

 Method 1:  

1. First, choose to enter the ladder diagram mode (Instruction mode or SFC mode). Move 

the editing block on the desired device. From the “Comments” menu, choose “Edit 

Device Comments(D)” or use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (D). 

 

2. The Comment dialog box will appear and you can edit comments for the desired device 

you choose, e.g. M1002 (If the device you choose is the special M and D device of ELC, 

you will see the preset comments shown in the Comment dialog box). After the device 

comments editing is completed, press “Enter” key on your keyboard or click the button 

“Close” by your mouse. 
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3. If you want to display or hide device comments in the ladder diagram mode, click “ ” 

on toolbar or choose “Show Comments(M)” from “View” menu. 

 

 Method 2: 

1. Choose to enter the ladder diagram mode (Instruction mode or SFC mode). Move the 

editing block on the desired device (such as MOV D1 D2). Right click your mouse and 

then the following pop-up menu will appear on the screen. 
 

In Ladder Diagram Mode: In SFC Mode: 

 

In Instruction Mode: 
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2. Choose “Edit Device Comments” from the pop-up menu, and the Comment dialog box 

will appear (see the figure below). Select the desired device, e.g. D2 and enter the 

comments for DATA 2. After the comments editing is completed, press “Enter” key on 

your keyboard or click the button “Close” by your mouse.  

 

 Method 3:  

1. Choose to enter the ladder diagram mode (Instruction mode or SFC mode). Move the 

editing block on the desired device. Then, choose “Show Comments(M)” from “View” 

menu or click “ ” on toolbar by your mouse. 
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2. Click “View” > “Edit Device Comments” to choose the device type, e.g. X. If the device 

comments are already edited, you will see a “*” symbol marked in front of the device.  

 

3. Click on the “Device Comment List” tab, and you can view all devices which their 

device comments are already edited. 
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4. Right click your mouse, the following pop-up menu will appear. ELCSoft allows users 

to copy the selected comments and paste them on a Microsoft Excel sheet that can be 

used to create and edit the technical documents of customer’s system. Also, ELCSoft 

allows users to copy the data from a Microsoft Excel sheet and paste them on the 

device comments editing area. 

 

6.2 Edit Row Comments(L) 

 Method 1:  

1. Move the editing block to the desired row. Right click your mouse and the pop-up 

menu below will appear. Click on “Edit Row Comments” to add and edit comments into 

the row.  
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2. After clicking on “Edit Row Comments”, the following dialog box will appear. Then, 

users can add and edit several row comments at the same time. After the comments 

editing is completed, close this dialog box to save the edited comments. 

 

 Method 2:  

Move the editing block on the desired device. From “Comments” menu, choose “Edit Row 

comments(L)” or use keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (L). The “Row 

comment” dialog box will appear. Then, users can enter the comments in each row. After 

the row comments editing is completed, close this dialog box to save the edited comments. 
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6.3 Segment Comments(B) 

 Method 1:  

Move the editing block to the blank area that you want to enter the segment comments 

(you also can use keyboard shortcuts by pressing keys (Ctrl) + (I) to insert a new row). 

Right click your mouse, and the pop-up menu below will appear. Then, choose “Edit 

Segment Comments” to enter the segment comments (60 characters maximum). Finally, 

press the button “OK” to complete the editing. 

 

 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


6 Editing Comments 

 6-12

 Method 2:  

Click “Comment” from the menu bar, and choose “Edit Segment Comments(B)” or use 

keyboard shortcuts by pressing keys (Ctrl) + (Alt) + (S) to enter and edit the segment 

comments. 

 

■ Show or Hide Comments 

User can show and hide the comment by clicking “View” > “Show Comments(M)” or 

clicking the icon  on toolbar. However, this function is provided for device comments 

and row comments only. Users cannot show and hide segment comments by using this 

function. When this function is enabled, the height of the ladder diagram will become higher 

in order to display the comments. 
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Before proceeding with the communication connection, please make sure that PC COM 

port and ELC communication port has finished connection setting. (the connection has 

been constructed between the RS232 communication port of PC and the communication 

port of ELC) ELCSoft provides various operation and control tools, such as device monitor, 

read/write register data to ELC, modem connection, communication setting, etc. It is 

convenient for you to edit, monitor or test by ELCSoft. 

7.1 Data Transmission 

■  COM port setting 

1. Before transmitting between ELCSoft and ELC, make sure that the PC and the ELC 

have completed the connection setting. 

2. Click “Options” > “Select COM Port(P)” to select COM port (COM port number is from 1 

to 8 and the COM port in relief cannot be selected (as shown below).   
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■ Read ELC 

When reading the ELC program after completing communication setting, the procedure is 

as follows:  

1. Click “Communication” > “Transfer Setup(C)” or click icon  on toolbar or use 

keyboard shortcuts by pressing keys (Ctrl) + (F1).  

 

2. To read data from ELC, select “Read from ELC” under the “Select Operation” after the 

transfer setup dialog window appeared.  
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3. If there is password setting in ELC, it will show a password enter dialog box. It will only 

allow reading data from ELC once after entering correct password. Moreover, you will 

get the error message when entering the wrong password.  

Step 1 

 

Step 2 
 

 

Step 3 

 

4. There are two methods to read from ELC: read whole data and partial data.  

a. Whole data: If there are 3792 STEPs of ELC, such as PB models, 3792 STEPs 

data will be read completely.  

b. Partial data: it will only read the partial ELC program from the start to the first 

END. It is recommended to use this method to save communication time.  

■ Write ELC 

1. You can transmit a new program to ELC by clicking “Communication” > “Transfer 

Setup(C)” or click icon  on toolbar or using keyboard shortcuts by pressing keys 

(Ctrl) + (F1).  

2. To write data from ELC, select “Write to ELC” under the “Select Operation” after the 

transfer setup dialog window appeared.  

3. If there is password setting in ELC, it will show a password enter dialog box. It will only 

allow writing data once to ELC after entering correct password. Moreover, you will get 

the error message when entering the wrong password.  
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4. There are two methods to write to ELC: write whole data and partial data. (footnote 1) 

a. Whole data: write whole data to the designated ELC. (as shown below)  

 

b. Partial data: you can set step range to write to ELC. If you select step range 

without setting start and end step. It will write the data from 0 step to the first end 

to ELC. (as shown below) 

   
＊footnote 1: 

Before executing “write to ELC”, make sure that the ELC is in STOP mode, or if ELC is 

in RUN mode, ELCSoft will then send out a warning message of “Cannot perform this 

operation in run mode” “Do you wish to continues if this instruction will affect the state of 

the connect ELC ?”(as shown below). If choose "Yes", ELCSoft will stop ELC first and 

write program into ELC. After completing, it will inquire you to return to RUN status or 

not. 
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■ HHP and PC Communication 

For the communication between PC and HHP, PC is the Slaver while the control power is 

held by HHP (which is the Master). First, connect HHP with PC first (the connection 

between the RS-232 communication port of PC and the communication port of HHP has 

been constructed, please refer to the HHP User Manual for the connection method). After 

clicking “File” > New” to get the new file, supply with the HHP power, and HHP is then at 

the (HHP→ PC) connection mode, and you could then READ/WRITE PC through the Menu. 

1. When reading HHP program by ELCSoft, the procedure is the same as create new 

project needed to set connection model and program capacity as shown below.  
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2. After opening new file or need to transmit ELCSoft current program to HHP, the 

communication setting should set to “PC  HHP” by following methods. The 

transmission can be controlled from HHP. 

a. Click “Communication” > “Transfer Setup(C)”  

 

7.2 Verify with ELC 

Use of this instruction could verify the ELC internal program and the PC editing program; 

the procedure is as follows: (as shown below)  

1. Click “Communication” > “Verify with ELC(V)” to verify ELC program (ELC must be no 

password setting)  
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2. If the PC editing program is different from the ELC program, ELCSoft will thus send a 

warning message of “Verification error!!” (as shown below), and if these two programs 

are the same, ELCSoft will thus send a message of “Verification is finished!!” (as shown 

below).  

  

The programs are different! 

  

The programs are the same! 
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7.3 Password Setting 

It is use to set up or decode the ELC read/write password.  

1. Enter password setting by clicking “Communication” > “password setting(P)” (as shown 

below), to input password for setting. It will show “ELC password is locked” in password 

dialog box.  

Step 4 

 

Step 2 

 

Step 1 

Step 3 

 

Step 5 
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2. If the password is forgotten for PB models, press the [Space] bar four times, ELCSoft 

will then present a confirmation message of “ELC Program delete”, if “Yes” is chosen, 

the ELC program will be cleared, then the password will be decoded.  

Step 1 

 

Step 3 

 

Step 2 

 

Step 4 

 

Step 5 

 

3. If the password is forgotten for PC/PA/PH models, please remove the battery for about 

10 minutes and the ELC program will be cleared, then the password will be decoded, or 

use “Communication” > “Format ELC Memory(M)” to clear ELC internal memory or 

return to factory settings and then the password will be decoded 
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7.4 Run/Stop ELC 

■ Run ELC 

Click “Communication” > “Run” (as shown below), or use keyboard shortcuts by pressing 

keys (Ctrl) + (F5), or click on the icon  to get the dialog box, then press “Yes” to set the 

ELC at the RUN condition.  

 

 

■ Stop ELC 

Click “Communication” > “Stop” (as shown below), or use keyboard shortcuts by pressing 

keys (Ctrl) + (F7), or click on the icon  to get the dialog box, then press “Yes” to set the 

ELC at the STOP condition. 
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7.5 Ladder Start Monitoring 

It is used to switch the ladder diagram mode to the ladder diagram monitor mode, and in 

the monitor mode, all the editing actions are banned. All the execution conditions of the 

program could be observed from the window, and usually, advantages will be 

accompanying the ladder diagram monitor mode in the program debug and the operation.  

1. If you want to monitor the ELC status under the PC window, you should start monitor 

function by clicking “communication” > “ladder start monitoring” or click icon  
directly in ladder diagram mode (as shown below).  
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2. After starting monitor, the green portion displayed in the window is an indication that 

the contact is at the continuity status or the output coil is ON. On the contrary, if the 

green color does not display on the contact or the output coil, it means that this portion 

is currently OFF.  Moreover, the current value (*Footnote 1) of the register will be 

shown on the upper part of the register (T, C, D) as shown below.  

 

＊Footnote 1: You could select number system of the Hexadecimal, the Decimal or the 

ASCII code system for display after clicking “View” > “Monitoring Data Format(N)”.  In 

ladder diagram monitor mode, there will be a letter represented in the front of number to 

distinguish the number system. For signed decimal system, it is K, such as K1234, and H 

for hexadecimal system, such as HABCD. If it is ASCII code, the figure has to be the ASCII 

code for display, otherwise, it will be “ * ”.  
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7.6 SFC Monitor 

It is used to switch the SFC diagram mode to the SFC diagram monitor mode, and in the 

monitor mode, all the editing actions are banned.  All the execution conditions of the 

program could be observed from the window, and usually, you can know current execution 

status from SFC diagram monitor mode.  

 

1. You can monitor by clicking icon  on tool bar or “communication” > “SFC Start 

Monitoring”.  

 

2. The red light of step points S0 above means that the step point is currently “ON” and is 

running the internal program.  
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7.7 Device Monitor 

Device monitor could monitor single device status or numerous device statuses 

simultaneously.  If you want to view the status of one or more device statuses under the 

PC window, simply use following steps for operation:  

1. Click “Communication” > “Device Batch Monitoring” or click the icon  directly.  

 

2. Double click on the device name at the following diagram or press [Enter] to get the 

device monitor input dialog box.  

 

3. Key in the device name and the device number at the “Monitor Device Input” dialog 

window, then press [OK].  

4. If you want to monitor other devices under the same window, simply repeat step 2 and 

3. (*Footnote 1)  

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


7 Communication 

 7-15

5. You can select “View” from right-click pop-up menu to choose the item you need to 

monitor. 

 

＊ Device Name: monitor the device name and number, such as X0, D1000, T2.  

＊ Comments: if there is device comment, you can monitor and edit/update in this window. 

＊ Device state: statuses of the devices (X, Y, M, S, T and C) at monitoring; red block 

displayed when it’s ON, white circle displayed when it’s OFF.  

＊ T/C Set value: the setup values of devices (T and C) in the program.  

＊ Current value (16Bits): the current value (16Bits) of devices (T, C, D) at monitoring will 

display its own value (16Bit) only; e.g. the current value (16Bits) of T1 is K7 or H7.  

＊ Current value (32Bits): the current value (32Bits) of devices (T, C, D) at monitoring will 

display its own value (16Bit) as low word and the next device number (16-bit) as high 

word; e.g. the current value (32Bits) of T0 displays the 32Bits-value, K458752 or 

H70000, that means T0 is H0000 and T1 is H0007.  

＊ Floating-point number: ELC uses 32-bit floating-point number that combined by two 

continuous registers with IEEE754 standard. There will be a character “F” in front of 

number to represent it, e.g. the number for D0 floating-point number will display 

F1.40129846432482e-43.  
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＊ Format: it provides many number systems, including signed decimal, unsigned decimal, 

hexadecimal, ASCII, BCD and binary system, for displaying registers T, C and D at 

monitoring as shown below.  

 

＊ T, C Set Reference: it displays if device T and C is used in program or not. If it is in use, 

it will display “constant”, otherwise it will display “none”. If the timer or counter that 

designated by T or C is a register, it will display the correspondent register.  

*Footnote 1: 

You can unify all display number for monitor by selecting “View” > “Monitoring Data Format” 

and there are the singed decimal, hexadecimal or ASCII for selection.  

In the device monitor mode, the current value (16Bits and 32Bits) format can be set 

separately. If it is Decimal system, letter K is represented in the front of the number, letter H 

is represented for the Hexadecimal system, letter F is represented for the floating point, 

and if it is the ASCII code or BCD code, the figure has to be the code of ASCII or BCD, 
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otherwise, “*” will be displayed.  

 

Three monitors can be run simultaneously in ELCSoft editor: a. the SFC mode monitor, b. 

the device monitor, c. the ladder diagram monitor.  
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7.8 Device Forced ON/OFF 

This instruction could force the status of certain devices to be ON or OFF, before 

proceeding with the forced ON/OFF operation, make sure that it will not be harmful to the 

equipment. When the external wirings have all been completed, you could test whether 

there is error through the forced ON/OFF functions. What follows is the explanation of the 

operation on the application example:  

Application example:  

 

 Method 1: 

1. After compiling the above ladder diagram program and have it written in to the ELC, 

click the icon  to enter the ladder start monitoring mode, as shown below.  

 

2. In the ladder diagram monitor mode, certain functions listed on the menu bar are not to 

be used, and ELCSoft will have these not-to-be-used icons displayed in relief.  
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3. Move the mouse to the forced ON/OFF devices (M1), right-click to get pop-up menu to 

select the forced ON function. (this function could also be used in the device monitor 

mode)  

Ladder diagram monitor mode: 

 

Device monitor mode:  

 

4. If the status of ELC is at the RUN condition, the output coil Y0 will be ON, and if the 

status is at the STOP condition, only the pre-set device will be in motion (ON/OFF).  
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 Method 2:  

1. Click “Communication” > “Set Device On/Off(O)” from the menu bar. (This function 

could also be used in the device monitor mode)  

 

2. Key in M0 at the device name section in the “Set Device ON/OFF” dialog window, then 

check the “Forced ON” or “Forced OFF” →  press “OK”.  

 
 Method 3: 

Move cursor to the device you want to force On/Off, then force to be On by pressing “+” 

and force to be Off by pressing “-“. (this function could be used in the ladder diagram 

monitor mode and device monitor mode)  
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7.9 Current Value Setting 

This function is only valid in the ladder diagram and the device monitor modes, and use of 

this instruction could open a window for modifying current values (as shown below); in this 

window, you could modify the current value (16/32 bit) of devices (D, T, C, E, F).  

1. Click “Communication” > “Enter value” to modify current value. (only can be used after 

monitoring ladder diagram or device) 

 

2. You should check suitable format for the device. If device C235 is 32-bit device, you 

should check 32 bits and if device D0 is 16 bits, you should check 16 bits. If you check 

32 bits for D0, that means D1 will be used for representing 32 bits register and D1 is 

upper 16 bits (high word) and D0 is lower 16 bits (low word).  

3. If the current value is the decimal system, the number should be prefixed with a “K” 

(e.g. K12345678), or if it is the hexadecimal system, the number should be prefixed 

with an “H” (e.g. H5555AAAA), or if it is the floating point, the number should be 

prefixed with a “F”(e.g. F3.45), or if it is the binary, the number should be prefixed with 

a “B”(e.g. B0100).  

4. In Enter value window, it has a history record for you to enter the repeated instruction 

by double click the instruction.  

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


7 Communication 

 7-22 

■  Application example  

 

As above figure, in the ladder diagram monitor mode, force the M4 contact to be ON first, 

and since the current value of D0 is K0, we are to change the value to be K200.  

1. Click “Communication” > “Enter value” from the menu bar to change current value.  
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2. After following dialog box appears, key in the device name D0 and the current value 

K200, then press “OK”.  

 

■ The current value of the D0 register will be changed to K200.  
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7.10 Edit Register Memory(T, C, D) 

ELCSoft provides register (T, C, D) edition functions, including edit, read communication, 

write, save/open file and print. (As shown below)  

 

You could designate the D register(except special D), the C register(high-speed counter is 

included), the T register, among all types of registers, to have the current value of each 

register undergone communication read/write, data save and data retrieve (*Footnote 1).  

The digital display and input method can be selected from “data format”.  

1. Click “Communication” > “Edit Register Memory(T, C, D)” from the menu bar or use 

keyboard shortcuts by pressing key (Ctrl)+ (R).  
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2. After opening view window, double click to input the designated register value (e.g. 

D41) →  then key in the value “1234” →  press “Enter”; there are the decimal, the 

hexadecimal, and the binary systems for the value input. (As shown below)  

 

3. After completing all the register values input, press “transfer” to write values into 

designated ELC.  

4. You can read or write ELC register and set read/write area.  
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5. Before writing, make sure that no bad effects will be incurred to the ELC that are in 

operation.  

 

■  There are numerous functions to edit the register:  

1. Read From ELC data register: read the register value from the ELC that is 

communicated currently.  

2. Write to ELC data register: write the value into the ELC that is communicated currently.  

3. Print: When the registers editing windows is activate, click the icon  on toolbar or 

choose “Print” command from the “File” menu. The printing dialog box will pop up and 

then users can select printing options to print the editing registers. 

4. Save file into disk: Click “File” > “Save(S)” to save the edited data register into the disk 

with the * .DVL file format. (*footnote 1)  

5. Read file from disk: Click “File” > “Open(O)” to read * .DVL file.  

6. Clear All: clear the data from the currently edited data register (D, C, the high-speed 

counter and T).  
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7. Function Title: editing Function Title. 

＊Footnote 1: The file format of the edited register for retrieve is the *.DVL.   

7.11 Edit Bit Memory(M, S) 

ELCSoft provides register (M, S) edition functions, including edit, read communication, 

write, retrieve file (Footnote 1) and print. (As shown below)  

 

1. Click “Communication” > “Edit Bit Memory(M, S)” from the menu bar.  

2. You can double click to set ON/OFF in the edition window.  
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3. After completing edition, select “write to ELC” or “read from ELC” to transmission. 

Please make sure that no bad effects will be incurred to the ELC that are in operation.  

Write to ELC 

 
Read from ELC 

 

■  There are numerous functions to edit the register: 

1. Read from ELC: read the state from ELC internal device (M, S).  

2. Write to ELC: write the state into ELC internal device (M, S).  

3. Print: When Bit Memory(M, S) windows is activate, click the icon  on toolbar or 

choose “Print” command from the “File” menu. The printing dialog box will pop up and 

then users can select printing options to print the Bit Memory(M, S). 

4. Save file into disk: Click “File” > “Save(S)” to save the edited data register into the disk 

with the * .DVB file format. 

5. Read file (Disk): Click “File” > “Open(O)” to read * .DVB file.  
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6. Block setting: you can select many states once and right-click to get pop-up menu to 

set the states to be ON or OFF.  

 

＊Footnote 1: The file format of the edited register for retrieve is the *.DVB.  

7.12 Format ELC Memory 

ELCSoft provides clear ELC memory function and is only valid when PCL is ON (as shown 

below)  

1.  Click “Communication” > “Format ELC Memory” from menu bar.  
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2.  Press Yes(Y) to confirm to clear ELC program in the confirmation dialog box.  

    

3.  Finish clearing. 

 

7.13 File Register 

ELC-PC/PA/PH models provide file register function to read/write via ELCSoft edit.  

1. Click “Communication” > “Edit File Register Memory(A)” from menu bar.  
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2. After opening file register window, double click to input the designated register value 

(e.g. 41) →  then key in the value “1234” →  press “Enter”; there are the unsigned 

decimal, the signed decimal, and the hexadecimal systems for the value input. (As 

shown below)  

 

3. After completing each file register settings, click “transfer” to read/write ELC. You can 

select partial transmission by setting start and the end address to read/write ELC.  

 

 

 

 

4. Before writing, make sure that no bad effects will be incurred to the ELC that is in 

operation.  

■  There are numerous functions to edit the file register memory: 

1. Read from ELC: read data from ELC file register.  

2. Write to ELC: write the edited data into ELC. 
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3. Print: When file register memory windows is activate, click the icon  on toolbar or 

choose “Print” command from the “File” menu. The printing dialog box will pop up 

and then users can select printing options to print the file register memory. 

4. Save file to disk: Click “File” > “Save(S)” to save file register memory data with 

extension file WFT into disk. 

5. Read file to disk: Click “File” > “Open(O)” to read * .WFT file. 

6. Clear: clear all file register content.  

7. Title: editing Title. 

＊Footnote 1: The file format of the edited register for retrieve is the *.WFT.  

7.14 Send Changes 

ELC-PC/PA/PH models allow modifying partial program or device when it is at RUN time 

and the limit for modification range is less than 15 STEPS. It is only for ladder diagram 

mode. Please make sure that no unexpected danger will occur before operation. 

After modifying program and generating new program code through compiler, you can 

select “Communication” > “Send Changes” from menu bar for update. 

■  The steps for “send changes” : 

1. ELCSoft is reading or writing a ELC program into ELC and ELC is at RUN time.  
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2. For ELCSoft program modification, it is 15 STEPS maximum. You can update program 

immediately by selecting “Communication” > “Send Changes”.  

 

3. Please press “Yes(Y)” to update program in the confirmation dialog box.   

 

7.15 Baud Rate Auto-Detect 

ELCSoft editor can auto-detect the ELC communication speed.  

 
It is detecting (you can break 

the communication by 
pressing “Cancel”) 

Succeed to detect (display 
detection information) 

Fail to detect (Please 
check communication 

setting) 
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7.16 ELC Information 

ELCSoft provides ELC with the detection function on the ELC status information (as shown 

below).  

1. Click “Communication” > “ELC Information” from the menu bar.  

 

2.  Provide the following ELC information, e.g. the ELC Operation Mode, the Program 

Memory, the ELC version, ELC model name(MPU), the ELC Station Address, Error 

check, Error Step Number, Protected, etc.  
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8.1 SFC Editing Environment 

Start up ELCSoft, and click “New” to create a new screen or click “Open” to open an old file. 

Then, users can enter into the editing environment of SFC (Sequence Function Chart) 

diagram mode and use SFC diagrams to create ELC programs as the figure shown below. 

 

To edit the SFC diagrams, users can use SFC toolbox shown on the upper side of the SFC 

mode page or function keys (F1~F9, (Shift) + (F1~F9)) on the keyboard. In the following 

sections, we will introduce you the methods and steps for creating and editing SFC 

diagrams.  

8.2 Basic Operation 

■ SFC Editing Principle: 

SFC (Sequence Function Chart) is one of the programming languages defined in the 

IEC1131-3 Standard and it is also one kind of the diagram editing mode. However, the 

whole structure of SFC diagram looks like a flow chart. In fact, it is to utilize the Step Relay 

S within the ELC. The number of every Step Relay S is to serve as a step point, which is 

equivalent to each procedure of the flow chart. After current procedures are completed, 

move on to the next procedure (which is the next step point S) requested according to the 

preset terms, in this case, users can simply follow the procedure repeatedly to obtain the 

best results that users need.  

■ SFC Toolbar and Icons Explanation: 

Icons 
shown on 

Description of 
Icons 

Explanation: (Click the icon or press the function keys 
(F1 ~F9)) 
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SFC toolbar 

 Common ladder 
Ladder diagram mode: indicates the inner editing 
program is the common ladder diagram (inner ladder 
diagram), not the step ladder program. 

 
Initial diagram of 
SFC 

Diagram for the initial step point: This double-framed 
diagram is used for SFC initial step point. The available 
devices are S0~S9. 

 Common SFC 
Diagram for the common step point: The available 
devices are S10~S1023. (For ELC-PB series models, 
the available devices are S10~S127) 

 Jump diagram 

Jump diagram for the step point: It is used to move from 
one step point to another that is not right next to it (step 
point jump up and down to the point that is not 
sequenced in order in the same procedure, return back 
to the initial step point, and jump between different 
program processes). 

 
Condition 
diagram 

Transition condition diagram for step point: It is the 
transition condition of step point that used to move 
between each step point. 

 
Divergence of 
condition diagram 

Alternative divergence of condition diagram: It is 
alternative divergence that used for a step point to move 
to different corresponding step point by different 
transition condition (If the divergence is consisted of 
more than two points, users can press function keys 
(Shift) + (F1~F9) to add more points for the divergence).

 
Convergence of 
condition diagram 

Alternative convergence of condition diagram: It is 
alternative convergence that used for two step points or 
more to move to the same step point according to 
transition condition (If the convergence is consisted of 
more than two points, users can press function keys 
(Shift) + (F1~F9) to add more points for the 
convergence). 

 
Divergence 
diagram  

Simultaneous divergence diagram: It is simultaneous 
divergence that used for a step point move to two step 
points or more by the same transition condition (If the 
divergence is consisted of more than two points, users 
can press function keys (Shift) + (F1~F9) to add more 
points for the divergence).  

 
Convergence 
diagram 

Simultaneous convergence diagram: It is simultaneous 
convergence that used for two step points or more to 
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move to the same step point with the same transition 
condition when the condition is established at the same 
time (If the convergence is consisted of more than two 
points, users can press function keys (Shift) + (F1~F9) to 
add more points for the convergence). 

 

Icons 
shown on 

SFC toolbar 

Description of 
Icons 

Explanation: (Click the icon or press the function keys 
(Shift) + (F1 ~F9)) 

 Auxiliary line for simultaneous divergence diagram 

 Auxiliary line for simultaneous connection diagram 

 Auxiliary line for simultaneous convergence diagram 

 Auxiliary line for simultaneous connection diagram 

 Auxiliary line for alternative divergence diagram  

 Auxiliary line for alternative connection diagram  

 Auxiliary line for alternative convergence diagram 

 Auxiliary line for alternative connection diagram 

 

Auxiliary line 

Auxiliary line for vertical-line connection diagram 
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■ SFC Editing Environment: 

In SFC mode, up to 16 columns (horizontal direction) can be used for programming, 

whereas there is no limit of the rows (vertical direction). Every dotted cell stands for one 

SFC symbol, and therefore, a maximum of 16 columns could be displayed on the screen in 

the horizontal direction at the same time.  

 

■ SFC Editing Methods: 

Method 1: Establish the whole structure of SFC diagram first and then edit the inner ladder 

diagram of each SFC symbol. 

Step 1: After entering SFC mode, the SFC toolbar will appear on the upper side of the 

SFC mode page. Normally, the first one is ladder diagram mode (press the 

function key [F1], or click the icon  on SFC toolbar) as the next one is the 

initial diagram of SFC, which available device is from S0 to S9. A regular ELC 

program will not enter the structure of SFC in the beginning, and therefore, the 

inner program of the first LAD-0 diagram is usually the pre-program and used to 

enter the structure of SFC. 
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Step 2: Mapping out the initial diagram of SFC (press the function key [F2], or click the 

icon  on SFC toolbar) and select one initial step point (S0 ~S9), i.e. the first 

step point that enter into the structure of SFC (This initial step point can be 

specified to S0~S9 only, if users use other step points with different numbers as 

the initial step points, an error message will be displayed in the last compiling 

process of the program. If in the ladder diagram mode and instruction mode, 

and the initial step points are not one of S0~S9, the SFC diagram cannot be 

converted correctly in the last compiling process of the program). 

Step 3: The transition condition diagram is essential between different step point 

diagrams (press the function key [F5], or click the icon  on SFC toolbar). 

Thus, each step point can link and move to other step points by the transition 

condition when the program is running. The inner ladder diagram of the step 

point is the program so far that can be executed to reach the position of this 

step point, and the inner ladder diagram of the transition condition diagram is 

the transition conditions among different step points. (If the step point in the 

inner ladder diagram is not the same as the step point for transition in SFC 

diagram, only the step point in SFC diagram is recognized after the program is 

compiled thoroughly). 

Step 4: When editing SFC diagram, use the far left cell as the criterion, and then edit 

SFC diagram in order from top to bottom and from left to right. Before editing the 

inner program within each step point (if there is no program within the step 

point), users can enter the inner ladder diagram mode and edit the inner 

program (Right click your mouse and choose the “Inner Ladder Mode” from the 

pop-up menu).  

Step 5: When edit the SFC diagram, the downward step point that is sequenced in 

order could be connected by using common SFC diagram (press the function 

key [F3] or click the icon  on SFC toolbar). However, if step point jump up 

and down to the point that is not sequenced in order, or return back to the initial 

step point or jump between different program processes, use the Jump Diagram 

(press the function key [F4], or click the icon  on SFC toolbar). The device 

number of every common step point diagram and initial step point diagram could 

only show up for one time when editing the SFC diagram. 
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Method 2: Edit each SFC symbol and its internal ladder diagram simultaneously and then 

complete the whole structure of SFC diagram. 

Step 1: When start editing, select the ladder diagram mode first as the pre-program to 

enter the SFC structure, and press the function key [F1], or click the icon  

on SFC toolbar. Place the editing block in the position of the far left column. As 

for the LAD-□  shown in the SFC editing window, the number of □  will 

increase progressively and automatically according to the times that the icon 

 is clicked. If the position of the editing block is incorrect, an error message 

dialog box will appear to warn you that the input position is incorrect.  
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Step 2: After the ladder diagram LAD-0 is set, start to edit the inner ladder diagram of 

LAD-0. First, move the editing block to the ladder diagram LAD-0, and then right 

click your mouse. Then, choose the “Inner Ladder Mode” from the pop-up menu. 

 

Step 3: After clicking the “Inner Ladder Mode” from the pop-up menu, the window for 

editing the internal ladder diagram will show on the right side of the original SFC 

mode window. Then, users can enter the following instructions in accordance 

with the editing methods of the ladder diagrams: 

LD M1002 

SET S0 

Editing in Internal Ladder Mode:  
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Step 4: After the editing is completed, close the internal ladder diagram mode, and the 

program that was just edited will be saved in the ladder diagram LAD-0. At this 

time, if you double click the mouse to activate the “Inner Ladder Mode”, then 

you can see the previous edited inner ladder diagram or inner instruction 

already existed in the ladder diagram LAD-0.  

Step 5: When you want to modify the inner ladder diagram of the diagram LAD-0, move 

the editing block to where the diagram LAD-0 is, and right click you mouse to 

choose the “Inner Ladder Mode” from the pop-up menu (Refer to Step 2 and 

Step 3). 

Step 6: Next, plan to edit the initial step point diagram. Move the editing block to the 

next row and press the function key [F2], or click  on SFC toolbar. At the 

same time, the SFC editing window will request you to input the number of the 

step point. Since this is the initial step point, the available devices are S0~S9 

(choose the desired device by click on the “Up” and “Down” key right of the cell 

or simply type the device you want). If the number you choose is not within the 

range of 0~9, the “S exceeds usage range (S0~S9)” warning message will pop 

up. Besides, when entering the device number, it does not matter if device name 

“S” does not input since it will be added automatically in SFC mode. After the 

numbering is completed, press Enter key on the keyboard, or left click your 

mouse twice, or simply move the editing block away.  

No transition condition diagram for step point is needed between the ladder diagram 

mode and the initial step point diagram  
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Step 6: So now you can edit the internal program of the initial step point diagram S0. 

Move the editing block to where the initial step point diagram located, and right 

click your mouse to choose the “Inner Ladder Mode” from the pop-up menu 

(Refer to Step 2 and Step 3). 

Step 7: The transition condition diagram is essential between different step point 

diagrams (press the function key [F5], or click the icon  on SFC toolbar). 

The editing method of the inner program of the transition condition diagram is 

the same as Step 2 and Step3, which could write in the transfer conditions. 

Every added condition diagram has its own number. The rule for numbering the 

condition diagram of the structure of SFC diagram is that numbering from top to 

bottom and from left to right in order. 
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Step 8: Design the common step points for connection. If there is no divergence, then 

the downward step point that is sequenced in order could be connected by 

using common SFC diagram (press the function key [F3], or click the icon  
on SFC toolbar). If there is divergence, use the alternative divergence of 

condition diagram (press the function key [F6], or click the icon  on SFC 

toolbar) for alternative connection and use the simultaneous divergence 

diagram (press the function key [F8], or click the icon  on SFC toolbar) for 

simultaneous connection. After that, users can then edit the internal program of 

every step point diagram. Move the editing block to where the initial step point 

diagram located, and right click your mouse to select the “Inner Ladder Mode” 

from the pop-up menu (Refer to Step 2 and Step 3). 

1. No divergence:  
Move from S0 to S20 
according to the transition 
condition 0. 

2. Alternative divergence:  
Move from S0 to S20 and 
S21 by different transition 
condition 0 and 1. 

3. Simultaneous divergence:
Move from S0 to S20 and 
S21 by the same 
transition condition 0 
simultaneously. 

 

Step 9: If the divergence is consisted of more than two points, users can press function 

keys (Shift) + (F1~F9) to add more points for the divergence. 

( : Auxiliary line for simultaneous divergence diagram, , : Auxiliary line 

for simultaneous connection diagram, : Auxiliary line for alternative 

divergence diagram, , : Auxiliary line for alternative connection diagram) 
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Step 10: After divergence, if you have to converge the step points, use alternative 

convergence of condition diagram (press the function key [F7], or click the icon 

 on SFC toolbar) for alternative connection and use simultaneous 

convergence diagram (press the function key [F9], or click the icon  on 

SFC toolbar) for simultaneous connection. After that, users can then edit the 

internal program of every step point diagram. Move the editing block to where 

the initial step point diagram located, and right click your mouse to select the 

“Inner Ladder Mode” from the pop-up menu (Refer to Step 2 and Step 3). 

1. Alternative convergence:  

Move from S30, S31, and S32 to the 

same step point, S40 according to the 

individual transition condition. 

2. Simultaneous convergence:  

Move from S30, S31, and S32 to the 

same step point, S40 according to the 

same transition condition. 

  

Step 11: If the convergence is consisted of more than two points, users can press 

function keys (Shift) + (F1~F9) to add more points for the convergence. 

( : Auxiliary line for simultaneous convergence diagram, , : Auxiliary 

line for simultaneous connection diagram, : Auxiliary line for alternative 

convergence diagram, , : Auxiliary line for alternative connection 

diagram) 
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※Quick memory: 1. Alternative divergence and convergence: Move from one step  

 point according to one transition condition.  

 2. Simultaneous divergence and convergence: Move from several  

 step points according to one transition condition. 

Step 12: When edit the SFC diagram, the downward step point that is sequenced in 

order could be connected by using common SFC diagram (press the function 

key [F3] or click the icon  on SFC toolbar). However, if step point jump up 

and down to the point that is not sequenced in order, or return back to the initial 

step point, or jump between different program processes, use the Jump 

Diagram (press the function key [F4], or click the icon  on SFC toolbar). 

The device number of every common step point diagram and initial step point 

diagram could only show up for one time when editing the SFC diagram. 

1. The step point S10, S11 and S12 is 

sequenced in order, and therefore, they 

can be connected by using common 

SFC diagram. But, if users want to 

return back to S0 from S13, and then 

users have to use the “Jump Diagram” 

to complete the transition.  

2. If users want to move from S20 within 

the procedure of S1 to S10 within the 

procedure of S0, and then users have to 

use the “Jump Diagram” to complete the 

transition. 
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Return to initial step point, S0 in the same 

procedure. 

 
Transition of SFC diagrams in two different 

procedures. 

Step 13: After the SFC diagram is completed, users can convert the SFC diagram into 

the instruction code through compiling. From the menu bar, click “Compiler” > ” 

SFC=> Instruction (C)”, or click the icon  on toolbar, or use keyboard 

shortcuts by pressing keys (Ctrl) + (F11). 
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1. Click “Compiler” > ” SFC=> Instruction (C)” from the menu bar to convert the SFC 
diagram into the instruction code. 

 
2. Click the icon  on toolbar to convert the SFC diagram into the instruction code. 

 

8.3 SFC Editing Explanation 

Convert SFC Diagram into Instruction Code through Compiling: (if want to correctly display 

the compiling ladder diagram, it is needed to convert the SFC diagram into the instruction 

code through compiling first, and then convert the instruction code into ladder diagram 

through compiling) 
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Example of the simultaneous divergence and simultaneous convergence procedures 
1.→ The SFC diagram is compiled and converted to the instruction code,  

2.→ The instruction code is compiled and converted to the ladder diagram 

 
 
 

■ Editing Device Comment in SFC Mode: 

The device S represents the step point within the SFC diagram, and therefore, the 

comments of step point are the comments of device S.  

 

In SFC mode, you can click 
“View” from menu bar, and 
click “Edit Device 
Comments(D)” from the 
pull-down menu. Then, you 
can edit several device 
comments at the same 
time.  
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In “Device Comment” 
window, select the device 
type “S”, and double click 
your mouse on the device 
number that you want to 
edit, or use “Up” and 
“Down” key to select the 
target device and enter the 
comments. After comments 
is edited and completed, 
press Enter key on your 
keyboard to save the 
comments. 

To edit the device 
comments, you can also 
click “Comment” from menu 
bar, and click “Edit Device 
comments(D)” from the 
pull-down menu, or use 
keyboard shortcuts by 
pressing keys (Ctrl) + (Alt) 
+ (D). 

If the position of the editing 
block is not allowed to input 
the device comments in it, 
a message dialog box, 
“Inhibit to input device 
comments on the position!!” 
will pop up. 
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Place the editing block on 
the step point that you want 
to edit device comments in 
it, and then right click your 
mouse to select the 
“Device comment” 
command from the pop-up 
menu. 

After select the “Device 
comment” command from 
the pop-up menu, the 
“Comment” window will 
appear for you to edit the 
device comments. After the 
comments is edited and 
completed, click the button 
“OK” or press Enter key on 
your keyboard to close the 
window. 

Click the icon  on 
toolbar or click “View” from 
menu bar, and click “Show 
Comments(M)” command 
from pull-down menu to 
have the device comments 
be shown on the SFC 
diagram.  
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The device comments will 
be shown on the right-hand 
side of the SFC diagram. 

■ Monitoring in SFC Mode: 

ELCSoft allows users to monitor the execution conditions of the programs in the SFC 

mode. 

 Click the icon  on 
toolbar, or click 
“communication” from 
menu bar, and click “SFC 
Start Monitoring” 
command from pull-down 
menu. Then, you can start 
the monitoring based on 
the program conditions in 
SFC mode. 
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There are three monitor functions can be run simultaneously in ELCSoft:  

1. SFC mode monitor, 2. Ladder diagram monitor, 3. Device monitor. 

 
■ Examples of Frequent Error SFC Diagrams: 

Error SFC diagram Revised (Correct) SFC diagram 
1. There are two consecutive transition 

condition diagrams connected between 
two step points. 

There should be only one transition 
condition diagram connected between 
two step points. 

  

 

Error SFC diagram Revised (Correct) SFC diagram 
2. There is no transition condition diagram 

connected between step point S0 and 
other step points. 

There should be transition condition 
diagrams connected between step point 
S0 and other step points. 
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3. After the alternative divergence, there is 
no transition condition diagram 
connected between step point S0 and 
other step points. 

After the alternative divergence, there 
should be transition condition diagrams 
connected between step point S0 and 
other step points. 
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Error SFC diagram Revised (Correct) SFC diagram 
4. It is a wrong connection if the 

alternative divergence of condition 
diagram is connected after one 
transition condition diagram. 

To make a correct connection, use the 
alternative divergence of condition 
diagram first, and then use condition 
diagrams to connect other step points as 
the figure shown below. 

  

  

5. It is a wrong connection if the condition 
diagram is connected after the 
simultaneous divergence diagram. 

To make a correct connection, use the 
condition diagram first, and then use 
simultaneous divergence diagram to 
connect other step points as the figure 
shown below. 
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Error SFC diagram Revised (Correct) SFC diagram 
6. Before alternative convergence 

diagram, the individual transition 
condition diagrams of the step points 
should exist.  

To make a correct connection, use the 
simultaneous convergence diagram as 
the figure shown below. 

  
  

7. Before simultaneous convergence 
diagram, the individual transition 
condition diagrams of the step points 
should not exist. However, the 
individual transition condition diagrams 
of the step points should be connected 
after the simultaneous convergence 
diagram. 

To make a correct connection, use the 
alternative convergence diagram as the 
figure shown below. 
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The figure below shows “Options” menu screen. The “Options” menu functions will be 

described as follows:  

 

9.1 Select COM Port(P) 

ELCSoft will detect applicable PC COM port and allow user to choose one of applicable 

COM port (COM1 ~ COM8) to connect to ELC.  

 Method: Click “Option” > “Select COM port(P)”  

9.2 Change ELC type(U) 

ELCSoft allows user to set the program title, ELC model setting (PB and PC/PA/PH), 

program capacity ( 4000, 8000, 16000 Steps) and the file name. 

 Method 1: Click “Options” > “Change ELC type(U)”  
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 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F6) 

 

9.3 Station Address(A) 

The default address of ELCSoft is 1. It means that PC connects to ELC, which the address 

is 1 (D1121). The setting range is from 0 to 255. 

 Method 1: Click “Options” > “Station Address(A)” 

 Method 2: Use keyboard shortcuts by pressing keys (Shift) + (Ctrl) + (F8) 

 

9.4 Autosave Setup(S) 

ELCSoft can save files automatically when editing programs. The autosave files will be 

stored in the folder named UserTemp. User can choose to autosave the files before 

compiling or by time interval (5 to 60 minutes). 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/5426585/ELCSOFT.html


9 Options Menu Functions 

 9-3

 Method: Click “Options” > “Autosave Setup(S)”  

 

9.5 Font Setting and Comment Format 

ELCSoft provides the default 16-color palette for user to color the ladder diagram, , ladder 

text, ladder symbol, ladder cursor, ladder monitor state, ladder device comment, ladder 

segment comment, ladder row comment and ladder monitor value. It also provides those 

fonts that Windows® uses. The text of device comment and row comment also can be 

arranged in this setting. It also provides symbol name display enabled or disable.. 

 Method: Click “Options” > “Font Setting and Comment Format” 

  

 .symbol name display enabled or disable 

 Method 1: Click “Options” > “  Font Setting and Comment Format” choice 
symbol name display enabled. 

 Method 2: Click the icon  on the toolbar. 
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9.6 Response Setup(R) 

This function is used to set the auto query times (1~50 times) and query interval time (3~10 

seconds) if a transmission error occurs when communicate PC with ELC.  

 Method: Click “Options” > “Response Setup(R)” 

 

9.7 Set Baud Rate(B) 

ELCSoft allows users to set the communication baud rate of ELC-PC/PA/PH series. The 

communication baud rate of ELC-PC/PA/PH series can be 9600, 19200, 38400, 57600 and 

115200 bps.  

 Method: Click “Options” > “Set Baud Rate(B)” 

9.8 Set ELC Date and Time(T) 

ELC-PC/PA/PH series supports RTC function that allows users can define the ELC date 

and time by themselves. In addition, this function also lets users set ELC date and time to 

be the same as the date and time of PC.  

 Method: Click “Options” > “Set ELC Date and Time(T)” 
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9.9 Prompt to Edit Device Comment(H) 

When this function is enabled, the comment input dialog box will pop up to remind users to 

edit the device comments after users edit ELC programs by entering instructions directly in 

the instruction mode or ladder diagram mode.  

 Method: Click “Options” > “Prompt to Edit Device Comment” 
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The figure below shows the “Help” menu screen. The “Help” menu functions will be 

described as follows:  

 

10.1 About ELCSoft(A) 

Display Delta website, ELCSoft program version, serial number and copyright. 

 Method: Click “Help” > “About ELCSoft(A)” 

 

10.2 Intelligent Function Utility(C) 

Provide functions that include RS-485 protocol setting(D1120) (MODBUS protocol value 

conversion), LRC and CRC generator, LRC/CRC generator, duplicate ELC service, screen 

capture and special instruction wizard. 
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 Method: Click “Help” > “Intelligent Function Utility(C)” 

 RS-485 protocol setting(D1120):  

Use this command to set communication format, such as 9600,7,E,1.  

 

 LRC/CRC generator 

Step 1: Click “Next step” 

 

Step 2: You can enter the format of the MODBUS communication data, and the digital 
system is hexadecimal. The maximum numbers can be 256 numbers. If the 
input value is not an even number, an error message window will appear. 
Besides, you can execute the number base conversion in this dialog box.  
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 Duplicate ELC Service 

Step 1: Choose the button “Read from Target ELC” 
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Step 2: Read the duplicated data from Target ELC. The duplicated data in target ELC 
includes programs, data registers, file registers, auxiliary relays, step points, 
timers and counters. 

 

Step 3: After reading action is completed, Make the duplicated data. Be sure to specify 
the file name extension as “.DUP”. You can read the DUP files by clicking the 
button “Read from Duplicated File” later. 
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Step 4: Enter new setting password and start to duplicate ELC file. At this time, the 
duplicated file and the password will both be written into ELC.  
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 Screen Capture:  

Save the current operating window of ladder diagram mode, instruction mode and SFC 
mode as an image file. 

 To Clipboard: Click “Help” > “Screen Capture” > “To Clipboard” or using keyboard 
shortcuts by pressing keys (Ctrl) + (Alt) + (P).  

 To File: Click “Help” > “Screen Capture” > “To File” or using keyboard shortcuts by 
pressing keys (Ctrl) + (Alt) + (F). 
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 Special Instruction Wizard:  

 PID Instruction Input Assistance 
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 High Speed Counter Auxiliary Function 

 

 Pulse Output Auxiliary Function 
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 ELC Link Auxiliary Function 

 

 Communication Program 
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 Position Control 

 

 Extension Module Setup 
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 Interrupt Label 

 

10.3 Reference Documents 

 ELC Instruction & Special Registers Reference(S)  all instructions list and 

explanation, the manual for internal special auxiliary relay of all ELC series and the 

manual for internal special data register of all ELC series. 

 Method: Click “Help” > “ELC Instruction & Special Registers Reference(S)” 

 ELCSoft User Manual(I)  User Manual for ELCSoft, 

 Method: Click “Help” > “ELCSoft User Manual(I)” 
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Data 1: Keyboard Operation Keys and Shortcuts 

User can use the keyboard to select any menu command on the menu bar and on a toolbar. 

The following tables summarize the available Keyboard operation keys and shortcuts for 

ELCSoft. Most of the keyboard shortcuts are displayed on the right-hand side of each 

menu command when you pull down the menu. 

 

Keyboard Operation Keys 

Functions Operation Keys 
(Keyboard Shortcuts) 

Move editing block up [↑ ] 

Move editing block down [↓ ] 

Move editing block left [← ] 

Move editing block right [→ ] 

Move editing block to the front of the row [Home] 

Move editing block to the end of the row [End] 

Delete the symbol on the left of the editing block [← Backspace] 

Move to the next page [Page Down] 

Move to the previous page [Page Up] 

Cancel, quit or close the selected function [Esc] 

 

Ladder Diagram Toolbar 

Functions Operation Keys 
(Keyboard Shortcuts) Icon 

Normally open contact [F1]  

Normally closed contact [F2]  

Rising pulse [F3]  
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Ladder Diagram Toolbar 

Functions Operation Keys 
(Keyboard Shortcuts) Icon 

Falling pulse  [F4]  

Step point [F5]  

Application instruction [F6]  

Output coil [F7]  

Horizontal line  [F8]  

Vertical line (cursor will not move) [F9]  

Reverse operation results  [F11]  

Compare instruction [F12]  

Delete vertical line [Ctrl] + [D]  

Draw vertical line and cursor move down [Alt] + [F9]  

 

SFC Toolbar 

Functions Operation Keys 
(Keyboard Shortcuts) Icon 

Common ladder [F1]  

Initial diagram of SFC  [F2]  

Common SFC  [F3]  

Jump diagram [F4]  

Condition diagram  [F5]  

Divergence of condition diagram [F6]  

Convergence of condition diagram  [F7]  
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SFC Toolbar 

Functions Operation Keys 
(Keyboard Shortcuts) Icon 

Divergence diagram  [F8]  

Convergence diagram  [F9]  
Auxiliary line for simultaneous 
divergence diagram [Shift] + [F1]  
Auxiliary line for simultaneous 
connection diagram [Shift] + [F2]  
Auxiliary line for simultaneous 
convergence diagram [Shift] + [F3]  
Auxiliary line for simultaneous 
connection diagram [Shift] + [F4]  
Auxiliary line for alternative divergence 
diagram [Shift] + [F5]  
Auxiliary line for alternative connection 
diagram [Shift] + [F6]  
Auxiliary line for alternative convergence 
diagram [Shift] + [F7]  
Auxiliary line for alternative connection 
diagram [Shift] + [F8]  
Auxiliary line for vertical-line connection 
diagram [Shift] + [F9]  

 

Menu bar and General Toolbar 

File Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Create a new file  “File” > “New(N)” [Ctrl] + [N]  

Open an old file “File” > “Open(O)” [Ctrl] + [O]  

Save a editing file “File” > “Save(S)” [Ctrl] + [S]  
Save current file to other 
file name or project “File” > “Save As(A)” [Ctrl] + [Alt] + [S]  

Close current editing file “File” > “Close(C)” --  
Print current editing file, 
i.e. instruction / ladder 
diagram/ comments… 

“File” > “Print(P)” [Ctrl] + [P]  
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Menu bar and General Toolbar 

File Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Select and set printer “File” > “Printer Setup(Q)” [Ctrl] + [Q]    

End ELCSoft “File” > “Exit(X)” [Alt] + [X] -- 

 

Menu bar and General Toolbar 

Edit Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Undo an action  “Edit” > “Undo(U)” [Ctrl] + [Z]  

Redo an action “Edit” > “Redo(R)” [Ctrl] + [Alt] + [Z]  
Select the entire 
document “Edit” > “Select All(A)” [Ctrl] + [A] -- 

Delete the selected 
content “Edit” > “Delete” [Delete]  

Cut a block “Edit” > “Cut(T)” [Ctrl] + [X]  

Copy a block “Edit” > “Copy(C)” [Ctrl] + [C]  

Paste a block “Edit” > “Paste(P)” [Ctrl] + [V]  
Insert block data into 
document “Edit” > “Insert Block(O)” [Ctrl] + [Insert] -- 

Insert a blank row “Edit” > “Insert Row(I)” [Ctrl] + [I]  
Delete a row and shift the 
program up  “Edit” > “Delete Row(L)” [Ctrl] + [Y]  
Delete the vertical line at 
the left side of the editing 
block  

“Edit” > “Delete Vertical 
Line(D” [Ctrl] + [D]  

Insert a blank cell to the 
right in SFC mode  “Edit” > “Insert Cell(B)” [Ctrl] + [B]  
Delete a blank cell to the 
left in SFC mode  “Edit” > “Insert Cell(K)” [Ctrl] + [K]  

Edit the program title  “Edit” > “Program Title(S)” [Ctrl] + [Alt] + [T]  
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Menu bar and General Toolbar 

Compiler Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Convert ladder diagram to 
instruction  

“Compiler” > 
“Ladder” =>”Instruction(I)” [Ctrl] + [F9]  

Convert Instruction to 
ladder diagram  

“Compiler” >  
“Instruction” =>”Ladder(L)” [Ctrl] + [F10]  

Convert SFC diagram to 
instruction  

“Compiler” >  
“SFC” => ”Instruction(C)” [Ctrl] + [F11]  

Convert instruction to SFC 
diagram  

“Compiler” >  
“Instruction” =>”SFC(S)” [Ctrl] + [F12]  

 

 

Menu bar and General Toolbar 

Comments Menu 
Functions Operating Procedure Operation Keys 

(Keyboard Shortcuts)
 

Icon 

Edit device comments  “Comments” > 
“Edit Device Comments(D)” [Ctrl] + [Alt] + [D]  

Edit segment comments “Comments” > 
“Edit Segment Comments(B)” [Ctrl] + [Alt] + [B]  

Edit row comments “Comments” > 
“Edit Row Comments(L)” [Ctrl] + [Alt] + [L]  

 

Menu bar and General Toolbar 

Search Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Go to designated Steps “Search” > “Go To(J)” [Ctrl] + [J]  
Find or replace the 
device and instruction  

“Search” > 
“Search/Replace(F)”  [Ctrl] + [F]  

Return to Start of the 
program  

“Search” > “Go to the 
Start(T)”  [Ctrl] + [Home] -- 

Go to End of the program “Search” > “Go to the End(N)” [Ctrl] + [End] -- 

 

Menu bar and General Toolbar 

View Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 
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Menu bar and General Toolbar 

View Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts) Icon 

Display Toolbar and 
Status bar  “View” > “Toolbars(T)”  -- -- 

Display or hide project 
work area “View” > “Workspace(W)”  -- -- 

Compiler message check “View” > “Output Window(M)”  -- -- 

Select monitoring data 
display mode 

“View” >  
“Monitoring Data Format(N)” -- -- 

Zoom in and Zoom out  “View” > “Zoom(Z)”  -- -- 

Switch to instruction 
mode “View” > “Instruction List(I)”  --  
Switch to ladder diagram 
mode  “View” > “Ladder Diagram(L)”  --  

Switch to SFC mode  “View” > “SFC Diagram(S)” --  
Display all device 
comments  

“View” >  
“Edit Device Comments(D)” --  

Display the list of used 
comments  

“View” > 
“List of Used Comments(U)” [Ctrl] + [Alt] + [U]  

Check the repeated use 
of output coil 

“View” > “Cross Reference 
List(F)” [Ctrl] + [Alt] + [K]  

Show or Hide the 
comments “View” > “Show Comments(M)” --  
Show or Hide the 
comments “View” > “Symbol Table(B)”  --  

 

Menu bar and General Toolbar 

Communication Menu 
Functions Operating Procedure Operation Keys 

(Keyboard Shortcuts) Icon 

PC communicates with 
ELC or HHP and 
read/write program 

“Communication” > “Transfer 
Setup(C)” [Ctrl] + [F1]  

Verify if current ELC 
program is the same as 
editing program 

“Communication” > “Verify with 
ELC(V)”  --  

Set or remove ELC 
password 

“Communication” > “Password 
Setting(P)” [Ctrl] + [F5]  

Execute ELC  “Communication” > “Run(R)”  [Ctrl] + [F8]  
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Menu bar and General Toolbar 

Communication Menu 
Functions Operating Procedure Operation Keys 

(Keyboard Shortcuts) Icon 

Stop executing ELC  “Communication” > “Stop(S)”  [Ctrl] + [F7]  
Switch to ladder diagram 
monitor mode  

“Communication” > “Ladder 
Start Monitoring(L)” [Shift] + [Ctrl] + [F1]  

Switch to SFC monitor 
mode  

“Communication” > “SFC Start 
Monitoring”  [Shift] + [Ctrl] + [F2]  

Monitor the designated 
device 

“Communication” > “Devices 
Batch Monitoring(D)” [Shift] + [Ctrl] + [F3]  

Force device to be On or 
Off 

“Communication” > “Set 
Device On/Off(O)”  -- -- 

Change the current value 
of the designated device  

“Communication” > “Enter 
Value(E)”  [Shift] + [Ctrl] + [F7] -- 

Edit register (T, C and D) “Communication” > “Edit 
Register Memory (T, C, D) (B)” [Ctrl] + [R] -- 

Edit device status “Communication” > “Edit Bit 
Memory (M, S)” -- -- 

Clear all ELC memory 
and set ELC to factory 
settings 

“Communication” > “Format 
ELC Memory(M)”  [Shift] + [Ctrl] + [F5]  

Read / Write the data of 
the file registers of series 
ELC 

“Communication” > “Edit File 
Register Memory(A)”  -- -- 

 

Menu bar and General Toolbar 

Communication Menu 
Functions Operating Procedure Operation Keys 

(Keyboard Shortcuts) Icon 

Update program while 
PC/PA/PH series ELC is 
running (On-line 
Programming) 

“Communication” > “Send 
Changes(N)” -- -- 

Auto detect ELC 
communication baud rate 
when connect ELC to PC 

“Communication” > “Baud 
Rate Auto-Detect(Q)” --  

Display current ELC 
information 

“Communication” > “ELC 
Information(I)”  [Ctrl] + [Alt] + [I]  

 

Menu bar and General Toolbar 
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Options Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts)

 
Icon 

Set PC COM port 
(COM1~COM8) to 
communication with ELC 

“Options” > “Select COM 
Port(P)”    

Set ELC type and 
program capacity 

“Options” > “Change ELC 
Type(U)”  [Shift] + [Ctrl] + [F6]  

Set the value of ELC 
communication address 
(D1121) 

“Options” > “Station 
Address(A)”  [Shift] + [Ctrl] + [F8]  

Save file automatically 
before compiling  

“Options” > “Autosave 
Setup(S)” --  

Set the font setting and 
format of ladder diagram 
and comments 

“Options” > “Font Setting and 
Comment Format”  --  

Set the auto query times 
and query interval time 
when transmission error 
occurs 

“Options” > “Response 
Setup(R)”  --  

Set the communication 
baud rate of PC/PA/PH 
series ELC 

“Options” > “Set Baud Rate(B)” --  

Set the date and time of 
PC/PA/PH series ELC 

“Options” > “Set ELC Date and 
Time(T)”  --  

Specify to enter device 
comments after inputting 
instruction 

“Options” > “Prompt to Edit 
Device Comment(H)”  --  

 

 

 

Menu bar and General Toolbar 

Window Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts)

 
Icon 

Arrange windows in an 
overlapping way  “Window” > “Cascade(C)”  --  
Arrange the file in a 
horizontal way  

“Window” > “Title 
Horizontally(H)”  --  

Arrange files in a vertical 
way  “Window” > “Title Vertically(V)” --  
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Menu bar and General Toolbar 

Help Menu Functions Operating Procedure Operation Keys 
(Keyboard Shortcuts)

 
Icon 

Display ELCSoft relevant 
information, including 
Delta website, ELCSoft 
program version, serial 
number and copyright 

“Help” > “About ELCSoft(A)”  --  

RS-485 protocol setting, 
LRC/CRC generator, 
Duplicate ELC Service, 
and image saving 

“Help” > “Intelligent Function 
Utility(C)”  --  

Help for ELCSoft 
“Help” > “ELC Instruction & 
Special Registers 
Reference(S)“ 

  

User Manual for ELCSoft  “Help” > “ELCSoft User 
Manual(I)”    
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Company Information 
Eaton’s electrical business is a global leader in electrical control, power 
distribution, and industrial automation products and services. Through advanced 
product development, world-class manufacturing methods, and global engineering 
services and support, Eaton’s electrical business provides customer-driven 
solutions under brand names such as Cutler-Hammer®, Powerware®, Durant®, 
Heinemann®, Holec® and MEM®, which globally serve the changing needs of the 
industrial, utility, light commercial, residential, and OEM markets. For more 
information, visit www.EatonElectrical.com. 

Eaton Corporation is a diversified industrial manufacturer with 2003 sales of $8.1 
billion. Eaton is a global leader in fluid power systems and services for industrial, 
mobile and aircraft equipment; electrical systems and components for power 
quality, distribution and control; automotive engine air management systems and 
powertrain controls for fuel economy; and intelligent drivetrain systems for fuel 
economy and safety in trucks. Eaton has 55,000 employees and sells products to 
customers in more than 100 countries. For more information, visit 
www.eaton.com. 
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