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1. Introduction

1.1 Purpose
The CY3263-ColorLock EZ-Color Evaluation Kit demonstrates the ability of a EZ-Color controller to
use real-time optical feedback to control three primary, high brightness LEDs and create accurate,
mixed-color output. The three LEDs on the CY3263 evaluation board use the primary colors red,
green, and blue, although any three primary color LEDs can be used in a design, depending upon
the application and the desired color gamut.

Right out of the box, CY3263-ColorLock EZ-Color Evaluation kit can be used to evaluate and dem-
onstrate EZ-Color functionality, including color mixing and optical feedback. See the quick start on
how to use the kit with the factory installed firmware.

The next step is to develop a ColorLock application using this kit as a platform. Use PSoC Express,
Cypress's revolutionary visual embedded design tool, to quickly design powerful lighting applica-
tions.

This guide serves three main purposes:
1. Chapter 1. Introduction‚ on page 5 discusses kit contents, installation instructions, adding drivers

and valuators to designs, MiniProg installation, and programming instructions for PSoC Express
Projects.

2. Chapter 2. on page 13 discusses the ColorLock Monitor application. The ColorLock Monitor
application is used to demonstrate the functionality of ColorLock by displaying important infor-
mation as it controls the ColorLock evaluation board. Connect the board via a USB cable to a
personal computer running the Windows Vista or Windows XP operating system. Use this appli-
cation with the default factory program discussed in the CY3263-ColorLock EZ-Color Quick
Start. Note that the ColorLock Monitor application is not compatible with PSoC Express projects.
The board must have the factory installed firmware (available on the CD) to work with the Color-
Lock Monitor application. A PDF of the quick start is available on the Tools CD in the \docu-
ments folder.

3. Chapter 3. on page 25 though Chapter 5. on page 53 contains detailed PSoC Express example
projects for the CY3263-ColorLock EZ-Color Evaluation Kit. Review Section 1.4 Introduction to
PSoC Express, on page 8 before starting a project. Use these projects as the first step to learn-
ing how to create a custom design using PSoC Express.

WARNING: HIGH BRIGHTNESS LEDs CAN CAUSE PERMANENT
EYE DAMAGE!
Do not look at the LEDs if they are not covered by the protective
enclosure. The LEDs illuminate at a very high intensity and can
cause permanent eye damage if they are viewed without the
protective enclosure.
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1.2 Install Software

1.2.1 Install PSoC Express Development Software
1. Insert the Tools CD.
2. Wait for the installer to start.
3. Install the following software in the order listed:

a. Install PSoC Programmer
b. Install .NET Framework 2.0
c. Install PSoC Express
d. Install ColorLock Express Pack
e. Install ColorLock Kit Documentation

1.2.2 Install the CY3263-ColorLock EZ-Color Kit Software
1. Insert the CY3263-ColorLock EZ-Color Kit CD.
2. Open CY3263-ColorLock Setup.msi.
3. Follow the Setup Wizard instructions.

1.2.3 Install the Latest Version of PSoC Programmer
To ensure you have the latest version of PSoC Programmer:
1. Launch PSoC Programmer.
2. Select Help → About PSoC Programmer.
3. Note the version number and click OK.
4. Click Check for Updates. PSoC Programmer launches your web browser and opens the PSoC

Programmer web site.
5. Compare the PSoC Programmer version number you noted in Step 3. to the latest version avail-

able on the web site. If the version on the web site is newer, click Download, and download and
install the newest version.

1.2.4 Install the PSoC MiniProg
1. Ensure all content on the Tools CD is installed. 
2. Plug the MiniProg into your PC via the USB cable. If this is the first time you have connected the

PSoC MiniProg, the Windows Found New Hardware Wizard opens. If the Windows Found New
Hardware Wizard does not open, then the PSoC MiniProg software is already installed and you
do not need to continue with these instructions.

3. Select the No, not this time option button, and click Next.
4. Select the Install from a list or specific location (Advanced) option button and click Next.
5. Select the Don't search. I will choose the driver to install option button, and click Next.
6. Select the USB Mini Programmer (x.x.x.x) driver and click Next.
7. When prompted that the USB Mini Programmer (x.x.x.x) software has not passed Windows

Logo Testing, click Continue Anyway.
8. When Windows has completed the installation, click Finish.
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1.3 Board Layout

1.3.1 The On/Off Button
The CY3263-ColorLock EZ-Color evaluation hardware has two buttons and a liquid crystal display.
These allow the board to be demonstrated without using a personal computer to control the board.
When held properly for use, the buttons liquid crystal display face upward. When held in this orienta-
tion, the right-most button alternately turns the high brightness LEDs on and off. The default setting
when power is applied is off; pressing this right-most button will illuminate the LEDs.

1.3.2 The Color Selection Button
The left-most button along the bottom edge cycles between seven preset colors. The initial color is
white (all three LEDs are illuminated at high intensity). Pressing this button changes to the next color
of the seven preset colors. The color sequence cycles through white, red, green, blue, yellow,
magenta and cyan.

Note If the board has been controlled from a personal computer using the USB interface, the color
displayed upon powering the board and pressing the On/Off button will be the last color setting
selected when using the monitor application. If the board has never been controlled from a personal
computer, or the last color selected could not be displayed at the selected intensity, the LEDs will not
illuminate (an impossible color and intensity combination has been selected). Pressing the color
selection button will select a valid color for display from the seven preset colors and the LEDs will
illuminate with that color.

1.3.3 The Liquid Crystal Display
The liquid crystal display displays the currently selected color using CIE 1931 color coordinates. The
values displayed on the top line of the LCD represent the CIE x, y coordinates for the currently
selected color, whether chosen from the seven preset colors or selected from the ColorLock Monitor
application (if using the factory firmware). The two values on the bottom line of the display represent
the CIE x, y coordinate currently being sensed by the integrated color sensor. The difference
between these two values represents the error. The coordinates for the currently sensed color are
displayed in real-time and are continuously varying as the EZ-Color continually senses and corrects
for the error in the displayed color.

If the LEDs are illuminated, an asterisk (‘*’) is displayed on the left end of the top row of the liquid
crystal display (this is useful if the last color selected cannot be displayed with the given LEDs,
resulting in the LEDs being turned off).

Figure 1-1.  ColorLock Board
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1.4 Introduction to PSoC Express
PSoC Express is a revolutionary tool that enables the engineer to go from concept to embedded
custom ASIC in an hour or less. PSoC Express is a code-free visual design interface that employs
drag-and-drop drivers in lieu of writing code. Designers have access to libraries of sensors,
switches, potentiometers, High Brightness LEDs, and more.

With PSoC Express, users can drag and drop Inputs, Outputs, Valuators, and Interfaces from a
menu of typical analog and digital devices (see Figure 1-2 on page 9). The driver blocks are then
connected graphically with appropriate logic that determines their behavior. PSoC Express automat-
ically places and routes the hardware and uses firmware to create actual chip functions. Before pro-
gramming, you can use the simulation tool to verify the design. This free tool generates a data sheet,
schematic, and bill of materials along with a hex file for programming. Once the part is programmed
with the hex file, use the powerful PSoC Express Monitor feature to control and observe the behavior
of the drivers in the project.

Chapters 3 through 5 walk you step-by-step through three PSoC Express ColorLock EZ-Color exam-
ple projects. The following sections provide the necessary background information to successfully
complete the projects. If you are new to PSoC Express, review these sections before starting the
example projects.

1.4.1 Add Drivers and Valuators to a Design
It is very easy to add drivers and valuators to a design in PSoC Express 3. Throughout this guide,
when a driver or valuator needs to be added to a design, a small table displays the required informa-
tion. See Table 1-1 for an example. The table is broken into three sections:

■ Driver/Valuator: Shows the actual name of the driver or valuator.
■ Location: Shows the path to the device in the Driver Catalog.
■ Properties: Lists all properties associated with a device. In the User Input column, default val-

ues are labeled as such. Manually enter any data not labeled as default.

Note: To add a driver to a design, you must open a new or existing project. Adding new drivers does
not work in the Start Page in PSoC Express.

Table 1-1.  Example of an Add Driver or Valuator Table

Driver/Valuator Banked Output

Location
Outputs Tab
 � Digital Output

� Banked Output

Properties

Field User Input
Name XLeds

Number of output pins 4

DriveMode Strong (default)
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To add drivers and valuators to your design:
1. Ensure the Driver Catalog pane (Figure 1-2) is visible. If it is not visible, select View → Driver

Catalog.

Figure 1-2.  Driver Catalog Pane

2. Each driver and valuator has certain properties associated with it. For the purposes of this tuto-
rial, ensure View → Use Add Driver Dialog is checked.
Note: Some of the projects in this guide will not work unless the Add Driver Dialog option is 
selected.

Figure 1-3.  Use Add Driver Dialog Menu Option is Selected
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3. In PSoC Express, there are three ways to add drivers and valuators to a design. In the Driver
Catalog pane, navigate to the driver or valuator you want to add, and either drag-and-drop the
item to your design (Figure 1-4), double-click the item, or right-click on the item and select Add
to Design (Figure 1-5).

Figure 1-4.  Adding a Driver Via Drag and Drop

Figure 1-5.  Adding a Driver Via the Contextual Menu
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4. When drivers and valuators are added to a design, the Add Driver window opens (Figure 1-6).
Name the item and enter the properties required for the design.

Figure 1-6.  Add Driver Window

5. Click OK.

1.4.2 Program Parts with PSoC Express Projects

1. Connect the USB cable to the MiniProg and to the PC.
2. Connect the MiniProg to the programming header specified by the lab instructions.
3. Select Program → PSoC Programmer from PSoC Express. The following three actions are

automatically accomplished:
a. PSoC Programmer starts.
b. The executable firmware is loaded into PSoC Programmer.
c. The EZ-Color device to be programmed is specified in PSoC Programmer.

Note: If the Actions column in the PSoC Programmer status box indicates “Firmware update
required at...”, the MiniProg's firmware is out of date. Before attempting to program the target EZ-
Color chip, go to Utilities → Upgrade Firmware to update the MiniProg's firmware.

WARNING: Disconnect all power sources from the board. Damage to the board may
occur if you program the board while leaving a wall adapter connected.
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4. In PSoC Programmer:
a. Select the MiniProg from the Port list.
b. Select the Power Cycle option button.
c. Click the Program button in the toolbar.
d. Wait until the Actions column of PSoC Programmer's status window indicates either Pro-

gramming Succeeded or Programming Terminated. If the Programming Terminated message 
appears, troubleshoot the problem, and re-attempt to program the device.

e. Exit PSoC Programmer.
5. Disconnect the MiniProg from the board.

1.5 Document Revision History 

1.6 Documentation Conventions 

Table 1-2.  Revision History

Revision PDF Creation 
Date

Origin of 
Change Description of Change

** 04/24/2008 SFVTMP3 New Guide
*A 05/06/2008 AESA Updated device to EZ-Color

Table 1-3.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File → Open Represents menu paths:
File → Open → New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.
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2. ColorLock Monitor

Note The ColorLock Monitor application is for demonstration purposes only and is completely sepa-
rate from the Tuner in PSoC Express, which is a design tool, and will not function while PSoC
Express is open.

The CY3263-ColorLock EZ-Color Evaluation Kit board demonstrates the ability of a EZ-Color con-
troller to provide closed-loop, high accuracy control for three primary, high brightness LEDs to create
mixed-color output. To provide the closed-loop capability, a TAOS TSC-230 color sensor is used to
determine the current color being produced by the LEDs. This information is fed to the EZ-Color
LED16 controller to determine the correct brightness for each of three primary, high brightness
LEDs. The three LEDs are the colors red, green, and blue. The application described in this chapter
controls the ColorLock evaluation board through a USB port on a personal computer that is using the
Windows Vista or Windows XP operating system.

2.1 Representing Colors
The application can represent either of two standard color coordinate systems: CIE 1931 x, y or CIE
1976 u’, v’. These two modes are available under the Settings > Color Space pull-down on the appli-
cation tool-bar. The CIE 1931 coordinate system is automatically selected when the application is
started. The CIE Color Mix Mode displays the 1931 CIE Color chart. This chart represents the range
of colors visible to the human eye. The interior portion of the triangle displayed on the color chart
represents the range of colors that can be represented by the LEDs on the ColorLock board. All syn-
thetic light sources, such as LEDs or incandescent lights, produce some limited range of the spec-
trum of colors the human eye can see. The triangle shows the colors that can be displayed by mixing
the light from the three LEDs on the evaluation board. Clicking anywhere within the triangle will place
a dot at the selected point. The corresponding CIE coordinates for that color are transmitted to the
ColorLock board, where the selected color is displayed by adjusting the three LEDs to brightness
levels that create the mixed color. The resulting coordinates are shown numerically in the Color
panel displayed below the color chart. If the CIE 1931 chart is selected, the x, y coordinates are
shown. If the CIE 1976 chart is selected, the u’, v’ coordinates are displayed.

The Manual Control Mode is an alternative to specifying colors using CIE coordinates. This mode
displays three slider controls, one for each LED on the board. Moving a slider from left-to-right
causes the corresponding LED to light from zero to one-hundred percent of this maximum bright-
ness. To control the LEDs manually, check Disable Feedback below the three horizontal slider con-
trols displayed on the bottom right portion of the application display. Notice that all controls related to

WARNING: HIGH BRIGHTNESS LEDs CAN CAUSE PERMANENT
EYE DAMAGE!
Do not look at the LEDs if they are not covered by the protective
enclosure. The LEDs illuminate at a very high intensity and can
cause permanent eye damage if they are viewed without the
protective enclosure.
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ColorLock Monitor

selecting color or brightness using the color-lock feature are disabled when the Disable feedback
box is checked. These controls have no meaning when setting the individual LED brightness levels
manually.

The colors that can be displayed are determined by the choice of LEDs used on the board. The col-
ors produced by individual LEDs are referred to as primary colors. All other colors are created by
mixing various intensities of the primary colors. Such mixed colors appear the same to the eye as if
produced by an LED producing that color as its primary color. The colors that can be selected are
called the evaluation board's color gamut. Once the primary LED colors are determined, as they are
on the evaluation board, the color gamut is defined by those choices. Thus, the bounding triangle
defines the color gamut for the board. Colors outside of the color gamut cannot be represented by
the given LEDs and the user cannot select colors outside of the color gamut. For any coordinate
selected outside of the color gamut, the LEDs turn off.

Note The triangle is an approximate gamut boundary. For points adjacent to the triangle edges,
especially close to the LED coordinates (i.e., the corners), it is possible to select a point that falls out-
side of the color gamut.

2.2 Installation Requirements
In order to use the ColorLock Monitor application, a personal computer running Window's Vista or
Window's XP is required. The computer must have the minimum amount of memory required to run
the desired version of Windows, as well as at least 1.5 megabytes of available hard disk space. In
addition, one available USB port is needed to connect the evaluation board to the computer using an
A to mini B USB cable. This port can be provided by using an expansion hub connected to one of the
host computer’s USB ports.
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2.3 Using the ColorLock Monitor Application

2.3.1 Initial Application Displays
Figure 2-1 shows the ColorLock Monitor window that appears when the ColorLock Monitor applica-
tion is started. As long as the ColorLock evaluation unit is not connected to the PC with a USB cable,
the USB Link Status box located in the bottom right corner of the window shows the status Not Con-
nected, with a red background. When the unit is connected to the host PC and the host recognizes
the hardware is present, the status changes to Connected to ColorLock Demonstration, along with
the version of the ColorLock unit’s firmware. The status box background changes to green to indi-
cate that communication has been established (see Figure 2-2).

Figure 2-1.  The ColorLock Startup Display
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In addition to displaying colors, the application turns the LEDs on or off. The LEDs are turned on
whenever the real-time color-lock is running (i.e., the green, right-pointing arrow on the left end of the
tool-bar has been clicked.) If color-lock has been turned off (i.e., the red ‘X’ to the right of the green
arrow) the LEDs are also turned off.

Figure 2-2.  Connected to the ColorLock Hardware
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The ColorLock Monitor window is divided into five panes. The upper two panes are graphs that show
the current CIE coordinates for the color output being sensed on the left and the corresponding error,
or deviation from the selected color on the right. Below these two graphs, the currently selected CIE
color chart (initially the CIE 1931 chart) and brightness slider are displayed in the bottom left quarter
of the monitor’s window. Below the color chart and brightness slider, the currently selected color is
displayed as CIE coordinates (x, y for CIE 1931 or u’, v’ for CIE 1976, Figure 2-3). Finally, the current
brightness setting is displayed numerically, with a range of 0 (LEDs off) to 1000 (LEDs at maximum
intensity). The bottom right quarter contains two panes: a real-time graph showing the current dim-
ming values for each of the three LEDs, and below that a pane containing the horizontal manual con-
trol intensity sliders for each LED. 

For each graph, any of the parameters shown can be selectively enabled or disabled. For example,
for the graph PrISM Values, the graph of the current PrISM value for the blue LED can be turned off
by unchecking B (Figure 2-3). When turned off, the corresponding graph trace is removed from the
graph. Checking B causes the graph for the blue LED to display again. There is no information loss
when a particular trace is disabled: checking the selected graph trace will cause it’s charted values
to be displayed again.

Figure 2-3.  CIE 1976 Color Display
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As shown in Figure 2-2, all of the graphs remain blank, displaying only the coordinate axes, without
an associated graph, until the monitor is placed in run mode. The monitor can be run by either click-
ing the right-pointing green arrow icon in the tool bar (see Section 2.3.2 Toolbar Icons and
Menubar Options on page 14), or by selecting the pull-down labeled Monitor and clicking and select-
ing the Run option. Upon selecting Run, the monitor will enable the ColorLock evaluation board and
begin charting the graphed parameters representing the currently sensed coordinates, the current
error and the three current PrISM values. The monitor updates in real time, showing the EZ-Color
color-lock function as the EZ-Color continually corrects the currently generated color relative to the
currently selected color. As the EZ-Color more closely approximates the requested color, the error
graph dynamically changes scale to provide a higher resolution graph of the error correction. Simi-
larly, the scales of the other graphs automatically update to graph only the range of values currently
displayed. When run is selected, the monitor renders the arrow icon in gray to indicate that the mon-
itor is running. See Figure 2-4.

Figure 2-4.  Running Monitor Showing the Three Graphs Actively Charting
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The manual control sliders in the bottom right pane are enabled if the Disable feedback checkbox is
checked, otherwise they are set automatically, based upon the current CIE color coordinate and the
color-lock firmware on the ColorLock unit. If Disable feedback is checked, the Red, Green and Blue
sliders become active. Simultaneously, all ColorLock related controls, including the graphs and the
CIE related controls, become inactive. The LEDs are controlled by setting the PrISM values directly
using the slider for each LED so ColorLock functionality no longer applies. See Figure 2-5.

Figure 2-5.  Feedback Disabled
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2.3.2 Toolbar Icons and Menubar Options
The ColorLock monitor application can be controlled using the toolbar icons or by using menu bar
options. Both provide the complete set of control options available in the monitor. This section
describes each icon and the corresponding menu-bar selection. In the descriptions that follow, each
icon is shown, followed by the corresponding menu selection path on the menu bar, followed by a
description of the use and function of the control.

(Monitor → Run) When selected, this icon starts the monitor. The charts begin displaying real-
time information about the current state of the ColorLock unit. Once selected, the Run control is
rendered inactive and is “grayed out,” as the monitor is now running.

(Monitor → Stop) This control stops the monitor. All charting stops, but the graphical information
recorded in the charts is preserved. Once selected, the Stop control is rendered inactive and is
“grayed out,” as the monitor is now stopped.

(Settings → ColorSpace → CIE1931) This icon causes the monitor to use CIE 1931 color coor-
dinates. This is the default coordinate system when the monitor is started. When selected, the
CIE 1931 color chart is displayed in the lower left pane and the charts display data using the x, y
coordinate values used in the CIE 1931 coordinate system.

(Settings → ColorSpace → CIE1976) This icon causes the monitor to use CIE 1976 color coor-
dinates. When selected, the CIE 1976 color chart is displayed in the lower left pane and the
charts display data using the u’, v’ coordinate values used in the CIE 1976 coordinate system.

(Settings → LED Color Coordinates) This icon results in a pop-up menu that shows the current
CIE 1931 x, y coordinates for the LEDs being used in the ColorLock unit. These values repre-
sent the primary colors that define the color gamut being displayed by the ColorLock unit. The
values in this window are measured from the existing LEDs on the board. New values can be
entered, which will only change the color gamut in the window, it does not change the capability
of the LEDs to create different colors. In general there is no reason to change these settings
unless the LED board in the ColorLock unit is being changed. If the system is calibrated using
the calibration tool, these values will be overwritten with the new gamut information.

(Tools → Calibration) This control results in a pop-up menu that allows for the calibration of the
ColorLock unit’s optical feedback system. Each of the sensor’s three color channels must be
calibrated with values obtained from an external color meter. The first menu displayed calibrates
the red color channel of the sensor, the second menu the green channel, and the third menu the
blue sensor. Each menu requires three color values from the color meter, corresponding to the
red, green and blue components for the given channel. Upon completion, the monitor sends the
calibration information to the ColorLock unit, where it is stored. The calibration information is
stored in non-volatile flash, unless the contents of flash memory is overwritten.

(Tools → Show Calibration Matrices) This control results in a pop-up window that displays the
values of the current calibration matrices. The values shown cannot be changed using this win-
dow, only the calibration menu can change the values of the three matrices displayed. The Col-
orLock firmware uses the contents of these matrices to transform the current sensor readings
into PrISM values for each of the three LEDs. For more calibration information for this system,
refer to Application Note 44533 ColorLock Optical Feedback for EZ-Color.

(Help → About) This menubar selection results in a pop-up window that displays the application
version and copyright information. Clicking the OK button closes the About window.
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2.3.3 Error Messages
There are several situations that will result in error windows being displayed. These result from situ-
ations where the monitor cannot communicate with the ColorLock unit and are related to situations
where the monitor needs to read or change matrix values on the unit. Figure 2-6 shows the result of
attempting to show the calibration matrix values when the ColorLock unit is not attached.

Figure 2-6.  Error Reading Calibration Matrices
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A similar error occurs if sensor calibration is attempted without an attached ColorLock unit. See
Figure 2-7. If this error occurs, the ColorLock unit can be attached and the calibration values are
retained so that the calibration can be completed without entering the values again.

Figure 2-7.  Calibration Failure
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2.3.4 Dynamic Update
The ColorLock evaluation board has two buttons that allow the board to be demonstrated without
using this application. One button is used to turn the LEDs on and off. The second button is used to
cycle between seven preset colors. At any time the user can use the buttons to control the evalua-
tion board.

2.3.5 Shutting Down the Application
Select Exit from the File menu to close the ColorLock Monitor application.

2.3.6 Reset the Board to the Original Factory Programming
Follow these steps if you wish to reset the board to the original factory installed programming:
1. Locate the CY3263-ColorLock CY8CLED16.hex file on the ColorLock CD included with this kit, it 

is in the following directory:
D:\Firmware\Hex Files\CY3263-ColorLock CY8CLED16.hex

2. To reset the board to the factory conditions, connect your computer to the Color-
Lock main board ISSP Connector (J4) using the PSoC MiniProg and a USB cable.

3. Open PSoC Programmer by going to the Windows Start menu � All Programs 
� Cypress MicroSystems � PSoC Programming � PSoC Programmer

4. Click File Load, navigate to, and open the cy3263-ColorLock CY8CLED16.hex file.
5. From the Device Family menu, select CY8CLED16.
6. From the Device menu, select CY8CLED16-48LFXI.
7. Click Program. “Programming Succeeded...” appears in the Actions pane when programming is 

complete.
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3. Tuner Project

3.1 Description
This project creates firmware that color mixes three primary high-brightness LEDs to a specific color
and introduces optical feedback into the system using a color sensor.

The user can then choose the Tuner to select other desired colors mapped along the 1931 CIE XYZ
Color Space.

The tuner enables turning ON/OFF the LEDs and adjusting the resultant flux output, over an I2C
interface. By default, the firmware will automatically generate a single color output within the defined
color gamut.

The project utilizes five different Interface (Communication) Valuators. Each set a specific register
which can be modified using the available tuner. The LEDEnable controls the 3LED ColorLock
Driver, the LEDTrigger controls the optical feedback loop, the LEDBrightness valuator controls a set
flux value and the final two valuators set the specific color. In turn, the 3-LED ColorLock Driver con-
trols the LM3404 Switching Regulators to power the LEDs.

3.2 EZ-Color Device
CY8CLED16, 48-Pin MLF

3.3 Start a New Project
1. Select File → New Project.
2. Name the project Tuner.
3. If needed, click Browse to save the project in a different location.
4. Click OK.

WARNING: HIGH BRIGHTNESS LEDs CAN CAUSE PERMANENT
EYE DAMAGE! 
Do not look at the LEDs if they are not covered by the protective
enclosure. The LEDs illuminate at a very high intensity and can
cause permanent eye damage if they are viewed without the
protective enclosure.
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3.4 Add an Output Driver

1. The ColorLock (Luxeon Rebel® with LM3402) Properties window opens. Set the following val-
ues:
■ Set LED1 Luminous Flux Bin to F, and the LED1 Color Bin to 4.
■ Set LED2 Luminous Flux Bin to G, and the LED2 Color Bin to 2.
■ Set LED3 Luminous Flux Bin to C, and the LED3 Color Bin to 2.

Table 3-1.  Luxeon Rebel® with LM3402

Driver/Valuator

Lumileds™ Luxeon® Rebel 3-LED Color Mixing Driver with Color-
Lock™ Closed Loop Optical Feedback and LM3402 External 
Constant Current Source
Note: When you click OK to close the Add Output Driver window, 
the ColorLock (Luxeon Rebel® with LM3402) Properties win-
dow opens.

Location

Outputs Tab
 � High Brightness LED

� 3-LED Color Mixing
� ColorLock™ Optical Feedback

� Lumileds™

� Luxeon® Rebel, 350mA
� Luxeon Rebel® with LM3402

Properties

Field User Input
Name ColorLock

ClockFrequency 20000 (Default)

Color Space 1931 XYZ Color Space (Default)

LED1 Part Number LXML-PD01 Red (Default)

LED2 Part Number LXML-PM01 Green (Default)

LED3 Part Number LXML-PB01 Blue (Default)

LED1 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED1 Color Bin 1 (Default)

LED2 Color Bin 1 (Default)

LED3 Color Bin 1 (Default)

Expose Tuning Values Yes (Default)
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Figure 3-1.  LED Settings in the ColorLock (Luxeon® Rebel with 3402) Properties Window

2. Click OK when finished.

3.5 Add Five Interface Valuators
Note: These steps must be performed in the Add Valuator dialog box that appears when the Discrete
Interface Valuator is initially placed in the design.

Table 3-2.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDEnable

Default Value 0x1

States (Default)
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Table 3-3.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name LEDBrightness

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 750

Table 3-4.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDTrigger

Default Value 0x1

States (Default)

Table 3-5.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name xValuator

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 2000
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3.6 Define Output Behavior
1. Right-click the ColorLock driver icon and select Transfer Function.
2. Set the following fields:

■ Set Enable to LEDEnable
■ Set Target x to xValuator
■ Set Target y to yValuator
■ Set Relative Flux to LEDBrightness
■ Set ColorLock Trigger to LEDTrigger

Figure 3-2.  ColorLock Transfer Function Window

3. Click OK when done.

Table 3-6.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name yValuator

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 2000
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3.7 Add an Interface Driver

With a little rearranging, your workspace should look like the example below.

Figure 3-3.  Tuner Project Design View Pane

3.8 Build project

3.8.1 Build the Project
1. Select Build → Generate\Build ‘Tuner’ Project.
2. In the Available Device Configurations pane, select CY8CLED16 → CY8CLED16, 48-Pin MLF.
3. In the Device Configurations Properties pane, set the following parameters:

■ Sample Rate → 8 Hz
■ Flash Interface → Enable

4. Ensure the Assign pins automatically check box is not selected.
5. Click Next.
6. In the User Pin Assignment window, click Unassign All Pins.

Table 3-7.  Slave Driver

Driver/Valuator I2C Slave Interface

Location

Interfaces Tab
 � Communication 

� I2C
� Slave

Properties
Field User Input

Name Interface1

I2C_Address 4 (Default)
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7. Assign drivers to pins by dragging and dropping the blue rectangles from the Unassigned Driv-
ers list to the pins listed in the following table.

Figure 3-4.  Tuner Pinout Diagram

8. Select Lock Pins, and click Next. PSoC Express builds your project.

WARNING: Assign pins in the order listed in Table 3-8. Assign drivers according to the
Order of Assignment column in Table 3-8, not the order of appearance in the User Pin Assign-
ment window.

Table 3-8.  Tuner Pinouts

Order of 
Assignment

Order of 
Appearance Function Pin Notes

0 0 ColorLock_ColorSensor Port 2_5

1 7 TCS230SHARED_0 S0 Port 2_0 �The these four drivers are 
assigned automatically when 
the ColorLock_ColorSensor 
driver is assigned. You must 
reassign them before assign-
ing the rest of the pins.

2 8 TCS230SHARED_0 S1 Port 2_1

3 9 TCS230SHARED_0 S2 Port 2_2

4 10 TCS230SHARED_0 S3 Port 2_3

5 1 ColorLock_Dim1 Port 1_2

6 2 ColorLock_Dim2 Port 1_3

7 3 ColorLock_Dim3 Port 1_4

8 4 ColorLock_Enable Port 4_0

9 6 Interface1 I2CSDAPin Port 1_5 �The I2CSCLPin driver is 
assigned automatically when 
the I2CDAPPin driver is 
assigned.10 5 Interface1 I2CSCLPin Port 1_7
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3.9 Program the EZ-Color Part
1. Disconnect any power sources from the evaluation board and connect the MiniProg to your PC 

using a USB cable.
2. Connect the Miniprog to the 5-pin ISSP header.
3. Program the part via J1 as described in the Program Parts with PSoC Express Projects section 

on page 11.

3.10 Tune Your Project
1. Apply power to the board using the supplied wall adapter.
2. Connect the board to your PC via a USB cable.
3. Select Monitor in PSoC Express.

Figure 3-5.  PSoC Express Monitor Pane

4. Click Play . The Monitor toolbar will change from Connected , to Running .
5. Right-click on the ColorLock driver icon and select Show Tuner.
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Figure 3-6.  ColorLock (Luxeon® Rebel with LM3402) Tuner

3.11 Calibrate the LEDs
1. Select Calibration.
2. Select Set LED1 to Maximum.
3. Select Set LED2 to Maximum.
4. Select Set LED3 to Maximum.
5. Select Calibrate.
6. Select OK to reenter Tuner.
7. Adjust the brightness of the LED using the slider and turn the LED on and off.
8. Enter coordinates directly into the x and y fields.
9. Click directly within color gamut.
10. Click Lock Color.
11. Click any other point inside color gamut and watch optical feedback response.
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4. Traffic Light Project

4.1 Description
This project creates firmware that color mixes three primary high-brightness LEDs to the three
cycled colors found in a traffic light and introduces optical feedback into the system using a color
sensor. 

The user can then choose the Tuner to select other desired colors mapped along the 1931 CIE XYZ
Color Space.

The tuner enables turning ON/OFF the LEDs and adjusting the resultant flux output, over an I2C
interface. By default, the firmware will automatically generate a red, green, and yellow color inside
the defined color gamut. The LCD display will generate text dependent on the state the program is
in.

The project utilizes three different Interface (Communication) Valuators. Each set a specific register
which can be modified using the available tuner. The LEDEnable controls the 3LED ColorLock
Driver, the LEDTrigger controls the optical feedback loop and the LEDBrightness valuator controls a
set flux value. Also utilized are two priority encoders to cycle through the traffic signal colors based
on x,y coordinates in the 1931 CIE XYZ Color Space. Next, the program contains a timing element
and three different priority encoders that feed a state machine. This timing element controls the
length of time Red, Green, and Yellow are displayed. Finally, the 3-LED ColorLock Driver controls
the LM3404 Switching Regulators to power the LEDs.

4.2 EZ-Color Device
CY8CLED16, 48-Pin MLF

4.3 Start a New Project
1. Select File → New Project.
2. Name the project TrafficLight.
3. If needed, click Browse to save the project in a different location.
4. Click OK.

WARNING: HIGH BRIGHTNESS LEDs CAN CAUSE PERMANENT
EYE DAMAGE! 
Do not look at the LEDs if they are not covered by the protective
enclosure. The LEDs illuminate at a very high intensity and can
cause permanent eye damage if they are viewed without the
protective enclosure.
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4.4 Add an Output Driver

1. The ColorLock (Luxeon Rebel® with LM3402) Properties window opens. Set the following val-
ues:
■ Set LED1 Luminous Flux Bin to F, and the LED1 Color Bin to 4.
■ Set LED2 Luminous Flux Bin to G, and the LED2 Color Bin to 2.
■ Set LED3 Luminous Flux Bin to C, and the LED3 Color Bin to 2.

Table 4-1.  Luxeon Rebel® with LM3402

Driver/Valuator

Lumileds™ Luxeon® Rebel 3-LED Color Mixing Driver with Color-
Lock™ Closed Loop Optical Feedback and LM3402 External 
Constant Current Source
Note: When you click OK to close the Add Output Driver window, 
the ColorLock (Luxeon Rebel® with LM3402) Properties win-
dow opens.

Location

Outputs Tab
 � High Brightness LED

� 3-LED Color Mixing
� ColorLock™ Optical Feedback

� Lumileds™

� Luxeon® Rebel, 350mA
� Luxeon Rebel® with LM3402

Properties

Field User Input
Name ColorLock

ClockFrequency 20000 (Default)

Color Space 1931 XYZ Color Space (Default)

LED1 Part Number LXML-PD01 Red (Default)

LED2 Part Number LXML-PM01 Green (Default)

LED3 Part Number LXML-PB01 Blue (Default)

LED1 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED1 Color Bin 1 (Default)

LED2 Color Bin 1 (Default)

LED3 Color Bin 1 (Default)

Expose Tuning Values Yes (Default)
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Figure 4-1.  LED Settings in the ColorLock (Luxeon® Rebel with 3402) Properties Window

2. Click OK when finished.

4.5 Add Three Interface Valuators
Note: These steps must be performed in the Add Valuator dialog box that appears when the Discrete
Interface Valuator is initially placed in the design.

Table 4-2.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDEnable

Default Value 0x1

States (Default)
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4.6 Add Three Transfer Function Valuators
Note: These steps must be performed in the Add Valuator dialog box that appears when the Discrete
Interface Valuator is initially placed in the design.

4.6.1 Add the TrafficState StateMachine Transfer Function Valuator

1. In the State Machine Transfer Function TrafficState window:
a. Click Add State, set the Name to Red, and click OK.
b. Click Add State, set the Name to Green, and click OK.
c. Click Add State, set the Name to Yellow, and click OK.

Table 4-3.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name LEDBrightness

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 1000

Table 4-4.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDTrigger

Default Value 0x1

States (Default)

Table 4-5.  StateMachine Valuator

Driver/Valuator StateMachine

Location
Valuators Tab
 � Transfer Function Valuators

� StateMachine

Properties
Field User Input

Name TrafficState
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Figure 4-2.  State Machine Transfer Function TrafficState Window

2. Click OK to close State Machine Window.

4.6.2 Add the xValuator Priority Encoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - xValuator window opens. Set the If/Else statements to 
the values in Table 4-7.

Table 4-6.  Priority Encoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name xValuator

Table 4-7.  xValuator Priority Encoder Transfer Function Values

Else/If Then xValuator =
TrafficState_state==TrafficState_state__Green 2000

TrafficState_state==TrafficState_state__Red 6800

TrafficState_state==TrafficState_state__Yellow 5300
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2. Select Continuous.

Figure 4-3.  Priority Encoder Transfer Function - xValuator Window

3. Click OK.

4.6.3 Add the yValuator Priority Encoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - yValuator window opens. Set the If/Else statements to 
the values in Table 4-9.

2. Select Continuous.

Figure 4-4.  Priority Encoder Transfer Function - yValuator Window

Table 4-8.  Priority Encoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name yValuator

Table 4-9.  yValuator Priority Encoder Transfer Function Values

Else/If Then yValuator =
TrafficState_state==TrafficState_state__Green 5000

TrafficState_state==TrafficState_state__Red 3000

TrafficState_state==TrafficState_state__Yellow 4200
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3. Click OK.

4.7 Add an Input Driver

4.8 Add Three Valuators 

4.8.1 Add the RedCount PriorityEncoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - RedCount window opens. Set the If/Else statements to 
the values in Table 4-12.

Figure 4-5.  Priority Encoder Transfer Function - RedCount

Table 4-10.  Interval Generator Driver

Driver/Valuator Interval Generator

Location
Inputs Tab
 � Timing

� Interval Generator

Properties
Field User Input

Name Count100ms

IntervalTime 100 (Default)

IntervalMode PULSE (Default)

Table 4-11.  PriorityEncoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name RedCount

Table 4-12.  RedCount Priority Encoder Transfer Function Values

Else/If Then RedCount =
(TrafficState_state==TrafficState_state__Red) && 
(Count100ms==Count100ms__Triggered) RedCount+1

TrafficState_state!=TrafficState_state__Red 0
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2. Click OK when finished.

4.8.2 Add the GreenCount PriorityEncoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - GreenCount window opens. Set the If/Else statements 
to the values in Table 4-14.

Figure 4-6.  Priority Encoder Transfer Function - GreenCount

2. Click OK when finished.

Table 4-13.  PriorityEncoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name GreenCount

Table 4-14.  GreenCount Priority Encoder Transfer Function Values

Else/If Then GreenCount =
(TrafficState_state==TrafficState_state__Green) && 
(Count100ms==Count100ms__Triggered) GreenCount+1

TrafficState_state!=TrafficState_state__Green 0
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4.8.3 Add the YellowCount PriorityEncoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - YellowCount window opens. Set the If/Else statements 
to the values in Table 4-16.

Figure 4-7.  Priority Encoder Transfer Function - YellowCount

2. Click OK when finished.

Table 4-15.  PriorityEncoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name YellowCount

Table 4-16.  YellowCount Priority Encoder Transfer Function Values

Else/If Then YellowCount =
(TrafficState_state==TrafficState_state__Yellow) && 
(Count100ms==Count100ms__Triggered) YellowCount+1

TrafficState_state!=TrafficState_state__Yellow 0
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4.9 Add an Output Driver

4.10 Define Output Behavior
1. Right-click on the LCD Text driver icon and select Transfer Function.
2. Select TableLookup in the list of transfer functions, and click OK.
3. Select TrafficState_state in the Select Input(s) list.
4. Click Next.
5. Drag the TrafficState_state Input values to the following LCD state columns:

■ Red → Text1
■ Green → Text2
■ Yellow → Text3

Figure 4-8.  TrafficLight Table Lookup

6. Click OK.

Table 4-17.  LCD Selectable Scrolling Text - Full Line

Driver/Valuator LCD Selectable Scrolling Text – Full Line

Location

Outputs Tab
 � Display

� LCD
� LCD Selectable Scrolling Text - Full Line

Properties

Field User Input
Name LCDText

Initial Value No_Text (Default)

Row Location Row 0 (Default)

Text 1 Stop

Text 2 Go

Text 3 Slow Down!

Text 4 (Leave Blank)

Text 5 (Leave Blank)

Text 6 (Leave Blank)

Text 7 (Leave Blank)

Step_time 100 (Default)
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4.11 Add State Machine Transitions

4.11.1 Add the Red State Machine Transition
1. Right-click on the TrafficState driver icon and select Transfer Function.
2. Right-click Red and select Edit.
3. Click Add.
4. In the Name field, enter RedGreen.
5. In the Expression field, enter RedCount>=50.
6. Set Transition From field to Red, and Transition To field to Green.
7. Click OK to close the Add Transition window.

Figure 4-9.  Add Transition Window

8. Click OK to close the Add State window.

4.11.2 Add the Green State Machine Transition
1. Right Click Green and select Edit.
2. Click Add.
3. In the Name field, enter GreenYellow.
4. In the Expression field, enter GreenCount>=50.
5. Set Transition From field to Green, and Transition To field to Yellow.
6. Click OK to close the Add Transition window.
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Figure 4-10.  Add Transition Window

7. Click OK to close the Add State window.

4.11.3 Add the Yellow State Machine Transition
1. Right Click Yellow and select Edit.
2. Click Add.
3. In the Name field, enter YellowRed.
4. In the Expression field, enter YellowCount>=30.
5. Set Transition From field to Yellow, and Transition To field to Red.
6. Click OK to close the Add Transition window.

Figure 4-11.  Add Transition Window

7. Click OK to close the Add State window.
8. Click OK to close the State Machine Transfer Function TrafficState window.
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4.12 Define Output Behavior
1. Right-click on the ColorLock driver icon and select Transfer Function.
2. Set the following fields:

■ Set Enable to LEDEnable
■ Set Target x to xValuator
■ Set Target y to yValuator
■ Set Relative Flux to LEDBrightness
■ Set ColorLock Trigger to LEDTrigger

Figure 4-12.  ColorLock Transfer Function Window

3. Click OK when done.

4.13 Add an Interface Driver

With a little rearranging, your workspace should look like the example in Figure 4-13.

Table 4-18.  Slave Driver

Driver/Valuator I2C Slave Interface

Location

Interfaces Tab
 � Communication 

� I2C
� Slave

Properties
Field User Input

Name Interface1

I2C_Address 4 (Default)
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Figure 4-13.  PSoC Express Design View Pane
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4.14 Build project
1. Select Build → Generate\Build ‘TrafficLight’ Project.
2. In the Available Device Configurations pane, select CY8CLED16 → CY8CLED16, 48-Pin MLF.
3. In the Device Configurations Properties pane, set the following parameters:

■ Sample Rate → 8 Hz
■ Flash Interface → Enable

4. Ensure the Assign pins automatically check box is not selected.
5. Click Next.
6. In the User Pin Assignment window, click Unassign All Pins.
7. Assign drivers to pins by dragging and dropping the blue rectangles from the Unassigned Driv-

ers list to the pins listed in the following table.

WARNING: Assign pins in the order listed in Table 4-19. Assign drivers according to
the Order of Assignment column in Table 4-19, not the order of appearance in the User Pin
Assignment window.

Table 4-19.  TrafficLight Pinouts

Order of 
Assignment

Order of 
Appearance Function Pin Notes

0 0 ColorLock_ColorSensor Port 2_5

1 7 TCS230SHARED_0 S0 Port 2_0 �The these four drivers are 
assigned automatically when 
the ColorLock_ColorSensor 
driver is assigned. You must 
reassign them before assign-
ing the rest of the pins.

2 8 TCS230SHARED_0 S1 Port 2_1

3 9 TCS230SHARED_0 S2 Port 2_2

4 10 TCS230SHARED_0 S3 Port 2_3

5 1 ColorLock_Enable Port 4_0

6 2 ColorLock_Dim1 Port 1_2

7 3 ColorLock_Dim2 Port 1_3

8 4 ColorLock_Dim3 Port 1_4

9 6 Interface1 I2CSDAPin Port 1_5

10 5 Interface1 I2CSCLPin Port 1_7
�The I2CSCLPin driver is 
assigned automatically when 
the I2CDAPPin driver is 
assigned

11 7 pse_LCD_SHARED_0 LCDPin11 Port 3_0

12 8 pse_LCD_SHARED_0 LCDPin12 Port 3_1 �The these six drivers are 
assigned automatically when 
the pse_LCD_SHARED_0 
LCDPin11 driver is assigned.

13 9 pse_LCD_SHARED_0 LCDPin13 Port 3_2

14 10 pse_LCD_SHARED_0 LCDPin14 Port 3_3

15 11 pse_LCD_SHARED_0 LCDPin6 Port 3_4

16 12 pse_LCD_SHARED_0 LCDPin4 Port 3_5

17 13 pse_LCD_SHARED_0 LCDPin5 Port 3_6
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Figure 4-14.  TrafficLight Pinout Diagram

8. Select Lock Pins and click Next. PSoC Express builds your project.

4.15 Program the EZ-Color Device
1. Disconnect any power sources from the evaluation board and connect the MiniProg to your PC 

using a USB cable.
2. Connect the Miniprog to the 5-pin ISSP header.
3. Program the part via J1 as described in the Program Parts with PSoC Express Projects section 

on page 11.
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4.16 Tune Your Project
1. Apply power to the board using the supplied wall adapter.
2. Connect the board to your PC via a USB cable.
3. Select Monitor in PSoC Express.

4. Click Play . The Monitor toolbar will change from Connected , to Running .
5. Right-click on the ColorLock driver icon and select Show Tuner.

Figure 4-15.  ColorLock (Luxeon Rebel® with LM3402) Tuner Window

4.17 Calibrate LEDs
1. Select Calibration.
2. Select Set LED1 to Maximum.
3. Select Set LED2 to Maximum.
4. Select Set LED3 to Maximum.
5. Select Calibrate.
6. Click OK to return to the Tuner.

4.18 Run Program
Uncheck Override to observe the TrafficLight program. After closing the tuner window, power cycle
the evaluation board before continuing with monitoring or tuning the design.
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5. Modulated Dimmer Project

5.1 Description
This project creates firmware that color mixes three primary high-brightness LEDs to a single color,
modulates the brightness and introduces optical feedback into the system using a color sensor.

The user can then choose the Tuner to select other desired colors mapped along the 1931 CIE XYZ
Color Space.

The tuner enables turning ON/OFF the LEDs and adjusting the resultant flux output, over an I2C
interface. By default, the firmware will automatically generate a single color inside the defined color
gamut and modulate the brightness. 

The project utilizes four different Interface (Communication) Valuators. Each set a specific register
which can be modified using the available tuner. The LEDEnable controls the 3LED ColorLock
Driver, the LEDTrigger controls the optical feedback loop and the xValuator and yValuator registers
create a color based on x,y coodinates in the 1931 CIE XYZ Color Space. Also utilized are a priority
encoder named LEDBrightness valuator which controls a modulated flux value. Next, the program
contains a timing element which feeds a state machine. This timing element controls the length of
time it takes to dim the LEDs from full intensity to OFF. Finally, the 3-LED ColorLock Driver controls
the LM3404 Switching Regulators to power the LEDs.

5.2 EZ-Color Device
CY8CLED16, 48-Pin MLF

5.3 Start a New Project
1. Select File → New Project.
2. Name the project ModulatedDimmer.
3. If needed, click Browse to save the project in a different location.
4. Click OK.

WARNING: HIGH BRIGHTNESS LEDs CAN CAUSE PERMANENT
EYE DAMAGE! 
Do not look at the LEDs if they are not covered by the protective
enclosure. The LEDs illuminate at a very high intensity and can
cause permanent eye damage if they are viewed without the
protective enclosure.
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5.4 Add an Output Driver

1. The ColorLock (Luxeon Rebel® with LM3402) Properties window opens. Set the following val-
ues:
■ Set LED1 Luminous Flux Bin to F, and the LED1 Color Bin to 4.
■ Set LED2 Luminous Flux Bin to G, and the LED2 Color Bin to 2.
■ Set LED3 Luminous Flux Bin to C, and the LED3 Color Bin to 2.

Table 5-1.  Luxeon Rebel® with LM3402

Driver/Valuator

Lumileds™ Luxeon® Rebel 3-LED Color Mixing Driver with Color-
Lock™ Closed Loop Optical Feedback and LM3402 External 
Constant Current Source
Note: When you click OK to close the Add Output Driver window, 
the ColorLock (Luxeon Rebel® with LM3402) Properties win-
dow opens.

Location

Outputs Tab
 � High Brightness LED

� 3-LED Color Mixing
� ColorLock™ Optical Feedback

� Lumileds™

� Luxeon® Rebel, 350mA
� Luxeon Rebel® with LM3402

Properties

Field User Input
Name ColorLock

ClockFrequency 20000 (Default)

Color Space 1931 XYZ Color Space (Default)

LED1 Part Number LXML-PD01 Red (Default)

LED2 Part Number LXML-PM01 Green (Default)

LED3 Part Number LXML-PB01 Blue (Default)

LED1 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED2 Luminous Flux Bin G (Default)

LED1 Color Bin 1 (Default)

LED2 Color Bin 1 (Default)

LED3 Color Bin 1 (Default)

Expose Tuning Values Yes (Default)
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Figure 5-1.  LED Settings in the ColorLock (Luxeon® Rebel with 3402) Properties Window

2. Click OK when finished.

5.5 Add Four Interface Valuators
Note: These steps must be performed in the Add Valuator dialog box that appears when the Dis-
crete Interface Valuator is initially placed in the design.

Table 5-2.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDEnable

Default Value 0x1

States (Default)
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Table 5-3.  Discrete Interface Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Interface (Communication) Valuators

� Discrete

Properties

Field User Input
Name LEDTrigger

Default Value 0x1

States (Default)

Table 5-4.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name xValuator

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 5000

Table 5-5.  Continuous Interface Valuator

Driver/Valuator Continuous

Location
Valuators Tab
 � Interface (Communication) Valuators

� Continuous

Properties

Field User Input
Name yValuator

Min -32767 (Default)

Max 32767 (Default)

Scale 1 (Default)

Default Value 2500
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5.6 Add a Transfer Function Valuator
Note: These steps must be performed in the Add Valuator dialog box that appears when the Discrete
Interface Valuator is initially placed in the design.

In the State Machine Transfer Function TickState window:
1. Click Add State. The Add State window opens.
2. Set the Name to State0.
3. Click OK.
4. Repeat Step 1 through Step 3, naming the states State1 through State7.

Figure 5-2.  State Machine Transfer Function TickState

5. Click OK when finished.

Table 5-6.  StateMachine Valuator

Driver/Valuator Discrete

Location
Valuators Tab
 � Transfer Function Valuators

� StateMachine

Properties
Field User Input

Name TickState
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5.7 Add an Input Driver

5.8 Add a Priority Encoder Transfer Function Valuator

1. The Priority Encoder Transfer Function - LEDBrightness window opens. Set the If/Else state-
ments to the values in Table 5-9.

Table 5-7.  Interval Generator Driver

Driver/Valuator Interval Generator

Location
Inputs Tab
 � Timing

� Interval Generator

Properties
Field User Input

Name Tick

IntervalTime 75

IntervalMode PULSE (Default)

Table 5-8.  PriorityEncoder Valuator

Driver/Valuator Priority Encoder

Location
Valuators Tab
 � Transfer Function Valuators

� PriorityEncoder

Properties
Field User Input

Name LEDBrightness

Table 5-9.  LEDBrightness Priority Encoder Transfer Function Values

Else/If Then LEDBrightness =

(TickState_state==TickState_state__State0)&& (LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-5

(TickState_state==TickState_state__State1)&&(LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-10

(TickState_state==TickState_state__State2) && (LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-20

(TickState_state==TickState_state__State3) &&(LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-50

(TickState_state==TickState_state__State4) && (LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-75

(TickState_state==TickState_state__State5) && (LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-100

(TickState_state==TickState_state__State6) && (LEDBrightness>=0)&& 
(Tick==Tick__Triggered) LEDBrightness-150

(TickState_state==TickState_state__State7) && (LEDBrightness>=0) && 
(Tick==Tick__Triggered) LEDBrightness-200

LEDBrightness<=0 1000
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2. Select Continuous.

Figure 5-3.  Priority Encoder Transfer Function - LEDBrightness

3. Click OK to close the Priority Encoder Transfer Function - LEDBrightness window.

5.9 Add Seven State Machine Transitions
1. Right-click TickState driver icon and select Transfer Function.
2. Right-click State0 and select Edit.
3. Click Add.
4. In the Name field, enter Dim1.
5. In the Expression field, enter LEDBrightness<=0.
6. Set Transition From field to State0, and Transition To field to State1.
7. Click OK to close the Add Transition window.

Figure 5-4.  Add Transition Window

8. Click OK to close the Add State window.
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9. Repeat for State 1 → 2, State 2 → 3, State 3 → 4, State 4 → 5, State 5 → 6, State 6 → 7, and 
State 7 → 0.

Figure 5-5.  Add State Window

10. Click OK.

5.10 Define Output Behavior
1. Right-click on the ColorLock driver icon and select Transfer Function.
2. Set the following fields:

■ Set Enable to LEDEnable
■ Set Target x to xValuator
■ Set Target y to yValuator
■ Set Relative Flux to LEDBrightness
■ Set ColorLock Trigger to LEDTrigger

Figure 5-6.  ColorLock Transfer Function Window

3. Click OK when done.
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5.11 Add an Interface Driver

With a little rearranging, your workspace should look like the example below.

Figure 5-7.  PSoC Express Design View Pane

5.12 Build project
1. Select Build → Generate\Build ‘ModulatedDimmer’ Project.
2. In the Available Device Configurations pane, select CY8CLED16 → CY8CLED16, 48-Pin MLF.
3. In the Device Configurations Properties pane, set the following parameters:

■ Sample Rate → 8 Hz
■ Flash Interface → Enable

4. Ensure the Assign pins automatically check box is not selected.
5. Click Next.
6. In the User Pin Assignment window, click Unassign All Pins.

Table 5-10.  Slave Driver

Driver/Valuator I2C Slave Interface

Location

Interfaces Tab
 � Communication 

� I2C
� Slave

Properties
Field User Input

Name Interface1

I2C_Address 4 (Default)
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7. Assign drivers to pins by dragging and dropping the blue rectangles from the Unassigned Driv-
ers list to the pins listed in the following table.

Figure 5-8.  ModulatedDimmer Pinout Diagram

8. Select Lock Pins, and click Next. PSoC Express builds your project.

WARNING: Assign pins in the order listed in Table 5-5. Assign drivers according to the
Order of Assignment column in Table 5-11, not the order of appearance in the User Pin Assign-
ment window.

Table 5-11.  ModulatedDimmer Pinouts

Order of 
Assignment

Order of 
Appearance Function Pin Notes

0 0 ColorLock_ColorSensor Port 2_5

1 7 TCS230SHARED_0 S0 Port 2_0 �The these four drivers are 
assigned automatically when 
the ColorLock_ColorSensor 
driver is assigned. You must 
reassign them before assign-
ing the rest of the pins.

2 8 TCS230SHARED_0 S1 Port 2_1

3 9 TCS230SHARED_0 S2 Port 2_2

4 10 TCS230SHARED_0 S3 Port 2_3

5 1 ColorLock_Enable Port 4_0

6 2 ColorLock_Dim1 Port 1_2

7 3 ColorLock_Dim2 Port 1_3

8 4 ColorLock_Dim3 Port 1_4

9 6 Interface1 I2CSDAPin Port 1_5 �The I2CSCLPin driver is 
assigned automatically when 
the I2CDAPPin driver is 
assigned.10 5 Interface1 I2CSCLPin Port 1_7
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5.13 Program the EZ-Color Part
1. Disconnect any power sources from the evaluation board and connect the MiniProg to your PC 

using a USB cable.
1. Connect the Miniprog to the 5-pin ISSP header.
2. Program the part via J1 as described in the Program Parts with PSoC Express Projects section 

on page 11.

5.14 Tune Your Project
1. Apply power to the board using the supplied wall adapter.
2. Connect the board to your PC via a USB cable.
3. Select Monitor in PSoC Express.

4. Click Play . The Monitor toolbar will change from Connected , to Running .
5. Right-click the ColorLock driver icon and select Show Tuner.

Figure 5-9.  ColorLock (Luxeon® Rebel with LM3402) Tuner

6. Click OK to return to the Tuner.

5.15 Calibrate LEDs
1. Select Calibration.
2. Select Set LED1 to Maximum.
3. Select Set LED2 to Maximum.
4. Select Set LED3 to Maximum.
5. Select Calibrate.
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5.16 Run Program
Uncheck Override to observe the ModulatedDimmer program. After closing the tuner window, power
cycle the evaluation board before continuing with monitoring or tuning the design.
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