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INSTRUCTIONS FOR USE—WARNING

This product is conform to the 89/336/EEC Directive. It complies with the ITE EN55022 standard for
EMC emissions and generic 50082-1 (1992 edition) immunity standards.

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, some parts of this emulator are not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix : EMC Conformity and Safety Requirements on page 63 for
relevant safety information.

USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.

STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN
LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:

1. Life support devices or systems are those
which (a) are intended for surgical implant into
the body, or (b) support or sustain life, and whose
failure to perform, when properly used in
accordance with instructions for use provided
with the product, can be reasonably expected to
result in significant injury to the user.
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2. A critical component is any component of a life
support device or system whose failure to
perform can reasonably be expected to cause the
failure of the life support device or system, or to
affect its safety or effectiveness.
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ST7MDTU2-EMU2B User Manual 1 - Introduction

1 INTRODUCTION

Thanks for choosing ST7! This manual will help you get started with the
ST7TMDTU2-EMU2B emulator Kit.

The ST7TMDTU2-EMU2B emulator allows you to control the execution of programs
that you have written for the ST7262x and ST7261x families of MCUs (see list
below) and assists you in debugging your application hardware as well as your
software. The ST7MDTU2-EMU2B kit comes with a new debugger software
package—STVD7 (ST7 Visual Debug)—which contains all of the necessary
resources to help you design, develop and debug ST7 application software running
in a real environment.

Note: If you come across any terms or abbreviations you do not understand, you can check their
meaning in the Glossary on page 69.

First off, check that the ST7 MCU that you have picked for your application is in the
list of devices supported by this version of the ST7TMDTU2-EMU2B emulator:

Supported Devices

ST 72621 J4
ST 72621 J2

ST 72621 L4
ST 72622 L2

ST 72621 K4
ST 72622 K2

ST 72623 F2

ST 72611 F1
ST 72F611 F1
ST 72P611 F4

Note: While all of the above devices are supported in the current version of this emulator kit, not all
features are available. On this emulator release, you can select between only two MCU
targets which approximate the above devices, and which support all MCU package types.
Please refer to Emulation functional limitations and discrepancies on page 61 for a
description of the limitations on the current release of this emulator kit.

The Emulator Package is made up of two main parts:

e The Hardware Development System (ST7-HDS2), which is the common
mainframe to all ST7 emulators.

5/77
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e The ST7/TMDTU2-Active Probe, dedicated to the family, which constitutes the
physical link between the emulator and your application.

Note: When receiving the ST7TMDTU2-EMUZB development tool, please refer to the Delivery
checklist on page 11 to confirm that all of the contents of the package are present.

The emulator performs two main functions:

< It replaces the microcontroller in the application, by means of an emulation
probe that is plugged into the application in place of the emulated MCU.

e It controls the internal data bus of the emulated microcontroller, providing
arbitration and tracing capabilities on all accesses to any of the following
resources:

- ST7-HDS2 resources,
- ST7MDTU2-Active Probe resources,
- Application resources.

Therefore, you can have the emulator running your software in the application just
as the emulated MCU would do, and have extensive tracing and control
capabilities (i.e. keeping track of what the MCU does, and making it react in a
specific way upon defined conditions).

In this way, it is possible to fully emulate microcontroller resources.

1.1 Emulator configuration

Figure 1 shows a general configuration for the ST7TMDTU2-EMU2B emulator Kit.
The main ST7-HDS2 box is connected to your PC via the parallel port. Two flat
cables connect the ST7-HDS2 box to the ST7TMDTU2-Active Probe, to which a
device adapter can be fixed so that you can connect the emulator to your
application board.

4
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Note: This illustration in Figure 1 shows the TQFP44 MCU package configuration—you can
however set up the emulator kit to emulate any of the following MCU packages: TQFP44,
SDIP42, SDIP32, SO34, PDIP20 or SOZ20.

connection to PC'’s
W parallel port

host PC
running

parallel cable
emulator power — S

supply

ST7 Active

< probe

TQFP44
Bug-Catcher

application board

application board
power supply

Figure 1: ST7TMDTU2-EMUZ2B general configuration

1.2 Emulator operation

The emulator is operated from a host PC using STVD7, a state-of-the-art,
integrated development environment, from which you can configure and control
the emulator, debug, edit and rebuild your application program. Chapter 3: STVD7
on page 27, explains how to install STVD7 on your PC, and set up the emulator
configuration so that you can begin your development session.

Through STVD7, your application software is downloaded into the emulator. The
emulator performs a real-time emulation of the target device, thus allowing high
performance testing and debugging of both application hardware and software.

When the program is fully debugged, the ST7 EPROM programming board
(ref.: STTMDTU2-EPB2 — not provided with this emulator kit) can be used to

4
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program the emulation device with the Motorola S Record format file produced by
the OBSEND formatter.

1.3 Software and documentation for the emulator kit
The “MCU on CD” CD-ROM contains:

e ST7 Tools, comprising the following software:

- The source-level graphic debugger, STVD7, that operates with ST7-HDS2
Emulators and ST7 Development Kits or as a standalone ST7 simulator.

- The ST7 Assembly chain, composed of an assembler, linker, librarian and
formatter.

- The ST7 Windows Epromer to program your MCU target devices.
e Third-party C compiler and toolchain demos (Hiware and Cosmic).

e ST7 application notes (with sources), training slides and exercises, this manual
(in PDF version), and other useful reference documents in PDF format, such
as:

- Datasheets for the ST7 MCU family
- ST7 Programming Manual
- ST7 Assembler-Linker User Manual

- STVD7 User Manual

1.4 About this manual....
Detailed instructions on how to install your emulator configuration is described in
Chapter 2: Getting Started on page 11.
How to start debugging your application using your emulator and STVD7 is
described in Chapter 3: STVD7 on page 27.
The emulator kit's hardware features are described in Chapter 4: Emulator
Features on page 51.
The following conventions are used in this manual:

Bold text highlights key terms, phrases and is used when referring to names of
dialog boxes, windows and tabs within windows.

Bold italic text denotes menu commands (or sequence of commands),
options, buttons or checkboxes which you must click in order to perform an
action.

4
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Italicized text highlights document names, variable strings, column names and
field names.

Code font designates file names, programming commands, path names and
any text you must type.

The > symbol is used in a sequence of commands to mean “then”. For
example, to open an application in Windows, we would write: “Click
Start>Programs>ST7 Tool Chain>....".

15 Getting assistance

For more information, application notes, FAQs and software updates on all the ST
microcontroller families, check out the CD-ROM or our website:

http://mcu.st.com

For assistance on all ST microcontroller subjects, or if you need help with using
your emulator, use the contact list provided in Product Support on page 71. We'll
be glad to help you!

9I77
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2 GETTING STARTED

2.1 Your host PC system requirements

The ST7MDTU2-EMU2B HDS2 Emulator (both hardware and software
components) has been designed to work with PCs meeting the following
requirements:

* One of the following operating systems: Microsoft® Windows® 95, 98, 2000 or
NT®.

+ Intel® Pentium (or compatible) processor with minimum speed of 100 MHz.

e Minimum RAM of 32 MB.

« 21 MB of free hard disk space to install all of the ST7 tools.

2.2 Delivery checklist
The emulator kit (ref.: ST7TMDTU2-EMU2B), is delivered with the following (refer to
Figure 2):
1 One emulator box containing the ST7-HDS2 main board (ref.: MB176).
2 One parallel cable.

3 Two 50-wire flat cables to connect the ST7-HDS2 main board to the emulation
probe.

One ST7MDTUZ2 generic emulation probe (ref.: DB401).

One TQFP44/SDIP42 Adapter Probe (ref.: DB444) with TQFP44 and SDIP42
pin sockets for these microcontroller packages.

6 One SDIP32/S0O34/PDIP20/SO20 Adapter Probe (ref.: DB445) with SDIP32/
S034/PDIP20 and SO20 pin sockets for these microcontroller packages.

A TQFP44 Bug Catcher (ref.: DB400).

A Yamaichi QFP44 (10 x 10) socket (ref.: 1C149-044-052-S5), with its cover,
screws and washers.

9 A PDIP20/S020 device adapter (ref.: DB447).
10 An SO34 device adapter (ref.: DB406).

11 Two SDIP42 device adapters.

12 Two cranked male-male connectors.

13 A TQFP44 socket adapter (ref.: DB508). (This fits between the TQFP44/
SDIP42 Adapter Probe (ref.: DB444) and the QFP44 Yamaichi socket.)

14 One emulator power supply.

15 One analyser probe cable.

4
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16 Two trigger cables.
17 Three ferrite clips.
18 This manual. (Not shown.)

19 The “MCU on CD” CD-ROM containing ST7 datasheets, user documentation
and software, including STVD7 and the Windows Epromer.(Not shown.)

|

(14) (15)

(16) (17)

Figure 2: Main components of ST/MDTU2-EMU2B emulator kit

4
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2.3 Installing the hardware

The ST7 HDS2 emulator is connected through the parallel port to a host PC
running STVD7, and to your application board through ST7-Active Probe and
device adapters. To connect your ST7 HDS2 emulator, you will have to follow
these general steps (see Figure 3), which are described in detail in the following
sections:

1
2

Connect the ST7 HDS2 to your PC using the parallel cable provided.

Connect the two flat cables of your ST7 HDS2 emulator to the emulation probe
connectors.

Connect the appropriate device adapter (i.e. SO34 or SDIP32) to the emulation
probe, then connect the device adapter to the matching socket on your
application board.

Connect the power supply cable between the power supply block and the power
connector located on the rear panel of your ST7 HDS2 emulator.

Power up the emulator and then connect your application power supply.

emulator power
supply @

application board power supply

@?———»ﬁg iﬁ}

host PC running
STVD7

application board

4

Figure 3: Emulator installation steps
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2.3.1 Step 1: Connecting the emulator to your PC
1 Shutdown and power-off the PC that is to be connected to the emulator.

2 Connect one end of the parallel cable to the emulator’s rear panel 25-pin SUB-
D connector and the other end to one of the PC’s parallel ports (LPT1 to
LPT2)—refer to Figure 4.

Note: Centronics (or PC-AT or SPP), ECP and EPP parallel port configurations are supported by
the emulator.
Be sure to use the parallel cable provided with the emulator—using a longer parallel cable
may cause emulator malfunctions.

0o e}

®

N—— rear panel

1, T
Se=
cera

SUBD25 connector

Figure 4: Connecting the emulator to the PC

2.3.2 Step 2: Connecting the HDS2 and the probe
1 Ensure that the application and the emulator are powered-off.

2 Plug the two 50-wire flat cables into the J1 and J2 connections on the probe, as
described below (refer also to Figure 5):

ST7-HDS2 emulator ST7MDTU2-Active Probe
(ref.: MB176) (ref.: DB401)
Upper cable J2
Lower cable Jl

14/77
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Red Line 50 pin Male Connectors
J1 J2

~ N = DB4o1

>

ST7-HDS2
Side View

Figure 5: Connecting the emulator to the ST7MDTU2 generic probe

3 EMC-compliant probes: In order to work under an EMC-compliant
environment, you will have to clip one or two EMC-ferrite on each 50-wire flat
cable linking the probe to the emulator box. Place these ferrites as close to the
emulator window as possible. Three ferrites are provided in the package. See
Figure 6 for an illustration of where to attach the ferrites.

ST7 HDS2 P[\/} \¥

Emulator Ferrites Probe + Application
Board

Side View

Side View

Flat Cables

Figure 6: Making your probes EMC-compliant

2.3.3 Step 3: Connecting the probe to your application board

The ST7MDTU2-Active Probe consists of two parts: a generic ST7 emulation
probe connected to a package-specific adapter probe. There are two adapter

15/77
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probes included in your emulator kit: one for use with the TQFP44 and SDIP42
packages, and another for use with the SDIP32, SO34, PDIP20 and S0O20
packages.

In addition, the device adapter for each MCU package type is different. Some
package types require you to solder special connectors onto your application
board.

Therefore, depending on the MCU package you are using in your application, this
step varies. Specific instructions for each MCU package follow as listed below:

A. TQFP44 package—see page 17.
B. SDIP42 package—see page 19.
C. SO34 package—see page 20.
D. SDIP32 package—see page 22.
E. PDIP20 package—see page 23.
F. SO20 package—see page 24.

Note: You can use your emulator kit with STVD7 without an application board—however the
emulation probes must be connected to the HDS2 emulator. To do this, connect the
ST7MDTUZ2 generic probe (ref.. DB401) to the adapter probe for the MCU package(s) you
are using (i.e. either DB444 or DB445)—instructions follow.

4
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A) If you are using the TQFP44 package, follow these steps (refer to Figure 7):

1 Solder the Yamaichi socket base of the TQFP44 device adapter (ref.: DB332)
onto your application board. For footprint information, please refer to TQFP44
footprint issues on page 68.

ST7MDTUZ2 Generic Probe
(ref.: DB401)

| LU L L L
TR
\ Yy

e LB, 1oFPa41SDIPS2 MCU
-

Adapter Probe

@ | (ref.: DB444)

TQFP44 device adapter
(ref.: DB508)

@ v
Iml Yamaichi QFP44 socket base

i h /I N/ h @ v e o
Application Board

Figure 7: TQFP44 MCU package connections

2 Place the TQFP44 device adapter upon the socket base, aligning pin 1 of the
device adapter with pin 1 on the Yamaichi QFP44 socket. Pin 1 is indicated by
a chamfer and an arrow on the TQFP44 device adapter and by a little arrow on
the socket. You may fix the adapter onto the socket base with screws provided
with the Yamaichi socket.

4
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3 Connect the TQFP44/SDIP42 Adapter Probe (ref.: DB444) to the ST7 generic
probe (ref.: DB401) (see Figure 8 for a close-up view of this step).

— ST7MDTU2
> Generic Probe

/_,—? TQFP44/SDIP42
— Adapter Probe

Figure 8: Connecting the TQFP44/SDIP42 adapter probe to the ST7MDTU2
generic probe

4 Now connect the joined generic and adapter probes to the TQFP44 device
adapter, by inserting the male pins of the device adapter into the female
connectors on the underside of the TQFP44/SDIP42 Adapter Probe. Take care
to align pin 1 of the device adapter with pin 1 on the underside of the adapter
probe. (On the TQFP44/SDIP42 MCU Adapter Probe (ref.: DB444), pin 1 is
indicated by a little arrow—see Figure 9.)

Pin 1
TQFP44

Figure 9: TQFP44 Pin 1 Location on TQFP44/SDIP42 adapter probe
(ref.: DB444)

4
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B) If you are using the SDIP42 MCU package, follow these steps (see Figure 10):

1 Connect the two SDIP42 device adapters together, and then connect them to
the SDIP42 socket (U1l) on the bottom of the TQFP44/SDIP42 Adapter Probe
(ref.: DB444).

ST7MDTU2 Generic Probe (ref.: DB401)

e
III III LUCCLCL L L]

LR AT
\ \

TQFP44/SDIP32 MCU
Adapter Probe (ref.: DB444)
= SDIP42 device adapters

@ v

A 1 — d N h A h
Application Board

Figure 10: SDIP42 MCU package connections

2 Connect the TQFP44/SDIP42 adapter probe to the ST7TMDTU2 Generic Probe
(ref.. DB401) (refer to Figure 8 for a close-up view of this step).

3 Connect the probe to your application board by inserting the male pins of the
SDIP42 device adapter (attached to the underside of the probe) into the
SDIP42 socket on your application board. Take care to align pin 1 of the
SDIP42 device adapter (indicated by a little arrow on the SDIP42 socket (U1)
on the underside of the adapter probe) to pinl of your application board socket.

S
ﬂ[jm

B
S| b

8T7282-EM]
r
L
1P

Pin 1
| | — SDIP42

-iruz

L
|§i\
ST7262

E

Figure 11: SDIP42 Pin 1 Location on TQFP44/SDIP42 adapter probe
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C) If you are using the SO34 MCU package, follow these steps (see Figure 12):

1 Solder the SO34 device adapter (ref.: DB406) to your application board.

ST7MDTU2 Generic Probe
(ref.: DB401)

AT
y

—
®

S034/SDIP32/PDIP20/S020
Adapter Probe (ref.: DB445)

\

HJMMMMJ_‘

S034 device adapter
(ref.: DB406)

[
(1 N/l
1 LI

D ¥

Application Board

Figure 12: SO34 MCU package connections

2 Connect the SO34/SDIP32/PDIP20/SO20 Adapter Probe (ref.: DB445) to the
ST7MDTU2 Generic Probe (ref.: DB401) (see Figure 13 for a close-up view of

this step).

ST7MDTU2 Generic Probe
(ref.: DB401)

%’/.

S0O34/SDIP32/PDIP20/SO2(

Adapter Probe (ref.: DB445)

Figure 13: Connecting the SO34/SDIP32/PDIP20/S0O20 probe to the

20/77
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3 Connect the probe to the SO34 device adapter, taking care to align pin 1 on the
device adapter with the female pin 1 connector on the underside of the probe.
On the SO34 device adapter, pin 1 is indicated by a chamfer on the adapter
base. On the probe, pin 1 is indicated by a little arrow adjacent to the SO34
socket (U4)—refer to Figure 14.

5[ B
o EE + l:l:Mln E s
ik J:I[ E—H E|:;||:|E =H
ul:'l %ﬂbﬁﬂﬂl] ¢ 5T7252—ED]P32
SDIP32 5. a[] [
- B <
Pin1 | | BTTIIT aIE _o - :
[(p}
[ _x®
~ o s
EE £E | | & e =
o<
S034 |u D S5 o
Pin 1 - ": < ﬂ\_ i
I_E 1 @ = )
VT | \ é o
n — 7 =
3 :‘| a
N m
PDIP20/S0O20 m na_
Pin 1 | a
£
!
N
N= = O L ~e
Figure 14: SO34/SDIP32/PDIP20/S020 pin 1 location
YI 21/77
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D) If you are using the SDIP32 MCU package, follow these steps (refer to Figure 15):
1 Connect the SO34/SDIP32/PDIP20/S0O20 Adapter Probe (ref.: DB445) to the

22/77

ST7MDTU2 Generic Probe (ref.: DB401) (see Figure 13 for a close-up view of

this step).
ST7MDTU2 Generic Probe
(ref.: DB401)

.
I L L L 1l

S034/SDIP32/PDIP20/SO20
Adapter Probe (ref.: DB445)
(delivered with SDIP32 device
@ * adapters already attached)
—

e e

Application Board

Figure 15: SDIP32 MCU package connections

2 Connect the SDIP32 device adapters (on the underside of the SO34/SDIP32/
PDIP20/S020 Adapter Probe) to the SDIP32 socket on your application board,
taking care to align pin 1 on the device adapter with the female pin 1 connector
on the socket. On the SDIP32 device adapter, pin 1 is indicated by a chamfer on

the adapter base.
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E) If you are using the PDIP20 MCU package, follow these steps (refer to Figure 16):

1 Connect the two PDIP20/SO20 device adapters (ref.: DB447) together and
connect them to the PDIP20 socket on your application board.

2 Connect the SO34/SDIP32/PDIP20/SO20 Adapter Probe (ref.: DB445) to the
ST7MDTU2 Generic Probe (ref.: DB401) (see Figure 13 for a close-up view of
this step).

3 Connect the probe to the PDIP20/SO20 device adapter (ref.: DB447), taking
care to align the device adapter’s female pin 1 connector with the male pin 1 on
the underside of the probe. On the PDIP20/SO20 device adapter, the pin 1
position is indicated by a chamfer on the adapter base. On the probe, pin 1 is
indicated by a little arrow adjacent to the PDIP20/SO20 socket (U3)—refer to

Figure 14.
ST7MDTUZ2 Generic Probe
(ref.: DB401)
I UL L]

N [ 5034/SDIP32/PDIP20/S020
— Adapter Probe (ref.: DB445)
® y

m PDIP20/SO20 device adapter

(ref.: DB447)
© v

A 1 [ ey e
Application Board

Figure 16: PDIP20 MCU package connections
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F) If you are using the SO20 MCU package, follow these steps (refer to Figure 17):

24177

1 Solder the two cranked male/male connectors onto your application board.

2 Connect the PDIP20/S0O20 device adapter (ref.: DB447) to the PDIP20 socket

(U3) on the underside of the SO34/SDIP32/PDIP20/SO20 Adapter Probe
(ref.: DB445). Take care to align the device adapter’s female pin 1 connector
with the male pin 1 on the underside of the probe. On the PDIP20/S0O20 device
adapter, the pin 1 position is indicated by a chamfer on the adapter base. On
the probe, pin 1 is indicated by a little arrow adjacent to the PDIP20/S0O20
socket (U3)—refer to Figure 14.

Connect the SO34/SDIP32/PDIP20/SO20 Adapter Probe (ref.: DB445) to the
ST7MDTUZ2 Generic Probe (ref.: DB401) (see Figure 13 for a close-up view of
this step).

Connect the PDIP20/SO20 device adapter (ref.: DB447) to the two cranked
male/male connectors attached to your application board. Take care to align pin
1 on your application board with pin 1 of the PDIP20/SO20 device adapter.

ST7MDTU2 Generic Probe
(ref.: DB401)
IE| L L L] ||
AT 7
\ v ¥
M S034/SDIP32/PDIP20/SO20
— Adapter Probe (ref.: DB445)
@y
PDIP20/SO20 device adapter
ﬁ (ref.: DB447)
@ \/
two cranked male-male
connectors
h.\.F@)* == =,
Application Board

Figure 17: SO20 MCU package connections
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234 Step 4: Connecting the emulator power supply

Warning: Make sure that both the emulator and the application are OFF before making any
connections.

Connect the external power supply provided with the emulator to the rear panel
of the mainframe using a 5-pin DIN connector.

Plug the power supply into the mains using the supply cable provided.
Mains voltage specifications:

AC voltage: 100 Vto 240V

Frequency: 50 to 60 Hz

2.3.5 Step 5: Powering up

1 Checkthe ST7 HDS2 operating voltage (110 V/220 V) indicated on the label on
the power supply. Contact your dealer if this voltage does not correspond to
your mains’ power supply.

2 Power up the ST7 HDS2 emulator from the ON/OFF switch located on the rear
panel. The LED labelled Power on the front panel should then light up.

3 Power up your application.

2.4 Debuggers supporting the ST7 HDS2 emulator series

The debuggers currently supporting the ST7 HDS2 emulator series are:

STVD7 (STMicroelectronics)
Hilight for ST7 (HIWARE)
HI_WAVE for ST7 (HIWARE)
Zap for ST7 (COSMIC)

STVDY7 is free software. It is available on the STMicroelectronics website.

The next chapter tells you how to configure your emulator and start debugging with
STVD?7.

4
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3 STVD7

STVD7 is an integrated development environment that allows you to edit, debug
and rebuild your application all from within STVD7.

The following sections tell you:

e Section 3.1—how to install the STVD7 software,

* Section 3.2—how to launch STVD7,

« Section 3.3—a little about STVD7’s debugging features,

e Section 3.4—what a workspace is,

* Section 3.5—what toolchains and executable files are supported by STVD7,
« Section 3.6—how to create a STVD7 workspace,

e Section 3.7—how to open existing workspaces,

» Section 3.8—how to open binary files,

« Section 3.9—how to change your project settings,

e Section 3.10—how to save workspaces,

e Section 3.11—how to switch from the build context to the debug context,

e Section 3.12—how to configure the target MCU in order to debug more
accurately and efficiently.

3.1 Installing STVD7

Your emulator comes with the “MCU on CD” CD-ROM which contains a number of
ST7 software tools. These tools run under the Windows® 95, 98, 2000 and
windows® NT® operating systems.

Note: To install the software on ‘MCU on CD”, Windows® 2000 and NT® users must have
administrator privileges.

To install and setup the ST7 software tools, follow these steps:
1 Close all other open applications on your Windows desktop.

2 Insert the “MCU on CD” into your CD-ROM drive. The CD-ROM’s autorun
feature will open up a welcome screen on your PC. If the autorun feature does
not work, use Windows® Explorer to browse to the CD-ROM'’ s root folder, and
double-click on &l cone. exe.

3 Select Install Your Development Tools from the list of options. A new screen
will appear listing the different families of STMicroelectronics MCUs.

4 Use your mouse to place the cursor over the ST7 Tools option. Choose
ST Tools, then ST7 Toolchain from the lists that appear.

4
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5 The install wizard will be launched. Follow the instructions that appear on the
screen.

You can choose to install the complete toolchain (i.e. the appropriate version of
STVD7, the Windows Epromer and the Assembler-Linker) for each type of
development tool (Development Kit, HDS2 or EMU3 emulators or simulator), or
perform a customized installation.

If you choose a customized installation, you can choose to install any or all of
the STVD7 versions, and/or the Windows Epromer and/or the Assembler-
Linker. As a minimum, in order to use your emulator, you must install STVD7
for HDS2.

If you also install the ST7 Assembly Toolchain, you will be able to use the ST7
Assembly Toolchain as part of STVD7’s integrated development environment.

The installation is now complete. You will be prompted to reboot your computer.
You should do so before launching STVD?7.

3.2 Launching STVD7Y

1 From your Windows desktop, select Start>Programs>ST7 Tool
Chain>Development Tools>STVD7 HDS2 emulator.

2 The first time you open a
version of STVD7 you will be
prompted to enter the
toolchain paths to be used Cosmic builder path:
by STVD7's integrated |cACOSMICIST?
development environment.

T oolchain Path

Hiware builder path:
Enter the paths for the

toolchains that you use (i.e. IEAHW&HE&PHDG —I
any or all of the Hiware, 5T7 Assembler path:

Cosmic or ST7 ASM IE:'&F‘rngram FilezhS T4zt ftoolchain's
toolchains) and click OK.

(The default paths for each

toolchain are shown below.) oK Carel

3 If you choose Cancel, you
will be prompted again to enter the toolchain paths the next time you launch
STVDY.

Note: You may modify the toolchain path at any time from within STVD7—simply select
Project>Toolchain Paths from the main menu to access the dialog box above.

4
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3.3 About STVD7 debugging features
A number of advanced features are included in the STVD7 software:

« Data Breakpoints on the occurrence of a memory access via a read operation
or a write operation, or both.

* Instruction Breakpoints on the occurrence of an opcode fetch.

* A Logical Analyser that allows you to control either the recording of the trace
buffer, or a break in the execution of the application using a series of specific
conditions (events).

« A Trace window to view the contents of the trace buffer, which permanently
records in real time on 32-bits:

- Address and data bus information.

- Flag status and 4 external signal values.

You can record up to 1024 executed cycles. Using trace filtering, you can filter
out only those cycles you wish to record in the trace buffer. You can equally
control which of the recorded cycles are displayed in the Trace window using
line filtering. Addresses, data, control/status bits and 4 user signals are
displayed using mnemonic and user symbols.

< Internal synchronization signals can be output to either of two Trigger Outlets
on the front panel of the emulator (OUT1 or OUT2). This feature enables you to
count events using an external equipment, when optimizing software for
example, or to synchronize an oscilloscope when debugging hardware.

« Hardware Events can be used to control the sending of signals to the trigger
outputs.

* You can choose the output that you wish the signal to be sent to (i.e. either
OUT1 or OUT2).

« A Hardware Test function that allows you to perform a number of hardware
tests on the Development Board, at your choosing. Refer to Running the
Hardware Test for more information.

« A powerful online help facility can be invoked at any time to give additional
information about the commands, the processor or the emulator kit.

4
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3.4 Workspaces

STVD7 organizes project development and debugging into workspaces.
Workspaces allow you to store application and project settings and save them as a
* wsp file, so that each time you wish to work on the project, you will find all of the
settings exactly as you left them.

Creating a workspace is the first thing that you need to do when using STVD7 for
the first time or when starting any new project. You must have an open workspace
to work with STVD7. How to create a new workspace is described in detail in
Section 3.6 on page 34. Sample workspaces for each supported toolchain are
provided so that you can familiarize yourself with STVD7 (for a listing of sample
workspaces, see Table 1 on page 32).

Each workspace is comprised of three information sets: the project settings, the
visual environment and the debugging context.

* The project settings consists of the information necessary for a successful
build of an application (commands to run, makefile file etc....). Your
workspace’s project settings include the definition of your application toolchain
(see Section 3.5 on page 31).

e The visual environment consists of the open windows elements along with
their current layout, bookmarks and other features. The visual environment is
composed of two environments, one in the Build context and one in the
Debug context (see Section 3.11 on page 43).

* The debugging information includes information on breakpoints, memory
mapping, advanced breakpoints programs, trace etc..

4
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3.5 Toolchains and application files

A quick summary of development toolchains and application file types supported
by STVD7 will help you in setting up your workspace.

Three different development toolchains are currently supported by the STVD7.
Each type of toolchain has its own application and executable file types, project
environment and building tools (i.e. linkers and convertors):

The ST7 macroassembler toolchain from STMicroelectronics, which
generates either . s19 or . hex executable files with various intermediate files,
such as . map or. | st files.

The Hiware C or Assembler toolchain, which generates . abs executable
files with various intermediate files, such as . o or . dbg files.

The Cosmic C or Assembler toolchain which generates . el f executable
files with various intermediate files, such as . o or . st 7 files.

When you set up a workspace, you will need to define the following project
settings:

4

The toolchain to be used— Hiware, Cosmic or ST7 macroassembler.

The executable file (*.abs, *.elf, *.s19 or *.hex depending on
toolchain—refer to Table 2 on page 33).

The maker program for the toolchain. The maker program can be a part of the
toolchain software (such as Hiware's maker . exe) or you can choose to use a
generic maker such as Nnake. exe or Grake. exe (which is provided with the
STVDY).

The maker batch file (*. mak or *. bat ). This is a file which you create for
each application which spawns the compilation and/or link step each time you
wish to build or rebuild. In it, you define the conditions for recompiling, re-
linking or both.

Default *. mak or *. bat files are often included with the toolchains—for
example, maker.mak is included with the Hiware toolchain and simply
recompiles your application if it detects that the file has been saved since the
start of your debugging session. The STVD7 software includes sample *. mak
and/or * . bat files for each toolchain—these are listed in Table 1.
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Table 1: Sample files included with STVD7

Toolchain

ST Macro
assembler

Sample Workspace (with
default path

...lrealtimrealtimwsp

Sample Make and/or Batch
files (with default path?l)

.../realtimtimrtc. bat

Description of
Make/Batch File

Batch file that
forces a recompile
of the application.

.../ spiml/spiml. wsp

./ spi mL1/ spi mLl. bat

Batch file that
forces a recompile
of the application.

Cosmic

...lclcosm c/sanpl e.wsp|. ..

/ c/ cosm c/ sanpl e. mak

Recompiles only if
one (or more) of

the application files
has been resaved.

./ c/cosm c/ sanpl e. bat

Batch file that
forces a recompile
of the application.

Hiware

... lc/lhiware/sanpl e.wsp

./ c/hiware/build. mak

Recompiles only if
one (or more) of

the application files
has been resaved.

./ c/hiware/rebuild. mak

Forces a recom-
pile of the applica-
tion.

1) The full default path is: C./ Program Fil es/ St n1 st 7t ool chai n/ st vd7/
hds/ sanpl e/ . ..

3.5.1 About executable files

The user should verify that the options to include debug information were active
during creation of the project files. Table 2 on page 33 summarizes the way each
toolchain functions and lists the different file types (source files, intermediate files
and executable files) used and produced by the toolchain. The executable file
types and intermediate file types necessary to exploit fully the STVD7
capabilities are listed.
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Table 2: Toolchain steps and their output files

Toolchain: ST Macroassembler Hiware Cosmic

Compile or Assemble Step:

Source File .asm .C, .asm|.c, .s
Types
Required asm-1li macrost7.asm <NONE> +debug
Options
Resulting File | . obj, .Ist .0, .dbg |.0
Types

L |
Linker Step:
Required I yn macrost7.obj, macrost7 <NONE> <NONE>
Options asm macrost7.asm -sym -fi=nacrost 7. map
Resulting File | . map, .| st . abs .st7
Types

L |
Converter obsend nmacrost7, f, macrost7.s19, srec not cvdwar f
Step: or applicable

obsend nmacrost7, f, macrost7. hex, intel

Resulting .s19 or . hex . abs, .elf

executable .elf

file:
l__________________________________________________________________________________________________________________ _________|

Necessary .map, .I|st .0, .dbg | <NONE>

Intermediate

Files:

The executable file(s), source files and any necessary intermediate files (these
are listed above and contain debug information necessary to the STVD) should be
located in the same project directory. You do this when you define your workspace.

Note: It is always preferable to have access to all of the files generated by the development
toolchain. However, you can load *. s19 or *. hex binary files directly and have limited
debugging capabilities (refer to Section 3.8 on page 38).
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3.6 Creating a workspace

1 Select File>New Workspace. This command opens a new window where you
define the name of your workspace and the directory in which you want to work.

Mew Workzspace |

Workzpace filenare:

Imywu:urld

Workzpace location:
IE:HF‘rngram FiIesHSTM'\st?tnnlchain'\.;I

Hest » I Cancel
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2 Then, click Next>. The New Workspace: Project Settings dialog box

appears:
New Workspace: ProjectSetngs KA
“Workzpace filenamne: I iy _wearkhmgsork. wEp
aoftware Toolchair: I ST7 Hiware Toolchain j
— Executable
Filenarme: Isample'*.u:"-.hiware"-.sample.al:us _I
— Build
Maker: I Hiware maker j
Maker filaname: ID:'\HIW.-‘E-.FEE LPROG Ymaker _I
Makefile ar batch file: Isample'ﬁc\hiware"«huild.mak _I
"Build" command line: Imaker build.rak
"Rebuild A" command line; Imaker rebuild.mak
Start “Build" # "Rebuild A" in: Isample'\.n:'\hiware _I
< Back IWI Cancel |

Here you enter your software toolchain, your executable filename and your
build parameters either by typing or using the drop boxes.

3 Select the toolchain and enter the name of your application’s executable file.
For example, if you wish to use the Hiware toolchain for ST7, your executable
file will be of type *. abs (refer to Table 2 on page 33)—click on the browse

button | to browse to the folder where your executable file is saved and
select it.

4 Next, choose the type of maker your application uses from the drop down list. In
the example above, we have chosen the default Hiware maker, maker . exe.
STVD7 will automatically look for this maker file in the folder you defined as the
Hiware toolchain path.

5 Finally, you must define a make file or a batch file. There are several sample
files provided with STVD7 (see Table 1 on page 32). Here we have chosen

4
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bui | d. mak as the default make file, used when the Build command is issued,
and r ebui | d. mak as the make file to use when the Rebuild command is
issued.

6 After you have finished defining your project settings, click Finish.
Once the workspace is opened, the Workspace window displays its contents.

When you create a new workspace, the first time you switch to Debug context (see
Section 3.11 for an explanation of STVD7 contexts), the MCU Configuration
window will automatically open to prompt you to choose you target MCU and
confirm or modify its option and memory configuration (see Section 3.12 on
page 44).

3.7 Opening an existing workspace
If you have already created a workspace, you simply need to open it in order to
load all of your project settings into the STVD?.

Note: There are a number of sample workspaces provided with STVD7Y that you can open to get
familiar with STVD7. These samples are listed in Table 1 on page 32.

1 From the main menu, select File>Open Workspace.
This command opens a window where you can browse to any folder you wish,
and select an existing workspace.

Open Workzpace EE |
Look jn: I £5) Debug =
&) gample

MmO s

File name: || | Open I
Files af type: ISTF" Project waork zpace [*.wszp) j Cancel |

4

36/77

Downloaded from Elcodis.com electronic components distributor


http://elcodis.com/parts/842348/ST7MDTU2-EMU2B.html

ST7MDTU2-EMU2B User Manual

3-STVD7

2 The Workspace window opens.

When a workspace is opened, all
of the predefined project settings
are loaded into the STVD7. The
Workspace window will show a
structured representation of the
project. For example,
mywor k. wsp shows that it uses
bui | d. mak as the make file and
sanpl e. abs as the executable
file.

2 x

= O3l mywork.wsp
=N zampletchhivaresbuild. mak,
e [ zamplebchhiwarehzample. abs

" &) Workspace |/ Source Directo. . |

Note: Although the name of the executable file

is shown in the Workspace window, it has

not yet been loaded into the emulation

memory—see page 38.

If you click on the Source
Directory tab, the window will
show every source and intermediate file type (*. c,*.s,*. asm*. hor*. 0)in
the selected directory.
=l =l
Cl-[@F C:\Program FileshSTh\stPtoolchaints
samplel.c
sampled. asm
sampled.c
startl? o
start0? h
Double click here...
4| I 12
G Workspace (3] Source Direct... |-

3 If there are no source files shown in the Source Directory tab of the Workspace
window, or you wish to list additional files stored in another folder, you may
browse to them by clicking the Double Click here... folder. The Add Source
Directory window pops up allowing you to enter or browse for a new directory,

&7
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and filter out the file types of interest. You may also choose to specify a
directory that is relative to the workspace directory by clicking on the Path
relative to the Workspace directory option.

o
E-[] C:A\Pragram Files'
gamplel.c
- B] sample2. asm
zample3.c
start? ¢
gtartd? h

----- Double click here

Add Source Directory E3 |

[T Path relative to the Workspace directon

Fath:

L

Files filker: I“.u: Fh azm Fe Finc spp bat j

0k I Cancel
o |

sl inior... 1) Sou. . |

4 To load the executable file, as well as any intermediate files, click the Debug
icon or the Reset Chip icon. The application and symbols will be loaded. Before

you can start debugging, you must set the target hardware device by
configuring the MCU.

3.8 Opening binary files

If you do not have access to the source or intermediate files generated by a
toolchain, you may also load *. abs, *. s19, *. hex or *. el f files on their own
using the Open Workspace command.

Note: The range of debugging features available when you open a binary file only will be very

restricted. You will only have access to basic debugging windows, such as the Disassembly
and Memory Windows.

1 Launch STVD7 and select File>Open Workspace from the main menu.
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2 Browse to the folder where your binary file is stored, and select ST7
Application files (*.abs, *s19, *.hex, *.elf) in the Files of type field.

Open Workspace EHE |

Loak, in: Ia rry_wark j ﬁl

File narme: IST? Application files [*.abz:* 519:* hex " elf] Open I
Files of tupe: I.-’-'-.II filez [*.%] j Cancel |

3 Select your binary file (*. abs, *. s19, *. hex or *. el f) and click Open.

The binary code in the executable file will be loaded into STVD7 and you will be
able to access the Disassembly Window. A workspace file (of the same name as
the binary file, but with an extension . wsp) will be created automatically.

3.9 Changing your project settings

The Project menu contains the Build and Rebuild All commands you need to
recompile your application after having made changes to it in the course of
debugging. You may also access your project or toolchain settings in the event you
wish to change them.

Project

(5] Buid F7

Bebuild Al

StopBud

Broject Settings... 2lt+F7F
Toolchaing Fath...

4
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From the main menu, select Project>Project Settings.

Project Sethings

Wiorkzpace filename:

Software Toolchain: IST? Hiware Toolchain j
— Executabls

Filenarme: Isample.abs _I
— Build

Maker: IDther maker j

M aker filename: IE:&HIW.&F!E'&F'HEIG'\M akerexe _I

bl k. efile: Isample.mak _I

"Build" command line: IMaker.e:-:e sample. mak

“Rebuild A" command IMaker.e:-:e sample. mak,

Start "Build” / "Rebuild All" II::"J'-.n"iew'*.'-.fcnb"«gui"xstvd\src‘xstvdebug'\[}e _I

] Cancel |

You can change your settings here and continue running your application. When
you exit STVD7, the system will ask you if you want to save these settings in the
workspace you have been working in. If you choose yes, these will become your
new workspace settings; if you choose no, these settings will be lost.

4
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The Toolchain Path... item invokes the following window:

Toolchain Path ] I

Cosmic builder path:

|CACOSMICIST?

Hiware builder path:
|E:RHIWI-‘«F|EHF'F|EIE

STY Azzembler path:
IE: YProgram FileshST MYzt ftoalchain's

] Cancel

In this window, you can define your builder and/or Assembler paths. Clicking _|
opens a browser window.

3.10 Saving workspaces

Whenever the current workspace is closed, it is automatically saved. This can
happen either when exiting STVD or opening or creating a new workspace.

In addition to this, a workspace can be explicitly saved with the File>Save
Workspace... or File>Save Workspace as... commands.

The user is given the choice of which of the workspace elements to include in the
saved file. Either the visual environment or the debugging information may be
saved alone, or both may be saved together. This is configured as follows:

1 From the main menu, select Too/s>Options.

2 In the Options window that opens (see Figure 18 on page 42), select the
Workspace tab.

3 Choose whether you wish your saved workspace to include either the visual
environment or the debugging information or both.

4
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4 Select which windows will appear docked when a project is opened by checking
the appropriate check boxes in the Floating windows in the main frame area.
Only windows currently docked in the main window can be included.

Options EHE3 |

Toolbars | Commands | Edit/Debug  ‘workspace |

Floating windows in the main frame:;

Workzpace includes:

Olutput W “isual ervironment
Dizazzembly
termony
Ingtruction Breakpoints
Watch
Call Stack
Local Yariables
ST7 Data Breakpoints
ST7Y Registers
ST7 Peripheral Registers

¥ Debugging contest

Qk. I Cancel (1

Figure 18: Options window

1 Click Apply to confirm your settings.
2 Click OK close the dialog box.

In addition, open file contexts and current window positions are saved when the
workspace is closed. This feature restores the workspace window, window layout
and file views to that which was current when STVD7 was closed. The toolbar
layout, plus customized toolbar content is also saved and restored with the
workspace (options set via the tabs entitled Toolbars and Commands).

By default (i.e. when saved automatically) the workspace is saved as file
<application>wsp. The name of the file corresponds to the name used for the
executable file (for example, <application>.abs for a Hiware executable file).

4
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Note: Using the Configuration Setup dialog box (available from the MCU Configuration dialog
box), you can also control what type of MCU configuration information is restored from a
workspace file (*.wsp).

3.11 Debug context and Build context

There are two STVD?7 contexts, the build context and the debug context. Until
now, in creating a workspace, and defining your project settings, you have been in
the build context. To proceed step—configuring your MCU—you need to change to
the debug context.

Briefly, the two contexts are different in that:

¢ In the build context, you can open and close workspaces and build or re-build
the application executable file.

¢ In the debug context you set the emulated MCU configuration (this step is
described in Section 3.12 on page 44) and debug the executable file created
while in the build context.

3.11.1 Build Context

The build context is the context set when starting STVD7. In this context, it is not
necessary to be connected to an emulator and the debug commands are not
available. You can also edit the source files of an application and perform the use
the Build command to perform compile and link actions in an interactive and
iterative way to re-build the application executable file.

3.11.2 Debug Context
In this context, the following debug actions can be carried out:
* Loading, running and stopping the application.
« Defining the MCU configuration (MCU options and memory mapping).
¢ Viewing source and disassembled code.
e Setting instruction breakpoints with a counter and/or condition.
« Setting data breakpoints.
« Viewing local variables, memory and ST7 registers.

* Viewing history of execution from the trace buffer or with the Call Stack feature
analyzing the performance of a piece of code.

43/77
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3.11.3 Switching between contexts

The switch between contexts usually occurs when the Start
Debugging and Stop Debugging commands are used:

©

From the main menu, choose Debug>Start Debugging or
Stop Debugging or click on the Start Debugging or Stop

Debugging icons shown at right.

While debugging, the editor allows source files to be
modified. To switch to the Build context perform either a
Build or Rebuild action or use the Stop Debugging
command.

©

Stop Debugaing

3.12 Configuring the MCU

After you create or open a workspace, the next step you must perform before
starting your STVD7 debugging session is to define and configure the target device
(MCU) that you wish to emulate.

The target device is defined and configured from the MCU Configuration window.

1 First, ensure that you are in Debug context by clicking on D (STVDY has
two contexts: Debug context and Build context—these are described in
Section 3.11.)

Note: The first time you enter into the Debug context after having created a new workspace, the
MCU Configuration window will be opened automatically.

2 Select Tools>MCU Configuration from the main menu. The MCU
Configuration window will open.

4

44777

Downloaded from Elcodis.com electronic components distributor


http://elcodis.com/parts/842348/ST7MDTU2-EMU2B.html

ST7TMDTU2-EMU2B User Manual 3-STVD7

An example of a typical MCU Configuration window is shown in Figure 19.

MCU Name field
MCU Configuration - ST7XX XXX
—Zoom

MCU name: IST?'XXXXXZI From | To Type | Selection auto zoom [V
040000 | 0+0002 | PERIFH

Option Value | | 00003 | 00003 | RESERVED = SYSTER R

LD 5 V. | OFF 0x0007 | 0x0007 | RESERVED RESERVED

ExT T [ITaEAAT | | 0#000b | 00011 | RESERVED e

CLOCK ON BOARD | | 0%0020 | 0x0026 | PERIPH

WATCHD | SOFT 0x0027 | 0x0027 | RESERVED

= 0x002f | 0x0030 | RESERVED L R
0<0031 | 0x004f | PERIPH
00050 | 0x006f | RESERVED
0:0070 | 0x0071 | PERIPH
020072 | 0x007f ESERVED Ll
0x0080 | 0x013f M
00140 | 0x017f SI\QCK
0=0180 | Oxdfff | RESERVED E tm
NwaNNN ﬂ:ifrﬂ nn?
0K Cancel | Conf... I Insert | / odity | Delete
7
Option configuration Memory configuration Graphic memory
fields fields configuration viewer
Figure 19: MCU Configuration window
Note: The options shown in the above example may not be available for your particular target MCU.

3 Set the Target MCU. In the MCU name field, select the target device for which
the application is intended from the dropdown box. Once a target MCU has
been chosen, the Option configuration and the Memory configuration fields will
show the default values for this device.

4 Configure the MCU Options and On-Chip Peripherals. All of the
configurable options on your target hardware device are listed in the Option
configuration fields. Beside each option, a default value is given. You may
change this value by clicking on it and choosing a new value from the drop
down list. This allows you to configure your target device’s options and on-chip
peripherals. Depending on the MCU selected, the default settings in the Option
configuration fields will change. It is up to you to configure those options that will
impact your application so that the emulator accurately emulates your target
device.
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Note:

For more information about the configurable options available on your target hardware
device, please consult your target MCU'’s datasheet.

5 Configuring the MCU Memory. The default memory settings depend on the
MCU selected. However, you can configure the memory settings as you wish if
your application requires non-default settings. This feature would enable you,
for instance, to temporarily increase the ROM size during the development
phase of your application.

— Zoom
From | To Type | |1: 1341 2 | 33 | Selection auto zoom [
[=0000 | 0x003f | PERIPH F5 7S TEME) [De10000
0x0040 | Dx00f | RAM Eon
0=0100 | Dx013F | STACK =T
0x0150 | Ox0eff | RESERYED ==
Ox0f00 | Ox0fff | SYSTEM (=000
0=1000 | Oxekf RESERWED
O=f000 | Oxfidf | ROM
Oxffe0 | D=fiff WECTORS 048000
04000
D003 H
Cant... | Ihgert | / [ it | Delete

Memory Graphic memory
configuration fields configuration viewer

There are two methods for configuring the memory settings on the MCU: by
typing in the start and stop addresses of each memory zone into the memory
configuration window, and by graphically moving the memory zone
boundaries in the graphic memory configuration viewer (see page 48 for
more instruction).

Memory zone types

46/77

The left column of the memory configuration window indicates the address
range of each memory zone. The right column indicates the memory type of each
zone. Depending on your target MCU, the available memory types may be:
Peripherals, RAM, ROM, Stack, System, EEPROM, Reserved, Vectors,
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Application. Some of these zones can have their type and size modified, others
cannot be modified. Their definitions and properties are explained as follows:

« Peripherals: Microcontroller internal or rebuilt peripherals registers. Their
properties are defined as in the microcontroller datasheet. This memory
cannot be modified.

*  RAM: Random-Access-Memory of the microcontroller. This memory type can
be modified.

*  ROM: Read-Only Memory of the microcontroller. Write protected. This memory
type can be modified.

« Stack: Stack of the microcontroller. This memory type cannot be modified.

« System: The emulator uses this space for emulation management. This
memory type cannot be modified.

« EEPROM: This memory is internal to the microcontroller and is located inside
the emulation device. The programming of this zone is done according to an
automaton found in the datasheet. This memory type cannot be modified.

« Reserved: This memory zone is reserved as on the microcontroller. It is not
allocated to any use and is write protected. This memory type cannot be
modified.

¢ Vectors: This memory zone contains the user interrupt vectors zone. It is write
protected. This memory type can be modified.

e Application: This memory type is microcontroller-specific. The user can add
memory or peripheral resources on its hardware. It is not available on every
emulator. Properties are linked to the user hardware. This memory type can be
modified.

For most target MCUs, you may modify the following types of memory zone: RAM,
ROM, Reserved and Application. This feature would enable you, for instance, to
temporarily decrease the RAM zone, increase the size of the ROM (to exceed what
is available on the real microcontroller) during the first stages of development.
Once your program is functional, you can start to optimize its size by reducing your
code and returning these zones to their original size. There are two different
actions you may perform on the memory configuration:

¢ change the type of an entire existing zone.

« define a new zone of any type wherever possible.

4
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To change an existing memory zone:

1
2

Select the memory zone to be modified.

Click on the Modify button at the bottom of the window. A New MCU Memory
Range dialog box will open, allowing you to change either the address range
and/or the memory type of the memory zone.

Mew MCU memary range
From : IUHUUEU To IEI:-:EI'I af
Type:  |RAM h

FERIFHERALS

OlSTACK Cancel |
EFR
EEF
VECTORS

To create a new zone of any type:

1

2
3
4

Click on the Insert button. The New MCU Memory Range dialog box will
appear.

Enter the address range of the new memory zone in the From and To fields.
Select the type of the new memory zone in the Type field.

Click OK to validate your choice.

The new memory zone will then appear in the MCU Configuration window unless
you tried to create a new zone in a non-modifiable memory space (such as Stack
or EEPROM).

To use the Graphic Memory Configuration viewer:

1

48/77

In the memory configuration window, click on the zone whose boundaries you
wish to move.

Check the Selection auto zoom box in the upper right-hand corner. The
graphical view of the memory configuration will be scaled so that the zone you
have selected is easily visible.

At the upper and lower boundary of the zone, at the left-hand side of the
graphical viewer, you will see a small triangle and rectangular box giving the
boundary addresses of the memory zone. You can change a boundary address
by dragging and dropping the triangle with the mouse to its new location. The
triangle can be moved either up or down, left or right in the graphical viewer.
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The MCU configuration that you specify will, by default, be saved in a workspace
file (*. wsp) for the project. The next time the application is opened, the STVD will
automatically set the MCU configuration (as well as the layout of opened windows
and other debug information) to the same conditions you had when you left the last
debugging session.

If you do not wish your MCU configuration information to be saved in the
workspace file, you must alter the default Configuration Setup options by clicking
on the Conf... button.

3.13 Start debugging!

Once in debug context, you are now ready to start debugging your application
using the emulator.Full documentation on how to:

e control your STVD7 work environment
e use its integrated editor
« use the many debugging windows and features

is available from the online help and the online STVD7 user manual, located under
Help in the main menu.

4
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4 EMULATOR FEATURES

4.1 Main features of the ST7 HDS2 emulator series

The features described below are common to all ST7 HDS2 emulators:

Real-time emulation capability (internal frequency from internal 0.5 MHz up to
8 MHz).

Full memory emulation (up to 64 KB).

Real-time trace with 3 event conditions allowing selective recording.
Hardware breakpoint capability on instruction Fetch.

Hardware breakpoint capability on address.

Breakpoint capability on invalid address access.

Breakpoint capability if trace is full.

1K x 32-bit real-time trace (address, data, ctrl).

6 different modes to configure trace access by combining 3 event conditions.
Selective trace recording capability.

2-Trigger output capability.

Can use as an external clock source either the on-probe oscillator, or an
external source via the front panel input.

4 probe inputs to display application signals in the trace.

4.2 Specific features

The features described below are specific to the ST7TMDTU2-Active Probe:

4

Clock source selection.
The application power supply follower allows this emulator to run with
application V¢ from 3.6 V to 5.5 V. When the probe is not connected to an

application board or if the application board isn't powered (application
Vc<3.6 V), the Vi default value is 3.6 V.

All I/O pins of the ST7262x MCU and its sub-family are directly interconnected
to the user application board. No buffers or protective devices are inserted on
the probe.
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4.3

Emulator architecture
The STTMDTU2-EMU2B emulator is composed of 2 parts:

The ST7 HDS2 (Hardware Development System) contains all of the common
resources necessary to emulate any ST7 device (such as memory and the link
interfaces with the PC). This board is connected to the PC via a parallel link
and to the second part by two 50-pin connectors.

The ST7TMDTU2-Active Probe contains the specific resources necessary to
emulate the ST726xx family of MCUs, and is used as a link between the
ST7 HDS2 and your application.

ST7/XXX-EMU2B

PC

ST7 HDS2 ST7 Active
Probe

Parallel Link [\ Emulation Memory Flat Cables [\ ST7 MCU
e Control RAM Automaton

5 — Trace Memory Control
STOMCU Address bus

Data bus
Control bus

Device Adapter

AN

Application
Board

43.1

52177

ST7 HDS2 hardware

The hardware functions provided by this component are listed below:

HDS2 CPU: Used to control of the ST7XXX-HDS board and manage common
HDS?2 features such as the parallel link with the PC.

RAM memory:
- 64 KB for ROM and RAM emulation.

4
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64K bytes as break points control and Mapping.

1K x 32-bit as trace memory.

« Hardware breakpoint control logic to manage breakpoints from the 16-bit
address bus.

« Logical analyser control logic to manage sophisticated recording and break
events in the trace.

¢ PC link: parallel interface for communication with PC.

¢ ST7MDTU2-Active Probe interface—3 buses connect the ST7 HDS2 to the
ST7MDTU2-Active Probe:

Address bus (16-bit) of the ST7 emulation chip used for RAM addressing

and trace.

DATA bus (8-bit) of the ST7 emulation chip.

Control bus to manage ST7/MDTU2-Active Probe hardware-like breakpoint

g

features.

Power
Supply )
Emulation o)

bata RAM Data <]> "~ ST7Data
> o
o
Parallel (€]
Parallel link C |
- Interface Data Fc;zt'\rﬂo Control ;
O o
o <
HDS2 AN
COntrOl Data Trace ST7-Add D
5T9050 N e RAM = -
e N N Q
Address Address ST7-Address
-y D\ D =
1T T =
|_
0p]
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4.3.2 ST7TMDTU2-Active Probe hardware

The ST7MDTUZ2-Active Probe is made up of two probe components—a
ST7MDTU2 Generic probe and one of the two adapter probes included in the
emulator kit (use the one that corresponds to the MCU package your application
uses). You must assemble the Active Probe yourself—see Step 3: Connecting the
probe to your application board on page 15 for more detail.

The hardware functions provided by the ST7MDTU2-Active Probe are:

e Probe Emulation MCU: This is an ST7 microcontroller similar to those of the
emulated target device(s), which runs in emulation mode. It acts as the ST7
core and gives access to all on-chip peripherals.

e Control logic: Control logic is provided to manage the software execution by
the user (i.e. program running and halting).

» Application V¢ follower: The probe emulation MCU is supplied with the
same voltage as the application (i.e. must be in the range 3.6 V to 5.5 V).

e« ST7 HDS2 interface: All of the communication buses connecting the active
probe to the ST7 HDS2 board are buffered:

- ST7 Address bus (16-bit) of the ST72F62 in emulation mode.
- Data bus (8-bit) of the ST72F62 in emulation mode.

- ST7 emulation chip control bus for trace recording, breakpoints and
memory mapping.

4
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4.4 Output triggers

Your ST7 HDS2 emulator has two output triggers, OUT1 and OUT2. The OUT1
and OUT2 outlets are available via SUB-click connectors located on the front panel
of the ST7 HDS2 emulator box. You can program the output signals to these
triggers using STVD7:

OUT1 Trigger output OUT2 Trigger output

|
_ y _

O00O0 @ @ @ Analyser

ST7 HDS2 Emulator Triggers Probe

1 From the main menuin STVD7, select View>Hardware Events. The Hardware
Events window will open in your workspace.

Enabled Hardware Disabled Hardware
Event Event
, I/
ill Hargh{are EVEM Size Type |
@ a0k 0+0002 aouT
=Th0100 00001 QT
@ E Foien [

Mew Hardware Event...

Enable/Dizable Selected Hardware Event
Enable/Dizable &ll Hardware Events

Remove Selected Hardware Event
Remowve All Hardware Events

v Allow Docking
Hide

Flaat [n kain wWindow
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2 Right-click the mouse while the mouse pointer is anywhere in the Hardware
Events window.

3 Choose New Hardware Event from the contextual menu. The Hardware event
settings dialog box will open as below.

e events setting

IEIL|T1 vI ¥ Enabled
Fram: IEI:-:EIEIIJEI

" WwWhale wariable

+ Tz 00000 + |0

......

Cancel |

4 Choose the trigger output that you wish the signal to be sent to (i.e. OUT1 or
OUT?2) and check the Enabled box.

5 You may trigger output signals by setting an event on any of the following:

- a whole variable—creating an event for synchronization, which enables
you to preset the pulse synchronization for external equipment connected
to the output trigger.

- asingle address—also creates an event for synchronization (see above).

- arange of addresses—creating an event to measure time, which enables
you to measure the time elapsed during a subroutine execution.

A positive impulse is emitted on OUT1 and OUT2 when a specific condition is met.
This impulse lasts for one Clock cycle.

57177
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4.5 Analyser probe input signals

The ST7 HDS2 allows you to use 4 external input signals (TTL level). These
signals are on pins 6,7,8,9 of the Analyser Probe connector located on the front
panel of the emulator as shown below.

&)
OA
Qw
Om
- @

©0 00
T

L3 AL2 AL1 ALO

You can view these probe inputs using STVD7. From the main menu, select
View>Trace. The input signal values are listed under the Sig column (AL3..0).

STVD7’s Logical Analyser allows you to use these input signals to define trace
filtering or output trigger events. From the main menu, select Tools>Logical
Analyser to open the dialog box. A full description of how to use this facility to
control trace recording or trigger output signals is given in the STVD7 online help.

A rainbow-colored cable will also be delivered to connect your application to these
inlets. Each red connector is to be connected to your signal. Each black connector
is to be connected to the reference ground for the signal.

Colors are attributed as follows:
e ALO is to be taken between the RED (signal) and BROWN (ground) wires

e ALl is to be taken between the YELLOW (signal) and ORANGE (ground)
wires.

« AL2is to be taken between the BLUE (signal) and GREEN (ground) wires.
« AL3is to be taken between the GREY (signal) and PURPLE (ground) wires.

4
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4.6 Front panel LEDs

Four LEDs on the front panel of the HDS2 box indicate the state of the
development tool during emulation:

» Power (Green)—indicates that the 5 V power supply is ON.

¢ Run (Yellow)—indicates that the ST7 is running (not in RESET, WFI and HALT
mode).

« System (Red)—not used with this emulator.

* Reset (Red)—not used with this emulator.

0000 © © () Analyser
ST7 HDS2 Emulator Triggers Probe
A
9 Poner
Run
“ " Unused
Reset
4.7 Using the TQFP44 bug-catcher

This emulator kit comes with a bug-catcher—a special device adapter that allows
you to measure each pin signal individually.

This device adapter is connected to the ST7TMDTU2-Active Probe and to your
application board in the same manner as an ordinary TQFP44 device adapter
(please refer to the TQFP44 section on page 17). However, there are easily
accessible pin connections that allow you to hook an external measuring device
such as a multimeter or an oscilloscope to any or all of the 44 pins. This allows you
to better observe the signal values sent to each pin.

4
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4.8 On-chip peripherals

You can configure certain on-chip peripherals in STVD7’ s MCU Configuration
dialog box (refer to Creating a workspace on page 34) so that the emulator
accurately emulates your target device.

The on-chip peripheral options supported by the emulator are:

4.8.1 Clock

The emulator can work with two clock sources (Max. Frequency = 12 MHz, Min.
Frequency =1 MHz):

e 12MHz or 6 MHz internal oscillator (depending on your target MCU
selection—refer to Emulation functional limitations and discrepancies on
page 61).

« An external clock source. The external clock frequency must be either 6 MHz
or 12 MHz (see Emulation functional limitations and discrepancies on
page 61). The external clock source signal is provided by the user via the SUB-
click connector located on the ST7TMDTU2-Active Probe as shown below.

External clock input

ﬂ / SUB-Click connector

| ]
= vt | SERESNUMBER

OOOOOOO‘ SUBCLIC
El

v R32K 1% | c
by | A " ik 4
gs A2 T C71000F| puadl oy
. s e C 3 100pF e
. ok oo b’
x 57 I TS272
N oz *4 | pel@a vd
Ny T 07 Dszu

The SUB-click external clock connector on the probe can be used with the two
SMB to BNC connectors provided in the emulator package. Voltage at these
connectors must range between 0V and 5 V. The levels are TTL.

However, if additional connectors are needed, you can purchase them at the
dealers or manufacturers listed in the section entitled Hardware spare parts on
page 72. (This list is not exhaustive.)

4
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4.9 Emulation functional limitations and discrepancies

The following is a list of functional limitations and discrepancies applicable when
emulating the actual target device features.

49.1 Power supply

The application supply follower allows this emulator to run with an application Vpp
ranging between 3.6 V to 5.5 V. If the application isn’'t powered, or the Vpp < 3.6 V,
the power supply is maintained at 3.6 V. If your application is powered by a voltage
greater than 5.5 V, the emulator will limit this value internally to 5.5 V.

49.2 Low voltage detector management

The Low Voltage Detector is not yet available on this emulator release.

4.9.3 Step mode

When using step by step mode some of the counter registers (TBU, timer, etc.) are
not always active. For example, the TBU counter is not always incremented, so the
counter value is not always guaranteed to be correct.
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APPENDIX A: EMC CONFORMITY AND SAFETY REQUIREMENTS

This emulator respects the EMC requirements of the European guideline 89/336/
EEC under the following conditions:

« Any tester, equipment, or tool used at any production step or for any
manipulation of semi-conductor devices must have its shield connected to
ground.

« All ferrites provided with the emulator kit must be attached as described in the
hardware installation instructions of the relevant user manual(s).

< Your emulator must be placed on a conductive table top, made of steel or clean
aluminum, grounded through a ground cable.
All manipulation of finished goods must be made at such a grounded
worktable.

* The worktable must be free of all non-antistatic plastic objects.

e Itis recommended that you wear an antistatic wrist or ankle strap, connected to
the antistatic floor covering or to the grounded equipment.

e If no antistatic wrist or ankle strap is worn, before each manipulation of the
powered-on emulator, you must touch the surface of the grounded worktable.

e Itis recommended that antistatic gloves or finger coats be worn.

* It is recommended that nylon clothing be avoided while performing any
manipulation of parts.
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APPENDIX B: TROUBLESHOOTING

B.1 Identifying the problem

IF YOU RECEIVE THE FOLLOWING: THEN...

Error Message (when starting the Ensure that:
STVDY for HDS Emulator):

“No message received from emula-
tor.”

e The parallel cable is connected between the
emulator and one of the PC’s parallel ports
(LPT1 or LPT2). Note that the use of switch
boxes between the parallel port connector of
your PC and the emulator is not recommended.

e The emulator is powered on.

* The parallel cable used is the one supplied with
the kit by STMicroelectronics.

If none of the above items has been overlooked,
this may mean that your parallel port connection
needs to be reconfigured.

Please refer to Changing the parallel port setup on
your PC on page 65 below.

Error Messages (when starting the Ensure that:

STVD7 for HDS Emulator): The flat cables linking the ST7MDTU2-Active

"Communication error with EMULA- Probe and the emulator box are properly
TOR board.”

connected.
or * The selected configuration file matches the
“SYSTEM ERROR DETECTED by connected ST7MDTU2-Active Probe
EMULATOR BOARD: RESET CPU.” configuration.
If it doesn’t, from within STVD7, open the MCU
Configuration dialog box by selecting
Tools>MCU Configuration from the main
menu.
Choose the correct MCU target device in the
dropdown list, then click OK to save your
changes.
B.2 Changing the parallel port setup on your PC

Under certain circumstances, you may receive the following error message:

"Connection Error (LPT1/LPT2): Interconnection failure. Verify your input/
output cable."

This may mean that the setup of the LPT1 or LPT2 port on your PC is not
compatible with the ST7TMDTU2-EMU2B.
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To set up the port correctly:
1 Shut down and restart your PC in order to enter the BIOS setup.

2 Follow the messages displayed on the screen and when prompted, press the
key required to enter the BIOS setup (usually a function key or the ESC key).

3 Select the parallel ports menu. (This may be listed under I/O ports.)

4 Change the Mode of the LPT port that you have connected the development
board to (i.e. either LPT1 or LPT2) to one of the following compatible modes,
according to the following table:

Operating System Compatible Parallel Port Modes
Windows 95 ECP, EPP, Bidirectional or Centronics
Windows 98 EPP, Bidirectional or Centronics

Windows NT4 ECP, EPP, Bidirectional or Centronics

5 Save your changes and exit the BIOS setup.

B.3 Running the hardware test

The Hardware Test in STVD7 lets you check that your emulator is correctly
connected, configured and working. You can test components of the development
board individually, or all at the same time.

If problems occur during debugging (such as bad debugger responses and
unexpected behavior), you should check for hardware problems using the
Hardware Test function, and if any are detected, contact your STMicroelectronics
sales representative (see Product Support on page 71).

You may open the Hardware Test dialog box by:

« selecting, from the Main Menu, Emulator>Hardware Test

« clicking on the Hardware Test icon ﬁ in the Emulator toolbar.

Warning: Be cautious in performing a Hardware Test on the emulator while an application is
open. The opened application WILL BE corrupted by the hardware testing process. If
you find that your application has been corrupted, simply close the application, and
reopen it.
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The Hardware Test
Hardware Test E

dialog box shows a

list of different tests Development Board test v ﬂ
that can be performed HALT and RESET emulator test 2
on the emulator. “winite pratect request test v
Check the box of Mext request test v
each test that you 5S4 breakpoint reguest test v
wish to perform (they Logical analyser request chack v

are all checked by Rd
default) and click |
Apply to start the
hardware test.

dpply | Selectal | Unselestai|

The Hardware tests e ——— K

will be performed one

by one, and the Developrent Board test ¥  TestOk j
results summarized in HALT and RESET emulator test W TestOK
the dIaIOg box as Wirite protect request test I~ Test OF
shown on the right: Mest request test v  TestOK
54, breakpoint reguest test I~ Test OF.
Logical analyzer request cheack ¥  OnGaing..
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B.4 TQFP44 footprint issues

Some of the emulated devices have a TQFP footprint and require you to solder a
Yamaichi socket onto your application board. However, be aware that you may
encounter problems owing to the fact that the Yamaichi sockets used to connect
the TQFP44 device adapter require footprints that are not compatible with TQFP
copper traces.

For this reason, when designing your board, plan to have a double trace
compatible with both Yamaichi sockets and TQFP copper traces. Specifications for
compatible footprints are provided below. If you use compatible footprints, a single
printed circuit board design will serve for both the development stage and the final
product. When you are finished the development stage, you can simply replace the
development Yamaichi socket by the programmable target device in an actual
TQFP44 package.

SK
mm inches
E Dim
E1 Min | Typ | Max [ Min | Typ | Max
-L-l B |0.35|0.45]050|0.014]0.018/0.020
- - E [13.40 0.527
]
| El 10.00 0.394
— — le
| | | |
= = _:gI E3 |7.95 | 8.00 | 8.05 [0.313(0.315(0.317
ol t
! : B e |0.75|0.80] 0.85 [0.029/0.031[0.033
¥ wl o @ SOCKET .
. / Sk 24.2 0.953
. DETAIL

= =] Number of Pins
= | |
= =
= N 44 (4x11)
171111 R nooo

* SK: Plastic socket overall dimensions.

Figure 20: TQFP44 Device and emulation probe compatible footprint
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APPENDIX C: GLOSSARY

Application Board

This is the printed circuit board onto which you wish to connect the target ST7
MCU. It should include a socket or footprint so that you can connect the application
board to your emulator or development kit using the probe and the appropriate
device adapter. This allows you to emulate the behavior of the ST7 MCU in a real
application in order to debug your application program.

Bug-Catcher

This is a special device adapter with easily accessible signal pins, so that you can
link each of the pins to an external measuring device (such as a multimeter or an
oscilloscope). You use the bug-catcher like any other device adapter—it connects
to the Active Probe and to your application board—but you have more control over
each individual pin signal.

Device Adapter

Device adapters are included in your emulator kit to allow you to connect the
emulator to your application board. The type of device adapter depends on the
target device’s packaging. Many MCUs come in more than one different package,
and you should therefore use the device adapter that corresponds to the type of
package you have chosen for your application.

DIL

Dual In Line. Designates a type of device package with two rows of pins for thru-
hole mounting. Sometimes also called DIP (Dual In-line Package).

ECP
Extended capabilities port communication standard.

EPP
Enhanced parallel port communication standard.

Footprint

Designates the dimensions of the location of a component on a printed circuit
board or in a socket. It depends on the number of pins, their size, type and
positioning. The footprint of each ST7 device is specified in the datasheet in the
section titled Package Mechanical Data.
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MCU

Microcontroller Unit. Otherwise referred to as the “target device” throughout this
manual. This is the core product (or family of products) for which the Development
Kit is designed to act as an emulator and programming tool. In general terms, an
MCU is a complete computer system, including a CPU, memory, a clock oscillator
and 1/0 on a single integrated circuit.

ST7MDTU2-Active Probe

A printed card having connector pins that allow you to connect the Emulator to the
MCU socket of the user application board. Using the active probe allows the HDS2
emulator to function as if it were the target device embedded in your application.
The probe is connected to the emulator by two flat cables.

PC (Program Counter)
The program counter is the CPU register that holds the address of the next
instruction or operand that the CPU will use.

RC network
Resistor-capacitor network.

SDIP
Serial Dual In-line Package.

SO

Small outline. Designates a type of device package with two rows of pins for SMD
or socket mounting. For example, SO34 designates a 34-pin device of this
package type.

ST7 Visual Debug (STVD7)

A graphic debugger software package that allows you to debug applications
destined for the ST7 family of MCUs, either using a built-in simulator function, a
Development Kit or an HDS2 Emulator.

Target Device
This is the ST7 MCU that you wish to use in your application, and which your
emulator or development kit will emulate for you.

User Application Board
Designates your application board.
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PRODUCT SUPPORT

If you experience any problems with this product or if you need spare parts or
repair, contact the distributor or ST sales office where you purchased the product.

Getting prepared before you call

Collect the following information about the product before contacting ST or your

distributor:

1 Name of the company where you purchased the emulator kit.

2 Date of purchase.

3 Order Code: Refer to the side of your emulatorkit box. The order code will
depend on the region for which it was ordered (i.e. the UK, Continental Europe
or the USA).

4 Serial Number: The serial number is located on the rear panel of the emulator
box.

5 Target Device: The sales type of the ST7 microcontroller you are using in your
development.

Contact list
Note: For American and Canadian customers seeking technical support the US/Canada is split

in 3 territories. According to your area, contact the following sales office and ask to be
transferred to an 8-bit microcontroller Field Applications Engineer (FAE).

Canada and East Coast

STMicroelectronics

Lexington Corporate Center

10 Maguire Road, Building 1, 3rd floor
Lexington, MA 02421

Phone: 781-402-2650

Mid West
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STMicroelectronics

1300 East Woodfield Road, Suite 410
Schaumburg, IL 60173

Phone: 847-517-1890
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West coast

STMicroelectronics, Inc.
30101 Agoura Court
Suite 118

Agoura Hills, CA 91301
Phone: 818-865-6850

Europe

France (33-1) 47407575
Germany (49-89) 460060
U.K. (44-1628) 890800

Asia/Pacific Region
Japan (81-3) 3280-4120
Hong-Kong (852) 2861 5700

Sydney (61-2) 9580 3811
Taipei (886-2) 2378-8088

Software updates
You can get software updates from the ST Internet web site http://mcu.st.com. For
information on firmware and hardware revisions, call your distributor or ST using
the contact list given above.

Hardware spare parts
Most of the hardware you will require is included in the emulator kit. However,
some special applications may require additional parts, such as connecting an
external clock, or you may need additional sockets for your application board.

Below is a list of manufacturers and dealers of SMB and BNC connectors that can
be used with our product.

European manufacturer Radiall

and product references: For worldwide sales locations,
visit Radiall's website at:
www.radiall.com

The EXTERNAL clock male connector on the emulation probe has the
following commercial reference:

- In SMB range: Ref.: 114665.
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Adaptable Female connectors that fit this connector are:

- SMB upright range
Ref.: 114005 for cable 2,6.
Ref.: 114003 for cable 4,2.
Ref.: 114009 for cable 3,8.

- SMB kneed range
Ref.: 114165 for cable 2,6.
Ref.: 114163 for cable 4,2.

- SMB to BNC range
Ref.: 191214. Adapter SMB female / BNC male.
Ref.: 191215. Adapter SMB female/ BNC female.

USA manufacturer R-Tek

and product references 411 Quentin Road
Palatine, IL 60067
Phone: (847) 934-7900
Fax: (847) 934-7946

Adaptable female connector part numbers:

- CCAX00168-2: cable length 2 ft, with SMB plug to BNC plug.

- CCAX00168-3: cable length 3 ft, with SMB plug to BNC plug.
Yamaichi sockets
You can order additional Yamaichi QFP sockets directly from Yamaichi at:

http://www.yamaichi.de/Pu/quad_flat_pack/spec/a2l-ic149.htm
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