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The information in this document is current as of September 2007. The information is subject to change 
without notice. For actual design-in, refer to the latest publications of NEC Electronics data sheets or 
data books, etc., for the most up-to-date specifications of NEC Electronics products. Not all products 
and/or types are available in every country. Please check with an NEC sales representative for 
availability and additional information. 
 
No part of this document may be copied or reproduced in any form or by any means without prior written 
consent of NEC Electronics.  NEC Electronics assumes no responsibility for any errors that may appear 
in this document. 
 
NEC Electronics does not assume any liability for infringement of patents, copyrights or other intellectual 
property rights of third parties by or arising from the use of NEC Electronics products listed in this 
document or any other liability arising from the use of such NEC Electronics products.  No license, 
express, implied or otherwise, is granted under any patents, copyrights or other intellectual property 
rights of NEC Electronics or others. 
 
Descriptions of circuits, software and other related information in this document are provided for 
illustrative purposes in semiconductor product operation and application examples.  The incorporation of 
these circuits, software and information in the design of customer's equipment shall be done under the 
full responsibility of customer.  NEC Electronics no responsibility for any losses incurred by customers or 
third parties arising from the use of these circuits, software and information.  

 
While NEC Electronics endeavors to enhance the quality, reliability and safety of NEC Electronics 
products, customers agree and acknowledge that the possibility of defects thereof cannot be eliminated 
entirely.  To minimize risks of damage to property or injury (including death) to persons arising from 
defects in NEC Electronics products, customers must incorporate sufficient safety measures in their 
design, such as redundancy, fire-containment and anti-failure features. 

 
NEC Electronics products are classified into the following three quality grades: “Standard”, “Special” and 
“Specific”. 

 
The "Specific" quality grade applies only to NEC Electronics products developed based on a customer-
designated “quality assurance program” for a specific application.  The recommended applications of 
NEC Electronics product depend on its quality grade, as indicated below.  Customers must check the 
quality grade of each NEC Electronics product before using it in a particular application. 
 
"Standard": Computers, office equipment, communications equipment, test and measurement 
equipment, audio and visual equipment, home electronic appliances, machine tools, personal electronic 
equipment and industrial robots. 
 
"Special":  Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-
disaster systems, anti-crime systems, safety equipment and medical equipment (not specifically 
designed for life support). 
 
"Specific": Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life 
support systems and medical equipment for life support, etc. 
 
The quality grade of NEC Electronics products is “Standard” unless otherwise expressly specified in NEC 
Electronics data sheets or data books, etc. If customers wish to use NEC Electronics products in 
applications not intended by NEC Electronics, they must contact NEC Electronics sales representative in 
advance to determine NEC Electronics’ willingness to support a given application. 
 

Notes: 
  1." NEC Electronics" as used in this statement means NEC Electronics Corporation and also 

includes its majority-owned subsidiaries. 
 

 2. " NEC Electronics products" means any product developed or manufactured by or for NEC 
Electronics (as defined above). 
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Regional Information 
 

Some information contained in this document may vary from country to country. Before using an NEC 
Electronics product in your application, contact the NEC Electronics office in your country to obtain a list 
of authorized representatives and distributors and to verify: 

• Device availability 

• Ordering information 

• Product release schedule 

• Availability of related technical literature 

• Development environment specifications (for example, specifications for third-party tools and 
components, host computers, power plugs, AC supply voltages, and so forth) 

• Network requirements 

In addition, trademarks, registered trademarks, export restrictions, and other legal issues may also vary 
from country to country. 
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1. Introduction 

DemoKit-LF3 is a demonstration system that supports onboard debugging, flash programming, and real-
time execution of application programs on NEC Electronics 8-bit 78K0/Lx3 microcontrollers (MCUs) with 
integrated liquid crystal display (LCD) controllers. The board is designed to be connected to user 
hardware such as digital I/O or analog signals. 

1.1 Features 

• Easy-to-use device demonstration capabilities—navigator switch, 224-segment LCD panel, 
temperature sensor, infrared (IR) receiver module, I/O lines, and UART serial interface—for easy 
demonstration of simple I/O functions 

• On-board debugging using the ID78K0-TK debugger and UART/USB interface without additional 
debugging hardware; standard commands for executing code, single-stepping, setting breakpoints, 
and manipulating memory 

• Optional QB-MINI2 emulator (available separately) that can be used with the microcontroller’s on-
chip debugging function 

• Flexible power supply via USB interface, QB-MINI2 on-chip debugging emulator, or external supply 

• 224-segment LCD panel  

• Windows®-based NEC Electronics’ WriteEZ3 flash programming software that enables you to select 
and download application programs for evaluation purposes 

• Various I/O signals 

− I/O ports for connection to user hardware 

− Timer I/O signals 

− Two- or three-wire serial I/O 

− UART interface via a FT232 USB UART chip  

− Eight-channel 10-bit A/D converter 

− Three channel 16-bit sigma-delta A/D converter 

− RPM7138 IR receiver module  

− S-8120C temperature sensor  

− Navigation switch for key interrupt generation 

• NEC Electronics C compiler, assembler (32 KB size limitation), and ID78K0-TK debugger 

• Full documentation for the MCU and software tools, including downloadable updates of the software 
tools, documentation and utilities, if available, from http://www.am.necel.com/micro/development 

The DemoKit-LF3 is not intended to be used for code development. NEC Electronics America does 
not allow and does not support any attempt to use the kit in a commercial or technical product. 

 

1 
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1.2 System requirements 
 
• Host computer 

− Windows® 2000 or Windows XP® operating system 

− 200 MHz (minimum) Pentium®-class processor 

− 128 MB RAM 

− 1024 × 768 display with 256 colors 

− Mouse 

− CD-ROM drive 

− 200 MB free hard disk space 

• Host interface: USB interface that enables communication based on USB version 1.1 or later 

1.3 Contents 

Before setting up the system, verify that all parts listed on the contents page are intact and accounted for. 
If not, contact your NEC Electronics America representative to report the problem. 

1.4 System configuration 

Figure 1 illustrates the configuration of the DemoKit-LF3 system. 

Figure 1. DemoKit-LF3 system configuration 

 

1.5 Demonstration board 

The DemoKit-LF3 board connects to the host computer via a USB interface cable. The host may be used 
for on-chip debugging using the ID78K0-TK debugger or for execution of application programs on the 
DemoKit-LF3 starter kit. The 78K0/LF3 MCU operates at 8 MHz and has a 32.768 kHz subclock. 
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1.6 Host computer 

The USB interface allows communication between the host computer and the DemoKit-LF3 board. 

• The FT232 USB UART chip allows application software to access the USB device in the same way it 
would access a standard RS-232 interface. 

• The FTDI driver for the virtual COM port (VCP) appears to the Windows operating system as an extra 
COM port.  

1.7 Flexible power supply 

The DemoKit-LF3 can receive power from the USB interface, the QB-MINI2 on-chip debugger, or an 
external power supply.  

 U18759EE1V0UMU1 3 
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2. DemoKit-LF3 components 

The DemoKit-LF3 is equipped with a navigation switch, 224-segment LCD panel, temperature sensor, 
and several connectors that can be used for connection to host computers, flash programmers, or 
external target hardware. 

Figure 2. Board connectors and switches (top view) 
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Some of the DemoKit-LF3 components are free for user application hardware and software. Refer to the 
78K0/LF3 device user’s manual to obtain information about electrical specifications for the available I/O 
ports before connecting any external signals to the DemoKit-LF3 board. 

2.1 SW1 and SW2 configuration switches 

The settings of SW1 and SW2 specify the DemoKit’s operating modes.  

Table 1. Settings for SW1 and SW2 configuration switches 
Mode SW2 SW1 

 1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

ON ON   ON ON ON ON ON ON   On-board 
debugger   OFF OFF 

 

Don’t care       OFF OFF 

 

  ON ON ON ON     ON ON 
WriteEZ3 

OFF OFF   

 

Don’t care   OFF OFF OFF OFF   

 

ON ON           
QB-MINI2 

  OFF OFF 

 

Don’t care OFF OFF OFF OFF OFF OFF OFF OFF 

 

2.1.1 IDK78K0-TK on-board debugging mode 

In this mode, you can perform on-board debugging via the default USB/UART connection to the 
host computer, without the use of additional debugging hardware. Standard commands for flash 
programming, downloading programs, executing code, single-stepping through programs, setting 
breakpoints, and manipulating memory are available. 

2.1.2 WriteEZ3 flash programming mode 

In WriteEZ3 mode, you can reprogram the microcontroller’s internal flash memory using NEC 
Electronics’ WriteEZ3 flash programming software and the default USB/UART connection to the 
host computer. 

2.1.3 QB-MINI2 on-chip debugging / normal execution 

In QB-MINI2 mode, you can connect the QB-MINI2 on-chip debugging emulator (available 
separately) to the DemoKit-LF3 board and use the microcontroller’s on-chip debugging function. 

When the on-chip debugging emulator is not connected to the board, the microcontroller begins 
normal execution and executes the user program stored in flash memory. 

2.2 SW4 reset button 

The SW3 reset button activates the power-on reset and controls the microcontroller’s reset input signal. 
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2.3 SW3 navigation switch 

The SW1 navigation switch connects to the microcontroller’s key interrupt input. The switch operates in 
five directions and has a push function in the center. 

Figure 3. SW3 navigation switch 

SW3 Connection to 78K0/LF3 MCU 

Left P43/KR3 

Down P42/KR2 

Select P44/KR4 

Right P45/KR5 

Up P46/KR6 

 

2.4 J1: external A/D measurement inputs 

You can configure connector J1 to measure external analog signals using the internal 10-bit A/D 
converter or the MCU’s 16-bit sigma-delta A/D converter by opening the corresponding A1–A8 soldering 
bridges. 

Table 2. Connector J1 inputs 
J1 Signal J1 Signal 

1 P20/ANI0/DS0- 9 GND 

2 P21/ANI1/DS0+ 10 GND 

3 P22/ANI2/DS1- 11 GND 

4 P23/ANI3/DS1+ 12 GND 

5 P24/ANI4/DS2- 13 GND 

6 P25/ANI5/DS2+ 14 GND 

7 P26/ANI6/REF- 15 GND 

8 P27/ANI7/REF+ 16 GND 

2.5 J2: external A/D measurement inputs 

Connector J2 can be used to measure an external analog signal using the internal 10-bit A/D converter or 
the microcontroller’s 16-bit sigma-delta A/D converter. 
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Table 3. Connector J2 inputs 
J2 Input 

1 P23/ANI3/DS1+ 

2 GND 

2.6 J4: IDD measurement 

Connector J4 (not assembled) can be used to measure the microcontroller’s current consumption. To use 
this mode, open the V8 soldering bridge. 

2.7 J5: external power supply input 

Connector J5 (not assembled) enables you to apply an external power supply to the DemoKit-LF3 board 
without an active USB connection. 

Table 4. Connector J3 inputs 
J5 Input 

1 VDD (+5V) 

2 GND 

Note: Be sure to unplug the USB connection before applying external power supply to input J5. 

2.8 Y1: external main oscillator 

The microcontroller’s clock generator can be configured to work with an external oscillator connected to 
the X1 and X2 pins. For this mode, you must equip the board’s Y1 pad with a corresponding oscillator. 
Refer to the microcontroller user’s manual for a description of how to configure the clock generator. 

2.9 OCD1: QB-MINI2 connector 

Connector OCD1 (not assembled) enables you to connect the QB-MINI2 on-chip debugging emulator 
(available separately) to the DemoKit-LF3 board to use the microcontroller’s on-chip debugging function. 

Table 5. Connector OCD1 signals 
OCD1 Signal 

1 RESET_IN 

2 RESET_OUT 

3 FLMDO 

4 VDD_IN 

5 X2 

6 GND 

7 X1 

8 GND 

9 Not connected 

10 VDD 
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When using QB-MINI2 for debugging purposes, configure SW2 of the DemoKit-LF3 board as follows. 

Table 6. Configuration of SW1 and SW2 when using the QB-MINI2 
Mode SW2 SW1 

 1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

ON ON           
QB-MINI2 

  OFF OFF 

 

Don’t care OFF OFF OFF OFF OFF OFF OFF OFF 

For more information about how to configure the DemoKit-LF3 for on-chip debugging, refer to Section 3, 
“On-Chip Debugging.” 

2.10 USB1 interface connector 

This interface enables you to connect the ID78K0-TK debugger to the DemoKit-LF3 for on-board 
debugging using commands for programming memory, executing code, single-stepping, setting 
breakpoints, and manipulating memory. The WriteEZ3 flash programming software also uses the USB 
communication channel to program application software into the CPU’s internal flash memory. 

The power supply of the DemoKit-LF3 board is also provided by the USB1 connector. 

Figure 4. Pin configuration of USB1 connector and USB mini-B-type host 

1 5

 
Table 7. Pin configuration of USB1 connector 
Connector USB1 Signal Name 

1 VBUS 
2 D- 

3 D+ 

4 No connection 

5 GND 

For connection with the host, use the USB cable (mini-B type) bundled with the DemoKit-LF3. 
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2.11 LCD1: 224-segment LCD panel 

The DemoKit-LF3 board is equipped with a 224-segment, transflective-type LCD panel that operates at a 
supply voltage of 5V and a multiplex rate of ×8. The LCD driver specifications are defined in Table 8. 

Table 8. LCD driver specifications 
Specification Mode 

Driver voltage generation Internal resistance division 

Bias method 1/4 

Timesharing 8 

Common signals 8 (COM0–COM7) 

Segment number 28 (SEG4–SEG31) 

Number of maximum display pixels 224 (28 segments × 8 common) 

The LCD is divided into character and indicator fields. The character field is composed of six 5 × 7 dot- 
matrix characters. The indicator field includes a set of predefined symbols, for instance weekday, battery, 
and antenna symbols. An outline of the LCD in Figure 5 and corresponding segment assignments are 
shown in Figure 6. 

Figure 5. LCD outline 

 

CHARACTER FIELD INDICATOR 
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Table 9. LCD segment assignments 

 

2.12 RR1–RR5: external LCD resistors  

The DemoKit-LF3 board can also be configured to use external voltage divider resistors for the 
generation of the LCD drive power supplies. For information about the external resistance division 
method, refer to the microcontroller user’s manual. 

2.13 U2: temperature sensor  

For temperature measurement and primarily as an application example, the DemoKit-LF3 board is 
equipped within an S-8120C temperature sensor IC. The output pin of the temperature sensor is 
connected to the microcontroller’s P21/ANI1/DS0+ pin. 

LCD RAM address Bit 
position +27 +26 +25 +24 +23 +22 +21 +20 

bit7 ALARM AM PM Sun MOON 
(symbol) 

SUN 
(symbol) Mon All FLASH 

78K0/Lx3  
bit6 520 510 500 440 430 420 410 400 
bit5 521 511 501 441 431 421 411 401 
bit4 522 512 502 442 432 422 412 402 
bit3 523 513 503 443  433 423 413 403 
bit2 524 514 504 444 434 424 414 404 
bit1 525 515 505 445 435 425 415 405 
bit0 526 516 506 446 436 426 416 406 

LCD RAM address Bit 
position +19 +18 +17 +16 +15 +14 +13 +12 +11 +10 
bit7 Tue Wed Thur Fri Sat  V A mA Hz Rem  
bit6 340  330  320  310  300  000  010  020  030  040  
bit5 341  331  321  311  301  001  011  021  031  041  
bit4 342  332  322  312  302  002  012  022  032  042  
bit3 343  333  323  313  303  003  013  023  033  043  
bit2 344  334  324  314  304  004  014  024  034  044  
bit1 345  335  325  315  305  005  015  025  035  045  
bit0 346  336  326  316 306 006 016 026  036  046 

LCD RAM address Bit 
position +9 +8 +7 +6 +5 +4 +3 +2 +1 +0 

bit7 Bt3 
(Battery) Bt2 Bt1 BtM An5 

(Antenna) An4 An3 An2 An1 AnM 

bit6 100  110  120  130  140  200  210  220  230  240  
bit5 101  111  121  131  141  201  211  221  231  241  
bit4 102  112  122  132  142  202  212  222  232  242  
bit3 103  113  123  133  143  203  213  223  233  243  
bit2 104  114  124  134  144  204  214  224  234  244  
bit1 105  115  125  135  145  205  215  225  235  245  
bit0 106  116  126  136  146  206  216  226  236  246  

 
   1       3       6 

Row index 

Colomn index 

Character index 
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2.14 U4: IR receiver module  

For remote control applications, the DemoKit-LF3 board is equipped with an RPM7138 IR receiver 
module whose output terminal is connected to the microcontroller’s P41/KR1/RIN remote control input pin. 

2.15 BUZ1: buzzer 

To generate acoustic signals and sound waves, a buzzer is connected to the timer output port of the 16-
bit timer/event counter 00, equivalent to port P34/TI52/TI010/TO00/RTC1HZ/INTP1 of the microcontroller. 
The AC buzzer operates in a voltage range of 2–5V. 

2.16 LED1: power LED 

LED1 is the power LED that indicates when the DemoKit-LF3 board has power. 

2.17 Connectors T1–T13 and wire-wrap field 

Pin assignments for the T1–T13 connectors are shown in Table 10. Additionally, the DemoKit-LF3 board 
provides a wire-wrap field area that allows integration of additional application hardware. 

Figure 6. Connectors T1–T13 and wire-wrap field 

Wire-wrap 
field 

Connectors 
T1–T13 

 

Table 10. Connectors T1–T13 
Connector Microcontroller I/O pins 

T1 P14 / SCKA0 / INTP4 

T2 P32 / TOH0 / MCG0 
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Connector Microcontroller I/O pins 

T3 P13 / SO10 / TxD0 

T4 P33 / TIO00 / RTCDIV / RTCCL / BUZ / INTP2 

T5 P12 / SI10 / RxD0 

T6 P16 / SOA0 / TxD6 

T7 P30 / INTP5 

T8 P11 / SCK10 

T9 P15 / SIA0 / RxD6 

T10 P31 / TOH1 / INTP3 

T11 P10 / PCL 

T12 P120 / INTP0 / EXLVI 

T13 P47 / KR7 
 

2.18 Soldering bridges 

Additional configuration of the DemoKit-LF3 board can be done using the A1–A8 and V1–V11 soldering 
bridges as described in the tables below. The A1–A8 and V7 soldering bridges can be used to 
reconfigure the A/D converter input channels and the reference input voltage. 

Table 11. Settings of A1—A8 and V7 soldering bridges 

Soldering bridge Configuration 78K0/LF3 pin 

Closed (default) Connected to VSS 
A1 

Open 
ANI0/DS0- 

Disconnected from VSS 

Closed (default) Connected to temperature sensor U2 
A2 

Open 
ANI1/DS0+ 

Disconnected from temperature sensor U2 

Closed (default) Connected to VSS 
A3 

Open 
ANI2/DS1- 

Disconnected from VSS 

Closed (default) Pin connected to jumper J2 
A4 

Open 
ANI3/DS1+ 

Disconnected from jumper J2 

Closed (default) Connected to VSS 
A5 

Open 
ANI4/DS2- 

Disconnected from VSS 

Closed (default) Connected to VDD27 
A6 

Open 
ANI5/DS2+ 

Disconnected from VDD27 

Closed (default) Connected to VSS 
A7 

Open 
ANI6/REF- 

Disconnected from VSS 

Closed (default) Connected to VDD 
A8 

Open 
ANI7/REF+ 

Disconnected from VDD 

Closed (default) Connected to VDD 
V7 

Open 
AVREF 

Disconnected from VDD 
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The V1–V6 and V8–V11soldering bridges can be used to reconfigure the power supply of the board’s 
dedicated circuits. For more information, refer to Section 13, “Schematics.” 

Table 12. Setting of V1–V6 and V8–V11 soldering bridges  

Soldering bridge Configuration Circuit 

Closed (default) Connected to VDD 
V1 

Open 
BUZ1 

Disconnected from VDD 

Closed (default) Connected to VDD 
V2 

Open 
U6 (not assembled) 

Disconnected from VDD 

Closed (default) Connected to VDD27 
V3 

Open 
U2 

Disconnected from VDD27 

Closed (default) Connected to VDD 
V6 

Open 
U5 

Disconnected from VDD 

Closed (default) Connected to VDD 
V8 

Open 
U1 

Disconnected from VDD 

Closed (default) Connected to VDD 
V9 

Open 
LED1 

Disconnected from VDD 

Closed (default) VDD connected to USBVDD 
V10 

Open VDD disconnected from USBVDD 

Closed (default) VDD2 connected to VDD 
V11 

Open VDD2 disconnected from VDD 
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2.19 Microcontroller memory map 

The memory map of the 78K0/LF3 microcontroller is shown in Figure 7. 

Figure 7. 78K0/LF3 memory map 

 
The DemoKit-LF3 board does not reserve any resources of the microcontroller; therefore, available 
device memory is free for application software. 
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3. On-chip debugging 

The DemoKit-LF3 offers two options for on-chip debugging (OCD): 

• Using the on-board ID78K0-TK debugger without external hardware, whereby the default USB 
connection to the host computer based on the virtual UART driver is used as a debugging interface 
and all standard commands for flash programming, downloading, executing code, single-stepping, 
setting breakpoints, and manipulating memory are available 

• Using the QB-MINI2 emulator with the microcontroller’s on-chip debugging function 

Figure 8. Configuration for on-chip debugging using the on-board debugging emulator 

 

3.1 On-chip debugging via the on-board ID78K0-TK debugging function 

To use the on-board debugging mode, configure switches SW1 and SW2 as described in Table 13. 

Table 13. Configuration for ID78K0-TK debugging 
SW2 SW1 

Mode 
1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

ON ON   ON ON ON ON ON ON   On-board 
debugging   OFF OFF 

 

Don’t care       OFF OFF 
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3.2 On-chip debugging via QB-MINI2 emulator 

To operate the DemoKit-LF3 board together with the QB-MINI2 on-chip debugging emulator, configure 
switches SW1 and SW2 as described in Table 14. 

Table 14. Configuration for QB-MINI2 debugging 
SW2 SW1 

Mode 
1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

ON ON           
QB-MINI2 

  OFF OFF 

 

Don’t care OFF OFF OFF OFF OFF OFF OFF OFF 

Note: When supplying power from the QB-MINI2, do not connect external hardware to the DemoKit-LF3 
board. In this mode, the board can operate without external power from the USB. 

 U18759EE1V0UMU1 16 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/841937/DEMOKIT-LF3.html


DemoKit-LF3 User’s Manual  

 

4. Installation and operation 

The bundled software tools, including the ID78K0-TK debugger, allow downloading and debugging af 
application software on the DemoKit-LF3 starter kit hardware. Additionally, you can use the WriteEZ3 
flash programming program to perform simple flash programming of the microcontroller’s internal flash 
memory. A USB interface line is needed for communication between the host computer and the DemoKit-
LF3 board. Before downloading, debugging, or executing an application program, make sure the 
hardware and software are installed properly. 

Table 15. Directory structure of CD-ROM 
 DemoKit_vx.x (F:) CD-ROM ROOT 

  Documents - Documentation 

  fscommand  

     K0  

   WriteEZ3 - WriteEZ3 GUI 

      driver - USB driver 

                              PRM - PRM parameter files 

   NECTools - C compiler, assembler, and debugger 

      SampleProgram   

                           DemoKitLF3 - Sample programs for the DemoKit-LF3 starter kit 

              dotnet - DotNet setup file for Applilet 
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5. Hardware installation 

After unpacking the kit, first connect the board to your host computer using the provided USB interface 
cable and then install the USB driver as explained in Section 6, “Software Initialization.” 

 

6. Software installation 

The DemoKit-LF3 package includes the following software demonstration packages: 

• NEC Electronics C compiler, assembler, linker, librarian, and debugger 

• WriteEZ3 flash programming software 

• Sample program 

6.1 NEC Electronics software tools installation 

To install the tools, select the SETUP program in the \fscommand\K0\NECtools directory and follow the 
dialog boxes to complete the installation process. If prompted for a product ID, use “00101386V.” 

6.2 Sample program installation 

To install the sample program, select the SETUP program in the \fscommand\SampleProgram\ directory 
and follow the dialog boxes to complete the installation process. 

6.3 WriteEZ3 program installation 

To install the WRITEEZ3 flash programming software, select the setup program in the 
\fscommand\K0\WRITEEZ3 directory and follow the instructions in the Setup dialog boxes. 

6.4 USB driver installation 

To use the DemoKit-LF3 board for on-chip debugging, install the USB driver on the host computer in 
accordance with one of the following procedures: 

Installation on Windows 98SE/Me operating system Section 6.4.1 

Installation on Windows 2000 operating system  Section 6.4.2 

Installation on Windows XP operating system  Section 6.4.3 
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6.4.1 Installation on Windows 98SE/Me operating system 

1. When you connect the DemoKit-LF3 board to the host computer, the Plug and Play function 
automatically initializes the Add New Hardware Wizard. Click Next. 

Figure 9. Add New Hardware Wizard (Windows 98SE) 

 

2. Select Search for a suitable driver for my device and click Next. 

Figure 10. Search Method (Windows 98SE) 
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3. Select the Specify a location box, click Browse… to find the \fscommand\K0\WRITEEZ3\drivers 
folder, and then click Next. 

Figure 11. Specify a Location (Windows 98SE) 

 

4. Click Next. 

Figure 12. Search for a Driver File (Windows 98SE) 

 

D:\fscommand\K0\WRITEEZ3\drive

D:\fscommand\K0\WRITEEZ3\driver
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5. Click Finish to complete the installation of the USB serial port driver. 

Figure 13. Installation of USB High-Speed Serial Converter Complete (Windows 98SE) 

 

6.4.2 Installation on Windows 2000 operating system 

1. When you connect the DemoKit-LF3 board to the host computer, the Plug and Play function 
automatically initializes the Found New Hardware Wizard. Click Next. 

Figure 14. Found New Hardware Wizard (Windows 2000) 
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2. Select Search for a suitable driver for my device and then click Next. 

Figure 15. Install Hardware Device Drivers (Windows 2000) 

 

3. Select Specify a location and then click Next. 

Figure 16. Specify a Location (Windows 2000) 
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4. Click Browse… to find the \fscommand\K0\WRITEEZ3\drivers folder and then click OK. 

Figure 17. Copy Manufacturer’s Files (Windows 2000) 

 

5. Click Next. 

Figure 18. Driver Files Search Results 1 (Windows 2000) 

 

D:\fscommand\K0\WRITEEZ3\drivers

D:\fscommand\K0\WRITEEZ3\drivers
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6. Click Finish to complete the installation of the USB driver. 

Figure 19. Installation of USB High-Speed Serial Converter Complete (Windows 2000) 

 

7. Open the Found New Hardware Wizard to install the USB serial port driver and click Next. 

Figure 20. Found New Hardware Wizard 2 (Windows 2000) 
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8. Select Search for a suitable driver for my device and then click Next. 

Figure 21. Install Hardware Device Drivers 2 (Windows 2000) 

 

9. Select Specify a location and then click Next. 

Figure 22. Specify a Location 2 (Windows 2000) 
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10. Browse to the \fscommand\K0\WRITEEZ3\drivers folder and click OK. 

Figure 23. Copy Manufacturer’s Files 2 (Windows 2000) 

 

11. Click Next. 

Figure 24. Driver Files Search Results 2 (Windows 2000) 

 

D:\fscommand\K0\WRITEEZ3\drivers

D:\fscommand\K0\WRITEEZ3\drivers
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12. Click Finish to complete the installation of the USB driver. 

Figure 25. Installation of USB Serial Port Complete (Windows 2000) 

 

6.4.3 Installation on Windows XP operating system 

1. After you connect the DemoKit-LF3 board to the host computer, the Plug and Play function 
initializes the Found New Hardware Wizard. Select Install from a list or specific location 
(Advanced) and then click Next. 

Figure 26. Found New Hardware Wizard (Windows XP) 
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2. Select Search for the best driver in these locations and Include this location in the search. 
Click Browse… to find the \fscommand\K0\WRITEEX\drivers folder and then click Next. 

Figure 27. Search for Best Driver (Windows XP) 

 

D:\fscommand\K0\WRITEEZ3\drivers

3. If you see this message, click Continue Anyway. 

Figure 28. Windows XP Logo Testing (Windows XP) 
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4. Click Finish to close the hardware wizard. 

Figure 29. Installation of USB High-Speed Serial Converter Complete (Windows ) 

 

5. Open the Found New Hardware Wizard for the USB serial port driver, select Install from a list 
or specific location (Advanced), and click Next. 

Figure 30. Found New Hardware Wizard 2 (Windows XP) 
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6. Select Search for the best driver in these locations and Include this location in the search. 
Click Browse... to find the \fscommand\K0\WRITEEZ3\drivers folder and then click Next. 

Figure 31. Search for the Best Driver 2 (Windows XP) 

 

7. If you receive this message, click Continue Anyway. 

Figure 32. Windows XP Logo Testing 2 (Windows XP) 

 

D:\fscommand\K0\WRITEEZ3\drivers
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8. Click Finish to complete the installation. 

Figure 33.   USB Serial Port2 Driver Installation Complete (Windows XP) 

 

Caution: On Windows 2000/XP operating systems, do not execute a Hardware Modification 
Scan from the Windows Device Manager when communicating with the target device. 

6.5 Confirmation of USB Driver Installation 

To confirm that the drivers have been installed, open the Windows Device Manager and verify that the 
USB serial port (COM3) and USB high-speed serial converter are listed. If the drivers are not displayed, 
or are marked with an "×" or "!" prefix, refer to Section 9, “Troubleshooting,” for guidelines about how to 
correct the problem. 

Note: In the Port list of the Device Setup box, make sure the COM port is the same as the USB Serial 
Port (COM?). 
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Figure 34. Windows Device Manager 

 

6.6 Driver uninstallation 

The driver uninstallation program is stored on the host computer when you install the WriteEZ3 program. 
This procedure explains how to use the program to remove the USB driver. 

1. On Windows XP operating systems, log on as the computer administrator. On Windows 2000 
operating systems, log on as the administrator. 

2. Double-click My Computer → C: → Program Files → NECTools32 → WRITEEZ3 → DRIVER 
→ Ftdiunin.exe. 

Figure 35. Driver Uninstallation 
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3. Click Continue. 

Figure 36. Driver Uninstaller 

 

4. Click Finish to complete the removal process. 

Figure 37. Completion of Driver Un-installation 

 

Caution: Removal of the GUI software causes the Ftdiunin.exe file to be deleted, in which case you 
must manually delete the USB serial port (COM?) and USB high-speed serial converter files from 
the Windows Device Manager. 
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7. WriteEZ3 flash programming program 

Installation of the WriteEZ3 program automatically installs the microcontroller’s <WriteEZ3 install-
path>\PRM parameter file. Nevertheless, you can also download the newest parameter file for the 
µPD78F0495 microcontroller from the NEC Electronics America web site. 

1. Go to http://www.am.necel.com/micro/develoment/ and download the file. 

2. Copy the file into the <WriteEZ3.EXE-install-path>\PRM subdirectory created during software 
setup (described in Section 7). 

7.1 Initialization 

1. Open the Start menu and click WriteEZ3.EXE to initialize the WriteEZ3 program and open the 
Main window. 

Figure 38. WriteEZ3 Main window 

 

Programmer 
parameter window 

Menu bar

Toolbar 

Action log window 

Status

The main window consists of the following elements. 

Table 16. Main window elements 
 Name Description 

Menu bar Displays menu items executable by the WriteEZ3 program 

Toolbar Displays frequently used commands as icons 

Action log window Displays an WriteEZ3 action log 

Programmer parameter window Displays programming parameter settings 

Status bar Displays status 
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7.2 Toolbar 

The toolbar contains buttons for executing WriteEZ3 commands. 

Figure 39. Toolbar command buttons 

Icon Description 

 
Device → Setup 

 
File → Load 

 
Device → Blank Check 

 
Device → Erase 

 
Device → Program 

 
Device → Verify 

 
Device → Autoprocedure(EPV) 

7.3 Menu bar 

Depending on the actual device status and device type, some commands may be unavailable. 

7.3.1 File menu 

Clicking the File menu displays a pull-down menu of two commands. 

Figure 40. File Menu 
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7.3.1.1 Load command 

1. Click the Load command to view the Open box. 

2. Select the file to be programmed io the microcontroller’s flash memory and click Open. 

Figure 41. Open box 

 

3. After you load the program, it performs a checksum calculation and displays the result in the 
Programmer Parameter window. 

7.3.1.2 Quit command 

The Quit command terminates the WriteEZ3 program and saves your settings in a WriteEZ3.INI file 
that will be initialized at the next session. On Window 98SE, Windows Me, and Windows XP 
operating systems, the program stores WriteEZ3.INI in the Windows folder. On Windows 2000 
systems, the program stores WriteEZ3.INI in the Winnt folder. 

7.3.2 Device menu 

Clicking the Device menu displays a drop-down menu of programming commands. 

Figure 42. Device menu 
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7.3.2.1 Blank Check command 

The Blank Check command enables you to check the target device connected to the WriteEZ3 
program. If the device’s flash memory is blank, the command terminates normally. If the flash 
memory is not blank, the program displays a message to that effect, in which case you should 
execute an Erase command before proceeding. 

7.3.2.2 Erase command 

The Erase command erases the target device’s flash memory and displays progress information in 
the Action Log window. Upon completion, the program displays the command result. 

To execute a Blank Check command before an Erase command, click Device → Setup and then 
set the command options accordingly on the Advance tab. 

7.3.2.3 Program command 

The Program command sends a specified user program to the target device and then writes the 
program to the device’s flash memory. During programming, the program displays progress 
information, in percentages, in the Action Log window to indicate programmer operation. Upon 
completion, the program displays the command result. 

To automatically execute a Verify command afterward, click Device → Setup and set the 
command options accordingly on the Advance tab. 

7.3.2.4 Verify command 

The Verify command sends a specified user program to the target device and then verifies that the 
data written to the device’s flash memory is correct. During verification, the program displays 
progress information, in percentages, in the Action Log window. Upon completion, the program 
displays the command result. 

7.3.2.5 Security command 

The Security command programs the security flag that you set for the target device on the 
Advance tab of the Device Setup box. 

7.3.2.6 Checksum command 

The Checksum command reads the target device’s checksum value. 

7.3.2.7 Autoprocedure(EPV) command 

The Autoprocedure(EPV) command executes an Erase command, Program command, and 
Verify command in succession. 

During Autoprocedure(EPV) execution, the Action Log window displays progress information to 
indicate programmer operation. After completion, the program displays the command result. 
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7.3.2.8 Signature Read command 

The Signature Read command reads the device name, flash memory capacity, and other 
signature information of the target device. 

7.3.2.9 Setup command 

The Setup command opens the Device Setup box and enables you to specify command and 
programming options that are saved in a parameter file (.PRM) and retrieved at each session. 
Shaded (unavailable) options may not be modified. 

The Device Setup box consists of two tabs: Standard and Advance. 

The Standard tab contains options for rewriting the target device’s flash memory. Settings will differ 
depending on the device being used, so refer to the user’s manual for your device before making 
your selections. 

Figure 43.  Standard tab 
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Table 17. Standard tab elements 

Element Description 

OK button Saves the settings on the Standard and Advance tabs and 
closes the Device Setup box 

Cancel button Closes the Device Setup box without saving the settings on the 
Standard and Advance tabs 

Parameter file box 

Contains the parameters and timing data needed to rewrite the 
target device’s flash memory; protected by the checksum function 
(if the checksum result indicates an error, the WriteEZ3 program 
does not accept the parameter file); may not be modified because 
the data is related to the guarantee of rewritten data 

PRM Read File button Opens a window for specifying a parameter file 

Port list 

Specifies a channel (COM1 to COM256) for communication 
between the DemoKit-LF3 board and host computer (selectable 
ports can be verified using the Windows Device Manager, as 
described in the section titled, “Confirmation of USB Driver 
Installation”) Host connection area 

Speed list 
Specifies a communication rate for the selected channel: 9600, 
19200, 38400, or 115200 bps (refer to the user's manual for your 
device) 

Frequency 
box 

Sets the clock frequency of the target system, which varies from 
one device to another (refer to the user’s manual for your device) 

Specifies a division or multiplication rate for the target device  

For target devices with an on-chip PLL circuit, enter a division rate 
or multiplication rate after checking the specifications for the 
device used 

Supply oscillator area 
Multiply 
rate box 

For target devices without a PLL circuit: select 1.0 (the default 
setting in the parameter file will be displayed on the initial screen) 

Chip check 
box 

Subjects the entire flash memory area of the target device to 
rewrite processing 

Block check 
box 

Subjects a block range to rewrite processing; must be 
accompanied by entries in the Start and End lists 

Start and 
End lists 

Specifies the starting and ending addresses for the block of flash 
memory to be rewritten 

Area check 
box 

Subjects a specific area to rewrite processing; must be 
accompanied by entries in the Start and End lists 

Operation mode area 

Show 
Address 
check box 

Displays addresses in the Start and End lists (clearing this option 
displays numbers in the Start and End lists) 

Target Reset Message check box Displays a message promoting the manual reset operation, even 
when the reset signal cannot be connected to the target’s cable 
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The Advance tab contains the Command options and Security flag settings areas. 

Figure 44.  Advance tab 

 

Table 18. Advance tab elements 

Element Description 

Blank check before Erase 
check box 

Executes a Blank Check command before an Erase or 
Autoprocedure (EPV) command; does not execute an Erase 
command if the Blank Check result is OK 

Read verify after Program 
check box 

Verifies the data written to flash memory after the execution of 
Program and Autoprocedure (EPV) commands 

Security flag after 
Program check box 

Automatically programs the selected security flag after execution 
of Program and Autoprocedure (EPV) commands 

Command 
options area 

Checksum after Program 
check box 

Reads the target device’s flash memory checksum value after 
execution of Program and Autoprocedure (EPV) commands 

Disable Chip Erase check 
box 

Disables the Erase command and displays a warning message 
stating that the chip can no longer be erased and programmed 
(if the security flag is set in the target device, erasing and writing 
to the device cannot be enabled afterward) 

Disable Block Erase check 
box (unavailable if the Chip 
option is selected) 

Disables the Erase command in all of the flash memory blocks 
specified in the Operation Mode section of the Standard tab 

Disable Program check 
box 

Disables the Program and Erase commands in all of the flash 
memory blocks specified in the Operation Mode section of the 
Standard tab 

Security flag 
settings 
area 

Disable Boot block 
cluster reprogramming 
check box 

Makes the boot block set in the boot block cluster the last block; 
displays a message indicating that the boot block can no longer 
be erased and programmed (also, if the security flag is set in the 
target device, the boot area cannot be rewritten to the device 
afterward) 
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The following is the correspondence between the Erase and Program commands when the 
microcontroller’s security functions are valid. 

Table 19. Correspondence between Erase and Program command during valid security functions 
Command 

Option 
Chip Erase Block Erase Program 

Disable Chip Erase Invalid Invalid Valid (1)

Disable Block Erase Valid Invalid Valid 

Disable Program Valid Invalid Invalid 

Disable Boot block cluster reprogramming Invalid Valid (2) Valid (2)

Notes: 

1. Since the Erase command is invalid, the program cannot erase the flash memory to remove 
the bad data and write the new. 

2. The command is valid for areas other than the one specified as the boot area. 

7.3.3 View menu 

Clicking the View menu displays the Toolbar and Status Bar options. 

Figure 45. View menu 

 

7.3.3.1 Toolbar option 

Selecting Toolbar displays the toolbar; clearing Toolbar hides the toolbar. 

7.3.3.2 Status Bar option 

Selecting Status Bar displays the status bar; clearing Status Bar hides the status bar. 

7.3.4 Help menu 

Clicking the Help menu displays the About WriteEZ3… option. 

Figure 46.  Help  menu 
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Clicking About WriteEZ3… displays version and copyright information for the WriteEZ3 program.  

Figure 47. About WriteEZ3 Window 

 

7.4 Programmer Parameter window 

The Programmer Parameter window displays information about the device, parameter file, load file, and 
device connection. 

Figure 48. Programmer Parameter Window 
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Table 20. Programmer Parameter window elements 

Element Description 

Device area Updated after communication with the target device to display information about the 
target device 

Parameter file area Updated after a  Setup command to display information about a read parameter file 

Load file area Updated after a Load command to display information about a selected program file 

Connection to device 
area 

Updated after a Setup command to display information about the connection with the 
target device 
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8. WriteEZ3 flash programming software 
 

This section explains the basic operation of the WriteEZ3 flash programming software, including how to 
start the system, execute an Autoprocedure(EPV) command, and program a target device. 

8.1 Configuration of the DemoKit-LF3 board 

• Baseboard  : DemoKit-LF3 

• Target device : 78K0/LF3 (µPD78F0495) 

• Clock  : 6 MHz 

• Voltage level : 5V 

8.2 Configuration of the WriteEZ3 software 

• Parameter file : 78F0495.PRM 

• Clock setting : 6 MHz multiplied by 1 

• Port  : COM3 (115200 bps) 

• Operation mode : Chip 

• Write HEX  : VOLTMETER.hex  

• Option setting : Blank check before Erase 

8.3 Installing the parameter file 

The parameter file for the microcontroller is installed automatically during installation of WriteEZ3 
program. You may also download the most recent version from 
http://www.am.necel.com/micro/development/ and save it in the <WriteEZ3.EXE-install-path>\PRM 
subdirectory, as described in Section 7, “Software Installation.” 
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8.4 Connecting and starting 

1. Set the SW1 and SW2 switches as shown in Figure 49 and explained in Table 21. 

Figure 49. SW1 and SW2 settings 

 

 

SW1 

SW2 

Table 21. SW1 and SW2 settings 
SW2 SW1 

Mode 
1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

  ON ON ON ON     ON ON 
WriteEZ3 

OFF OFF   

 

don’t care   OFF OFF OFF OFF   

2. After you connect the DemoKit-LF3 board to the host computer via the USB cable, the Plug and 
Play feature initializes the driver. If the connection was already established, press the SW4 reset 
button to release flash programming mode. 
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3. To initialize the WriteEZ3 program, click Start → Programs → NEC Electronics Tools → 
WriteEZ3 → WriteEZ3. 

Figure 50. Main window 

 

4. Click Device → Setup to open the Device Setup box. Click the PRM File Read button. 

Figure 51. Device Setup box 
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5. Locate and select the 78F0495.prm parameter file in the C:\Program Files\NEC Electronics 
Tools\WriteEZ3\V1.10\PRM directory and then click Open. 

Figure 52.   Parameter File Selection 

 

6. In the Port list, select the communication port that matches the host computer being used. (Note: 
Selectable ports can be checked using the Windows Device Manager. For details, refer to 
Section 6.5, “Confirmation of USB Driver Installation.”) 

7. In the Speed list, select the communication speed for the host connection. 

Figure 53. Port Selection 
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8. In the Supply oscillator area, set the Frequency to 6.00 MHz and the Multiply rate to 1.00. 

9. In the Operation Mode area, select Chip. 

Figure 54.  Standard tab settings 

 

10. Click the Advance tab. 

Figure 55.  Advance tab settings 
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11. Select Blank check before Erase and click OK to set the parameters. 

Figure 56. Completion of Parameter Setting 

 

12. Click File → Load, select a program file to be written to the target device, and then click Open. 

Figure 57. After Downloading 
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13. Click Autoprocedure(EPV) to execute Blank Check, Erase, Program, and Verify commands 
on the µPD78F0495 device in succession. 

Figure 58.  Result of EPV command 

 

14. Click File → Quit to terminate the program and save your settings in the WriteEZ3.INI file for 
initialization at the next session. 

15. Reset the DemoKit-LF3 board to normal operation (QB-MINI2 mode) using the Plug and Play 
feature or pressing the SW4 reset button. 

16. Restart the program by clicking Start → Programs → NEC Electronics Tools → WriteEZ3 → 
WriteEZ3. 
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9. Troubleshooting 

In some cases, connection to the DemoKit-LF3 cannot be established. This section provides some 
guidelines for troubleshooting the problem. 

9.1 The Plug and Play feature does not initialize after driver installation. 

Cause: The USB connector may not be inserted normally into the computer’s USB port. 

Action: Check that the USB connector is inserted fully into the USB port of the personal 
computer. Alternatively, disconnect the USB connector and then insert the USB connector again 
after a while. 

9.2 The driver file cannot be found at a specified location. 

Cause: The WriteEZ3 flash programming software may not be installed correctly. 

Action: Install the GUI software again by referring to the “Software Installation” section. 

9.3 The drivers did not in install correctly. 

The USB serial port and/or USB high-speed serial converter are not listed on the Windows Device 
Manager, or they are listed with an "!" or "×" prefix. 

1. Cause: The USB connector may not be inserted normally into the computer’s USB port. 

Action: Check that the USB connector is inserted fully into the computer’s USB port. 
Alternatively, disconnect the USB connector from the USB port and re-insert again. 

2. Cause: The driver may not be installed correctly. 

Actions: 

− When this product is connected to the computer, right-click the driver marked with "!" or 
"×". 

− Click Erase. 

− On the Windows Device Manager, execute a Hardware Modification Scan. 

− Install the driver again to initialize the Plug and Play feature. 

 U18759EE1V0UMU1 51 

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/841937/DEMOKIT-LF3.html


DemoKit-LF3 User’s Manual  

3. Cause: The device may not be recognized (when connected to the USB hub). 

Action: Try the following: 

− Disconnect the USB connector and then re-insert it again. 

− Connect the USB connector to another port of the USB hub. 

If the same symptom occurs, do not use the USB hub, but directly connect the connector to the 
computer’s USB port. 

9.4 The Add New Hardware Wizard initializes unexpectedly. 

Cause: If the USB connector of this product is inserted into a USB port other than the one used 
at the time of installation, this product may be recognized as new hardware. 

Action: Install the driver in accordance with the procedure described in the section titled, “USB 
Driver Installation”. 

9.5 Communication with the DemoKit-LF3 board is disabled. 

1. Cause: The driver may not be installed correctly. 

Action: Verify that the USB serial port and USB high-speed serial converter are installed 
correctly by referring to Section 6.4, “USB Driver Installation.” 

2. Cause: The COM port selected in the Device Setup → Port box may not be set correctly. 

Action: Use the Windows Device Manager to set the port. 

3. Cause: The DemoKit-LF3 board is operating in normal mode. 

Action: Set the board to the WriteEZ3 flash programming mode. 

4. Cause: The PRM file selected in the Device Setup box may be incorrect. 

Action: Use the corresponding PRM file that matches the target device. For information 
about the PRM file, refer to Section 7, “WriteEZ3 flash programming software”. 

5. Cause: The setting of the Supply oscillator in the Device Setup box may be incorrect. 

Action: Make a correct setting according to the specifications of the target device. 
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10. Project Manager and Debugging 

Before using the DemoKit-LF3’s on-board debugging function with the debugger, you must first install the 
USB driver. The communication between the starter kit and debugger—running on the personal 
computer—is done via the standard UART / USB connection. 

To operate the board in on-board debugging mode, switches SW1 and SW2 must be configured as 
follows. 

Table 22. SW1 and SW2 settings 
Mode SW2 SW1 

 1 2 3 4 5 6 7 8 1 2 3 4 5 6 7 8 

ON ON   ON ON ON ON ON ON   On-board 
debugger   OFF OFF 

 

don’t care       OFF OFF 

 

Figure 59. SW1 and SW2 settings 

 

SW1 

SW2 
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1. To launch the NEC Electronics Project Manager (PM Plus), click Start → Programs → 
NECTools32 → PM Plus. 

Figure 60. Project Manager 

 

2. Click File → Open Workspace to locate the sample project. Open the 78K0_LCD_DEMO.prw 
file, the workspace file that contains general information about the demonstration projects and 
settings. 

Figure 61. Project Workspace 

 

3. At this point, you can edit, build, and link the sample code provided. For information about how to 
use the NEC Electronics software tools, refer to the associated documents for each. 
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4. To debug the code, make sure that the board is configured for on-chip debugging. From the Start 
menu, click Programs → NEC Tools32 → Portconfig for ID78K0-TK and then configure the 
port for the serial communication. 

Figure 62.  Portconfig for ID78K0-TK 

 

5. Click Tools → Debugger Settings. Select the ID78K0-TK debugger and click OK. 

Figure 63. Debugger Settings 
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6. Click Build → Rebuild and Debug to invoke the ID78K0-TK. 

7. Click Yes in response to the prompt. 

Figure 64. Prompt for Load Module File 

 

8. After a successful download, standard commands for single-stepping, starting, stopping, setting 
breakpoints, and manipulating registers and memory are available. 

Figure 65. ID78K0-TK debugger 

 

For more information about the debugger’s configuration and capabilities, refer to the user’s manual 
for the ID78K0-TK debugger. 
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11. Sample Projects 

Each of the sample programs is located in a single directory, called the main directory in each sample. 
This main directory contains the complete project, inclusive of all output files of the development tool. The 
78K0_LCD_DEMO.prw workspace file is located on top of the sample program directories. All sample 
programs use the same directory structure. 

Table 23. Example directory structure 

 DemoKitLF3 78K0/LF3 project and output files 

  inc  C header files 

  source  C source files 

 78K0_LCD_DEMO.prw workspace file 

The main directory contains most project files for the PM Plus. All source files are located in the directory 
/source and the /inc directory contains the header files.  

11.1 Buzzer sample 

This demonstration program drives the buzzer using the 16-bit 00 timer/event counter. The timer is 
configured to generate a rectangle waveform. By changing the timer’s output frequency, you can have the 
buzzer generate different tones. As demonstration, the buzzer plays a simple melody. 

11.2 Kitchen Timer sample 

Kitchen timer functionality is realized using the real-time counter and interrupt interval function. The 
setting of the kitchen timer’s count value and the cancellation of a started count process can be done 
using the navigation switch. When the timer’s count time elapses, the LCD displays the alarm symbol and 
the buzzer sounds an alarm. 

11.3 Real-Time Clock sample 

This sample project realizes a real-time clock. The program initializes the real-time counter to generate 
an exact clock reference based on the 32.768 kHz subclock and displays the actual time on the LCD. You 
can then use the navigation switch to adjust the time or switch between AM and PM in 24-hour mode. 

11.4 Remote Control sample 

The remote control sample uses the DemoKit’s IR receiver module. For this program, connect the 
receiver’s IR output terminal to the microcontroller’s P41/KR1/RIN remote control input pin. The program 
can then be executed to receive NEC Electronics-formatted custom code and data transmitted by an 
external remote controller. The LCD will display the received data 16-bit wise. 
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11.5 Temperature sample 

The temperature measurement program uses the onboard temperature sensor IC and both of the 
microcontroller’s A/D converters. You may select from two display formats, degrees centigrade (°C) and 
degrees Fahrenheit (°F), using the navigation switch. Additionally you may select from two different A/D 
converter resolutions using the microcontroller’s 10-bit successive-approximation-type A/D converter or 
16-bit delta-sigma type A/D converter. 

11.6 Voltmeter sample 

This program measures either the DemoKit-LF3 board’s power supply voltage or an external voltage 
supplied to the J2 connector. Before applying an external voltage to the J2 connector, carefully read the 
user’s manual for your device to find the electrical specifications for the A/D converter’s input port. 

The P25/ANI5/DS2+ input port is used to measure the power supply voltage. For external voltage 
measurement, the input port P23/ANI3/DS1+ is reserved. You can select the different measurement 
sources using the navigation switch. You can also select from two different A/D converter resolutions 
using the microcontroller’s 10-bit successive-approximation-type A/D converter or 16-bit delta-sigma A/D 
converter. 
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12. USB Interface Cable (mini-B type) 
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13. Schematics 
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DemoKit-LF3 schematics (2/2) 
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