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C8051F411 EVALUATION KIT USER ’S GUIDE

1.  Kit Contents
The C8051F411 Evaluation Kit contains the following items:

C8051F411 Evaluation Board
Silicon Laboratories Evaluation Kit IDE and Product Information
CD-ROM. CD contents include:
 Silicon Laboratories Integrated Development Environment (IDE)
 Source code examples and register definition files
 Documentation
 C8051F411 demo object code

6’ USB Cable
2 AAA Batteries
C8051F411 Evaluation Kit Quick Start Guide

2.  Kit Overview
The C8051F411 Evaluation Kit demonstrates some of the unique features of the C8051F41x family:

High-performance 8051 Core – Up to 50 MIPS with a 50 MHz system clock derived from the internal oscillator 
and clock multiplier.
Low-voltage Operation – Can operate on a core supply voltage as low as 2.0 V.
Versatile Interfacing – Includes an internal voltage regulator that can supply up to 50 mA at 2.5 V or 2.1 V 
output.
Real Time Clock – Can accurately maintain time for up to 137 years as long as the RTC peripheral is powered 
by at least 1.0 V, even if the MCU core supply voltage is lost.

The C8051F411 Evaluation Board includes a USB interface that allows debugging with the Silicon Laboratories
IDE. Power for the C8051F411 board can be supplied from the batteries or the USB connection. Refer to “3.
Evaluation Board Interface” for more details.

3.  Evaluation Board Interface
The user interface of the C8051F411 Evaluation Board includes an LCD and four push-buttons. There is also a
USB port for debugging and downloading to the C8051F411 target device.

3.1.  LCD User Interface
The C8051F411 Evaluation Board user interface consists of an LCD screen, four buttons, and a switch. The LCD
screen displays menu choices and information to the user. The four push buttons, MENU, SELECT, UP, and
DOWN, are used to navigate the menus and make selections. The switch determines the power source for the
C8051F411 and can be used to switch between the batteries (the left position) and the USB bus (the right position).
The C8051F411 Block Diagram shown in Figure 1 shows all elements of the user interface.
When the board is powered but idle, the LCD screen will display the time in the upper left corner and cycle through
different sets of information, depending upon the operating mode of the board. Refer to “4. Evaluation Modes” for
more details on the operating modes.
The MENU button brings up the menu on the LCD display. When navigating through the menu options, pressing
this button will revert back to the beginning of the menu, and none of the changes will be saved. The menu
interface is described in “4. Evaluation Modes”.
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Figure 1. C8051F411 Evaluation Board Block Diagram
The SELECT, UP, and DOWN buttons are used to navigate through the menus and choose the desired options.
These buttons also have special functionality depending upon the current mode.

3.2.  Reset Button and LEDs
The remaining push button is connected to the RESET pin of the C8051F411. Pressing this button puts the device
into its hardware-reset state.
Two LEDs are also provided on the evaluation board:

D2–The bi-color LED indicates communications between the PC and the DEBUG USB port.
D3–The red LED labeled “DEMO PWR” indicates a power connection to the evaluation board.

3.3.  DEMO/DEBUG Interface (J1)
The evaluation board DEMO/DEBUG USB port (J1) provides the interface between a PC USB port and the
C8051F411’s in-system debug/programming circuitry.

4.  Evaluation Modes
The C8051F411 Evaluation Board has two modes: Keepsake mode and Demo mode. In Keepsake mode, the
‘F411 uses the 32.768 kHz RTC crystal as the system clock. Demo mode allows the user to vary the internal
oscillator and internal voltage regulator configuration. The board is in Keepsake mode upon powerup.

4.1.  Keepsake Mode
Upon powerup, the evaluation board is in Keepsake mode (see Figure 2). Keepsake mode can be used when the
board is powered from the batteries or the USB bus. In Keepsake mode, the device displays the following
information:

Time (in the upper-right hand corner of the LCD)
Date (in the lower section of the LCD)
Temperature (in the lower section of the LCD)

The time is persistent in the upper right-hand corner. The date (month and day) and temperature will be alternately
displayed in the lower section of the LCD. By default, the temperature is displayed in Celsius.
Notes:

1. Pressing the UP button while in Keepsake mode will force the LCD to display only the temperature and not 
the date. Pressing UP again will cause the LCD to switch between the date and temperature as normal.

2. Pressing the DOWN button while in Keepsake mode will switch the display between a 12-hour clock and 24-
hour clock.
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Figure 2. Keepsake Mode Display Options
The time, date, and temperature can be set and calibrated while in Keepsake mode. To do so, press the MENU
button, and use the UP and DOWN buttons to cycle through the options. Pressing the MENU button at any time will
bring the display back to the default Keepsake display. The menu options in Keepsake mode are as follows:

DEMO
TIME
DATE
TEMP
FAH-CEL
12/24 HR

Press the SELECT button to choose one of the menu options. The menu options are summarized in Figure 3.

KEEPSAKE Mode

Temperature / Date

Time 
(24 hr)

DOWN

Temperature / Date

Time 
(12 hr)

DOWN

Temperature / Date

Time UP

Temperature

Time UP
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Figure 3. Keepsake Mode Menu Options
4.1.1. DEMO
Selecting DEMO will put the device in Demo mode, which is described in “4.2. Demo Mode”.
4.1.2. TIME
Selecting this option allows the user to configure the time. The lower section of the display will appear as:
H 00

Press the UP and DOWN buttons to set the hour. The hour is a 24-hour value; so, an hour of 20 is equivalent to
10:00 PM. After setting the hour, press SELECT to set the minutes. This will appear as:
M 00

As before, press the UP and DOWN buttons to change the minutes. Pressing SELECT will set the time in the upper
right-hand corner to the time that was entered. Pressing MENU will cancel the operation and go back to Keepsake
mode.
4.1.3. DATE
Selecting this option allows the user to configure the date. The lower section of the display will appear as:
Y 2000
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Press the UP and DOWN buttons to set the year. The valid range is 2000 to 2136. After setting the year, press
SELECT to set the month. This will appear as:
M 00

Press the UP and DOWN buttons to change the month. After setting the year, press SELECT to set the day. This
will appear as:
D 00

Pressing SELECT will set the date, and the device will go back to Keepsake mode. Pressing MENU will cancel the
operation and go back to Keepsake mode.
4.1.4. TEMP
In this menu option, the temperature offset can be calibrated. The temperature calibration is done in Celsius. In this
option, the lower part of the LCD screen will appear as:
25 deg C

Use the UP and DOWN buttons to change this value to the current room temperature for calibration. Press
SELECT to calibrate the device, or press MENU to cancel temperature calibration.
4.1.5. FAH-CEL
In this menu option, the LCD can be changed to display the temperature in Celsius or Fahrenheit. Use the UP and
DOWN keys to move between CELSIUS and FAHREN. Press SELECT to change the display, or press MENU to
go back to Keepsake mode.
4.1.6. 12/24 HR
In this menu option, the LCD can be changed to display the time in 12 or 24 hour format. Use the UP and DOWN
keys to move between 12 HOUR and 24 HOUR. Press SELECT to change the display, or press MENU to go back
to Keepsake mode.

4.2.  Demo Mode
To put the device in Demo mode, use the Keepsake menu options as described in “4.1.1. DEMO”. Demo mode
should only be used when the board is powered from the USB bus (the red switch is in the right position). In Demo
mode, the user can configure the system clock speed and the core voltage. The default settings for demo mode
are 3 MHz and a core voltage of 2.5 V.
In Demo mode, the LCD displays:

Time (in the upper right hand corner of the LCD)
Core Voltage (in the lower section of the LCD)
System Clock Speed (in the lower section of the LCD)
Temperature (in the lower section of the LCD)

The time is persistent in the upper right-hand corner. The core voltage, system clock speed, and temperature will
be alternately displayed in the lower section of the LCD.
The system clock speed and core voltage can be configured from the Demo mode menu. Press the MENU button
to bring up the menu. Use the UP and DOWN buttons to cycle through the options. Pressing the MENU button at
any time will bring the display back to the default Demo mode from Menu mode. The menu options in Demo mode
are as follows:

SET MHZ
SETVREG
KEEP

Press the SELECT button to choose one of the menu options. The options are summarized in Figure 4.
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Figure 4. Demo Mode Menu Options
4.2.1. SET MHZ
In this menu option, the system clock speed can be set to one of a few different settings. When selected, the
following will appear in the lower section of the LCD:
3 MHZ

Use the UP and DOWN keys to cycle through the various system clock options. The available system clock
settings are 3, 6, 12, 24, and 50 MHz.
Press SELECT to change the SYSCLK and go back to the Demo mode display. Press MENU to go back to the
Demo mode display without changing the system clock.
4.2.2. SET VREG
In this menu option, the output voltage of the regulator can be set. When selected, the following will appear in the
lower section of the LCD:
2.5 VREG

Use the UP and DOWN keys to cycle between 2.1 and 2.5 V. Press SELECT to change the core voltage and go
back to the Demo mode display. Press MENU to go back to the Demo mode display without changing the core
voltage.
4.2.3. KEEP
Select KEEP to go back to Keepsake mode.
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5.  Software Setup
The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools, and additional documentation. Insert the CD-ROM into your PC’s CD-ROM drive. An installer will
automatically launch, allowing you to install the IDE software or read documentation by clicking buttons on the
installation panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found
in the root directory of the CD-ROM. Refer to the readme.txt file on the CD-ROM for the latest information
regarding known IDE problems and restrictions.

6.  Silicon Laboratories Integrated Development Environment (IDE)
The Silicon Laboratories IDE integrates a source code editor, source-level debugger, and in-system Flash
programmer. The IDE uses the Keil 8051 Tools by default. An evaluation version of the Keil tools with a 2 k code
size limit is included with this kit. The use of third-party compilers and assemblers is also supported.

6.1.  System Requirements
The Silicon Laboratories IDE requirements are as follows:

Pentium-class host PC running Microsoft Windows 2000 or later
One available USB port.

6.2.  Using the Keil Software 8051 Tools with the Silicon Laboratories IDE
To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. You may build the OMF-51
absolute object file by calling the Keil 8051 tools at the command line (e.g., batch file or make file) or by using the
project manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project
manager enables object extension and debug record generation. Refer to “AN104: Integrating Keil 8051 Tools into
the Silicon Labs IDE” in the “SiLabs\MCU\Documentation\Appnotes” directory for additional information on using the
Keil 8051 tools with the Silicon Laboratories IDE.
To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project.
A project consists of a set of files, IDE configuration, debug views, and a target build configuration (a list of files and
tool configurations used as input to the assembler, compiler, and linker when building an output object file).
The following sections illustrate the steps necessary to manually create a project with one or more source files,
build a program, and download the program to the target in preparation for debugging. (The IDE will automatically
create a single-file project using the currently open and active source file if you select Build/Make Project before a
project is defined.)
6.2.1. Creating a New Project
Perform the following steps:
1. Select Project->New Project to open a new project and reset all configuration settings to default.
2. Select File->New File to open an editor window. Create your source file(s), and save the file(s) with a 

recognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.
3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file browser, 

and click Open. Continue adding files until all project files have been added.
4. For each of the files in the Project Window that you want assembled, compiled, and linked into the target build, 

right-click on the file name, and select Add file to build. Each file will be assembled or compiled as appropriate 
(based on its file extension) and linked into the build of the absolute object file.

Note: If a project contains a large number of files, the “Group” feature of the IDE can be used to organize them.
Right-click on “New Project” in the Project Window. Select Add Groups to project. Add predefined groups, or
add customized groups. Right-click on the group name, and choose Add file to group. Select the files to be
added. Continue adding files until all project files have been added.
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6.2.2. Building and Downloading the Program for Debugging
1. Once all source files have been added to the target build, build the project by clicking on the Build/MakeProject 

button in the toolbar or selecting Project->Build/Make Project from the menu.Note: After the project has been 
built the first time, the Build/Make Project command will only build the files that have been changed since the 
previous build. To rebuild all files and project dependencies, click on the Rebuild All button in the toolbar or 
select Project->Rebuild All from the menu.

2. Before connecting to the target device, several connection options may need to be set. Open theConnection 
Options window by selecting Options->Connection Options... in the IDE menu. First, selectthe adapter that was 
included with the kit in the “Serial Adapter” section. Next, the correct “Debug Interface”must be selected. 
C8051F41x family devices use the Silicon Labs 2-wire (C2) debug interface. Once all theselections are made, 
click the OK button to close the window.

3. Click the Connect button in the toolbar or select Debug->Connect from the menu to connect to the device.
4. Download the project to the target by clicking the Download Code button in the toolbar.Note: To enable 

automatic downloading if the program build is successful select Enable automatic con-nect/download after build 
in the Project->Target Build Configuration dialog. If errors occur during the build process, the IDE will not 
attempt the download.

5. Save the project when finished with the debug session to preserve the current target build configuration,editor 
settings and the location of all open debug views. To save the project, select Project->Save ProjectAs... from 
the menu. Create a new name for the project and click on Save.

6.2.3. Downloading the C8051F411 Evaluation Board Demonstration Firmware
To download the demonstration code to the C8051F411 evaluation board, follow steps 2 and 3 in “6.2.2. Building
and Downloading the Program for Debugging”. The demonstration code can be found in
C:Silabs\MCU\Demos\C8051F411EK\F411EK_DEMO.hex by default.
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7.  Schematics
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Contact Information
Silicon Laboratories Inc.
4635 Boston Lane
Austin, TX 78735
Tel: 1+(512) 416-8500
Fax: 1+(512) 416-9669
Toll Free: 1+(877) 444-3032
Email: MCUinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 
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