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We want your feedback!

SofTec Microsystems is always on the look-out for new ways to improve its Products and
Services. For this reason feedback, comments, suggestions or criticisms, however small,
are always welcome.

Our policy at SofTec Microsystems is to comply with all applicable worldwide safety and
EMC/EMI regulations. Our products are certified to comply to the European New
Approach Directives and the CE mark is applied on all our products.

This product as shipped from the factory has been verified to meet with requirements
FCC as a CLASS A product.

This product is designed and intended for use as a development platform for hardware or
C software in an educational or professional laboratory.

In a domestic environment, this product may cause radio interference in which case the

user may be required to take adequate prevention measures.

Attaching additional wiring to this product or modifying the product operation from the
factory default as shipped may effect its performance and cause interference with other
apparatus in the immediate vicinity. If such interference is detected, suitable mitigating
measures should be taken.

SofTec Microsystems

E-mail (general information): info@softecmicro.com
E-mail (technical support): support@softecmicro.com
Web: http://www.softecmicro.com

Important

SofTec Microsystems reserves the right to make improvements to this product, its documentation and software routines,
without notice. Information in this manual is intended to be accurate and reliable. However, SofTec Microsystems assumes no
responsibility for its use; nor for any infringements of rights of third parties which may result from its use.

SOFTEC MICROSYSTEMS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE
OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY
THEREOF.

Trademarks

SofTec Microsystems™ and the SofTec Microsystems logo are trademarks of SofTec Microsystems S.p.A.
Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc.

Microsoft and Windows are trademarks or registered trademarks of Microsoft Corporation.

PC is a registered trademark of International Business Machines Corporation.

Other products and company names listed are trademarks or trade names of their respective companies.
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1 Introduction

1.1 Overview

The EVBQE128 Evaluation Board has been designed for the evaluation, demonstration and
debugging of the Freescale Flexis QE128 Microcontrollers (MC9S08QE128 and
MCF51QE128).

The EVBQE128 can be used as a standalone application or can be controlled by a host PC
via its built-in microDART™ interface.

1.2 Package Contents

The EVBQE128 package includes the following items:

= The EVBQE128 evaluation board;

. 80-pin LQFP MC9S08QE128 and MCF51QE128 microcontrollers;

" A USB cable;

= A pick-up vacuum pump;

" A universal, 12 V DC power supply;

" System software DVD-ROM, including CodeWarrior™ Development Studio;
. A Quick Start Guide sheet.

1.3 Supported Devices

The EVBQE128 Evaluation Board supports the following devices:

MC9S08QE128;
MCF51QE128;
And any other pin-to-pin compatible devices.

1.4 Recommended Reading

" Freescale microcontroller-specific datasheets and application notes;
EVBQE128 Schematic.
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2 Hardware Features

2.1 Evaluation Board Features

The EVBQE128 board features:
1. An “MCU” section containing:

=  An 80-pin LQFP socket accepting either the MC9S08QE128 or the MCF51QE128
microcontroller;

= A crystal oscillator, a provision for a clock module, a provision for a connector for
providing an external clock source, together with jumpers to select the clock
source;

" A BDM connector for in-circuit debugging/programming with an external
instrument;

" A female header connectors with all of the MCU signals.
2. A power supply section containing:

. A 12V DC barrel input connector (2.1 mm);

" A four-way micro terminal block for providing specific power supplies and voltage
references to the microcontroller;

" A jumper to select the power supply source (USB bus or barrel connector);

" A power on/off switch.

3. A built-in “microDART INTERFACE” section (with the main circuitry mounted on the
back of the board) which allows the host PC to communicate with the microcontroller
through a standard USB interface. Jumpers are present to configure this module.
Thanks to the microDART in-circuit debugging firmware, BDM commands are sent to
the target microcontroller through the USB bus. Additionally, a virtual COM port is
automatically available over the same USB connection. This virtual COM port can be
used by standard terminal programs, like HyperTerminal, to send/receive serial
characters to/from the target microcontroller.

4. An “I/O” section containing:

= A Reset push-button;

] Four additional push-button;
= One potentiometer;

. Eight dip-switches;
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] A piezoelectric buzzer;

] A light sensor;

] A temperature sensor;

] Ten user LEDs;

" A circuitry for driving and external LCD;

" A series of jumpers to connect/disconnect the above controls to/from the

microcontroller.

5. An “RS-232” section containing two RS-232 connectors together with a jumper to enable
the RS-232 communication.

6. A “SERIAL SETTINGS” section containing jumpers to select communication options.
7. A prototype area.
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The EVBQE128 Evaluation Board

2.2 microDART Interface

Thanks to the microDART in-circuit debugging firmware, CodeWarrior can send BDM
commands to the target microcontroller through the USB bus.
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Additionally, when you plug the USB cable into the PC, a “virtual” COM port is automatically
created and, through this port, serial data can be transferred to/from the target microcontroller.
In other words, a terminal application such as HyperTerminal is able to use the virtual COM
port as if it were a normal COM port and send and receive characters normally.

This serial communication and BDM communication work simultaneously: CodeWarrior can be
used to work with the target microcontroller while HyperTerminal sends and receives
characters.

2.2.1 Hot Plug-In

The “Hot Plug-In” feature gives you the possibility to connect to a target microcontroller that is
running an application and to trace and debug the current running code without the need of a
complete erase and re-program of the flash memory.
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3 Software Setup

3.1 Overview

Before connecting the Evaluation Board to the PC, it is recommended that you install
CodeWarrior first, so that the appropriate USB driver will be automatically found by Windows
when you connect the Evaluation Board.

3.2 Host System Requirements

The Evaluation Board is controlled by CodeWarrior Development Studio. The following
hardware and software are required to run the CodeWarrior user interface together with the
Evaluation Board:

" A 200-MHz (or higher) PC compatible system running Windows 2000 or Windows XP;
. 128 MB of available system RAM plus 1 GB of available hard disk space;

. A USB port;

" DVD-ROM drive for installation.

3.3 Installing CodeWarrior Development Studio

To install the CodeWarrior Development Studio, insert the CodeWarrior DVD-ROM into your
computer's DVD-ROM drive. A startup window will automatically appear. Follow the on-screen
instructions.
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4 Hardware Setup

4.1 First Connection

The Evaluation Board is connected to a host PC through a USB port. Connection steps are
listed below in the recommended flow order:

1. Install all the required system software as described in the previous section.

2. Power the board through either the barrel connector or the USB connector, making sure
that the “POWER SEL” jumper selects the correct power source.

3. Make sure the “ON-OFF” switch is in the “ON” position. The “POWER” LED will turn on.

4. Insert one end of the USB cable into a free USB port of the PC.

5. Insert the other end of the USB cable into the USB connector on the Evaluation Board.

6. The first time the Evaluation Board is connected to the PC, Windows recognizes the

instrument and starts two separate “Found New Hardware Wizard” procedures: one
for the main USB driver and one for the USB virtual COM port driver.

7. The first “Found New Hardware Wizard” procedure asks you to specify the USB driver
to use for the instrument. On Windows XP (SP2) the following dialog box will appear.

Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard
windows will zearch for curent and updated software by

looking on your computer, on the hardware installation CO, or on
the Windows Update ‘Web site [with your permission).

CanWindows connect to Windows Update to search for
software?

() Yes, this time only

(O res, now and every time | connect a device

() No, nat this time

Click Mest to continue.

Mext » ] [ Cancel

Select the “No, not this time” option and click the “Next >” button.
8. The following dialog box will appear.
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Found Mew Hardware Wizard

.I Thiz wizard helpz you install saftware for:

EVBOET22

f\:‘) If your hardware came with an installation CD
4 or floppy disk, insert it now.

What do you want the wizard to da?

() Inztall the software automatically [Fecommended)
() Intall fram a list or specific lacation [Advanced]

Click Mexst to continue.

< Back " Mext > ][ Cancel

Click the “Next > button.

9. Windows will install the driver files to your system. At the end of the installation, the
following dialog box will appear.

Found Mew Hardware Wizard

Completing the Found New
% Hardware Wizard
~§

The wizard haz finished instaling the software far:

EVBOE122
=

Click Finish to close the wizard.

Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure.
10. The Evaluation Board’s main USB driver is now installed on your system.

11. The second “Found New Hardware Wizard” procedure asks you to specify the USB
virtual COM driver to use. On Windows XP (SP2) the following dialog box will appear.
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Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard
Wwindows will search for curent and updated software by

looking on your computer, on the hardware installation CO, or on
the Windows Update Web gite [with your permission).

Can Windows connect ta Windows Update to search for
software?

() Wez, this time only
() ez, now and every time | connect a device
(%) Ma, nat this time

Click Next to continue.

Mlext > ][ Cancel

Select the “No, not this time” option and click the “Next >” button.
12. The following dialog box will appear.

Found Mew Hardware Wizard

Thiz wizard helpz you install software for:

Wirtual USE COM Port

I;j') If your hardware came with an installation CD
~1= or floppy disk. insert it now.

‘what do you want the wizard to da?

(%) Inztall the software automatically [Fecommended)
() Install from a list or specific location [advanced)

Click Mexst to continue.

< Back " Mt > ][ Cancel

Click the “Next >” button.
13. Depending on your Windows settings, the following warning may appear.
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Hardware Installation

1 E The software you are ingtalling for thiz hardware:
-
Yirkual USE COM Part

has not paszed Windows Loga testing to verify its compatibility

with Windows =P, [Tel me why this testing iz important ]

Continuing your installation of this software may impair
or deztabilize the correct operation of your spstem
either immediately or in the future. Microsoft strongly
recommends that you stop this installation now and
contact the hardware vendor for software that has
pazzed Windows Logo testing.

Continue drymway ] [ STOR Installation

Note: this warning is related to the fact that the USB driver used by
the Evaluation Board is not digitally signed by Microsoft, and
Windows considers it to be potentially malfunctioning or dangerous
for the system. However, you can safely ignore the warning, since
every kind of compatibility/security test has been carried out by
SofTec Microsystems.

Click the “Continue Anyway” button.

14.  Windows will install the driver files to your system. At the end of the installation, the
following dialog box will appear.

Found Mew Hardware Wizard

Completing the Found New
% Hardware Wizard
~§

The wizard has finizhed instaling the zoftware for:

(g Wirtual USE COM Port

Click Firizh to close the wizard.

Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure.
15. The Evaluation Board’s USB virtual COM driver is now installed on your system.
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5 Operating Modes

5.1 Overview

The Evaluation Board can work in two modes: “standalone” mode and “host” mode.

5.2 Standalone Mode

In standalone mode, no PC connection is required. Both microcontrollers are factory
programmed with the same sample application.

To run the built-in example:

Power off the board.

Put either the MC9S08QE128 or MCF51QE128 microcontroller in the socket.
Ensure that all of the jumpers in the “I/O” sections are inserted.

Power on the board.

Press the "PTD4" push-button. The value of the ADPO/PTAO potentiometer will be
displayed on the PTE[7..0] LEDs.

6. Press the "PTD5" push-button. The value of the light sensor will be displayed on the
PTE[7..0] LEDs.

7. Press the "PTD6" push-button. The ADPO/PTAOQ potentiometer will vary the frequency of
the sound played by the buzzer.

o bk wh =

8. Press the "PTD7" push-button. The value of the temperature sensor will be displayed on
the PTE[7..0] LEDs.

The output of the potentiometer, light sensor and temperature sensor is also sent to the host
PC (if connected) through the virtual COM port over the USB connection. To see the data sent
to the virtual COM port, do the following:

1. Ensure that the J206 jumpers (“COM1 ENA”) select the “MDI” position;
2. Connect the board to the PC through the USB connection;
3. Start your terminal utility (e.g. HyperTerminal) with these parameters:

Baud rate: 9600
Data bits: 8

Parity: None

Stop bits: 1

Flow control: None
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5.3 Host Mode

In host mode the program execution is controlled by the host PC through the “USB” connector.
You can use the PC to debug the application by, for example, executing the program step by
step and watching how the microcontroller registers vary, using the provided CodeWarrior
Development Studio.

Note: the MC9S08QE 128 and MCF51QE128 devices contain a single-
wire background debug interface which supports in-circuit programming of
on-chip non-volatile memory. This system does not interfere with normal
application resources. It does not use any user memory or locations in the
memory map. The Background Debug Module (also known as
Background Debug Controller, BDC) uses a single-wire communication
interface (via the BKGD line) to allow non-intrusive access to target
system memory and registers.

To work in host mode (using the built-in microDART interface):

" Make sure that the board is powered on;

" Make sure that the “RESET” and “BKGD” jumpers in the “microDART INTERFACE”
section are inserted;

" Connect the host PC to the board through the provided USB cable.
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6 Application Tutorial

6.1 Overview

MC9S08QE128 and MCF51QE128 devices share the same peripherals and registers.
Software written for one device can be easily recompiled for the other.

This section will provide a step-by-step guide on how to launch a MC9S08QE128-based
project and get started with the CodeWarrior user interface. Later, the same project will be
converted for the MCF51QE128 device.

6.2 MC9S08QE128 Step-by-Step Tutorial

The sample application is the same as the one described in the “Standalone Mode” section
above.

1. Make sure that the MC9S08QE 128 device is present in the socket.
2. Set up the board so that it works in host mode (see “Host Mode” above).

3. Ensure that the Evaluation Board is connected to the PC (via the USB cable) and that
the board is powered on.

4, Start CodeWarrior by selecting it in the Windows Start menu.

5. From the CodeWarrior main menu, choose “File > Open” and choose the “\Program
Files\Freescale\[CodeWarrior Folder]\(CodeWarrior Examples)\HCS08\Evaluation
Board Examples\EVBQE128\C\Demo\Demo.mcp”.

6. Click “Open”. The Project window will open.
7. The code of this example is contained in the “main.c” file. Double click on it to open.

8. From the main menu, choose “Project > Debug”. This will compile the source code,
generate an executable file and download it to the evaluation board.

9. A new debugger environment will open. From the main menu, choose “Run >
Start/Continue”. The program will be executed in real-time.

10. From the main menu, choose “Run > Halt”. The program execution will stop. The next
instruction to be executed is highlighted in the Source window.

11.  From the main menu, choose “Run > Single Step”. The instruction highlighted in the
Source window will be executed, and the program execution will be stopped immediately
after.

12.  From the main menu, choose “Run > Start/Continue”. The application will restart from
where it was previously stopped.

Congratulations! You have successfully completed this tutorial! You can continue to
experiment with the CodeWarrior user interface and discover by yourself its potentialities. For
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an in-depth guide of all of the user interface features, select “Help > CodeWarrior Help” from
CodeWarrior Development Studio’s main menu.

6.3 Converting the Example for the MCF51QE128

The same example illustrated above can be easily converted to work with the MCF51QE128

device.

1. Open the project you want to convert. In this case, from the CodeWarrior main menu,
choose “File > Open” and choose the “\Program Files\Freescale\[CodeWarrior
Folder]\(CodeWarrior Examples)\HCS08\Evaluation Board
Examples\EVBQE128\C\Demo\Demo.mcp”.

In the project pane, click the “Change MCU/Connection” button (see below).

E i

[ Fle Edt Wew Search Projsct Processor Expert Devies Inbialzation Window Help

BEx]

I = a EBShsEE®R
A b ()« M- [ - 07 Path [CAProgram Fies\Freosoale\Codewarion fr Micacontalers VE.0 Bela\{Codet atior_EaneleshHCSOB\Evakialion Board ExamplesE. main s <
[ D soimecHEs08 MIT=R Gl / Sanple for Fresscals EVBOE128 (MCISOBOE128) =
v
Fies | Link Drder | Terget ot 7 This progran doss the following
3 File Bd- | Data (@ || /1. Press the "PTD4" push-button. The value of the ADPO/PTD4 potentiometer will be
PEETE 0 U~ sz ©; displayed on the PTE[?..0] LiDs
M E E . ﬂ 7/ 2. Press the "PTDS* push-button. The value of the light sensor will be ||
»7 " displayed on the PTE[7..0] LEDs
%3 Incudes 0 0 o
¥ [ 0 U /7 3. Press the "PTD6" push-button. The APDO/PTD4 potentiomster will vary the
w #0 Project Settings 0 0« 77 frequency of the sound played by the buzzer
v
/7 4. Press the "PTD?* push-button. The temperature will be displayed on the PTE[7..0]
s 1EDs. Hote: to correctly read the temperaturs, the J302C jumper must be removed
v
7/ The output of the potentiometer. light sensor and temperature is also sent to the
#7 host FC (if comnected) through the virtual COM port over the USE comnection. To see
7/ the data semt to the virtual COM port, do the following
o
#7 - Comnect the board to the PC through the USB connection
<7~ Start your terninal utility (=.g. HyperTerminal) with these parameters
/7 BAUD rate —> 9600
#7  Data Bits —> 8
ss Barity > Home
/7 Stop bits - 1
v
<+ Before to run this esample. verify that all jumpers are in their default
/7 position. See the 'Summary of Jumper and Connector Ssttings® chapter in
7/ the user's manual
v
o
v
/ CodeVarrior V6.0 for HO(S)08 and HCFS1
/7 Registers Files version 3.00.000 (RegistersPrg V2.13)
v
v
o
7/ Copyright {(c) 2007 SofTec Microsystems
/7 bttpoZwwy . sof tecnicro. con/
o
DIIIIIIIIIIIIIIIIIIIEIILIIEIIOEPIIILIELPIIIIIELIIIIIILIIIIIILIIIIIILIIIIIIEIIIIIPIIIIS
#include <hidef by ¢ for EnableInterrupts macro x/
#include “derivative.h' /% include peripheral declarations */
#include "sci b
#define PUSH_PTD4 0
#define PUSH_PTDS 1
#detine PUSH_PTDE 2
#define PUSH_PTD? 3
#detine CR 0=0D
+7 BS=237 const and nessages
#detine NUM_ROVS
#define NUM_COLUMNS 30
unsigned char messageTX[NUM_ROWS][NUM_COLUMNS] =
{"n_xxxxmmxxxxxxxxxnxxnnx Yeloons to EVBQE128 Demo Program xxxssxxxxxecexxereerin’}
| {" The value of the Potentiomster is:"}
11 fes 0 0 =
2] e Col 1 | 'l

The following dialog box will appear.
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Device and Connection
Select the derivative pou would like to uze: Chooze your default connection:
+-HC503 Connections
+- R50G P&E Multilink/Cyelone Pro
+- CaldFire W1 i
—I- Flexis
—|- QE Family
MCISO3QEL2E
MZAS0S0EE
MCAS0SESE
MCFS10ELZE
MCFS10QEG Connect to any of the USB-bazed SofTec
MCFS10E96 ticrozyztens tools for ColdFire W1
[INDART-OME, ete...).
Iv Do create a backup zip file
| Finizh | Cancel ‘
3. In the tree on the left, choose the MCF51QE128 device and, on the connections list,

choose “SofTec ColdFire”. Click the “Finish” button. Project conversion is done and
the new project is ready to be compiled.

A similar procedure may be used to convert a MCF51QE128 project into a MC9S08QE128
project.

6.4 Additional Examples

Two additional examples are provided:

" DemoLCD. Shows how to drive the optional 16x2 LCD controller. A string is shifted from
right to left on the first LCD row. Any LCD based on the HD44780U (LCD-Il) controller is
correctly driven. Make sure to comment/uncomment the appropriate delay line in the
delay.c file depending on which device you are working with.

" MicroDartDemo. Shows how to communicate with the target microcontroller through
the microDART interface.
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7 Hot Plug-In

7.1 Overview

The “Hot Plug-In” feature gives you the possibility to connect to a target microcontroller that is
running an application and to trace and debug the current running code without the need of a
complete erase and re-program of the flash memory.

7.2 How to Enable Hot Plug-In

While the target application is running:

1.
2.
3.

4.

Launch CodeWarrior.
Open the target application project.
Start a debugging session (“Project > Debug”). The following dialog box will appear.

Target Connection

Hardware kodel

Code: |EvBOETZE ~|

Starter Kit for Freescale MCIS080ET28.

Device

Device code:
|MCas0eaE28 ~|

Communication Settings |

Connection Mode

" Mormmal [target will be reset]

* Hat plugin [nan intrusive, target will not be rezetf

Cancel

Make sure that the “Hot plug-in” connection mode is selected, then click the

“Connect” button.

The following dialog box will appear.
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Hot Plug-In

Warning

! E Loading a new application will stop the execution of the current one.
.

Click “Cancel”.
5. The following dialog box will appear.

Hot Plugging 5

9 | Dovyouwant boload
\-‘4-} application symbolic information?

Yes Mo |

Click “Yes”. You will enter the debugging environment.

6. Afterissuing an halt command (“Run > Halt”), the Program Counter and all of the other
registers are updated with the actual microcontroller values.
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8 Jumper and Connector Settings

8.1 Jumpers

Name Reference Description/Pinout

J103 1 2 PTB6/PTB7 MODE SELECTION
-
5@ @ |6 1-3, 2-4 (“ALT. FUNCTION”): PTB6 and PTB?7 lines are used
® @ s either as I°C lines (must be
'@ @10 enabled via software) or as
"o @ user I/Os (default)

5-7, 6-8 (“CRYSTAL”): PTB6 and PTB7 lines are
connected to the Y101 crystal
oscillator

9-11, 10-12 (“EXT OSC"): PTB6 and PTBY lines are

connected to the U102 external
oscillator (“EXT OSC1”)

J202 111 POWER SELECTION
2
3 m 1-2 (“USB”): Power supply is taken from the USB bus
2-3 (“12Vv”): Power supply is taken from the barrel
connector (default)
J204 1l @2 LCD ENABLE
[0
5@ @] Installed: Connects the SPI2 function of the
7@ @ microcontroller to the LCD driving
circuitry (default)
Not Installed: The SPI2 function of the microcontroller is
not connected to the LCD driving circuitry
J205 1 COM ENABLE
2
3 @ 1-2 (“ON=1"): Enables the RS-232 transceiver (ANDed
with PTGO) (default)
2-3 (“OFF"): RS-232 transceiver disabled
J206 1 MDI/COM1 SELECTION

ool
oo

6 1-3, 2-4 (“MDI”): TXD1 and RXD1 signals of the
microcontroller are routed to the
microDART interface (default)

3-5, 4-6 (“COM1”):  TXD1 and RXD1 signals of the
microcontroller are routed to the RS-232
transceiver
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Name Reference Description/Pinout
J207 1l @2 COM2 ENABLE
o e
Installed: TXD2 and RXD2 signals of the
microcontroller are routed to the RS-232
transceiver (default)
Not Installed: TXD2 and RXD2 signals of the
microcontroller are not routed to the RS-
232 transceiver
J301 1l @] LED ENABLE
x]
X Installed: The “PTEx” LEDs are connected to the
@ PTE[7..0] ports of the microcontroller
E (default)
@ Not Installed: The “PTEX” LEDs are not connected to the
E microcontroller
J302 1l @] USER1 ENABLE
[x]
® o Installed: Connects the indicated microcontroller
o e signals to the relative 1/O device (default)
® o Not Installed: The indicated microcontroller signal is not
@ o connected to any I/O device
J303 1l @2 lIC1 PULL-UP ENABLE
o0
Installed: Enables 10KOhm pull-up resistors on
SDA1 and SCL1 signals of the
microcontroller (default)
Not Installed: Disables 10KOhm pull-up resistors on
SDA1 and SCL1 signals of the
microcontroller
J304 1l @2 lIC2 PULL-UP ENABLE
o0
Installed: Enables 10KOhm pull-up resistors on
SDA2 and SCL2 signals of the
microcontroller (default)
Not Installed: Disables 10KOhm pull-up resistors on
SDA2 and SCL2 signals of the
microcontroller
J305 1l @] USER2 ENABLE
® o
o @ Installed: Connects the indicated microcontroller
@ o signal to the relative push-button
E (default)
Not Installed: The indicated microcontroller signal is not
connected to a push-button
Page 26
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Name

Reference

Description/Pinout

J402

LK)
3@4

USB TO BDM ENABLE

All installed:

Not Installed:

The microDART interface is enabled
(default)

The microDART interface is disabled
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8.2 Connectors

Name Reference Description/Pinout
J101 1 2 MCU pin replication
3 4
5 6
7 8
77 78
79 80
J102 1l @ |2 BDM Connector
3@ @ |4
5@ @6 1 BKGD
2 GND
3 N.C.
4. RESET
5 N.C.
6 3V
J201 12V DC Power Supply Input Connector (Barrel, 2.1 mm)
2 1
1. 12V DC
2. GND
J203 =1 MCU POWER Connector
-2
=3
4 1.  MCU_VDD
2. MCU_VSS
3. MCU_VDDA
4. MCU_VSSA
J208 1H @ |2 LCD Connector
3@ @ |4
5@ @6 1.  GND
70 @8 2. 5V
° @ @0 3. CONTRAST
1@ @ |12 4. RS
O @) 5. GND
6. EN
7. GND
8. GND
9. GND
10. GND
11. DB4
12. DB5
13. DB6
14. DB7
Page 28
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Name

Reference

Description/Pinout

J209

o—

©o—
J

[, PR

RS-232_1 Connector

Connected to pins 4, 6
TX

RX

Connected to pins 1, 6
GND

Connected to pins 1, 4
N.C.

N.C.

N.C.

© NGk~ wN=

J210

o —

©o—
P U

o

RS-232_2 Connector

Connected to pins 4, 6
TX

RX

Connected to pins 1, 6
GND

Connected to pins 1, 4
N.C.

N.C.

N.C.

© 0N OGN

J401

USB Connector

5V DC USB Bus Power Supply Line
USB D-

USB D+

GND

Pobd-~
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9 Troubleshooting

9.1 USB Driver Problems

If you connected the Evaluation Board to the PC before installing CodeWarrior, the Evaluation
Board’'s USB drivers may not have been correctly installed on your system. Unplugging and
replugging the USB cable is of no use, since Windows has marked the devices as “disabled”.
As a consequence, the PC cannot communicate with the Evaluation Board.

To restore/upgrade the USB drivers (provided CodeWarrior has been installed), perform the
following steps under Windows XP:

Connect the Evaluation Board to the PC.

Open the Control Panel (Start > Settings > Control Panel).

Open the “System” options.

Select the “Hardware” tab.

Click the “Device Manager” button.

Two “EVBQE128” devices will be shown with an exclamation mark next to it.

For each device, double click on it and, in the “General” tab, click the “Reinstall
Driver” button. Follow the on-screen instructions.

N gk owd-=

9.2 Communication Problems between the PC and the
Demo Board

1. Make sure that the “BKGD” and “RESET” jumpers in the “USB” section are inserted.
2. Make sure that the microcontroller is powered:

" Make sure that the “ON-OFF” switch in the “POWER SUPPLY” section selects the
“ON” position;

" Make sure that the “POWER SEL” jumper in the “POWER” section selects the
appropriate power supply source.

9.3 Problems with RS-232 Communication

The Jumper J205 allows the user to control the state of the RS-232 transceiver: when the
position 1-2 (“ON”, default position) is selected, the RS-232 transceiver is enabled (with the
aid of an external pull-up), but the user has the option to turn the transceiver off (on) by driving
the PTGO line of the microcontroller low (high).

When the position 2-3 (“OFF”) is selected, the RS-232 transceiver is powered off via
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hardware, without the need of any microcontroller action, in order to minimize the power
consumption of the board.

In order to communicate via the RS-232_2 COM port, you must remove the “ACMP2-ENA”
and “ADPO/ACMP1+ ENA” jumpers. These pins are shared with other 1/O functions that can
generate hardware conflicts with the RS-232 communication.
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