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C8051F326/7-DK

C8051F326/7 DEVELOPMENT KIT USER ’S GUIDE

1.  Kit Contents
The C8051F326/7 Development Kit contains the following items:

• C8051F326 Target Board
• C8051Fxxx Development Kit Quick-Start Guide
• Silicon Laboratories IDE and Product Information CD-ROM. CD content includes:

• Silicon Laboratories Integrated Development Environment (IDE)
• Keil 8051 Development Tools (macro assembler, linker, evaluation ‘C’ compiler)
• Source code examples and register definition files
• Documentation
• C8051F326/7 Development Kit User’s Guide (this document)

• USB Cable
• AC to DC Power Adapter
• USB Debug Adapter (USB to Debug Interface)
• USB Cable

2.  Hardware Setup using a USB Debug Adapter
The target board is connected to a PC running the Silicon Laboratories IDE via the USB Debug Adapter as shown
in Figure 1.

1. Connect the USB Debug Adapter to the DEBUG connector on the target board with the 10-pin ribbon cable.
2. Connect one end of the USB cable to the USB connector on the USB Debug Adapter. 
3. Connect the other end of the USB cable to a USB Port on the PC.
4. Connect the ac/dc power adapter to power jack P1 on the target board.

Notes:
• Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.
• Remove power from the target board and the USB Debug Adapter before connecting or disconnecting the 

ribbon cable from the target board. Connecting or disconnecting the cable when the devices have power can 
damage the device and/or the USB Debug Adapter.

 

Figure 1. Hardware Setup using a USB Debug Adapter
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3.  Software Setup
The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools and additional documentation. Insert the CD-ROM into your PC’s CD-ROM drive. An installer will auto-
matically launch, allowing you to install the IDE software or read documentation by clicking buttons on the Installa-
tion Panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found in the
root directory of the CD-ROM. Refer to the readme.txt file on the CD-ROM for the latest information regarding
known IDE problems and restrictions.

4.  Silicon Laboratories Integrated Development Environment
The Silicon Laboratories IDE integrates a source-code editor, source-level debugger and in-system Flash program-
mer. The use of third-party compilers and assemblers is also supported. This development kit includes the Keil
Software A51 macro assembler, BL51 linker and evaluation version C51 ‘C’ compiler. These tools can be used
from within the Silicon Laboratories IDE.

4.1.  System Requirements
The Silicon Laboratories IDE requirements:

• Pentium-class host PC running Microsoft Windows 98SE or later.
• One available COM port or USB port.
• 64 MB RAM and 40 MB free HD space recommended.

4.2.  Assembler and Linker
A full-version Keil A51 macro assembler and BL51 banking linker are included with the development kit and are
installed during IDE installation. The complete assembler and linker reference manual can be found under the Help
menu in the IDE or in the “SiLabs\MCU\hlp” directory (A51.pdf).

4.3.  Evaluation C51 ‘C’ Compiler
An evaluation version of the Keil C51 ‘C’ compiler is included with the development kit and is installed during IDE
installation. The evaluation version of the C51 compiler is the same as the full professional version except code
size is limited to 4 kB and the floating point library is not included. The C51 compiler reference manual can be
found under the Help menu in the IDE or in the “SiLabs\MCU\hlp” directory (C51.pdf).

4.4.  Using the Keil Software 8051 Tools with the Silicon Laboratories IDE
To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. You may build the OMF-51
absolute object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the
project manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project
manager enables object extension and debug record generation. Refer to Applications Note AN104 - Integrating
Keil 8051 Tools Into the Silicon Labs IDE in the “SiLabs\MCU\Documentation\Appnotes” directory on the CD-
ROM for additional information on using the Keil 8051 tools with the Silicon Laboratories IDE. 

To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project. A
project consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and tool
configurations used as input to the assembler, compiler, and linker when building an output object file).

The following sections illustrate the steps necessary to manually create a project with one or more source files, build
a program and download the program to the target in preparation for debugging. (The IDE will automatically create a
single-file project using the currently open and active source file if you select Build/Make Project before a project is
defined.) 
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4.4.1. Creating a New Project
1. Select Project→New Project to open a new project and reset all configuration settings to default.

2. Select File→New File to open an editor window. Create your source file(s) and save the file(s) with a rec-
ognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.

3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file
browser and click Open. Continue adding files until all project files have been added.

4. For each of the files in the Project Window that you want assembled, compiled and linked into the target
build, right-click on the file name and select Add file to build. Each file will be assembled or compiled as
appropriate (based on file extension) and linked into the build of the absolute object file.

Note: If a project contains a large number of files, the “Group” feature of the IDE can be used to organize. 
Right-click on “New Project” in the Project Window. Select Add Groups to project. Add pre-defined 
groups or add customized groups. Right-click on the group name and choose Add file to group. Select files 
to be added. Continue adding files until all project files have been added.

4.4.2. Building and Downloading the Program for Debugging
1. Once all source files have been added to the target build, build the project by clicking on the Build/Make

Project button in the toolbar or selecting Project→Build/Make Project from the menu.

Note: After the project has been built the first time, the Build/Make Project command will only build the 
files that have been changed since the previous build. To rebuild all files and project dependencies, click 
on the Rebuild All button in the toolbar or select Project→Rebuild All from the menu.

2. Before connecting to the target device, several connection options may need to be set. Open the
Connection Options window by selecting Options→Connection Options... in the IDE menu. First, select
the appropriate adapter in the “Serial Adapter” section. Next, the correct “Debug Interface” must be selected.
C8051F326/7 family devices use the Silicon Labs 2-wire (C2) debug interface. Once all the selections are
made, click the OK button to close the window. 

3. Click the Connect button in the toolbar or select Debug→Connect from the menu to connect to the device. 

4. Download the project to the target by clicking the Download Code button in the toolbar.

Note: To enable automatic downloading if the program build is successful select Enable automatic con-
nect/download after build in the Project→Target Build Configuration dialog. If errors occur during the 
build process, the IDE will not attempt the download.

5. Save the project when finished with the debug session to preserve the current target build configuration,
editor settings and the location of all open debug views. To save the project, select Project->Save Project
As... from the menu. Create a new name for the project and click on Save.
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5.  Example Source Code
Example source code and register definition files are provided in the “SiLabs\MCU\Examples\C8051F326_7\” direc-
tory during IDE installation. These files may be used as a template for code development. Example applications
include a blinking LED example which configures the green LED on the target board to blink at a fixed rate.

5.1.  Register Definition Files
Register definition files C8051F326.inc and C8051F326.h define all SFR registers and bit-addressable control/
status bits. They are installed into the “SiLabs\MCU\Examples\C8051F326_7\” directory during IDE installation.
The register and bit names are identical to those used in the C8051F326/7 datasheet. Both register definition files
are also installed in the default search path used by the Keil Software 8051 tools. Therefore, when using the Keil
8051 tools included with the development kit (A51, C51), it is not necessary to copy a register definition file to each
project’s file directory. 

5.2.  Blinking LED Example
The example source files blink.asm and blinky.c show examples of several basic C8051F326/7 functions. These
include: configuring a timer for an interrupt routine, initializing the system clock, and configuring a GPIO port. When
compiled/assembled and linked this program flashes the green LED on the C8051F326 target board about five
times a second using the interrupt handler with a C8051F326 timer. 
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6.  Target Board
The C8051F326/7 Development Kit includes a target board with a C8051F326 device pre-installed for evaluation
and preliminary software development. Numerous input/output (I/O) connections are provided to facilitate prototyp-
ing using the target board. Refer to Figure 2 for the locations of the various I/O connectors.

P1 Power connector (accepts input from 7 to 15 VDC unregulated power adapter)
J1 22-pin Expansion I/O connector
J2 Power Target Board from power adapter at P1
J3 Port I/O Configuration connector
J4 DEBUG connector for Debug Adapter interface
J5 DB-9 connector for UART0 RS232 interface
J7 VIO to VDD connector
J8 USB Debug Adapter target board power connector
J9 USB connector for USB interface
J10 External CMOS oscillator connector
J11 Power Target Board from USB at J9

Figure 2. C8051F326 Target Board
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6.1.  System Clock Sources
The C8051F326 device installed on the target board features a calibrated programmable internal oscillator which is
enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of 1.5 MHz
(±1.5%) by default but may be configured by software to operate at other frequencies. Therefore, in many applica-
tions an external oscillator is not required. However, if you wish to operate the C8051F326 device at a frequency not
available with the internal oscillator, an external CMOS oscillator may be used. Refer to the C8051F326/7 datasheet
for more information on configuring the system clock source.

The target board is designed to facilitate the installation of an external CMOS oscillator. Remove shorting block at
header J10 and connect the oscillator output to the header. Refer to the C8051F326/7 datasheet for more informa-
tion on the use of external oscillators.

6.2.  Switches and LEDs
Three switches are provided on the target board. Switch S1 is connected to the /RST pin of the C8051F326. Press-
ing S1 puts the device into its hardware-reset state. Switches S2 and S3 are connected to the C8051F326’s gen-
eral purpose I/O (GPIO) pins through headers. Pressing S2 or S3 generates a logic low signal on the port pin.
Remove the shorting blocks from the header to disconnect S2 and S3 from the port pins. The port pin signals are
also routed to pins on the J1 I/O connector. See Table 1 for the port pins and headers corresponding to each
switch.

Three LEDs are also provided on the target board. The red LED labeled PWR LED is used to indicate a power con-
nection to the target board. The green surface mount LEDs labeled with port pin names are connected to the
C8051F326’s GPIO pins through headers. Remove the shorting blocks from the header to disconnect the LEDs
from the port pin. The port pin signals are also routed to pins on the J1 I/O connector. See Table 1 for the port pins
and headers corresponding to each LED.

6.3.  Universal Serial Bus (USB) Interface (J9)
A Universal Serial Bus (USB) connector (J9) is provided to facilitate connections to the USB interface on the
C8051F326. Table 2 shows the J9 pin definitions.

Table 1. Target Board I/O Descriptions

Description I/O Header
S1 Reset none
S2 P2.0 J3[1–2]
S3 P2.1 J3[3–4]

Green LED (D4) P2.2 J3[5–6]
Green LED (D2) P2.3 J3[7–8]

Red LED PWR none

Table 2. J9 USB Connector Pin Descriptions

Pin # Description
1 VBUS
2 D–
3 D+
4 GND (Ground)
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6.4.  Expansion I/O Connector (J1)
The 22-pin Expansion I/O connector J1 provides access to all signal pins of the C8051F326 device. Pins for +3 V,
and digital ground are also available. A through-hole prototyping area is also provided. Each connection point is
labeled indicating the signal available at the connection point. See Table 3  for a list of pin descriptions for J1.

 

6.5.  USB Self-powered Configuration
The C8051F326 target board can be powered from three different sources. The sources are the ac/dc adapter
(P1), USB connection (J9), and the USB Debug adapter (J4). Only one power source should be enabled at any
time. See Section 6.8. for infomation on using the USB Debug Adapter as a power source for the board.

The C8051F326 target board can be configured as a self-powered USB device to take power from the USB cable
at J9 instead of the ac/dc adapter connected at P1. To configure the target boards as a self-powered USB device,
remove the shorting block from J2 and install on J11. (A shorting block should only be installed on J2 or J11, never
both at the same time.) Install shorting blocks in the following manner:

J2(ON) & J11(OFF) →Target Board is powered from the ac/dc Adapter (P1).
J2(OFF) & J11(ON) →Target Board is powered from the USB connection (J9)

Notes:
• When the C8051F326 target board is self-powered from the USB connection (J9), the EC2 Serial Adapter is 

not powered from the target board. The EC2 Serial Adapter must be powered directly by connecting the ac/
dc adapter to the Serial Adapter’s dc power jack. 

• The RS232 Serial Interface (J5) cannot be used when powering the target board from the USB connection (J9).

Table 3. J1 Pin Descriptions

Pin # Description Pin # Description
1 P0.0 12 P2.3
2 P0.1 13 P2.4
3 P0.2 14 P2.5
4 P0.3 15 P3.0
5 P0.4 16 C2CK/RST
6 P0.5 17 VREGIN
7 P0.6 18 VIO
8 P0.7 19 VBUS
9 P2.0 20 VDD

10 P2.1 21 +3VD
11 P2.2 22 GND

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/841125/C8051F326DK.html


C8051F326/7-DK

8 Rev. 0.2

6.6.  Target Board DEBUG Interface (J4)
The DEBUG connector (J4) provides access to the DEBUG (C2) pins of the C8051F326. It is used to connect the
Serial Adapter or the USB Debug Adapter to the target board for in-circuit debugging and Flash programming.
Table 4 shows the DEBUG pin definitions.

6.7.  Serial Interface (J5)
A RS232 transceiver circuit and DB-9 (J5) connector are provided on the target board to facilitate serial connec-
tions to UART0 of the C8051F326. The TX, RX, RTS and CTS signals of UART0 may be connected to the DB-9
connector and transceiver by installing shorting blocks on header J3.

J3[9–10] - Install shorting block to connect UART0 TX (P0.4) to the transceiver.
J3[11–12] - Install shorting block to connect UART0 RX (P0.5) to the transceiver.
J3[13–14] - Install shorting block to connect UART0 RTS (P2.4) to the transceiver.
J3[15–16] - Install shorting block to connect UART0 CTS (P2.5) to the transceiver.

6.8.  USB Debug Adapter Target Board Power Connector (J8)
The USB Debug Adapter includes a connection to provide power to the target board. This connection is routed
from J4[10] to J8[1]. Place a shorting block at header J8[2-3] to power the board directly from an ac/dc power
adapter. Place a shorting block at header J8[1–2] to power the board from the USB Debug Adapter. Please note
that the second option is not supported with either the EC1 or EC2 Serial Adapters.

Table 4. DEBUG Connector Pin Descriptions

Pin # Description
1 +3 VD (+3.3 VDC)

2, 3, 9 GND (Ground)
4 C2D
5 /RST (Reset)
6 P3.0
7 C2CK
8 Not Connected
10 USB Power
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7.  Schematics   
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DOCUMENT CHANGE LIST

Revision 0.1 to Revision 0.2
Removed EC2 Serial Adapter from Kit Contents.
Removed Section 2. Hardware Setup using an EC2 Serial Adapter. See RS232 Serial Adapter (EC2) User's 
Guide.
Removed Section 8. EC2 Serial Adapter. See RS232 Serial Adapter (EC2) User's Guide.
Removed Section 9. USB Debug Adapter. See USB Debug Adapter User's Guide.
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CONTACT INFORMATION
Silicon Laboratories Inc.
4635 Boston Lane
Austin, TX 78735
Tel: 1+(512) 416-8500
Fax: 1+(512) 416-9669
Toll Free: 1+(877) 444-3032
Email: MCUinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 
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