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Camera Interface Application Kit
Getting Started

Application Kit Contents
• 3 CDs — Dynamic C®, Dynamic C FAT File System module, and supplemental CD with sample programs and infor-

mation related to Camera Control Application Kit — with complete product documentation on disk.
• RCM3365 RabbitCore module.

• Camera Interposer Board to interface camera and micro-servo motors with RCM3365 and Prototyping Board.

• RCM3365 Prototyping Board, with a bag of accessory parts for use on the Prototyping Board.

• Miniature C328-7640 serial camera, plastic bracket, and 4-wire cable with friction-lock connectors.

• 10-pin header to DB9 programming cable with integrated level-matching circuitry.

• 2 power-supply harnesses (3-pin connector to red/black wires with bare leads).

• AC adapter, 12 V DC, 1 A.

• Ethernet cables.

• 2 Blue Arrow micro-servo motors.

• Infrared motion sensor.

• 4 foam doubled-sided mounting strips.

• Getting Started instructions.

• 32 MB xD-Picture Card™ (NAND flash)
• Rabbit 3000 Processor Easy Reference poster.

• Registration card.

Connect the servo motor wires to the Interposer Board — connect the pan servo motor to PWM3 (header J5). 
The black wire is GND and the white wire is the PWM signal.

Calibrate the pan servo motor now by running the SERVO_CALIB.C sample program from the Dynamic C 
SAMPLES\CAMERAINTERFACE folder. Use the File menu to open the sample program, and press func-
tion key F9 to compile and run the program.The STDIO window will open on your PC and will display a 
calibration dialog box. Use a felt pen to mark a dot on the servo motor’s rotating blade, and watch the blade 
rotate as you repeatedly press the “l” key on your keyboard with the STDIO window active. A PAN value 
will also display in the STDIO window. The blade will not rotate any further when it reaches its limit, and 
you may hear the motor humming. Go back at least two “steps” by pressing the “r” key on your keyboard, 
and press the “s” key on your keyboard to save the PAN value. (Write down the value.) Answer the 
prompts in the STDIO window and. Now repeatedly press the “r” key on your keyboard until the blade 
reaches its other limit, and go back at least two “steps” by pressing the “l” key on your keyboard. Press the 
“s” key on your keyboard to save the PAN value and answer the prompts. (Write down the value.) Finish 
by continuing to press the “l” key on your keyboard until the PAN value is midway between the two limits.

Cut a second piece of a foam mounting strip and use it to secure a side of the other micro-servo motor to 
the blade on the turning axis of the pan servo motor. This other servo motor is the tilt servo motor.

Connect the tilt servo motor to PWM1 (header J4), and calibrate it using the “u” and “d” keys on your key-
board to rotate the blade to its limits as you did for the pan servo motor. Go back at least two “steps,” and 
press the “s” key on your keyboard to save the TILT values (write down the values), answering the prompts 
in the STDIO window. Since the SERVO_CALIB.C sample program will terminate once all four limit 
values have been saved, run the SERVO.C sample program to be able to press the “u” and “d” keys on 
your keyboard as prompted in the STDIO window until the TILT value is midway between the two limits.

Use a third piece of foam mounting strip to secure the plastic camera bracket to the blade of the tilt servo 
motor, and finally use the remaining foam mounting strip the attach the camera to the plastic bracket — 
remove any labels from the back of the camera board before attaching it with the foam mounting strip.

Use the 4-wire cable with polarized friction-lock plugs to connect the camera to header J9 on the Interposer 
Board — connect the white plug to the camera, and connect the black plug to header J9.

Where Do I Go From Here?
If the sample servo calibration program ran fine, you are now ready to go on to other sample programs on 
the supplemental Dynamic C CD, which are discussed in Application Note AN412, Camera Interface 
Application Kit. The source code for the sample programs is provided to allow you to modify them for 
your own use. The RCM3365/RCM3375 User's Manual on the Dynamic C CD also provides complete 
hardware reference information and describes the software function calls for the RCM3365 RabbitCore 
modules and the Prototyping Board. If there are any problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor/Z-World Technical Bulletin Board at www.rabbit.com/support/bb/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Camera Interface Application Kit through a distributor or through a Rabbit 
Semiconductor or Z-World partner, contact the distributor or partner first for technical support.

Starting Dynamic C
Once the RCM3365 is connected as described in the preceding pages, start Dynamic C by double-clicking 
on the Dynamic C icon or by double-clicking on dcrab_XXXX.exe in the Dynamic C root directory, 
where XXXX are version-specific characters. Dynamic C uses the serial port specified during installation.
If you are using a USB port to connect your computer to the RCM3365, choose Options > Project 
Options and select “Use USB to Serial Converter.”
Set the compiler to run the application in the fast program execution SRAM by selecting “Code and BIOS 
in Flash, Run in RAM” from the Dynamic C Options > Project Options > Compiler menu.

Installing Dynamic C®

Insert the CD from the Development Kit in 
your PC’s CD-ROM drive. If the installation 
does not auto-start, run the setup.exe pro-
gram in the root directory of the Dynamic C 
CD. Install any Dynamic C modules and the 
software from the supplemental CD after you 
install Dynamic C.

Pan Motor 
Connections

Connect 
Camera
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Tilt Motor 
Setup

Calibrate 
Pan Motor

Downloaded from Elcodis.com electronic components distributor 

http://elcodis.com/parts/840322/101-1121.html


Hardware Connections
1.  Install Camera Interposer Board and RCM3365
Orient the Camera Interposer Board as shown in Figure 1 and line up the pins on the bottom of the Inter-
poser Board with sockets JA and JB on the Prototyping Board. Press the Interposer Board’s pins firmly into 
the Prototyping Board sockets.

Use a power-supply harness to connect the PWR pins (header J3, middle terminal is +5 V) on the Inter-
poser Board to the +5 V and GND terminals on screw-terminal header J6 on the Prototyping Board.

Install the RCM3365 on the Interposer Board as shown in Figure 1. Line up the pins on the bottom of the 
RCM3365 module with sockets JA and JB on the Interposer Board. Press the RCM3365 module’s pins 
firmly into the Interposer Board sockets. The xD-Picture Card may be inserted into header J6 on the 
RCM3365 at this time.

Figure 1.  Install the RCM3365 and Interposer Board on the Prototyping Board

NOTE: It is important that you line up the pins on the RCM3365 module and the Interposer 
Board exactly with the corresponding pins of the sockets. The header pins may become bent or 
damaged if the pin alignment is offset, and the boards will not work. Permanent electrical dam-
age to the modules may also result if a misaligned module is powered up.

A ¼" (6.3 mm) standoff is recommended to secure the RCM3365 module and the Interposer Board to the 
Prototyping Board in high-vibration environments. Attach one standoff to the top side of the Interposer 
Board as shown in Figure 1. Then secure the Interposer Board to the Prototyping Board using the standoff 
already on the Prototyping Board, and secure the RCM3365 into the other standoff on the Interposer Board.

2.  Connect Programming Cable and Power Supply
Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM3365 as 
shown in Figure 2. Be sure to orient the marked (red) edge of the cable towards pin 1 of the connector. (Do 
not use the DIAG connector, which is used for a normal serial connection.) Connect the other end of the 
programming cable to a COM port on your PC.
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Figure 2.  Connect Programming Cable, Interposer Board Power, and Motion Sensor

NOTE: Be sure to use the programming cable (part number 101-0542) supplied with this Appli-
cation Kit—the programming cable has blue shrink wrap around the RS-232 converter section 
located in the middle of the cable. Programming cables with red or clear shrink wrap from other 
Z-World or Rabbit Semiconductor kits are not designed to work with RCM3365 modules.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use an RS-232/
USB converter (Rabbit Semiconductor Part No. 540-0070) with the programming cable supplied 
with this Application Kit. Note that not all RS-232/USB converters work with Dynamic C.

If you are using the motion sensor, connect its +5 V and GND terminals to screw-terminal header J6 on the 
Prototyping Board—the middle black wire is +5 V—and connect its gray wire to IN0.

Once all the other connections have been made, you can connect power to the Prototyping Board. Connect 
the AC adapter to jack J1 on the Prototyping Board. The POWER LED on the Prototyping Board should 
light up. The RCM3365 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow a hardware reset without 
disconnecting power.
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Figure 3.  Servo Motor and
Camera Setup
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3.  Set Up and Connect Servo Motors and Camera
Complete the assembly of each servo motor by attaching the cross-shaped plastic blade to 
the motor shaft using the smallest screw from the parts bag in the motor box.

Cut a piece of a foam mounting strip and use it to secure the end opposite the turning axis of 
one of the micro-servo motors in an unused area of the Prototyping Board close to the edge. 
This will be the pan servo motor. You may also use another surface located close to the Proto-
typing Board. This pan servo motor can be secured more firmly if it is next to something else 
such as a screw-terminal header, and its side is also secured with the foam mounting strip.

Alternate Power-Supply Connections

All Development Kits include a harness that may be used to connect your power supply to 3-pin 
header J2 on the Prototyping Board. The connector may be attached either way as long as it is not 
offset to one side—the center pin of J2 is always connected to the positive supply, and either edge 
pin is negative. The power supply should deliver 8 V–30 V DC at 1 A.
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Hardware Connections
1.  Install Camera Interposer Board and RCM3365
Orient the Camera Interposer Board as shown in Figure 1 and line up the pins on the bottom of the Inter-
poser Board with sockets JA and JB on the Prototyping Board. Press the Interposer Board’s pins firmly into 
the Prototyping Board sockets.

Use a power-supply harness to connect the PWR pins (header J3, middle terminal is +5 V) on the Inter-
poser Board to the +5 V and GND terminals on screw-terminal header J6 on the Prototyping Board.

Install the RCM3365 on the Interposer Board as shown in Figure 1. Line up the pins on the bottom of the 
RCM3365 module with sockets JA and JB on the Interposer Board. Press the RCM3365 module’s pins 
firmly into the Interposer Board sockets. The xD-Picture Card may be inserted into header J6 on the 
RCM3365 at this time.

Figure 1.  Install the RCM3365 and Interposer Board on the Prototyping Board

NOTE: It is important that you line up the pins on the RCM3365 module and the Interposer 
Board exactly with the corresponding pins of the sockets. The header pins may become bent or 
damaged if the pin alignment is offset, and the boards will not work. Permanent electrical dam-
age to the modules may also result if a misaligned module is powered up.

A ¼" (6.3 mm) standoff is recommended to secure the RCM3365 module and the Interposer Board to the 
Prototyping Board in high-vibration environments. Attach one standoff to the top side of the Interposer 
Board as shown in Figure 1. Then secure the Interposer Board to the Prototyping Board using the standoff 
already on the Prototyping Board, and secure the RCM3365 into the other standoff on the Interposer Board.

2.  Connect Programming Cable and Power Supply
Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM3365 as 
shown in Figure 2. Be sure to orient the marked (red) edge of the cable towards pin 1 of the connector. (Do 
not use the DIAG connector, which is used for a normal serial connection.) Connect the other end of the 
programming cable to a COM port on your PC.
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Figure 2.  Connect Programming Cable, Interposer Board Power, and Motion Sensor

NOTE: Be sure to use the programming cable (part number 101-0542) supplied with this Appli-
cation Kit—the programming cable has blue shrink wrap around the RS-232 converter section 
located in the middle of the cable. Programming cables with red or clear shrink wrap from other 
Z-World or Rabbit Semiconductor kits are not designed to work with RCM3365 modules.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use an RS-232/
USB converter (Rabbit Semiconductor Part No. 540-0070) with the programming cable supplied 
with this Application Kit. Note that not all RS-232/USB converters work with Dynamic C.

If you are using the motion sensor, connect its +5 V and GND terminals to screw-terminal header J6 on the 
Prototyping Board—the middle black wire is +5 V—and connect its gray wire to IN0.

Once all the other connections have been made, you can connect power to the Prototyping Board. Connect 
the AC adapter to jack J1 on the Prototyping Board. The POWER LED on the Prototyping Board should 
light up. The RCM3365 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow a hardware reset without 
disconnecting power.
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Figure 3.  Servo Motor and
Camera Setup
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3.  Set Up and Connect Servo Motors and Camera
Complete the assembly of each servo motor by attaching the cross-shaped plastic blade to 
the motor shaft using the smallest screw from the parts bag in the motor box.

Cut a piece of a foam mounting strip and use it to secure the end opposite the turning axis of 
one of the micro-servo motors in an unused area of the Prototyping Board close to the edge. 
This will be the pan servo motor. You may also use another surface located close to the Proto-
typing Board. This pan servo motor can be secured more firmly if it is next to something else 
such as a screw-terminal header, and its side is also secured with the foam mounting strip.

Alternate Power-Supply Connections

All Development Kits include a harness that may be used to connect your power supply to 3-pin 
header J2 on the Prototyping Board. The connector may be attached either way as long as it is not 
offset to one side—the center pin of J2 is always connected to the positive supply, and either edge 
pin is negative. The power supply should deliver 8 V–30 V DC at 1 A.
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Camera Interface Application Kit
Getting Started

Application Kit Contents
• 3 CDs — Dynamic C®, Dynamic C FAT File System module, and supplemental CD with sample programs and infor-

mation related to Camera Control Application Kit — with complete product documentation on disk.
• RCM3365 RabbitCore module.

• Camera Interposer Board to interface camera and micro-servo motors with RCM3365 and Prototyping Board.

• RCM3365 Prototyping Board, with a bag of accessory parts for use on the Prototyping Board.

• Miniature C328-7640 serial camera, plastic bracket, and 4-wire cable with friction-lock connectors.

• 10-pin header to DB9 programming cable with integrated level-matching circuitry.

• 2 power-supply harnesses (3-pin connector to red/black wires with bare leads).

• AC adapter, 12 V DC, 1 A.

• Ethernet cables.

• 2 Blue Arrow micro-servo motors.

• Infrared motion sensor.

• 4 foam doubled-sided mounting strips.

• Getting Started instructions.

• 32 MB xD-Picture Card™ (NAND flash)
• Rabbit 3000 Processor Easy Reference poster.

• Registration card.

Connect the servo motor wires to the Interposer Board — connect the pan servo motor to PWM3 (header J5). 
The black wire is GND and the white wire is the PWM signal.

Calibrate the pan servo motor now by running the SERVO_CALIB.C sample program from the Dynamic C 
SAMPLES\CAMERAINTERFACE folder. Use the File menu to open the sample program, and press func-
tion key F9 to compile and run the program.The STDIO window will open on your PC and will display a 
calibration dialog box. Use a felt pen to mark a dot on the servo motor’s rotating blade, and watch the blade 
rotate as you repeatedly press the “l” key on your keyboard with the STDIO window active. A PAN value 
will also display in the STDIO window. The blade will not rotate any further when it reaches its limit, and 
you may hear the motor humming. Go back at least two “steps” by pressing the “r” key on your keyboard, 
and press the “s” key on your keyboard to save the PAN value. (Write down the value.) Answer the 
prompts in the STDIO window and. Now repeatedly press the “r” key on your keyboard until the blade 
reaches its other limit, and go back at least two “steps” by pressing the “l” key on your keyboard. Press the 
“s” key on your keyboard to save the PAN value and answer the prompts. (Write down the value.) Finish 
by continuing to press the “l” key on your keyboard until the PAN value is midway between the two limits.

Cut a second piece of a foam mounting strip and use it to secure a side of the other micro-servo motor to 
the blade on the turning axis of the pan servo motor. This other servo motor is the tilt servo motor.

Connect the tilt servo motor to PWM1 (header J4), and calibrate it using the “u” and “d” keys on your key-
board to rotate the blade to its limits as you did for the pan servo motor. Go back at least two “steps,” and 
press the “s” key on your keyboard to save the TILT values (write down the values), answering the prompts 
in the STDIO window. Since the SERVO_CALIB.C sample program will terminate once all four limit 
values have been saved, run the SERVO.C sample program to be able to press the “u” and “d” keys on 
your keyboard as prompted in the STDIO window until the TILT value is midway between the two limits.

Use a third piece of foam mounting strip to secure the plastic camera bracket to the blade of the tilt servo 
motor, and finally use the remaining foam mounting strip the attach the camera to the plastic bracket — 
remove any labels from the back of the camera board before attaching it with the foam mounting strip.

Use the 4-wire cable with polarized friction-lock plugs to connect the camera to header J9 on the Interposer 
Board — connect the white plug to the camera, and connect the black plug to header J9.

Where Do I Go From Here?
If the sample servo calibration program ran fine, you are now ready to go on to other sample programs on 
the supplemental Dynamic C CD, which are discussed in Application Note AN412, Camera Interface 
Application Kit. The source code for the sample programs is provided to allow you to modify them for 
your own use. The RCM3365/RCM3375 User's Manual on the Dynamic C CD also provides complete 
hardware reference information and describes the software function calls for the RCM3365 RabbitCore 
modules and the Prototyping Board. If there are any problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor/Z-World Technical Bulletin Board at www.rabbit.com/support/bb/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Camera Interface Application Kit through a distributor or through a Rabbit 
Semiconductor or Z-World partner, contact the distributor or partner first for technical support.

Starting Dynamic C
Once the RCM3365 is connected as described in the preceding pages, start Dynamic C by double-clicking 
on the Dynamic C icon or by double-clicking on dcrab_XXXX.exe in the Dynamic C root directory, 
where XXXX are version-specific characters. Dynamic C uses the serial port specified during installation.
If you are using a USB port to connect your computer to the RCM3365, choose Options > Project 
Options and select “Use USB to Serial Converter.”
Set the compiler to run the application in the fast program execution SRAM by selecting “Code and BIOS 
in Flash, Run in RAM” from the Dynamic C Options > Project Options > Compiler menu.

Installing Dynamic C®

Insert the CD from the Development Kit in 
your PC’s CD-ROM drive. If the installation 
does not auto-start, run the setup.exe pro-
gram in the root directory of the Dynamic C 
CD. Install any Dynamic C modules and the 
software from the supplemental CD after you 
install Dynamic C.
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